
 

 

 

 

 

 

 

 

 

FEMtools 4 .0 リリース・ノート 
 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 1994-2017, Dynamic Design Solutions NV (DDS). 

このドキュメントのどの部分についても、電子的、機械的、写真複写、記録、あるいはその他の如何なる手

段を用いても、かつ如何なる目的であろうとも、Dynamic Design Solutions NV, Interleuvenlaan 64, B-3001 Leuven, 
Belgiumの文書による承諾なく複製したり、検索システムに保存したり、第三者に開示したりすることはでき
ません。 

このドキュメントに記載されている情報は、通告なしに変更されることもありますし、それらはまた Dynamic 
Design Solutions NVの公約を示すものでもありません。このドキュメントに記載されているソフトウェアは、
ライセンスの合意または非公開の合意の下でのみ提供されます。Dynamic Design Solutionsとその代理店は、
最も正確なドキュメントやトレーニング資料を提供することを旨としますが、両者とも当該ソフトウェア・

システムのドキュメントやトレーニング資料における記述の誤りによって生じる結果や損傷に対し責任を負

うものではありません。したがって、Dynamic Design Solutions NVとその代理店は、人または財産への損傷、
消失利益、データ復旧費、訴訟費あるいはその他の費用のうち、何ら規制されないような損害に対してその

責任を負いません。 

FEMtoolsは Dynamic Design Solutions NV （DDS）の登録商標です。このドキュメントにおいて使用される他
のすべてのブランド名および製品名は、それらの所有権保有者の商標または登録商標です。 

Version 4.0.0 – June 2017 
Part No. FTRN-400-1706 

Dynamic Design Solutions NV (DDS) 
Interleuvenlaan 64 – 3001 – Leuven – Belgium 
Phone +32 16 40 23 00 – Fax +32 16 40 24 00 
info@femtools.com – www.femtools.com 

 

FEMtools Version 4.0 リリース・ノート － 2017年 7月 

株式会社 ストラクチャルサイエンス 

〒211-0016川崎市中原区市ノ坪 66-5 LM武蔵小杉第 2- 215 
TEL: 044-738-0315  FAX: 044-738-0316 
E-mail: support@ssinst.com URL: http://www.ssinst.com

http://www.femtools.com/
http://www.ssinst.com/


 

 

序文 

ドキュメントについて 

このドキュメントは、FEMtools 4.0における新しい機能、機能強化、および訂正について記述したものです。 

FEMtoolsドキュメントにおいて使用される規則 

FEMtoolsマニュアルは、視覚的に情報を識別するのに便利なように、いくつかの規則を設けています。 

タイプのスタイルまたは記号          用途                     

extract nodes FEMtools コマンドラインの例 

SET ECHO FEMtools コマンドまたはコマンドの構文 

Settings メニュー・コマンド 

※ この規則は日本語ドキュメントにおいては、必ずしも適用されるとは限りません。 

統一性と UNIX プラットフォームでの大文字／小文字の区別を考慮して、FEMtoolsコマンド・スクリプトに

おけるすべてのコマンドと引数（特にファイル名）に対して小文字が使用されています。しかし、FEMtools

のドキュメンテーションでは、読み易くするためにコマンドは通常大文字で記されています。 

関係のあるドキュメンテーション 

本ドキュメントは、次のドキュメント、マニュアルと一緒に用いるのがよいでしょう。 

• FEMtools Getting Started Manual（入門マニュアル） 

ドキュメンテーションの使用について 

FEMtoolsドキュメンテーションは、HTML ベースのヘルプとして、および PDFフォーマットでのオンライン

マニュアルとして利用できます。 

ヘルプにアクセスするには、Helpメニューから Help Topicsを選びます。 

• 全マニュアルの目次の完全なリストを見たい場合は、Contentsタブを使います。 

• すべてのインデックスエントリのリストを見たい場合は、Indexタブを使います。 

その他のタブは、使用するオペレーティング・システムに依存して利用することができます。 

マニュアルにアクセスするには、Helpメニューから Manualsを選んでください。PDFファイルを読むには、

Adobe Acrobat Readerがシステムにインストールされなければなりません。 
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FEMtools 4 リリース・ノート 

FEMtools 4 は、すべての解析機能の修正と拡張が伴うメジャー・アップデートバージョンです。また、FE

プログラムの最新バージョンをサポートし、過去のメンテナンス・リリースを統合した最新バージョンです。

その主な新機能・更新情報を以下に示します。 

概説 

インストールとコンフィグレーション 

 Windows64ビットのプラットフォーム（7、8、10）および Linux 64ビット（RHEL6+）対応リリース 

 ダウンロード、USBメモリ、CD-ROMによるリリース 

 Linuxコンピューター対応の Safenet HLドングルのサポート 

 ライセンス・コード指定による FEプログラム・インターフェイス 

 最新バージョン対応プログラム自動更新機能 

 ライセンス（ノードロック、ネットワーク、ローミング）用コンフィグレーター 

ユーザー・インターフェイス 

 最新ベクトル・ベース・アイコン（SVG） 

 高解像度モニタ（4K）用の自動スケーリング・アイコン 

フレームワーク 

 MS Office（Excel, PowerPoint, Word）対応レポート・コマンド 

 最新インタラクティブ・テストモデル・エディタ 

 グラフィック・ピッキング（アイテム選択、フェイス選択、追加ピッキング）の拡張 

 DOFリレーション・コマンド 

 最新デジタル信号処理（DSP）コマンド 

 時系列データチャンネル（data channels）とウィンドウ関数を定義するためのコマンド 

データ・インターフェイス 

 Abaqus 2016、Abaqus 2017のサポート 

 MSC.Nastran 2017のサポート 

 Ansys 18+のサポート 

 LS-DYNA 有限要素パッケージの最新インターフェイス 

ダイナミック解析 

 アウトオブメモリ・コントロール最新ソルバー・オプション 
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 マスターDOF選択のための K/M 比の計算コマンド 

 モーダル・ベース・アセンブル（MBA:Modal-Based Assembly）データベース用コマンドの拡張 

 MBA のモーダル・ベース剛結合のサポート 

プリテスト解析 

 質量荷重感度（MLS:Mass Loading Sensitivity）計算用ツール 

 モード刺激解析（MPA:Mode Participation Analysis）ツール 

 最新モード刺激マップ（MPM:Mode Participation Analysis）ツール 

 初期化および FEモデルの消去用ユーティリティ 

 最新の加振／保持の最適ロケーション選択ツール 

 最新センサー選択ロケーションのインポート／エクスポート・コマンド 

相関分析 

 最新インタラクティブ・モードシェープ・ペア・ビュー 

 モード刺激係数の計算機能の拡張 

 モーダル直交関数（EVO:modal orthogonality）の拡張計算機能 

感度解析とモデルアップデーティング 

 最新パラメータ・タイプ（スプリング剛性スケーリング係数）のサポート 

実験計画法 

 最新の RSM分析と検証のためのコマンド 

 DOEデータをインポートしリセットするためのコマンド 

最適化 

 FRFレベル最小化設計のためのトポメトリー最適化 
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FEMtools 4ドキュメンテーションおよびトレーニング 

FEMtoolsドキュメンテーションは、システム・ヘルプ、コース・ノート、システム・ブック（PDF）および

出力物のマニュアルで構成されます。すべてのドキュメンテーションが現在のリリース・バージョン用に更

新されています。 

ドキュメンテーション概説 

FEMtools 4.0ドキュメンテーションは次のドキュメントで構成されます。 

 FEMtools 4.0 Release Notes（リリース・ノート）：このマニュアルは、FEMtools 4.0の新しい特徴を紹介

し、従来バージョンからのアップグレード方法などについて解説します。 

 FEMtools 4.0 Getting Started Manual（導入マニュアル）：このマニュアルは、インストール、ライセン

ス・マネージメント、起動、FEMtoolsを形成方法について解説します。 

 FEMtools 4.0 Framework User's Guide（フレームワーク・ユーザーガイド）：このガイドは、FEMtools

モジュール（ユーザー・インターフェイス、データベース、データ・インターフェイス、スクリプト言

語、グラフィックス）についての情報を含んでいます。 

 FEMtools 4.0 Mesh User's Guide（メッシュ・ユーザーガイド）：このガイドは、メッシュ生成、メッシ

ュ変形、要素変換、メッシュ精度などのメッシュ・ツールについての情報を含んでいます。 

 FEMtools 4.0 Dynamics User's Guide（ダイナミクス・ユーザーガイド）：このガイドは、FEMtoolsの構

造ダイナミクス・シミュレーションの理論的な背景、実際的な情報、例題を含んでいます。 

 FEMtools 4.0 Pretest and Correlation Analysis User's Guide（プリテスト解析と相関分析ユーザーガイ

ド）：このガイドは、プリテスト解析と相関分析に関する理論的な背景、実際的な情報、例題を含んで

います。 

 FEMtools 4.0 Sensitivity Analysis and DOE User's Guide（感度解析と実験計画法ユーザーガイド）：この

ガイドは、感度解析と実験計画法（DOE）に関する情報を含んでいます。 

 FEMtools 4.0 Model Updating User's Guide（モデルアップデーティング・ユーザーガイド）：このガイ

ドは、モデルアップデーティング、外力同定、確率論的解析に関する実際的な情報を含んでいます。 

 FEMtools 4.0 Model Updating Theoretical Manual（モデルアップデーティング理論マニュアル）：この

マニュアルは、モデルアップデーティングに関する理論的背景を含んでいます。FEMtoolsモデルアップ

デーティングに使用される有限差分解析法などについて解説します。 

 FEMtools 4.0 Model Updating Examples Manual（モデルアップデーティング例題マニュアル）：このマ

ニュアルはモデルアップデーティングに関するそれぞれの例題について解説します。 

 FEMtools 4.0 Optimization User's Guide（最適化ユーザーガイド）：このガイドは、一般非線形プログラ

ムによる最適化、サイズ、形状、トポロジー、トポメトリーの最適化およびDOE/RSMプリケーションに

よる構造最適化に関する理論的な背景、実際的な情報、例題を含んでいます。 

 FEMtools 4.0 Modal Parameter Extractor （MPE） User’s Guide（モーダル・パラメータ・エクストラ

クター（MPE）ユーザーガイド）：このガイドは、モーダル・パラメータ・エクストラクター（MPE）

アドオン・ツールに関する情報と例題を含んでいます。 
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 FEMtools 4.0 Rigid Body Properties Extractor （RBPE） User’s Guide（剛体特性エクストラクター・ユ

ーザーガイド）：このガイドは、周波数レスポンス関数（FRF）から剛体特性を推定するための剛体特

性エクストラクター（RBPE）用のアドオン・ツールに関する理論的背景、実際的な情報、例題を含んで

います。 

 FEMtools 4.0 ARTeMIS Interface User's Guide（ARTeMISインターフェイス・ユーザーガイド）：この

ガイドは、ARTeMISファイルをインポートし／エクスポートする方法についての情報を含んでいます。 

 FEMtools 4.0 ABAQUS Interface User's Guide（ABAQUSインターフェイス・ユーザーガイド）：このガ

イドは、ABAQUSファイルをインポート／エクスポートする方法およびABAQUSドライバーの使用方法

についての情報を含んでいます。 

 FEMtools 4.0 ANSYS Interface User's Guide（ANSYSインターフェイス・ユーザーガイド）：このガイド

は、ANSYSファイルをインポート／エクスポートする方法およびANSYSドライバーの使用方法について

の情報を含んでいます。 

 FEMtools 4.0 LS-DYNA Interface User's Guide（LS-DYNAインターフェイス・ユーザーガイド）：この

ガイドは、LS-DYNAファイルをインポート／エクスポートする方法およびLS-DYNAドライバーの使用

方法についての情報を含んでいます。 

 FEMtools 4.0 NASTRAN Interface User's Guide（NASTRANインターフェイス・ユーザーガイド）：こ

のガイドは、NASTRANファイルをインポート／エクスポートする方法およびNASTRANドライバーの使

用方法についての情報を含んでいます。 

 FEMtools 4.0 UNIVERSAL FILE  Interface User's Guide（UNIVERSAL FILE インターフェイス・ユーザ

ーガイド）：このガイドは、ユニバーサル・ファイル・フォーマットを使用して、FEAとテストのデー

タをインポート／エクスポートする方法およびI-DEASドライバーの使用方法についての情報を含んで

います。 

 FEMtools 4.0 SAP2000 Interface User's Guide（SAP2000インターフェイス・ユーザーガイド）：このガ

イドは、SAP2000ファイルのインポート方法、およびSAP OAPIドライバーの使用方法についての情報を

含んでいます。 

 FEMtools 4.0 Programmer’s Guide（プログラマガイド）：このマニュアルは、FEMtoolsスクリプト言語

プログラムの使用方法についての情報を含んでいます。また、FEMtoolsスクリプト・リファレンスマニ

ュアルおよびAPIリファレンスマニュアルと一緒に利用されます。 

 FEMtools 4.0 GUI Reference：このリファレンスは、メニュー、ツールバー、ダイアログボックスに関す

る情報を含むリファレンスマニュアルです。 

 FEMtools 4.0 Command Reference：このリファレンスは、FEMtoolsコマンド言語要素、シンタックス、

引き数および例証を含む各コマンドについての詳細な情報を含むリファレンスマニュアルです。 

 FEMtools 4.0 Scripting Reference：このリファレンスは、FEMtoolsスクリプト言語要素（変数、演算子、

関数、ステートメント）について記述するリファレンスマニュアルです。 

 FEMtools 4.0 Application Programming Interface （API） Reference（アプリケーションプログラムイン

ターフェイス・リファレンス）：このリファレンスマニュアルは、FEMtoolsデータベースとのインタラ

クティブ・インターフェイスに関して解説します。 
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次表は、それぞれのドキュメント・フォーマットを示します。 

ドキュメント名 フォーマット 

FEMtools 4.0 Release Notes  PDF  

FEMtools 4.0 Getting Started Manual  PDF, Help  

FEMtools 4.0 Framework User's Guide  PDF, Help  

FEMtools 4.0 Mesh User's Guide  PDF, Help  

FEMtools 4.0 Dynamics User’s Guide  PDF, Help  

FEMtools 4.0 Pretest and Correlation Analysis User’s Guide  PDF, Help  

FEMtools 4.0 Sensitivity Analysis and DOE User’s Guide  PDF, Help  

FEMtools 4.0 Model Updating User’s Guide  PDF, Help  

FEMtools 4.0 Model Updating Theoretical Manual  PDF  

FEMtools 4.0 Model Updating Examples Manual  PDF  

FEMtools 4.0 Optimization User’s Guide  PDF, Help  

FEMtools 4.0 Modal Parameter Extractor （MPE） User’s Guide  PDF, Help  

FEMtools 4.0 Rigid Body Properties Extractor （RBPE） User’s Guide  PDF, Help  

FEMtools 4.0 ARTeMIS Interface User’s Guide  PDF, Help  

FEMtools 4.0 ABAQUS Interface and Driver User’s Guide  PDF, Help  

FEMtools 4.0 ANSYS Interface and Driver User’s Guide  PDF, Help  

FEMtools 4.0 LS-DYNA Interface and Driver User’s Guide  PDF, Help  

FEMtools 4.0 NASTRAN Interface and Driver User’s Guide  PDF, Help  

FEMtools 4.0 UNIVERSAL FILE Interface and Driver User’s Guide  PDF, Help  

FEMtools 4.0 SAP2000 Interface and Driver User’s Guide  PDF, Help  

FEMtools 4.0 Programmer’s Guide  PDF  

FEMtools 4.0 GUI Reference Manual  Help  

FEMtools 4.0 Command Reference Manual  Help  

FEMtools 4.0 Scripting Reference Manual  Help  

FEMtools 4.0 API Reference Manual  Help  

Help（ヘルプ）は、FEMtoolsの Help メニューからアクセス可能なドキュメンテーションを参照します。ヘ

ルプはマイクロソフト HTML ヘルプ（Windows）、HTML WebHelp（Linux）を使用します。 

PDFはアドビ・アクロバット（Adobe Acrobat）ポータブル・ドキュメント・フォーマット（PDF）を参照し

ます。これらのファイルは、アドビ・リーダ・ソフトウェア（Windows/Linux用ユーティリィティ：アドビ・

システムズ（www.adobe.com）から利用可能）を使用して読むことができます。また、アドビ・アクロバッ

トから PDFフォーマット・マニュアルを出力することができます。それらの電子マニュアルにアクセスする

には、Helpメニューから Manualsを選んでください。  
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FEMtoolsウェブサイト 

インターネット上の FEMtoolsカスタマー・サポート・サイトは、FEMtoolsメンテナンスおよび技術サポー

トサービス権を持つすべての FEMtoolsユーザーのためのコミュニケーション／サポートのセンターとして

活用できるように意図されています。次のサイトからソフトウェア・インストール・パッケージに付属する

ドキュメンテーションや補語情報を見つけることができます。また、ソフトウェア、パッチ、スクリプト、

ドキュメンテーションなどの新バージョンをダウンロードすることが可能です。 

http://www.femtools.com/support 

FEMtoolsトレーニング・コース 

DDS（Dynamic Design Solutions）および FEMtoolsパートナーは、新規のユーザーのためのイントロダクショ

ン・コースおよび上級ユーザーや FEMtoolsアプリケーション開発者のためのトレーニング・コースを提供し

ます。 

詳細については、support@femtools.comにお問い合わせ頂くか、あるいは最新情報サイトの

http://www.femtools.com/coursesを閲覧してください。 
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FEMtools 4の更新情報 

インストール、ライセンス、コンフィグレーション 

サポート対象オペレーティング・システムとインストールのための最少必要条件を示します。 

サポートされたプラットフォーム 

FEMtoolsは、Windows 64ビットおよび Linux 64ビットのプラットフォームのみで利用可能です。32ビット・

バージョンおよび MAC OSはもはやサポートされません。 

次表は、FEMtools 4のサポート対象プラットフォームを示します: 

Platform  Operating System（s）  Processor（s）  

WIN64  Windows 7/8/8.1/10 64-bit  Intel 64; AMD 64  

LIN64  Linux 64-bit （RHEL 6+, CentOS 6+,…）  Intel 64; AMD 64  

最新の対象プラットフォーム情報については、FEMtools サイト （http://www.femtools.com） を確認くださ

い。  

最小インストール必要条件 

Windows 

 Microsoft Windows 7、8、8.1、10  64ビット? 

 最小 4 GB RAM 

 最小 500MBハードディスク・スペース 

 Open GLをサポートするグラフィックスカード 

OpenGL対応のハードウェア・アクセレレータ・グラフィックスカードであればグラフィックス性能は

向上するでしょう。 

 CDまたは電子メールからインストールするための CD-ROMドライブまたはインターネット接続 

 USBポート（ノードにロック・ライセンス・オプション用のドングルを使用する場合） 

 ライセンスサーバー（ネットワーク・ライセンス・オプション用）の TCP/IP接続 

 アドビ・アクロバット・リーダあるいは PDFドキュメンテーションを読むためのアプリケーション 

Linux 

 インテル MKL 11.0や、インテル 64（RHEL 6+(CentOS 6+)...）をサポートする Linux 64ビット OS 

その他の Linux OSもサポートされるかもしれません。 

 最小 4 GB RAM 

 最小 500MBハードディスク・スペース 
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 Open GLをサポートするグラフィックスカード 

OpenGL対応のハードウェア・アクセレレータ・グラフィックスカードであればグラフィックス性能は

向上するでしょう。 

 CDまたは電子メールからインストールするための CD-ROMドライブまたはインターネット接続 

 ライセンスサーバー（ネットワーク・ライセンス・オプション用）の TCP/IP接続 

 アドビ・アクロバット・リーダあるいは PDFドキュメンテーションを読むためのアプリケーション 

インストールの変更点 

 FEMtools 4は、ダウンロードあるいは、USBメモリや CD-ROMによってリリースされます。 

 FEMtoolsアドオン・マネージャーは、空白を含むパスネームを扱うことができます。 

 新しいパッチがある場合でも、アドオン・マネージャーは、スタートアップを起動しません。新しいア

ドオンが検知された場合のみにスタートアップが起動されます。 

 パッケージ・マネージャーは、利用可能なライセンスがない新しいアドオンのスタートアップを起動し

ません。ライセンスが見つからない場合でも、今までどおりパッケージ・マネージャーを手動で（Add-ons 

> Install/Remove Add-on）操作することにより、インストール・パッケージのアドオンを確認すること

ができます。 

 アンインストール処理では、FEMtoolsプリプロセッサー・スクリプト（uninstall_packages.bas）が最初に

アドオン・パッケージをアンインストールし、次にその他の手続きがアンインストールされます。 

 データ・インターフェイスに関するスクリプト・ファイルは、現在のフォルダー

（<installdir>/scripts/interfaces）にインストールされます。各インターフェイスの専用サブフォルダーが

あります。ドライバー・スクリプトおよびセッティング・ファイルの場所（<installdir>/scripts/drivers）

は変わりません。 

コマンドライン・パラメータ 

コマンドライン・パラメータが環境変数を定義するために付け加えられました。それらの変数がスタートア

ップ・スクリプトにおいて利用できるように、FEMtoolsを実行した直後に、この環境変数が適用されます。

スクリプト・プログラマは、そのカスタマイズ構成セッティングを使用することができます。 

プログラムの更新点 

FEMtoolsは定期的にアップデート情報をチェックされ、その情報にはアップデート・バージョンが存在する

場所やシステム情報が含まれます。また、新たにリリースされたアドオン・モジュールに関する通知がある

かもしれません。 

FEMtoolsは 2つのアップデート・オプションを提供します。 

 スタートアップ時の通知：スタートアップ時にシステムの最新版を定期的にチェックし、ダウンロード

とインストールの準備ができていることが通知されます。このオプションはソフトウェアを最新にして

おくために推奨されます。 

 アップデート・バージョンのインストールの手動チェック：システムはアップデートを自動ではチェッ
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クをしません。代わりに、ヘルプ（Help > Check for Updates.）を使用し、いつアップデートをすべきか

を決定することができます。 

 

FEMtoolsアップデート・サーバーとの接続を確立するには、インターネット接続が要求されることに注意し

てください。 

スタートアップ時に応答指示があり、以降において、アップデート・オプションの変更は、Configureボタン

を使用して行うことができます。 

これは次のダイアログボックスを開きます。 

 

スタートアップの通知は単に 7日間隔で作成されます。これはユーザー・セッティング・ファイル（ユーザ

ー・ホームディレクトリー内の femtools_400.ini）で設定され、CheckDaysIntervalで修正することができます。

その値として、0か負が設定されれば、アップデートのチェックは行われません。これは、Manually check…

オプションを選ぶことと等価です。 
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FEMtoolsライセンス・コンフィグレーター 

FEMtoolsライセンス・コンフィグレーター（License Configurator）は更新され、ノードロック、ネットワー

ク、ローミングのそれぞれのライセンスを形成するために使用することができます。Windowsでは、Help > 

License Configuratorを使用し、インストーラー（Start > All Progams > FEMtools 4 > FEMtools License 

Configurator）によって、FEMtools 4にリンクへアクセスされます。Linuxでは、ftlm を使用してください。 

 

FEMtools License Configurator 

ノードロック・ライセンスとネットワーク・ライセンスについては、License settingsを使用します。 
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Core Product Nameが入力されない場合、スタートアップ時に、FEMtoolsはライセンスが利用可能なプロダク

ト名を提示します。個別の利用可能なライセンスである場合、自動チェックによるプロダクト名になります。 

次のダイアログボックスを開くには、Configure license roamingを使用します。 

 

ローミング・オプションの設定後、このダイアログボックスを閉じて、選択された Core Product Nameのライ

センスをチェックするために FEMtoolsを再開してください。ライセンスが利用可能なアドオンもすべて自動

的にチェックされます。 

その他のライセンスの変更点 

 個別のライセンス・コードによって許可された FEプログラム・インターフェイス（解析アドオン） 

 新しい hostid UUIDが利用されます。これは、wrlmhostid.exeユーティリティ中で示され、UUID識別 ID

は、Ft_HostInfo("uuid")関数プログラムによって検索されます。 

 引き数Ft_ProductInfo("server")は、Ft_ProductInfo("name" ) を使用するために加えられました。 
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例 

Sub Main 

print "hostid(uuid) = "; Ft_HostInfo("uuid")  

print "ft_productinfo(server)=";ft_productinfo("server")  

print "ft_productinfo(name)=";ft_productinfo("name") 

End Sub   

 FEMtools 4はライセンス・マネージメントのために RLM 12.2を使用します。あおの詳細な情報に関し

ては、RLM ドキュメンテーションを参照してください。 

 RLM_ROAM環境変数は１日間のライセンスを有効とするために、”tiday”値を受理します。この機能は、

RLM v11.0+クライアントとサーバーの両方の設定に依存します。 

 環境変数RLM_QUEUEのサポートが加えられ、RLM_QUEUE環境変数が存在する場合（重要でない値）、

FEMtoolsはメイン機能のチェックアウト設定が可能になります。ライセンスが受理されない場合（他の

ユーザーによって使用されているライセンス）、そのライセンスが利用可能になるまで、FEMtoolsは待

ちます。RLM_QUEUE変数が設定されていない場合、FEMtoolsはライセンスを受理しません。

RLM_QUEUEは RLM_ROAMと非互換性であることに注意してください。RLM_ROAMはローミングの

準備ができている場合、RLM_QUEUEは非アクティブ化されます。言いかえれば、RLM_ROAMと

RLM_QUEUEの両方がセットされる場合、RLM_QUEUEは無視されます。 

この制限は RLM v12.0によって、起動コントロールを強化します。これはライセンスが受理される場合

でも、RLM_ROAMがモバイル・コンピューターでのライセンスをロックします。一旦ライセンスが有

効になれば、あおのライセンスがノードロック・ライセンスになるので、RLM_QUEUEはもはや作動し

ません。 

 ライセンス・ファイルには、‘customer’と‘contract’のフィールドが存在します。このライセンス情報（Help 

> License Information）は、カスタマーと契約の情報を示します。起動が受理された場合、コンソール・

ウィンドウにそのカスタマー情報を出力します。カスタマー情報は aboutダイアログボックスでも確認

できます。 

 RLM サポート・サイトへのリンクが、Helpメニュー（Help > RLM Support Site）に加えられました。 

 RLM マネージメント・マニュアルへのリンクが、FEMtools License Configurator に加えられました。 

ドングル 

 FEMtoolsは、Safenet SuperProに加えて、Linuxコンピューター上で使用することができる新しい Safenet 

HLドングルをサポートします。そのドングルはノードロック・ライセンスとして使用されます。 

FEMtools前バージョンからのアップグレード 

以下は、FEMtoolsの前バージョンから FEMtools 4へアップグレードするユーザーのための情報です。 

 FEMtools 4.0は、新しいディレクトリーにインストールすることを推奨します。そのデフォルト・イン

ストール・ディレクトリは、c: ¥femtools¥4です。 

 ドングルによって保護されたライセンス・ユーザー、あるいは旧バージョン（v3.3~）からアップグレー
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ドするユーザーは新しいライセンス・ファイルが必要となります。 

 最初にこのバージョンを開始する時、新しいセッティング・ファイルがホームディレクトリー中に作成

されます。また、そのセッティング・ファイルは femtools_400.iniです。 

 以前のインストール・セッティング・ファイル中で行なった修正は、スタートアップ上の新しいセッテ

ィング・ファイルに自動的にコピーすることができます。それはアップデートのスタートアップ時に提

案されます。 

 以前のバージョン中で使用されたドライバー・スクリプトのドライバー・セッティングやカスタマイゼ

ーションは、FEMtools 4.0には自動的に回復されません。以前のドライバーに行なったカスタマイゼー

ションは、FEMtools 4.0バージョン中の INI ファイルおよび BASドライバー・スクリプトで繰り返し設

定しなければなりません。それらのファイルは、<installdir>¥scripts¥driversに位置します。 

 FEMtools 4.0リリース・ノートの FEMtoolsコマンド言語の変更点をチェックしてください。必要な場合

はコマンド・スクリプトを更新してください。 

 FEMtools 4.0リリース・ノートの FEMtools APIの変更点をチェックしてください。必要な場合はプログ

ラム・スクリプトを更新してください。 

 FEMtools 3.xプロジェクト・ファイルは FEMtools 4.0にインポートすることができます。 

ドキュメンテーションの変更点 

次の大変化がドキュメンテーションと例に作られました: 

 FEMtoolsドキュメンテーションはこのリリース伴って更新されます。 

 新規の LS―DYNAインターフェイスとドライバーのガイドが追加されます。 

 実験計画法（DOE:design of experiments）の基礎情報およびレスポンス・フェイス・モデリング

（RSM:response surface modeling）は、FEMtools Model Updating User’s GuideとFEMtools Optimization User’s 

Guidから新しいFEMtools SensitivityとDesign of Experimentsのユーザーガイドに移動しました。FEMtools 

Model Updating User’s Guideと FEMtools Optimization User’s Guidは、FEMtools DOE/RSMの使用方法につ

いてのより実際的な情報を提供します。 

 個別のトポメトリー最適化の例題の詳細な記述が、FEMtools Optimization User’s Guidに追加されます。 

 PointCloudオブジェクトのドキュメンテーションが変更されます。CreateObject関数はスクリプト関数と

してドキュメント化されました。ただし、Fill、FindNearest、SearchRadiusは、PointCloudオブジェクト

の使用方法としてドキュメント化されました。PointCloudオブジェクトの使用方法と新しい辞書オブジ

ェクトは、スクリプト・リファレンスマニュアルの新しい「Object Methods（オブジェクトの使用方法）」

の章にグループ化されます。 

 コマンド SENSITIVITY SOLVERはドキュメント化されていましたが、もはや存在しません。それはド

キュメンテーションから取り除かれ、SENSITIVITY SOLVERは SENSITIVITY METHOD char_valに替わ

ったことに注意してください。 
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例題の変更点 

 次の例題が追加されます。 

 Calculixのインターフェイスとドライバー：..¥examples¥interfaces¥calculix 

 LS-Dynaのインターフェイスとドライバー：のためのドライバー:..¥examples¥interfaces¥lsdyna 

 ボルト締めプレート構造（“BoxBeam”）のプリテスト解析: ..¥examples¥pretest¥boxbeam 

 ボルトで締めプレート構造（“BoxBeam”）の FEMテキスト相関分析: ..¥examples¥correlation ¥boxbeam 

 GVTシミュレーション・モデルのモデルアップデーティング: ..¥examples¥updating¥gvt 

 ボルトで締めプレート・モデル（“JimBeam”）のモデルアップデーティング:  

..¥examples¥updating¥jimbeam 

 スプリング要素のアップデート・パラメータ KT と KRの使用方法： 

..¥examples¥updating¥plate_modal¥run06ktr.cmd 

 スプリング要素のアップデート・パラメータ Dの使用方法： 

..¥examples¥updating¥plate_modal¥run06d.cmd 

 ジェネリックなパラメータ、レスポンス、ソルバーのモデルアップデーティング方法:  

..¥examples¥generic¥excel (using MS Excel solver)  

..¥examples¥generic¥frf (generic solver to driver PADEFRF and MODALFRF) 

..¥examples¥generic¥modal 

 レポート例題：..¥examples¥reporting¥updating 

 次の例題フォルダーが移動しました。 

 ￥fea￥complex_modesは、フォルダー¥dynamics¥complex_modesに移動しました。 

 ￥fea￥modal_solverは、フォルダー¥dynamics¥modal_solverに移動しました。 

 次の例題が更新されました。 

 ¥dynamics¥modal_solver 

 ..¥examples¥updating¥generic¥excel¥demo.cmd 

 ..¥examples¥optimization¥doe¥spring¥spring_doe_excel.bas 

 ..¥examples¥optimization¥genetic¥dmo¥dmo_ga.cmd 

 inertia.basデモ・プログラム・スクリプトは削除されました。 
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FEMtoolsフレームワーク 

FEMtoolsフレームワークの主な変更点を示します。 

FEMtoolsスクリプト言語 

 Dictionary（辞書）オブジェクトがサポートされました。Dictionary は、様々なデータ・タイプを格納し

マネージメントするために使用することができる柔軟なデータベース・オブジェクトです。Help（Help > 

Help Topics > Scripting Reference > Object Methods > Dictionary）から FEMtoolsスクリプト・リファレンス

マニュアルを参照してください。 

 ジャーナル・ファイルは、” journal_FT<pid>.tmp”のように、現在のセッションプロセス pidが付けられま

す。複数の FEMtoolsセッションが同じテンポラリファイル・フォルダーに共有される場合の問題を回避

します。 

ABAQUSインターフェイスとドライバー 

 ABAQUSインターフェイスとドライバーは、femtools_abaqusプロダクトコード・ライセンスを要求しま

す。FEMtools 3 の ABAQUSプロダクトコード・ライセンスはそれらが終了まで有効です。 

 Abaqus 2016と Abaqus 2017のサポート 

 *TRANSFORMカード（節点のローカル座標系）のサポート 

 

*TRANSFORM,NSET=nset,TYPE=type 

a1,a2,a3,b1,b2,b3 

ここで、タイプが R、S、 Tの場合、（a1、a2、a3）（b1、b2、b3）は、ポイント aと b の座標定義 

nsetは、*TRANSFORM csが適用されるノード・セットです。 

 補語SIM=NOがAbaqus 2016やAbaqus 2017で使用される*FREQUENCYキーワードに追加されました。 

 スーパー要素としての剛性と質量のマトリックス（.mtxフォーマット）をインポートする新しいスクリ

プトが加えられました。これについては、<installdir>¥scripts¥interfaces¥abaqus¥abqrselemx.basを参照して

ください。 

スーパー要素をインポートするために、その剛性マトリックス（名称 xxx_STIF1.mtx）をインポートす

ると、対応する質量マトリックス（名称 xxx_MASS1.mtx）も自動的にインポートされます。abqrselem.bas

では、スーパー要素に参照付けられたノードが定義され、生成されます。 

 ABAQUSの剛体モード計算は、サブスペース・ソルバーで実行されます。しかし、サブスペース・ソル

バーはフリー（未拘束）モデルに対応する 0値あるいは最小周波数を受理しないため、FEMtoolsは自動

的に 0でない値の最小周波数に変更します。この値は、1E-3に固定されましたが、最小周波数のデフォ

ルト値を指定するための新しい設定 interface.abaqus.fminfreeが加えられました。このセッティングは Edit 

> Settings > Data Interfaces > ABAQUS > Minimum Frequency for Free Modelsで変更することができます。

そのデフォルト値は 1E-3です。 

 いくつかの ABAQUS 警告メッセージには単語「エラー」を含んでいます。そのエラーメッセージ例は
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次のとおりです。 

'HIGH CURVATURE、IT MAY LEAD TO SURFACE AREA INTEGRATION ERRORS 

これらのメッセージは、エラーメッセージとして誤って解釈され、FEMtoolsのプロセスを中断させまし

た。そのようなエラーメッセージによってプロセスを中断させないいように、ABAQUSインターフェイ

スが修正されます。 

 FEMtools ABAQUSドライバーは実例をサポートしていません。実例として ABAQUSモデルの「フラッ

ト・モデル」に変える手続きが、FEMtools ドキュメンテーションに加えられました。この手続きは、

ABAQUS インターフェイスおよびドライバーのユーザーガイドで見つけることができます。ABAQUS

データ・ファイル・インターフェイスの保存のセクションを参照してください。 

ANSYSインターフェイスおよびドライバー 

 ANSYSインターフェイスとドライバーは、femtools_abaqusプロダクトコード・ライセンスを要求します。

FEMtools 3 の ANSYSプロダクトコード・ライセンスはそれらが終了まで有効です。 

 ANSYS v18+のサポート 

 CDB リーダは、KEYOPT と KEYOP の変数をサポートします。ANSYS はインポート時の KEYOP と

KEYOPTをサポートします。KEYOPTは ANSYS以外の CDBライターによって生成されるかもしれま

せん。 

LS-DYNA インターフェイスとドライバー 

 新しいアドオン・ツールとして、LS-DYNA 有限要素ソフトウェアとのインターフェイスがサポートさ

れ、感度解析およびモデルアップデーティングのための外部ソルバーとして LS-DYNA を使用すること

ができます。より詳細については、LS-DYNA インターフェイスおよびドライバー・ユーザーガイドを

参照してください。 

 LS-DYNA インターフェイスとドライバーは、プロダクトコード femtools_lsdynaのライセンスを要求し

ます。 

NASTRAN インターフェイスとドライバー 

 MSC.Nastran 2017のサポート 

 NASTRANインターフェイスとドライバーは、、プロダクトコード femtools_nastranのライセンスを要求

します。FEMtools 3の ANSYSプロダクトコード・ライセンスはそれらが終了まで有効です。 

 呼び出しファイルとして別のフォルダーに位置するファイルのインターフェイスがサポートされます。 

 routput4.basスクリプトは、SC.Nastranによって作成された OUTPUT4ファイルをインポートすることが

できます。これは新しい int64データ・タイプを利用します。 

 NASTRANドライバーは縮小ソルバーとして NX Nastranをサポートするために修正されました。 

 MSC.Nastran 2016コンフィグレーション・ファイル（nastxxxxx.rcf）中の MODEセッティングのデフォ

ルト値が、i4から i8に変わりました。これは、FEMtools NASTRANドライバーに関する問題を引き起こ

します。 

 FEMtoolsから、MSC.Nastran2016をスタートするには、nastran.iniファイル中のフラグに'mode=i4'
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を追加しなければなりません。この i4モード指定は、モードが NASTRANコンフィグレーション・

ファイル中の i4と等しくない場合の問題を回避します。 

 検証手続きが NASTRANドライバーに加えられました。MODEが i4と等しくない場合、診断モー

ド（Edit > Run Mode > Diagnostics Mode）で実行される場合、この手続きは警告を生成します。これ

は FEMtools中から、MSC.Nastranを実行する場合の問題を識別するのに有用になります。 

 ドライバー・セッティング、ファイル<installdir>¥scripts¥drivers¥nastran.iniは、MSC.Nastranと NX Nastran

バージョンの形成方法を識別する追加ラインを含んでいます。 

 SOL200 中で適切なパラメータに参照付けるために、スプリング要素は、CELAS2 の代わりに

CELAS1/PELASカードとしてエクスポートされます。 

 BGSETカードがドライバーにサポートされます。 

 要素剛性マトリックスのインポート時のエラーメッセージ「Matrices are too large to store（マトリックス

は大き過ぎるので格納することがでません。）」は、内部記憶装置のスペースを増大させることにより

解決されました。 

SAP2000インターフェイスとドライバー 

 SAP2000インターフェイスとドライバーは、プロダクトコード femtools_sap2000のライセンスを要求し

ます。 

 SAP2000 v18をサポートします。SAP2000 v18インターフェイスはカスタム・セッティングを必要とし

ます。SAP2000 v18の FEMtoolsコンフィグレーション手続きは、SAP2000インターフェイスとドライバ

ー・ユーザーガイドで見つけることができます。 

 FEMtoolsソルバーにサポートされないアクティブなDOF選択を備えたモデルがインポートされる場合、

s2kファイル・リーダは警告メッセージを生成します。 

 OAPIインターフェイスは、以下の新しいパラメータをサポートします。 

 エリア特性パラメータ：薄膜曲げ f11（mf11）、薄膜曲げ f22（mf22）、薄膜曲げ f12（mf12）、曲

げ m11（bm11）、曲げ m22（bm22）、曲げ m11（bm11）、曲げ m22（bm22）、曲げ m12（bm12）、

せん断 v13（sv13）、せん断 v23（sv23）、質量（m）、重量（w） 

 ケーブル特性パラメータ：軸断面積（csa）、質量（m）、重量（w） 

 ColdCフレーム断面パラメータ：外径縦幅（ａ）、外径横幅（b）、リップ厚さ（c）、角半径（r）、

断面厚さ（t） 

 ColdHatフレーム断面パラメータ：外径縦幅（ａ）、外径横幅（b）、リップ厚さ（c）、角半径（r）、

断面厚さ（t） 

 ColdZ レーム断面パラメータ：外径縦幅（ａ）、外径横幅（b）、リップ厚さ（c）、角半径（r）、

断面厚さ（t） 

 連結スプリング剛性パラメータ：U1-U1スプリング剛性（11）、U1-U2スプリング剛性（12）、U2-U2

スプリング剛性（22）、U1-U3スプリング剛性（13）、…、U6―U6スプリング剛性（66） 

 DoubleAngleフレーム断面パラメータ：外側背々距離（dist）、外径深さ（t2）、外径幅（t3）、水

平脚厚さ（tf）、垂直脚厚さ（tw） 

 DoubleChannelフレーム断面パラメータ：外側背々距離（dist）、外径深さ（t2）、外径幅（t3）、
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フランジ厚さ（tf）、壁厚さ（tw） 

 フレーム特性パラメータ：軸断面積（csa）、2方向せん断エリア（sa2）、3方向せん断エリア（sa3）、

ねじれ定数（tc）、2 軸間慣性モーメント（moi2）、3 軸間慣性モーメント（moi3）、質量（m）、

重量（w） 

 プレキャスト I フレーム断面パラメータ：水平断面寸法（b1、…、b4）、底フランジ溝角（f）、縦

断面寸法（d1、…、d6）、壁厚さ寸法（t、t2） 

 プレキャスト Uフレーム断面パラメータ：水平断面寸法（b1、…、b6）、縦断面寸法（d1、…、d7） 

 長方形フレーム断面パラメータ：断面幅（t2）、断面深さ（t3） 

 Tフレーム断面パラメータ:フランジ幅（t2）、断面深さ（t3）、フランジ厚さ（tf）、壁厚さ（tw） 

 台形フレーム断面パラメータ：トップの断面幅（t2）、底断面幅（t2b）、断面深さ（t3） 

 パラメータは値が無指定の場合でも定義されます。その場合のパラメータ値は SAP2000モデルから検索

されます。 

 コマンド SET INTERFACE SAPは SAP2000データ・インターフェイス・セッティングを定義するために

付け加えられました。 

Calculix インターフェイスとドライバー 

 FRFリーダは、短いまたは長い ASCII フォーマットをサポートするために更新されました。 

 ドライバー・プログラム・スクリプト（calculix.bas）は、Windowsと Linux の両方のために更新されま

した。 

 ドライバー・コンフィグレーションは、セッティング・ファイル calculix.ini中で設定されます。 

 例題の..¥examples¥interfaces¥calculixが追加されました。 

ユニバーサル・ファイル・インターフェイスとドライバー 

 デフォルトのインターフェイス・セッティングでは、異なるファイルからインポートされたモードシェ

ープや ODS がデータベースに追加されないか、既存のモードに上書きするように修正されます。FRF

については、appendモードのオンがデフォルトです。この振る舞いは、SET INTERFACE UFFコマンド

あるいは変数 interface.uff.aflagsの設定により修正することができます。 

データベース・マネージメント 

 オイラー角（DEFINE EULERコマンド）を使用したローカル座標系の定義 

 新しいパラメータ D（材料の弾性マトリックス係数とスプリング・スケール係数）：このパラメータは

ビームやスプリング（ゼロ・レングスも含む）と同様にシェルやソリッドの特性を表わすことができま

す。次のデモンストレーション例を参照してください。 

¥examples¥updating¥plate_modal¥run06d.cmd  

 新しいパラメータ KTと KRは、スプリング並進剛性とスプリング回転剛性に関するスケール係数です。

次のデモンストレーション例を参照してください。 

¥examples¥updating¥plate_modal¥run06ktr.cmd 

 PARAMETER TEXTは、Nastranスタイルの倍精度フォーマット（例えば、7.17+10）を読むことができ
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ます。以前は、7.17として読まれていましたが、7.17E+10として読み込まれます。 

 CLEAR SHAPESコマンドが改善されました。このコマンドが実行された場合の警告メッセージも改善さ

れました。 

 ポップ・アップ・メニューから重力荷重（Gravity Loads）を実行した場合、Gravity Loadsテーブルに追

加されない問題を改善しました。 

 コマンド MODIFY FRFが更新され、より多くのオペレーションが解析およびテストの FRFに対して実

行されます。 

 ANALYZE[KEYWORD=VALUE ,...コマンドは、総体的な解析特性を指定するために使用することができ

ます。その API関数 Ft_GetProperties("analyze")はそれらを検索するために使用することができます。 

ユーザー・インターフェイス 

FEMtoolsユーザー・インターフェイスの変更点について概説します。 

メイン・アプリケーション・ウィンドウ 

 デフォルト・スタイルは白い背景（white background）に変わりました。FEMtools 3では、レポート・ス

タイル（report.sty）として知られていました。これが、default.styになり、report.styは削除されました。 

 新しいスタイルとして、FEMtools 4スタイルを FEMtools 3にリセットするための ft3.styが追加されまし

た。 

ツールバー 

 新しいベクトル・ベースのアイコン（SVG） 

 高解像度モニタ（4K）対応の自動的スケーリング・アイコン 

コンソール・ウィンドウ 

 一般に、実行メニュー関数によって生成される FEMtoolsコマンドは小文字のキャラクターが使用されま

す。しかし、少数のメニューには大文字のコマンドが生成されていました。これが改善され、すべての

コマンドは小文字キャラクターを使用して生成されます。 

データベース・エクスプローラー 

 プリテスト解析の変形は、もはや変形シェープとしてではなく、コンター・シェープとして表示されま

す。 

グラフィックス・ピッキング 

 ピッキング・インターフェイスが更新され、新しいアルゴリズムがより正確なピッキング操作のために

導入されました。 

 Graphicsツールバー上の Pickingボタンは、サブメニューに変わってパネルを開きます。Pickingパネル

は、次の機能がサポートされます。 
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 節点と要素、ポイントとトレースラインのピッキングを選択します。その機能は、現在表示されている

メッシュ（FEまたはテスト）タイプに依存します。 

 Single Pick, Polygon Pick, Pick by Face, Pick by Attached などの選択が可能です。 

 アイテムの追加、アイテムの削除、ピッキング・モードの選択などが可能です。 

 ピッキング操作の開始、中断、継続など可能です。 

 セットで選択されたアイテムを保存が可能です。 

 データベース・フィルタを使用し、ピック選択を初期化することが可能です。 

 隠れアイテムのビューをコントロールするために、See-through Element Highlight Mode（透明要素のハ

イライト・モード）を選択することが可能です。 

 

Pickingパネル 

Node-pointペア・ピッキングは、Pickingパネルにおいてもはや利用できません、Node-Point Pairingダイアロ

グボックス（(Tools > Correlation Analysis > Node-Point Pairs)）に追加されます。 
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モードシェープペア・ビューア 

インタラクティブ・モードシェープペア・ビューアが Tools > Correlation Analysisメニューに追加され、Tools 

> Correlation Analysis > Mode Shape Pair Viewerを使用することができます。 

 

インタラクティブ・モードシェープペア・ビューア 

テーブルには現在のモードシェープ・ペアを示します。ペアを選択すると、グラフィックス・ディスプレイ

を更新し、マトリックスビュー中の MAC 値をハイライト化します。 

モードシェープ・ビューを更新するために任意の MAC 値をクリックしてください。ペア・モードは、白い

輪郭を伴って識別されます。モードシェープは適切なスケーリングで表示されます。非ペア・モードも並ん

で表示されます。 
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非ペア・モードシェープ（インタラクティブ・モードシェープ・ペア・ビューア） 

モードシェープ・ペアを強調するには、Create Pairボタンを使用します。するとテーブルとグラフィックス

が更新されます。 

Delete Pair、 Clear All、Auto Pair を使用し、モードシェープ結果をコントロールすることができます。 

インタラクティブ・モードシェープ・ペア・ビューア・パネルを閉じるには、Closeボタンをクリックしてく

ださい。 

メニュー・コマンド 

次のメニュー・コマンドが FEMtools 4に加えられました。 

 Database > Test Model Editor：テスト・モデルのインタラクティブ・エディタ・パネルを開きます。 

 Tools > Pretest Analysis > Mode Participation Maps：プリテスト解析のモード刺激マップを計算します。 

 Tools > Pretest Analysis > Excitation Location Selection：テスト構造モデルの最適加振レイアウトを探索

するパネルを開きます。 

 Tools > Pretest Analysis > Support Location Selection：テスト構造モデルの支持方法やサスペンド最適方

法を見つけるためにプロット表示します。 

 Tools > Correlation Analysis > Mode Shape Pair Viewer：インタラクティブ・モードシェープペア・ビュ

ーアを開きます。 

 Help > License Configurator：ライセンス・コンフィグレーターをアサインします。 

 Help > FEMtools Support Site：FEMtoolsサポートページを開きます。 

 Help > RLM Support Site：RLMサポートページを開きます。 
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 Help > Check for Updates：最新バージョンをチェックします。 

次のメニュー・コマンドが FEMtools 4において、削除されました。 

 View > Graphical Pickingサブメニューは、View > Graphical Pickingメニューによって開く、Picking Panel

に替えられました。 

 メッシュ・ウィンドウのポップ・アップ・メニューのGraphical Pickingサブメニューは、ポップ・アッ

プ・メニューのGraphical Pickingメニューによって開く、Picking Panelに替えられました。 

 グラフィックス・ツールバー中のpickingボタンのサブメニューは削除され、そのボタンは、Pickingを開

きます。 

グラフィックス 

FRFデフォルト・ディスプレイの改善：以前バージョンでは、0 振幅値が検知された場合、Y 軸スケーリン

グを固定されていました。それが改善され、そのスケーリングは中間値または STDベースになります。ログ

（FRF）カーブ・デフォルトの Y 軸下限値はログ（FRF）値のレンジ外消去技術に基づいた中間値（log(FRF)）

-10*std（log’(FRF)）以下になるように決定されます。 

レポーティング 

FEMtoolsデータベースの情報を直接的に MSWord、Powerpoint、Excel、または ASCIIテキストファイルにレ

ポートすることができます。その動作条件としては、Office2013以上が必要です。 

次の機能がコマンドによってサポートされます。 

 新しいセッションの開始：ProgramNameがWORD、POWERPOINT、EXCELの場合、コマンド REPORT 

ProgramName LAUNCHを使用します。 

 既存ドキュメントの開く：ProgramNameが WORD、POWERPOINT、EXCEL、TEXT の場合、コマンド

REPORT ProgramName OPENを使用します。 

 新しいドキュメントを作成：ProgramNameが WORD、POWERPOINT、EXCEL、TEXT の場合、コマン

ド REPORT ProgramName NEWを使用します。 

 セクションまたはスライド・タイトルの追加：ProgramNameがWORD、POWERPOINT、EXCEL、TEXT

の場合、コマンド REPORT ProgramName TITLEを使用します。 

 グラフィック、テーブルのエクスポート：ProgramNameが WORD、POWERPOINT、EXCEL、TEXT の

場合、コマンド REPORT ProgramName MODELを使用します。 

 グラフィック、テーブルとして、シェープ情報（例えば、モードシェープ）のエクスポート：ProgramName

がWORD、POWERPOINT、EXCEL、TEXTの場合、コマンド REPORT ProgramName SHAPEを使用し

ます。 

 新規スライドの追加：コマンド REPORT POWERPOINT ADDSLIDEを使用します。 

 ペア情報（ノード、DOF、モードシェープペア）のエクスポート：ProgramNameがWORD、POWERPOINT、

EXCEL、TEXTの場合、コマンド REPORT ProgramName PAIRを使用します。 

 グラフィック、テーブルとして、マトリックス（例えば、MAC マトリックス）のエクスポート：
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ProgramNameがWORD、POWERPOINT、EXCEL、TEXTの場合、コマンド REPORT ProgramName MATRIX

を使用します。 

 内部セッティングのエクスポート：コマンド REPORT TEXT VARIABLEを使用します。 

 ドキュメントの保存：ProgramNameが WORD、POWERPOINT、EXCEL の場合、コマンド REPORT 

ProgramName SAVEを使用します。 

 ドキュメントを閉じる：ProgramNameがWORD、POWERPOINT、EXCEL、TEXTの場合、コマンドREPORT 

ProgramName CLOSEを使用します。 

 セッションを閉る：ProgramNameが WORD、POWERPOINT、EXCEL の場合、コマンド REPORT 

ProgramName QUITを使用します。 

 レポーティング過程によって生成されたテンポラリファイルの削除：ProgramNameが WORD、

POWERPOINT、EXCELの場合、コマンド REPORT ProgramName RMFを使用します。 

これらの新しいコマンドについての詳細については、FEMtools Command Reference（コマンドリファレンス）

を参照してください。レポーティングの例題は、../examples/reporting/updating フォルダーで見つけることが

できます。 

メッシュ生成 

Lattice（格子）メッシュのポイント間のリレーションを追加することができます。 

 リレーションは、DEFINE FMDRELATIONコマンドによって追加されます。 

 リレーションは、CLEAR FMDRELATIONコマンドによって削除されます。 

 既存のリレーション情報は、EXTRACT FMDRELATIONコマンドによって確認できます。 

テスト・モデル・エディタ 

テスト・モデルのための新しいエディタ・パネルが追加されました。これは、Database > Test Model Editor

から開くことができます。 
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テスト・モデル・エディタ・パネル 

パネルは、タブがつけられたテーブル（左）とグラフィックス・ディスプレイ・エリア（右）の２つで構成

されます。それは、ポイント座標、座標系および接続を編集するように意図されています。 

4 つのタブおよびすべてのオペレーションはポップアップ・メニュー（テーブル内で右クリック）からアク

セスされます。そのメニューは選択されたタブに依存します。各タブについて、以下に記述します。 

Measurement Points（測定ポイント） 

新しい測定ポイントがテーブルに入力されます。Append new pointを使用し、新しいポイントを追加します。

また、ラインあるいはプレート・サーフェイス用の新しいポイントを生成するには、Create new point(s)を使

用します。 

グラフィックス・プロットのポイント・マーカーをクリックすることにより、ポイントを選択するか、Select

メニュー・コマンドを使用することも可能です。 

既存の座標系定義は、選択セルをクリックし編集するか、すべての選択セルにグローバルな変更を加えるこ

とができます。編集操作としては、セル選択後、選択されたセルの 1 つをダブルクリックし、Ctrl キーボー

ド・ボタンを保持し、内容を編集してリターン・ボタンをクリックします。選択されたすべてのセルは同じ

値を示します。この振る舞いは、テスト・モデル・エディタのすべてのテーブルに当てはまります。または、

Edit Selected Pointsメニュー・コマンドを使用してください。 

その他のオペレーションとしては、Number points, Delete Selection, Sort all points, Renumber all points and 

Record point selection in setなどがサポートされます。 
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Measurement Pointsタブの右クリック・メニュー 

 

Add Pointsダイアログボックス 

Coordinate Systems（座標系）タブ 

新しい座標系定義をテーブルに入力するには、Append new itemを使用します。または、各ポイントに対応

する Generate a unique CSか、Define CS referenced by pointsを使用します。 

既存の座標系の定義は各セル中をクリックすることにより編集することができます。補語のプロパティ
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（System, Position & Directions、Rotation groups）も編集することができます。 

CSが定義されたポイントの矢印マーカーを見るには、テーブル中の CS行をハイライト化し、ポイントをク

リックすることによって可能です。CSが定義されている場合、そのマーカーが CS IDを共有するすべてのポ

イントに現われます。 

Sort all item(s)および Renumber all item(s) respectivelyを使用し、行はソートし、再番号付けすることができ

ます。 

 

 

Coordinate Systemタブの右クリック・メニュー 

Connectivities（結線）タブ 

新しい結線の定義方法としては、クリップボード（例えば、MS Excelでの定義）から貼る付けたり、テーブ

ルに入力することができます。それには、Paste from clipboard と Insert after Selectionを使用します。 

既存の結線の編集方法としては、セルをクリックするか、あるいは Number connectivities、Sort all 

connectivities、 Renumber all item(s)などを使用することができます。 

テーブルの行番号（第 1カラム）をクリック選択し、そのクリックを維持したまま、Ctrlと Shiftのキーボタ

ンを一緒にクリックするか、あるいはグラフィックス・ウィンドウ内のインタラクティブ選択によって、複

数の結線を選択することができます。 

結線メンバー・グループを設定するには、グループ ID を編集するか、その結線を選択し、Assign groupを使

用します。また、Group Selectionリストボックスからターゲット・グループを選択し、メンバーにする結線

を選択し、Recordをクリックし、設定することもできます。 
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さらに、Record connectivity selection in a setを使用することもできます。 

 

 

結線タブの右クリック・メニュー 

Connectivity Groups（結線グループ）タブ 

このテーブルでは、結線グループの ID、カラ―、ラベルなどが編集できます。ID は、Connectivitiesタブ中

で使用されるグループ IDに相当します。グループは、Append New Itemメニュー・コマンドで追加すること

ができます。デフォルトのカラ―が新しく追加されたグループに割り当てられます。結線を選択するには、

Connectivitiesタブを使用し、そのグループのメンバーを作成します。 

 

 

結線グループ・タブの右クリック・メニュー 
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解析 

解析モジュールへの変更点について以下に概説します。 

FEMtoolsソルバー 

 モード解析ソルバーのアウト・オブ・コア（out-of-core）のサポート 

デフォルトでは、FEMtoolsソルバーはイン・コア（in-core）ソルバーです。そのため、RAM 容量に制

限があるコンピューターでは、メモリ容量に関するエラーが生じる場合がありました。例えば、モード

解析（Lanczosソルバー）において、次のような典型的なエラーが生じました。 

ERROR : Numerical factorization failed [-2] : Not enough memory 

ERROR : SOLVER failed : No result file. 

この制限を克服するために、アウト・オブ・コア・ソルバーは、部分的に記憶内容をダンプするために

ディスク・スペースを使用します。その場合、大規模モデルサイズの解析速度は、ディスク・アクセス

の性能に依存します。そのため、アウト・オブ・コア・ソルバーモードの使用する場合には、多くのデ

ィスク I/Oに応えるために、より高速なディスクの使用することが推奨されます。 

正規モード解析（Lanczosソルバー）において、２つの新しいアウト・オブ・コア・モードが追加され

ました。 

 選択的アウト・オブ・コア解析（必要とされる超過メモリの動的割り当て） 

 アウト・オブ・コア解析モードに固定 

アウト・オブ・コア・モードはコマンド SET DYNAMICあるいは DYNAMIC で選択されます。 

SET DYNAMIC ... COREMODE int_val .... CORESIZE int_val ...  

DYNAMIC ... COREMODE int_val .... CORESIZE int_val ...  

COREMODE = 1 ：選択的アウト・オブ・コア解析 

COREMODE=2： アウト・オブ・コア解析モードに固定 

選択的アウト・オブ・コアは CORESIZEを使用します。マトリックス係数の格納に必要な総メモリ（メ

ガバイト単位）が、指定された CORESIZE値未満である場合はイン・コア・ソルバーが使用されます。 

 システム・マトリックス縮小機能の改善 

 ダイナミック解析、ダイナミック IRS解析の縮小機能が適切に処理されなかった問題が改善されま

した。 

 GUIインターフェイスの一貫性などに関する問題が改善されました。 

 標準 IRSと反復 IRSのオプションの組み合わせが可能になりました。標準の反復 IRSの縮小を行な
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うためには、Number of Iterations = 1を使用します。 

デジタル信号処理（DSP） 

DSP機能は、以下のよう更新されました。 

 プロットには FIT 補完関数が使用されます。信号が DC成分を持つ場合、その信号は適切にプロットさ

れます。 

 DSP CURVEコマンドで生成されたカーブは、データベース・エクスプローラーで生成したカーブと同

一タイトルになります。 

 コマンド DSP RESAMPLEと DSP UPSAMPLEが追加されます。 

ダイナミクス 

 マスターDOF選択に利用できる K/M 比を計算する新しいコマンド 

スーパー要素解析 

 CONDENSEコマンドのコンソール・フィードバックが改善されました。 

モーダル・バース・アセンブリ（MBA :Modal-Based Assembly） 

 モーダル・バース・アセンブリは、コンポーネント間の剛結合をサポートします。剛結合は、Rigid 

Connections as Coupling Method in the Modal Based Assembly Settingsダイアログ・ウィンドウ（メイン・

メニューのTools > Modal Based Assembly > Settings）あるいは、SET MBA COUPLING RIGIDコマンドを

使用し、アクティブにすることができます。剛結合カップリングの使用方法をスクリプ

ト ../examples/dynamic/mba/fea_substructure/ mba_fea_rigid.cmdで例証します。その例題は、FEMtools 

Dynamics User’s Guide（ダイナミクス・ユーザーガイド）で解説されます。 

プリテスト解析 

センサー選択ツール 

 EIM ベースのセンサー選択が改善されまました。 

 安定化手続き（stability procedure）は、センサー数がモードの数より少ない場合のために改善され

ました。 

 センサー数が 0の場合、エラーメッセージを出力します。 

 SEAMACベースのセンサー選択が改善されました。 

 SEAMACベースのセンサー選択は、1軸センサーのみまたは正規表面のセンサーで適応されます。 

 IGRベースのセンサー選択が改善されました。 
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 IGR手続きは、センサー数が 0の場合エラーメッセージを出力します。 

 NMD ベースのセンサー選択が改善されました。 

 NMD ベースのセンサー選択は正規表面のセンサーにおいて適応されます。 

 CLEAR NMDコマンドが改善されました。 

 NKEベースのセンサー選択が改善されました。 

 正規表面の NKEの計算がシェル・モデルにおいてサポートされます。 

 CLEAR NKEコマンドが改善されました。 

手動および自動のセンサー選択 

次の修正が、Manual Sensor Selection パネル （Tools > Pretest Analysis > Manual Sensor Selection）に行われ

ました。 

 Show Sensor Node NumberingオプションがPlot Settingsに追加されました。これは選択されたセンサー位

置のノード番号を迅速に識別することを可能にします。 

次の修正および拡張が、Automated Sensor Selection パネル（Tools > Pretest Analysis > Automated Sensor 

Selection）に行われました。 

 maximum’ metricオプションが削除されました。このオプションは、単に支持またはサスペンションの位

置選択に利用できました。 

 Candidate Sensor Location（候補センサー位置）のPreviewボタンは、Show Candidatesボタンに替えられ

ました。これは、選択したプリテスト技術、プリテスト・トリック（適用可能な場合）、ノード選択と

最小距離の指定に基づく選択候補位置数を確認することが可能になりました。 

 Show Sensor Node Numberingオプションが、Plot Settingsセクションに追加されました。これは選択され

たセンサー位置のノード番号を迅速に識別することを可能にします。 

モード刺激解析（MPA:Mode Participation Analysis） 

 モード刺激解析（MPA）が改善されました。 

 多くの入力 DOFを考慮する場合、メモリ容量と CPU時間の縮小を可能にするため、MPAのインプリメ

ンテーションが改善されました。 

 EXAMINE MPA コマンドのコンソール出力が改善されました。MPAデータは、5つの入力 DOFのブロ

ック中で示されます。これは、多くの入力 DOFを考慮する場合のデータ検査を容易にします。 

 モード刺激解析は、モードの特定セットに対して実行することができます。これは、Mode Participation 

AnalysisダイアログボックスのCandidate Modesドロップダウンリストを使用するか、EXAMINE MPAコ

マンドの新しいMODE補語を使用して行うことができます。 

 MPA結果に基づいた自動セット生成がユーザー・インターフェイスでサポートされます。それには、

Create Target Mode Select Setsチェックボックスをチェックし、セット生成基準を選択します。 
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 それはすべての並進DOFを使用し、また、メッシュ・プロットによって結果を確認し、MPAを実行する

ことができます。そのモード刺激マップは、メイン・メニューからTools > Pretest Analysis > Mode 

Participation Map (MPM) を選択するか、EXAMINE MPMコマンドを使用することによって計算されま

す。モード刺激マップはポテンシャル加振位置を識別するために使用することができます。MPM結果は

EXTRACT MPMコマンドを使用してコンソール・ウィンドウに出力することができます。また、CLEAR 

MPMコマンドを使用して消去することができます。 

 新しい EXAMINE SPAMPAコマンドは、最適の加振位置を識別するためにモード刺激マップを使用しま

す。 

Excitation Location Selection（加振位置選択）の新しいツール 

Excitation Location Selectionパネル（Tools > Pretest Analysis > Excitation Location Selection）が追加されまし

た。このパネルは次の機能をサポートします。 

 NMD、NKE、MPAマップに基づいた最適加振位置を識別します。 

 手動で既存の加振位置選択を微調整するか、手動で FEメッシュ・プロット上のピッキング DOF操作に

よって加振位置選択を作成することができます。 

 モード刺激解析（MPA）を使用し、現在の加振位置選択を評価することができます。 

最適サポート選択用の新しいツール 

 最適サポート位置選択マップを供給するNMDとNKEのデータを処理する新しいツールが追加されまし

た。これらのマップを生成するには、メイン・メニューから、Tools > Pretest Analysis > Support Location 

Selectionを選択するか、あるいは EXAMINE SUPPORTコマンドを使用します。 

相関分析 

 EXAMINE MPFコマンドが改善されました。 

 FILE 補語は削除されました。この補語は他のコマンドのシンタックスと一致していませんでした。

結果をエクスポートするには、EXPORT MATRIXコマンドを代わりに使用してください。 

 FRFの存在を確認するチェックは加えられました。 

 コンソール・フィードバックが改善されました。 

 EXAMINE NSEコマンドが改善されました。 

 プロット名前が修正され、Nodal Strain EnergyがFEA Normal Modesに取って代わりました。 

 コンソール・フィードバックは改善されました。 

 EXTRACT NKEコマンドが修正されました。 

 FEMtoolsコマンド言語と一致していなかったため、その UPPERと LOWERの補語は削除されまし

た。 
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 EXTRACT NMDコマンドが修正されました。 

 FEMtoolsコマンド言語と一致していなかったため、その UPPERと LOWERの補語は削除されまし

た。 

 グラフィック・ピッキングによるノード/ポイント・ペア定義が、Node-Point Pairに追加されました。こ

れはピッキングニューではもはや利用できません。グラフィック・ピッキングを介して。ノード/ポイン

ト・ペアを作成するには、Node-Point Pairダイアログボックス（Tools > Correlation Analysis > Node-Point 

Pairs）を開き、Graphical Picking of Node-Point Pairsオプションを選択し、OKボタンをクリックします。

これはピッキング・モードでNode/Point Pairプロットを開きます。新しいノード/ポイント・ペアを作成

するには、最初にノードを選択し、次にポイントを選択します。ピッキングを中断するには、単にノー

ド/ポイント・ペア・プロットを閉じてください。 

 Auto-EVOの計算は、コマンドEXAMINE EVOを使用するか、あるいはダイアログボックス（Database > 

Verify > Auto -EVO…）から実行されます。マスターDOFとしては、縮小されたFEA-to-FEA（非ペアDOF）

が必要になります。また、Normalizeボタンは削除され、デフォルト（=NORMALIZE ON）のUse Normalized 

Mode Shapesが使用されます。 

 手動でのモードシェープ・ペアリングは、インタラクティブ・モードシェープ・ペア・ビューアで定義

することができます。それには、Tools > Correlation Analysis > Mode Shape Pair Viewerを使用します。  

感度解析とモデルアップデーティング 

 新しいパラメータ D（材料の弾性マトリックス係数とスプリング・スケール係数）：このパラメータは、

ビームとスプリング（ゼロ・レングスを含む）およびシェルとソリッドのプロパティを表わすことがで

きます。次のデモンストレーション例を参照してください。 

¥examples¥updating¥plate_modal¥run06d.cmd  

 新しいパラメータ KT と KR は、スプリング並進剛性とおよびスプリング回転剛性のスケール係数を表

します。次のデモンストレーション例を参照してください。 

¥examples¥updating¥plate_modal¥run06ktr.cmd  

Design of Experiments（実験計画法） 

 テキストファイル（Tools > Design of Experiments > Export DOE Data）に関するDOEサンプルのエクス

ポートが改善されました。 

Optimization（最適化） 

トポメトリー（topometry）の最適化モジュールが改善されました。 

 トポメトリーの最適化の例題の詳細が、FEMtools Optimization User’s Guide（最適化ユーザーガイド）に

追加されました。 

 分散厚さのトポメトリーの最適化は、最小 FRFレベル設計問題に利用可能です。 

 トポメトリーの最適化オプティマイザーは、ポスト処理においての初期厚さ値が許可された厚さ範囲の
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上限と同じだった場合の結果に関するエラーを生成しません。 

 コンソール出力で報告された分散品質指数が改善されました。 

モーダル・パラメータエクストラクター・アドオン 

デジタル信号処理（DSP）、DOFリレーションとチャンネル、windowingのコマンドは、FEMtoolsフレーム

ワークで含まれ、FEMtools MPEのライセンスなしで利用可能です。これは以下のコマンドに関係します。 

DSP CURVE, DSP DECIMATE, DSP DETREND, DSP FILTER, DSP FINDDEADCHANNELS, DSP 

FINDREFERENCES, DSP INFO, DSP RESAMPLE, DSP SPECTRUM, DSP UPSAMPLE, DSP WINDOW, DSP 

XPS, APPLY DOF RELATION, CLEAR DOF RELATION, DEFINE DOF RELATION, EXTRACT DOF 

RELATION CLEAR CHANNEL, CLEAR WINDOW, DEFINE CHANNEL, DEFINE WINDOW, EXTRACT 

CHANNEL, EXTRACT WINDOW 

APPLY DOF RELATION、CLEAR DOF RELATION、DEFINE DOF RELATION（EXTRACT DOF RELATION） 

 

CLEAR CHANNEL, CLEAR WINDOW, DEFINE CHANNEL, DEFINE WINDOW, EXTRACT CHANNEL, 

EXTRACT WINDOW 

剛体特性エクストラクター・アドオン 

 ユーザー・インターフェイスに次の修正が加えられました。 

 周波数レンジが修正された場合、加振テーブルの RBエラー係数も更新されます。 

 レスポンス選択が変更された場合、加振テーブルの条件番号も更新されます。 

 FRFプロット上の周波数レンジ選択は、加振選択の修正によっても消えません。 

 非アクティブの加振が復活した場合、レスポンス選択も回復されます。 

 加振がすべて非アクティブになった場合、レスポンス・テーブルは無効になります。 

 選択 FRFをサポートするために、RBPE COMPUTEコマンドに追加されました。 
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FEMtoolsコマンド 

FEMtoolsコマンド言語はいくつかの新しいコマンドが拡張されましたす。また、既存のコマンドが増強され

ました。そのすべての情報について、FEMtoolsヘルプの FEMtools Command Referenceで参照することができ

ます。 

新しいコマンド 

このセクションは、FEMtools 4で利用可能な新しいコマンドについて記述します。 

CLEAR FMDRELATION フリーメッシュ変形（FMD）リレーションを消去します。 

CLEAR MPM モード刺激マップシェープを消去します。 

CLEAR NKE Normalized Kinetic Energy（正規化運動エネルギ）シェープ

を消去します。 

CLEAR NMD Normalized Modal Displacement（正規化モーダル変位）シェ

ープを消去します。 

DEFINE FMDRELATION フリーメッシュ変形（FMD）リレーションを定義します。 

DEFINE EULER オイラー角度を使用したローカル座標系を定義します。 

DSP RESAMPLE 再サンプリング時刻歴 

DSP UPSAMPLE  アップ・サンプリング時刻歴 

EXAMINE MPM 加振位置選択用のモード刺激マップを計算します。 

EXAMINE SPAMPA モード刺激解析マップを使用した最適加振位置を識別しま

す。 

EXAMINE SUPPORT 最適支持位置選択用マップを生成します。 

EXTRACT FMDRELATION フリーメッシュ変形（FMD）情報を出力します。 

EXTRACT MPM モード刺激マップ結果を出力します。 

FORM、 フォームをロードします。 

REPORT EXCEL CLOSE MS EXCELドキュメントを閉じます。 
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REPORT EXCEL LAUNCH 新しい MS EXCELセッションを開始します。 

REPORT EXCEL MATRIX アクティブなMS EXCELドキュメントにマトリックスを出

力します。 

REPORT EXCEL MODEL アクティブなMS EXCELドキュメントにモデルを出力しま

す。 

REPORT EXCEL NEW 新しい MS EXCELドキュメントを作成します。 

REPORT EXCEL OPEN 既存の MS EXCELドキュメントを開きます。 

REPORT EXCEL PAIR アクティブなMS EXCELドキュメントへペア情報を貼り付

けます。 

REPORT EXCEL QUIT MS EXCELセッションを閉じます。 

REPORT EXCEL SAVE アクティブな MS EXCELドキュメントを保存します。 

REPORT EXCEL SHAPES アクティブなMS EXCELドキュメントへシェープを出力し

ます。 

REPORT EXCEL TITLE アクティブなMS EXCELドキュメントにタイトルを加えま

す。 

REPORT POWERPOINT ADDSLIDE 新しい空のスライドを加えます。 

REPORT POWERPOINT CLOSE MS POWERPOINT・ドキュメントを閉じます。 

REPORT POWERPOINT LAUNCH 新しい MS POWERPOINTセッションを開始します。 

REPORT POWERPOINT MATRIX アクティブなプレゼンテーションにマトリックスを出力し

ます。 

REPORT POWERPOINT MODEL アクティブなプレゼンテーションにモデルを出力します。 

REPORT POWERPOINT NEW 新しいプレゼンテーションを作成します。 

REPORT POWERPOINT OPEN 既存のプレゼンテーションを開始します。 

REPORT POWERPOINT PAIR アクティブなプレゼンテーションへのペア情報を出力しま

す。 

REPORT POWERPOINT QUIT MS POWERPOINTセッションを閉じます。 
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REPORT POWERPOINT RMF レポーティング過程のテンポラリファイルを削除します。 

REPORT POWERPOINT SAVE アクティブなプレゼンテーションを保存します。 

REPORT POWERPOINT SHAPES アクティブなプレゼンテーションへシェープを出力します。 

REPORT POWERPOINT TITLE 現在のスライドのタイトルをセットします。 

REPORT TEXT CLOSE ASCIIドキュメントを閉じます。 

REPORT TEXT MATRIX アクティブな ASCII ドキュメントにマトリックスを出力し

ます。 

REPORT TEXT MODEL アクティブな ASCIIドキュメントにモデルを出力します。 

REPORT TEXT NEW 新しい ASCIIドキュメントを作成します。 

REPORT TEXT OPEN 既存の ASCIIドキュメントを開きます。 

REPORT TEXT PAIR アクティブな ASCII ドキュメントへペア情報を出力します。 

REPORT TEXT SHAPES アクティブな ASCII ドキュメントへシェープを出力します。 

REPORT TEXT TITLE アクティブな ASCIIドキュメントにタイトルを加えます。 

REPORT TEXT VARIABLE アクティブな ASCII ドキュメントに内部セッティングを出

力します。 

REPORT WORD CLOSE MS Wordドキュメントを閉じます。 

REPORT WORD LAUNCH 新しい MS Wordセッションを開始します。 

REPORT WORD MATRIX アクティブな MS Word ドキュメントにマトリックスを出

力します。 

REPORT WORD MODEL アクティブな MS Word ドキュメントにモデルを出力しま

す。 

REPORT WORD NEW 新しい MS Wordドキュメントを作成します。 

REPORT WORD OPEN 既存の MS Wordドキュメントを開きます。 

REPORT WORD PAIR アクティブな MS Word ドキュメントへペア情報を出力し

ます。 
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REPORT WORD QUIT MS Wordセッションを閉じます。 

REPORT WORD RMF レポーティング過程のテンポラリファイルを削除します。 

REPORT WORD SAVE アクティブな MS Wordドキュメントを保存します。 

REPORT WORD SHAPES アクティブな MS Word ドキュメントへシェープを出力し

ます。 

REPORT WORD TITLE アクティブな MS Word ドキュメントにタイトルを加えま

す。 

SET INTERFACE SAP SAP2000データ・インターフェイスのためのデータ・イン

ターフェイス・セッティングを定義します。 

修正済のコマンド 

このセクションは、コマンドへの変更点について記述します。 

DEFINE SELEM 補語 GE、ALPHA、BETA が構造（Structural）減衰および

レーリー粘性（Rayleigh viscous）減衰を定義するために付

け加えられました。 

DEFINE SET 補語 ATTACHED は現在のアイテムに選択アイテムを追加

します。 

EXAMINE MPA  補語 MODEがモード選択を指定するために追加されます。 

EXAMINE MPF 補語 FILEは旧式のため削除されます。 

EXTRACT NKE  補語 UPPERと LOWERは削除されます。 

EXTRACT NMD  補語 UPPERと LOWERは削除されます。 

GUI スタイル SGI、MOTIFPLUS、PLATINUM、TITANIUM、

XPは、もはやサポートされません。 

スタイル CLEANLOOKS、PLASTIQUE、WINDOWSVISTA

およびWINDOWSXPが加えられました。 

MODIFY MBA SUBSTRUCTURE 補語 Bは、吸収器の減衰特性を修正するために追加されま

す。それは、DAMPING補語の別名になります。 

MODIFY MBA SUBSTRUCTURE 補語 B1、B2、B4、B5が減衰修正要素（グランド間）の減

衰特性を修正するために追加されました。 
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MODIFY MBA SUBSTRUCTURE  補語 K1、K2、K4、K5がスプリング修正要素（グランド間）

の剛性特性を修正するために追加されました。 

SET MBA  補語 COUPLINGに伴う SET MBA A RIGID値が追加されま

した。 

FEMtoolsスクリプト 

FEMtoolsスクリプト言語は新しい機能を伴って拡張されました。全ての情報は、FEMtoolsヘルプの FEMtools 

APIリファレンスを参照できます。 

新しいスクリプト関数 

このセクションは新しい FEMtoolsスクリプト関数について記述します。 

一般関数 

Do … Loop  Doループを追加する。 

For … Next  For繰り返しを追加する。 

ScreenSize  モニター・スクリーンのピクセルサイズ(x,y)を返します。 

Dictionary Object（辞書オブジェクト） 

.Add 辞書オブジェクトにアイテムを追加します。 

.CompareMethod 辞書オブジェクト中の比較ストリング・キーの比較方法を

設定または検索が実行されます。 

.Count 辞書中のアイテム数を数えます。 

.Exists 辞書アイテムが存在するか否か識別します。 

.Item 辞書オブジェクトのアイテムを修正または検索が実行され

ます。 

.Items 辞書オブジェクトからアイテムをすべて検索し、異なる配

列にそれらを格納します。 

.Key アイテムのキーを修正します。 

.Keys 辞書オブジェクトに格納されたすべてのアイテムの名前の



 

40 

リストを返します。 

.Load Matlab 5と互換データ・ファイルの辞書をロードします。 

.Remove 辞書オブジェクトからアイテムを取り除きます。 

.RemoveAll 辞書オブジェクトからアイテムをすべて取り除きます。 

.Save Matlab 5と互換データ・ファイルの辞書を保存します。 

修正済スクリプト関数 

このセクションは、FEMtoolsスクリプト関数の変更点について記述します。 

CreateObject 辞書オブジェクトを作成するための入力値’dictionary’をサ

ポートします。 

RmDir ステートメントあるいは関数として呼び出すことができま

す。 

FEMtools API 

FEMtools APIのいくつかの新しい関数が拡張され、また、既存の関数が増強されました。全ての情報に関し

ては、FEMtoolsヘルプの FEMtools API Referenceから参照することができます。 

新しい FEMtools API 関数 

Ft_CheckOutFeature 解析機能のライセンスが有効かどうかチェックします。 

Ft_FormCommand フォームにコマンドを送ります。 

Ft_GetForm フォームから情報を得ます。 

Ft_GetProperties ANALYSE コマンドへの引き数を渡します。 

Ft_LoadForm フォームベースのダイアログボックスかパネルを開きます。 

Ft_SetForm フォームに情報を送ります。 

修正済の FEMtools API 関数 

このセクションは、FEMtools API関数の変更点について記述します。 

Ft_GetItemList この関数が返すことができる要素リストに基づくノードリ

ストを返します。Ft_GetItemList(ST_NODE, "ELEMENT", 
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elist)のように使用します。 

Ft_HasFeature この関数は、もはや重要な機能ではありません。ただし、

利用可能なライセンス数が>0 かどうかをチェックします。

これは、単に有効な機能の数を計算するようなチェックに

使用されます。Ft_HasFeatureは常に真値（True）を返し、

機能がセッション間で有効かどうかチェックします。 

Ft_HostInfo 付属の Safenet HASP HLドングル情報をレポートするため

の引数’hl’をサポートします。 

Ft_ProductInfo 引数’server’をサポートします。 

Ft_SendWindowCommand 引数’Activate’がターゲット MDI ウィンドウをアクティブ

にするために付け加えられます。 

Ft_SetGUIStyle GUIスタイルとして、sgi, motifplus, platinum, titanium, xpは、

もはやサポート対象外ですが、 cleanlooks, plastique, 

windowsvista and windowsxpが加えられました。 

新しい API 環境変数 

スカラーとストリング 

interface.abaqus.fminfree ABAQUSのサブスペース・ソルバーを使用し、剛体モード

シェープを計算するための最小周波数を指定します。 

interface.show.extra FEアプリケーション（Algor, Femap, MSC.Marc,…）のファ

イルの拡張子を出力します。それらの拡張子はファイルイ

ンポート・ダイアログボックスに含まれています。デフォ

ルトでは、それらは定義されていません。 
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