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 i  

  めにࡌࡣ 

  についてࣝ࢔ࣗࢽ࣐

 ࠋࡍ࡛ࡢࡶࡓࡋい࡚記述ࡘ࡟び訂ṇࡼ࠾機能強化ࠊい機能ࡋ新ࡿࡅ࠾࡟FEMtoolsࠊࡣࢺン࣓ࣗ࢟ࢻࡢࡇ

関連ࢻキ࣓ࣗンࢺ 

 ࠋいࡉࡔࡃ࡚ࡋ参照ࡶࣝ࢔ࣗࢽ࣐ࡢ௚ࡢࡑࠊࡣࣝ࢔ࣗࢽ࣐ࡢࡇ

  使用方法ࡢࢺキ࣓ࣗンࢻ

FEMtools࣓ࣗ࢟ࢻࡢンࠊࡣࢺHTML࡟基࡙いࡼ࠾ࣉࣝ࣊ࡓび PDF࣐࡚ࡗࡼ࡟ࣝ࢔ࣗࢽ利用࡛ࠋࡍࡲࡁ 

 ࠋいࡉࡔࡃ࡚ࡋ選択ࢆࢡࢵࣆࢺࣉࣝ࣊ࡽ࠿࣮ࣗࢽ࣓࣭ࣉࣝ࣊ࠊࡣ࡟ࡿࡍࢫࢭࢡ࢔࡟ࣉࣝ࣊

 ࣐ࡢࣝ࢔ࣗࢽ目次ࢆ参照ࠊࡣ࡟ࡿࡍContentsࢆࣈࢱ使用ࡉࡔࡃ࡚ࡋいࠋ 

 索引㡯目ࣜࢆࢺࢫ参照ࠊࡣ࡟ࡿࡍIndexࢆࣈࢱ使用ࡉࡔࡃ࡚ࡋいࠋ 

 ࠋࡍࡲࡋ準ᣐ࡟࣒ࢸࢫࢩ࣭ࢢン࢕ࢸ࣮ࣞ࣌࢜ࡣい࡚ࡘ࡟௙様ࡢࣈࢱࡢ௚ࡢࡑ

࡟ࡵࡓࡴㄞࢆࣝ࢖࢓ࣇPDFࠋいࡉࡔࡃ࡚ࡋ選択ࢆManualsࡽ࠿࣮ࣗࢽHelp࣓ࠊࡣ࡟ࡿࡍࢫࢭࢡ࢔࡟ࣝ࢔ࣗࢽ࣐
ࡣ Adobe Acrobat Reader࢖ࢆンࠋࢇࡏࡲࡾ࡞ࡤࢀࡅ࡞ࡋ࣮ࣝࢺࢫ 

FEMtoolsࢻキ࣓ࣗンࢺに࠾いて使用さࡿࢀ規則 

FEMtools࣐ࠊࡣࣝ࢔ࣗࢽ視覚的࡟情報ࢆ識別࡟ࡢࡿࡍ便利ࡼ࡞うࠊ࡟いࡢ࠿ࡘࡃ規則ࢆ設࡚ࡅいࠋࡍࡲ 

                     記号          用途ࡣࡓࡲࣝ࢖ࢱࢫࡢࣉ࢖ࢱ
extract nodes FEMtools ࣐ࢥン࢖ࣛࢻンࡢ例 
SET ECHO FEMtools ࣐ࢥン࣐ࢥࡣࡓࡲࢻンࡢࢻ構文 
Settings ࣓࣐ࢥ࣭࣮ࣗࢽンࢻ 

 ࠋࢇࡏࡲࡾ限ࡣ࡜ࡿࢀࡉ適用ࡶࡋࡎ必ࠊࡣい࡚࠾࡟ࢺン࣓ࣗ࢟ࢻ᪥本語ࡣ規則ࡢࡇ ※

統一性࡜ Linuxࡢ࡛࣒࣮࢛ࣇࢺࢵࣛࣉ大文Ꮠ／ᑠ文Ꮠࡢ区別ࢆ考慮ࠊ࡚ࡋFEMtools࣐ࢥン࠾࡟ࢺࣉࣜࢡࢫ࣭ࢻ
ࢻࡢFEMtoolsࠊࡋ࠿ࡋࠋࡍࡲい࡚ࢀࡉ使用ࡀᑠ文Ꮠ࡚ࡋ対࡟㸧ྡࣝ࢖࢓ࣇ࡟引数㸦特࡜ࢻン࣐ࢥࡢ࡚࡭ࡍࡿࡅ
࣓࢟ࣗンࠊࡣ࡛ࢺㄞࡳ易࣐ࢥ࡟ࡵࡓࡿࡍࡃンࡣࢻ通常大文Ꮠ࡛記࡚ࢀࡉいࠋࡍࡲ 
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FEMtools 4 について 

FEMtools 4ࠊࡣFEMtools࣒࣮ࣞࣇワ࣮ࡼ࠾ࢡびࡢࡑ௚ࣙࢩ࣮ࢣࣜࣉ࢔ࡢ࡚࡭ࡍࡢン࣭ࣔࡼ࠾࣮ࣝࣗࢪび࢜ࢻ࢔
ン࣭ࡢ࣮ࣝࢶ新ࣙࢪ࣮ࣂン࡛ࠊࡓࡲࠋࡍFE࢖࣭ࢱ࣮ࢹンࡼ࠾ࢫ࢖࢙ࣇ࣮ࢱびࡣࣂ࢖ࣛࢻ FEࡢ࣒ࣛࢢࣟࣉ現行版
 ࠋࡍࡲࢀࡉ更新࡟ࡵࡓࡿࡍࢺ࣮࣏ࢧࢆ

FEMtools 4ࣙࢪ࣮ࣂンࢆࢺ࢖ࣛ࢖ࣁࡢ以ୗ࡟要約ࠋࡍࡲࡋ 

 Windows 64-bit࣒࣮࢛ࣇࢺࢵࣛࣉ㸦710ࠊ8ࠊ㸧ࠊLinux 64-bit RHEL6+ ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆ 
 新ࠕCheck for Updates࣒ࠖࣛࢢࣟࣉ自動更新機能 
 ࣛࢭ࢖ンࢥ࣭ࢫン࣮ࢱ࣮ࣞࢢ࢕ࣇ㸦ࢺࢵࢿࠊࢡࢵࣟࢻ࣮ࣀワ࣮࣑࣮ࣟࠊࢡンࢢ㸧ࡢ更新 
 最新࣋ࢥ࢖࢔࣭ࢫ࣮࣭࣋ࣝࢺࢡン㸦SVG㸧ࡢᑟ入 
 高解像ᗘࣔࢱࢽ㸦4K㸧ࢥ࢖࢔ࡢ࡬ン自動対応 
 新࢖ࠕンࠖࢱ࢕ࢹ࢚࣭ࣝࢹ࣭ࣔࢺࢫࢸ࣭ࣈ࢕ࢸࢡࣛࢱ 
 ࢟ࢵࣆ࣭ࢡࢵ࢕ࣇࣛࢢンࢢ機能ࡢ改良㸦表示用࢟ࢵࣆンࠊࢢFace࢟ࢵࣆン࢟ࢵࣆ࣭ࢻࢳࢵࢱࢵ࢔ࠊࢢンࢢ㸧 
 最適化࣭ࣞࢫࢡࢵ࢕ࣇࣛࢢンࣜࢲン࢚࣭ࢢンࢪン㸦v4.1㸧 
 新ࣝࢱࢪࢹࠕ信号処理㸦DSP㸧࣐ࢥンࠖࢻ 
 時系列ࡼ࠾ࠖࣝࢿࣕࢳ࣭ࢱ࣮ࢹࠕび࢘࢕ン࢘ࢻ関数ࢆ定義ࡢࡵࡓࡿࡍ新ࡋい࣐ࢥンࢻ 
 2D࡜ 3Dࡢ要素ࡢෆ部計算࢖ࠊࢱ࣮ࢹン࢖࣭ࢫ࢖࢙ࣇ࣮ࢱン࣏࣮࢖࣭ࢱ࣮ࢹࠊࢱ࣮ࢹ࣭ࢺンࡢࢫ࢖࢙ࣇ࣮ࢱ

Strainࢸン࡜ࣝࢯ Stressࢸンࢺ࣮࣏ࢧࡢࣝࢯ㸦v4.1㸧 
 AbaqusࠊAnsysࠊNastranࠊSAP2000ࡢ最新ࣙࢪ࣮ࣂン対応 
 静的変఩ࠊStrain࡟関ࡿࡍ AbaqusࠊAnsysࠊNastran࢖ンࡼ࠾ࢫ࢖࢙ࣇ࣮ࢱびࡢࣂ࢖ࣛࢻ追加ࢺ࣮࣏ࢧ㸦v4.1㸧 
 Abaqus SIMࡢࣝ࢖࢓ࣇ新ࡋい࢖ンࢫ࢖࢙ࣇ࣮ࢱ㸦v4.0.1㸧 
 LS-DYNA᭷限要素ࡢࢪ࣮ࢣࢵࣃ新ࡋい࢖ンࢫ࢖࢙ࣇ࣮ࢱ 
 ࣓ࣔࣜ制御用ࡢ新ࠕout-of-core solverࠖ࢜ࣙࢩࣉン 
 FEMtoolsࡢ࣮ࣂࣝࢯ ILP64㸦8ࢺ࢖ࣂ㸧整数࢖ンࢫࢡࢵࢹ対応：ILP64ࡣᣑ張࣏࢖ン࢖࣭࣮ࢱンࡼ࡟ࢫࢡࢵࢹ

 㸦v4.1㸧ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆࢺࢵࢭࢱ࣮ࢹ࡞膨大ࡿ
 質量荷重感ᗘ㸦MLS: Mass Loading Sensitivity㸧新計算࣮ࣝࢶ 
 ่࣮ࣔࢻ激係数࣐ࣉࢵ㸦MPM:Mode Participation Maps㸧新計算࣮ࣝࢶ 
 加振ࡼ࠾び支持఩置ࡢ新ࡋい選択࣮ࣝࢶ 
 ࢖ンࡢ࢔࣮ࣗࣅ࣭࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮࣭ࣔࣈ࢕ࢸࢡࣛࢱ更新 
 相関ศ析ࠊ感ᗘ解析࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔࠊンࡿࡅ࠾࡟ࢢ Strain࣏ࣞࢫンࢺ࣮࣏ࢧࡢࢫ㸦v4.1㸧 
 RSM逆算࡜検証ࡢࡵࡓࡢ新ࡋい࣐ࢥンࢻ 
 最ᑠ FRFࣞ࣋ࣝ設計ࡢ࣮ࣜࢺ࣓࣏ࢺࡢࡵࡓࡢ最適化 

主ࣙࢪ࣮ࣂ࡞ン࣭࣮ࣜࣜࢫᒚ歴 

V4.0.0.1830      June 2017  
V4.0.1.1850 to v4.0.1.1885   December 2017 – April 2019  
V4.1.0       May 2019 
V4.1.1      December 2019 
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FEMtools 4ࢻキ࣓ࣗンࢺとࢽ࣮ࣞࢺンࢢ 

FEMtools࣓ࣗ࢟ࢻンࢡࢵࣈ࣭࣒ࢸࢫࢩࠊࢺ࣮ࣀ࣭ࢫ࣮ࢥࠊࣉ࣭࣒ࣝ࣊ࢸࢫࢩࡣࢺ㸦PDF㸧ࡼ࠾び出力物࢔ࣗࢽ࣐ࡢ
࡛ࣝ構成࣓ࣗ࢟ࢻࡢ࡚࡭ࡍࠋࡍࡲࢀࡉンࡀࢺ現ᅾࣙࢪ࣮ࣂ࣭ࢫ࣮ࣜࣜࡢン用࡟更新࡚ࢀࡉいࠋࡍࡲ 

 概説ࢺキ࣓ࣗンࢻ

FEMtools 4࣓ࣗ࢟ࢻンࡣࢺ次࣓ࣗ࢟ࢻࡢン࡛ࢺ構成ࠋࡍࡲࢀࡉ 

 FEMtools 4 Release Notes㸦࣮ࣜࣜࢺ࣮ࣀ࣭ࢫ㸧：ࠊࡣࣝ࢔ࣗࢽ࣐ࡢࡇFEMtools 4.0ࡢ新ࡋい特徴ࢆ紹௓ࠊࡋ従
来ࣙࢪ࣮ࣂンࢻ࣮ࣞࢢࣉࢵ࢔ࡢࡽ࠿方法ࡘ࡟࡝࡞い࡚解ㄝࠋࡍࡲࡋ 

 FEMtools 4 Getting Started Manual㸦ᑟ入࣐ࣝ࢔ࣗࢽ㸧：࢖ࠊࡣࣝ࢔ࣗࢽ࣐ࡢࡇンࢭ࢖ࣛࠊ࣮ࣝࢺࢫンࢿ࣐࣭ࢫ
 ࠋࡍࡲࡋい࡚解ㄝࡘ࡟形成方法ࢆFEMtoolsࠊ起動ࠊࢺン࣓ࢪ࣮

 FEMtools 4 Framework User's Guide㸦࣒࣮ࣞࣇワ࣮ࢻ࢖࣮࢞ࢨ࣮࣭ࣘࢡ㸧：ࠊࡣࢻ࢖࢞ࡢࡇFEMtoolsࣔ ࣮ࣝࣗࢪ
㸦࣮ࣘ࢖࣭࣮ࢨン࢖࣭ࢱ࣮ࢹࠊࢫ࣮࣋ࢱ࣮ࢹࠊࢫ࢖࢙ࣇ࣮ࢱンࢺࣉࣜࢡࢫࠊࢫ࢖࢙ࣇ࣮ࢱ言語ࢡࢵ࢕ࣇࣛࢢࠊ

 ࠋࡍࡲい࡛ࢇ含ࢆ情報ࡢい࡚ࡘ࡟㸧ࢫ
 FEMtools 4 Mesh User's Guide㸦࣓ࢻ࢖࣮࢞ࢨ࣮࣭ࣘࣗࢩࢵ㸧：ࣗࢩࢵ࣓ࠊࡣࢻ࢖࢞ࡢࡇ生成ࣗࢩࢵ࣓ࠊ変形ࠊ

要素変換ࣗࢩࢵ࣓ࠊ精ᗘࡘ࡟࣮ࣝࢶ࣭ࣗࢩࢵ࣓ࡢ࡝࡞い࡚ࡢ情報ࢆ含࡛ࢇいࠋࡍࡲ 
 FEMtools 4 Dynamics User's Guide㸦ࢻ࢖࣮࢞ࢨ࣮࣭ࣘࢫࢡ࣑ࢼ࢖ࢲ㸧：ࠊࡣࢻ࢖࢞ࡢࡇFEMtoolsࡢ構造ࢼ࢖ࢲ

 ࠋࡍࡲい࡛ࢇ含ࢆ例題ࠊ情報࡞実際的ࠊ背景࡞理論的ࡢンࣙࢩ࣮࣑ࣞࣗࢩ࣭ࢫࢡ࣑
 FEMtools 4 Pretest and Correlation Analysis User's Guide㸦ࢺࢫࢸࣜࣉ解析࡜相関ศ析࣮ࣘࢻ࢖࣮࢞ࢨ㸧：࢞ࡢࡇ

 ࠋࡍࡲい࡛ࢇ含ࢆ例題ࠊ情報࡞実際的ࠊ背景࡞理論的ࡿࡍ関࡟相関ศ析࡜解析ࢺࢫࢸࣜࣉࠊࡣࢻ࢖
 FEMtools 4 Sensitivity Analysis and DOE User's Guide㸦感ᗘ解析࡜実験計画法࣮ࣘࢻ࢖࣮࢞ࢨ㸧：ࢻ࢖࢞ࡢࡇ

 ࠋࡍࡲい࡛ࢇ含ࢆ情報ࡿࡍ関࡟実験計画法㸦DOE㸧࡜感ᗘ解析ࠊࡣ
 FEMtools 4 Model Updating User's Guide㸦ࣔ࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹンࢻ࢖࣮࢞ࢨ࣮࣭ࣘࢢ㸧：ࢹࣔࠊࡣࢻ࢖࢞ࡢࡇ

 ࠋࡍࡲい࡛ࢇ含ࢆ情報࡞実際的ࡿࡍ関࡟確率論的解析ࠊ外力ྠ定ࠊࢢン࢕ࢸ࣮ࢹࣉࢵ࢔ࣝ
 FEMtools 4 Model Updating Theoretical Manual㸦ࣔ࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹンࢢ理論࣐ࣝ࢔ࣗࢽ㸧：ࣝ࢔ࣗࢽ࣐ࡢࡇ

FEMtoolsࣔࠋࡍࡲい࡛ࢇ含ࢆ理論的背景ࡿࡍ関࡟ࢢン࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔࠊࡣ 使࡟ࢢン࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹ
用ࡿࢀࡉ᭷限差ศ解析法ࡘ࡟࡝࡞い࡚解ㄝࠋࡍࡲࡋ 

 FEMtools 4 Model Updating Examples Manual㸦ࣔ࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹンࢢ例題࣐ࣝ࢔ࣗࢽ㸧：ࡣࣝ࢔ࣗࢽ࣐ࡢࡇ
 ࠋࡍࡲࡋい࡚解ㄝࡘ࡟例題ࡢࢀࡒࢀࡑࡿࡍ関࡟ࢢン࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔ

 FEMtools 4 Optimization User's Guide㸦最適化࣮ࣘࢻ࢖࣮࢞ࢨ㸧：ࠊࡣࢻ࢖࢞ࡢࡇ一般非線形ࡿࡼ࡟࣒ࣛࢢࣟࣉ
最適化ࠊࢬ࢖ࢧࠊ形状ࡢ࣮ࣜࢺ࣓࣏ࢺࠊ࣮ࢪ࣏ࣟࢺࠊ最適化ࡼ࠾びDOE/RSࣉM 構造最適ࡿࡼ࡟ンࣙࢩ࣮ࢣࣜ

化࡟関ࡿࡍ理論的࡞背景ࠊ実際的࡞情報ࠊ例題ࢆ含࡛ࢇいࠋࡍࡲ 
 FEMtools 4 Modal Parameter Extractor 㸦MPE㸧 User’s Guide㸦࣮࣮ࣔࢱࢡࣛࢺࢫࢡ࢚࣭ࢱ࣮࣓ࣛࣃ࣭ࣝࢲ

㸦MPE㸧࣮ࣘࢻ࢖࣮࢞ࢨ㸧：࣮ࢱࢡࣛࢺࢫࢡ࢚࣭ࢱ࣮࣓ࣛࣃ࣭ࣝࢲ࣮ࣔࠊࡣࢻ࢖࢞ࡢࡇ㸦MPE㸧࢜ࢻ࢔ン࣭
 ࠋࡍࡲい࡛ࢇ含ࢆ例題࡜情報ࡿࡍ関࡟࣮ࣝࢶ

 FEMtools 4 Rigid Body Properties Extractor 㸦RBPE㸧 User’s Guide㸦剛体特性࢚࢖࣮࢞ࢨ࣮࣭࣮ࣘࢱࢡࣛࢺࢫࢡ
ࢱࢡࣛࢺࢫࢡ剛体特性࢚ࡢࡵࡓࡿࡍ推定ࢆ剛体特性ࡽ࠿関数㸦FRF㸧ࢫン࣏ࢫ周波数ࣞࠊࡣࢻ࢖࢞ࡢࡇ：㸧ࢻ
࣮㸦RBPE㸧用࢜ࢻ࢔ࡢン࣭࡟࣮ࣝࢶ関ࡿࡍ理論的背景ࠊ実際的࡞情報ࠊ例題ࢆ含࡛ࢇいࠋࡍࡲ 

 FEMtools 4 ARTeMIS Interface User's Guide㸦ARTeMIS࢖ンࢻ࢖࣮࢞ࢨ࣮࣭ࣘࢫ࢖࢙ࣇ࣮ࢱ㸧：ࠊࡣࢻ࢖࢞ࡢࡇ
ARTeMIS࢖ࢆࣝ࢖࢓ࣇン࣏࣮ࡿࡍࢺ࣮࣏ࢫࢡ࢚／ࡋࢺ方法ࡘ࡟い࡚ࡢ情報ࢆ含࡛ࢇいࠋࡍࡲ 

 FEMtools 4 ABAQUS Interface User's Guide㸦ABAQUS࢖ンࢻ࢖࣮࢞ࢨ࣮࣭ࣘࢫ࢖࢙ࣇ࣮ࢱ㸧：ࠊࡣࢻ࢖࢞ࡢࡇ
ABAQUS࢖ࢆࣝ࢖࢓ࣇン࣏࣮ࡿࡍࢺ࣮࣏ࢫࢡ࢚／ࢺ方法ࡼ࠾びABAQUSࡢࣂ࢖ࣛࢻ使用方法ࡘ࡟い࡚ࡢ情報
 ࠋࡍࡲい࡛ࢇ含ࢆ

 FEMtools 4 ANSYS Interface User's Guide㸦ANSYS࢖ンࢻ࢖࣮࢞ࢨ࣮࣭ࣘࢫ࢖࢙ࣇ࣮ࢱ㸧：ࠊࡣࢻ࢖࢞ࡢࡇ
ANSYS࢖ࢆࣝ࢖࢓ࣇン࣏࣮ࡿࡍࢺ࣮࣏ࢫࢡ࢚／ࢺ方法ࡼ࠾びANSYSࡢࣂ࢖ࣛࢻ使用方法ࡘ࡟い࡚ࡢ情報ࢆ含
 ࠋࡍࡲい࡛ࢇ

 FEMtools 4 LS-DYNA Interface User's Guide㸦LS-DYNA࢖ンࢻ࢖࣮࢞ࢨ࣮࣭ࣘࢫ࢖࢙ࣇ࣮ࢱ㸧：ࠊࡣࢻ࢖࢞ࡢࡇ
LS-DYNA࢖ࢆࣝ࢖࢓ࣇン࣏࣮ࡿࡍࢺ࣮࣏ࢫࢡ࢚／ࢺ方法ࡼ࠾びLS-DYNAࡢࣂ࢖ࣛࢻ使用方法ࡘ࡟い࡚ࡢ情報
 ࠋࡍࡲい࡛ࢇ含ࢆ

 FEMtools 4 NASTRAN Interface User's Guide㸦NASTRAN࢖ンࢻ࢖࣮࢞ࢨ࣮࣭ࣘࢫ࢖࢙ࣇ࣮ࢱ㸧：ࢻ࢖࢞ࡢࡇ
い࡚ࡘ࡟使用方法ࡢࣂ࢖ࣛࢻびNASTRANࡼ࠾方法ࡿࡍࢺ࣮࣏ࢫࢡ࢚／ࢺン࣏࣮࢖ࢆࣝ࢖࢓ࣇNASTRANࠊࡣ
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 ࠋࡍࡲい࡛ࢇ含ࢆ情報ࡢ
 FEMtools 4 UNIVERSAL FILE Interface User's Guide㸦UNIVERSAL FILE࢖ン࢖࣮࢞ࢨ࣮࣭ࣘࢫ࢖࢙ࣇ࣮ࢱ

ン࣏࣮࢖ࢆࢱ࣮ࢹࡢࢺࢫࢸ࡜FEAࠊ࡚ࡋ使用ࢆࢺࢵ࣐࣮࢛ࣇ࣭ࣝ࢖࢓ࣇ࣭ࣝࢧ࣮ࣂࢽࣘࠊࡣࢻ࢖࢞ࡢࡇ：㸧ࢻ
 ࠋࡍࡲい࡛ࢇ含ࢆ情報ࡢい࡚ࡘ࡟使用方法ࡢࣂ࢖ࣛࢻびI-DEASࡼ࠾方法ࡿࡍࢺ࣮࣏ࢫࢡ࢚／ࢺ

 FEMtools 4 SAP2000 Interface User's Guide㸦SAP2000࢖ンࢻ࢖࣮࢞ࢨ࣮࣭ࣘࢫ࢖࢙ࣇ࣮ࢱ㸧：ࠊࡣࢻ࢖࢞ࡢࡇ
SAP2000࢖ࡢࣝ࢖࢓ࣇン࣏࣮ࢺ方法ࡼ࠾ࠊびSAP OAPIࡢࣂ࢖ࣛࢻ使用方法ࡘ࡟い࡚ࡢ情報ࢆ含࡛ࢇいࠋࡍࡲ 

 FEMtools 4 Programmer’s Guide㸦ࢻ࢖࣐࢞ࣛࢢࣟࣉ㸧：ࠊࡣࣝ࢔ࣗࢽ࣐ࡢࡇFEMtoolsࢺࣉࣜࢡࢫ言語ࣛࢢࣟࣉ
びࡼ࠾ࣝ࢔ࣗࢽ࣐ࢫンࣞ࢓ࣇ࣭ࣜࢺࣉࣜࢡࢫFEMtoolsࠊࡓࡲࠋࡍࡲい࡛ࢇ含ࢆ情報ࡢい࡚ࡘ࡟使用方法ࡢ࣒
APIࣜࣞ࢓ࣇン࡜ࣝ࢔ࣗࢽ࣐࣭ࢫ一緒࡟利用ࠋࡍࡲࢀࡉ 

 FEMtools 4 GUI Reference：ࣞ࢓ࣇࣜࡢࡇン࡟ࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲࠊ࣮ࣂ࣮ࣝࢶࠊ࣮ࣗࢽ࣓ࠊࡣࢫ関ࡿࡍ情報ࢆ
含ࣞ࢓ࣇࣜࡴンࠋࡍ࡛ࣝ࢔ࣗࢽ࣐࣭ࢫ 

 FEMtools 4 Command Reference：ࣞ࢓ࣇࣜࡢࡇンࠊࡣࢫFEMtools࣐ࢥンࢻ言語要素ࢩࠊンࠊࢫࢡࢵࢱ引ࡁ数࠾
 ࠋࡍ࡛ࣝ࢔ࣗࢽ࣐࣭ࢫンࣞ࢓ࣇࣜࡴ含ࢆ情報࡞ヲ細ࡢい࡚ࡘ࡟ࢻン࣐ࢥ各ࡴ含ࢆび例証ࡼ

 FEMtools 4 Scripting Reference：ࣞ࢓ࣇࣜࡢࡇンࠊࡣࢫFEMtoolsࢺࣉࣜࢡࢫ言語要素㸦変数ࠊ演算子ࠊ関数ࢫࠊ
 ࠋࡍ࡛ࣝ࢔ࣗࢽ࣐࣭ࢫンࣞ࢓ࣇࣜࡿࡍい࡚記述ࡘ࡟㸧ࢺン࣓ࢺ࣮ࢸ

 FEMtools 4 Application Programming Interface 㸦API㸧 Reference㸦ࣙࢩ࣮ࢣࣜࣉ࢔ン࢖࣒ࣛࢢࣟࣉン࢖࢙ࣇ࣮ࢱ
ン࢖࣭ࣈ࢕ࢸࢡࣛࢱン࢖ࡢ࡜ࢫ࣮࣋ࢱ࣮ࢹFEMtoolsࠊࡣࣝ࢔ࣗࢽ࣐࣭ࢫンࣞ࢓ࣇࣜࡢࡇ：㸧ࢫンࣞ࢓ࣇ࣭ࣜࢫ
 ࠋࡍࡲࡋ解ㄝ࡚ࡋ関࡟ࢫ࢖࢙ࣇ࣮ࢱ

次表࣓ࣗ࢟ࢻࡢࢀࡒࢀࡑࡣンࢆࢺࢵ࣐࣮࢛ࣇ࣭ࢺ示ࠋࡍࡲࡋ  

 ࢺࢵ࣐࣮࢛ࣇ ྡࢺン࣓ࣗ࢟ࢻ
FEMtools 4 Release Notes PDF 
FEMtools 4 Getting Started Manual  PDF, Help  

    

FEMtools 4 Framework User's Guide  PDF, Help  

FEMtools 4 Mesh User's Guide  PDF, Help  

FEMtools 4 Dynamics User’s Guide  PDF, Help  

FEMtools 4 Pretest and Correlation Analysis User’s Guide  PDF, Help  

FEMtools 4 Sensitivity Analysis and DOE User’s Guide  PDF, Help  

FEMtools 4 Model Updating User’s Guide  PDF, Help  

FEMtools 4 Model Updating Theoretical Manual  PDF  

FEMtools 4 Model Updating Examples Manual  PDF  

FEMtools 4 Optimization User’s Guide  PDF, Help  

    

FEMtools 4 Modal Parameter Extractor (MPE) User’s Guide  PDF, Help  

FEMtools 4 Rigid Body Properties Extractor (RBPE) User’s Guide  PDF, Help  
   
FEMtools 4 ARTeMIS Interface User’s Guide PDF, Help 
FEMtools 4 ABAQUS Interface and Driver User’s Guide  PDF, Help  
FEMtools 4 ANSYS Interface and Driver User’s Guide  PDF, Help  
FEMtools 4 LS-DYNA Interface and Driver User’s Guide  PDF, Help  
FEMtools 4 NASTRAN Interface and Driver User’s Guide  PDF, Help  
FEMtools 4 UNIVERSAL FILE Interface and Driver User’s Guide  PDF, Help  
FEMtools 4 SAP2000 Interface and Driver User’s Guide  PDF, Help  
   
FEMtools 4 Programmer’s Guide  PDF  
FEMtools 4 GUI Reference Manual  Help  
FEMtools 4 Command Reference Manual  Help  
FEMtools 4 Scripting Reference Manual  Help  
FEMtools 4 API Reference Manual  Help 



10 - FEMtools 4 Release Notes  

 Help㸦࣊ࣝࣉ㸧ࠊࡣFEMtoolsࡢ Help࣓ྍࢫࢭࢡ࢔ࡽ࠿࣮ࣗࢽ能࣓ࣗ࢟ࢻ࡞ンࢆࢺ参照ࣟࢡ࢖࣐ࡣࣉࣝ࣊ࠋࡍࡲࡋ
ࢺࣇࢯ HTML  ࠋࡍࡲࡋ使用ࢆHTML WebHelp㸦Linux㸧ࠊ㸦Windows㸧ࣉࣝ࣊

PDFࢺࢵࣂࣟࢡ࢔࣭ࣅࢻ࢔ࡣ㸦Adobe Acrobat㸧࣏࣮࣓ࣗ࢟ࢻ࣭ࣝࣈࢱンࢺࢵ࣐࣮࢛ࣇ࣭ࢺ㸦PDF㸧ࢆ参照ࠋࡍࡲࡋ
ࢬ࣒ࢸࢫࢩ࣭ࣅࢻ࢔：࢕ࢸ࢕ࣜ࢕ࢸ㸦Windows/Linux用࣮ࣘ࢔࢙࢘ࢺࣇࢯ࣭ࢲ࣮࣭ࣜࣅࢻ࢔ࠊࡣࣝ࢖࢓ࣇࡢࡽࢀࡇ
㸦www.adobe.com㸧ࡽ࠿利用ྍ能㸧ࢆ使用࡚ࡋㄞࡽ࠿ࢺࢵࣂࣟࢡ࢔࣭ࣅࢻ࢔ࠊࡓࡲࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡴ PDF࣮࢛ࣇ
ࡽ࠿࣮ࣗࢽHelp࣓ࠊࡣ࡟ࡿࡍࢫࢭࢡ࢔࡟ࣝ࢔ࣗࢽ電子࣐ࡢࡽࢀࡑࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ出力ࢆࣝ࢔ࣗࢽ࣐࣭ࢺࢵ࣐
Manualsࢆ選ࡉࡔࡃ࡛ࢇいࠋ 

FEMtools࢙࢘ࢺ࢖ࢧࣈ 

ࡢୖࢺࢵࢿ࣮ࢱン࢖ FEMtools࢝ࠊࡣࢺ࢖ࢧ࣭ࢺ࣮࣏ࢧ࣭࣮࣐ࢱࢫFEMtools࣓ンࢼࢸンࡼ࠾ࢫびᢏ術࣮ࢧࢺ࣮࣏ࢧ
ࡢ࡚࡭ࡍࡘ持ࢆᶒࢫࣅ FEMtools࣮ࣘࣙࢩ࣮ࢣࢽ࣑ࣗࢥࡢࡵࡓࡢ࣮ࢨン／ࢭࡢࢺ࣮࣏ࢧン࡚ࡋ࡜࣮ࢱ活用࡛ࡼࡿࡁ
う࡟意ᅗ࡚ࢀࡉいࠋࡍࡲ次࢖࣭࢔࢙࢘ࢺࣇࢯࡽ࠿ࢺ࢖ࢧࡢン࡟ࢪ࣮ࢣࢵࣃ࣭࣮ࣝࢺࢫ付属࣓ࣗ࢟ࢻࡿࡍンࢺや補語

情報ࢆ見࣓ࣗ࢟ࢻࠊࢺࣉࣜࢡࢫࠊࢳࢵࣃࠊ࢔࢙࢘ࢺࣇࢯࠊࡓࡲࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡅࡘンࡢ࡝࡞ࢺ新ࣙࢪ࣮ࣂンࢆ

 ࠋࡍ能࡛ྍࡀ࡜ࡇࡿࡍࢻン࣮ࣟ࢘ࢲ

http://www.femtools.com/support 

FEMtoolsࢽ࣮ࣞࢺン࣭ࢢコ࣮ࢫ 

DDS㸦Dynamic Design Solutions㸧ࡼ࠾び FEMtoolsࠊࡣ࣮ࢼࢺ࣮ࣃ新規࢖ࡢࡵࡓࡢ࣮ࢨ࣮ࣘࡢンࣙࢩࢡࢲࣟࢺン࣭
や࣮ࢨびୖ級࣮ࣘࡼ࠾ࢫ࣮ࢥ FEMtoolsࣙࢩ࣮ࢣࣜࣉ࢔ン開Ⓨ者ࢽ࣮ࣞࢺࡢࡵࡓࡢンࢆࢫ࣮ࢥ࣭ࢢᥦ供ࠋࡍࡲࡋ 

ヲ細ࡘ࡟い࡚ࠊࡣsupport@femtools.com࠾࡟問い合わࡏ頂ࠊ࠿ࡃあࡿいࡣ最新情報ࡢࢺ࢖ࢧ
http://www.femtools.com/coursesࢆ閲覧ࡉࡔࡃ࡚ࡋいࠋ 
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 ンࣙࢩ࣮ࣞࢢ࢕ࣇコン、ࢫンࢭ࢖ࣛ、࣮ࣝࢺࢫン࢖

 ࠋࡍࡲࡋ示ࢆ最少必要条件ࡢࡵࡓࡢ࣮ࣝࢺࢫン࢖࡜࣒ࢸࢫࢩ࣭ࢢン࢕ࢸ対象࣮࢜࣌ࣞࢺ࣮࣏ࢧ

 ࣒࣮࢛ࣇࢺࢵ࣭ࣛࢺ࣮࣏ࢧ

FEMtoolsࠊࡣWindows 64ࡼ࠾ࢺࢵࣅび Linux 64࡛ࡳࡢ࣒࣮࢛ࣇࢺࢵࣛࣉࡢࢺࢵࣅ利用ྍ能࡛࣮ࣂ࣭ࢺࢵࣅ32ࠋࡍ
 ࠋࢇࡏࡲࢀࡉࢺ࣮࣏ࢧやࡣࡶࡣびMAC OSࡼ࠾ンࣙࢪ

次表ࠊࡣFEMtools 4ࢺ࣮࣏ࢧࡢ対象ࢆ࣒࣮࢛ࣇࢺࢵࣛࣉ示ࡍࡲࡋ: 

Platform  Operating System㸦s㸧  Processor㸦s㸧  
WIN64  Windows 7/8/8.1/10 64-bit  Intel 64; AMD 64  
LIN64  Linux 64-bit 㸦RHEL 6+, CentOS 6+,…㸧  Intel 64; AMD 64  

最新ࡢ対象࣒࣮࢛ࣇࢺࢵࣛࣉ情報ࡘ࡟い࡚ࠊࡣFEMtools ࢺ࢖ࢧ 㸦http://www.femtools.com㸧 ࢆ確認ࡉࡔࡃいࠋ  

最小࢖ン࣮ࣝࢺࢫ必要条件 

Windows 

 Microsoft Windows 7ࢺࢵࣅ64  10ࠊ8.1ࠊ8ࠊ? 
 最ᑠ 4 GB RAM 
 最ᑠ 500MBࢫ࣮࣌ࢫ࣭ࢡࢫ࢕ࢹࢻ࣮ࣁ 
 Open GLࢻ࣮࢝ࢫࢡࢵ࢕ࣇࣛࢢࡿࡍࢺ࣮࣏ࢧࢆ 

OpenGL対応࡛ࢻ࣮࢝ࢫࢡࢵ࢕ࣇࣛࢢ࣭ࢱ࣮ࣞࣞࢭࢡ࢔࣭࢔࢙࢘ࢻ࣮ࣁࡢあࢫࢡࢵ࢕ࣇࣛࢢࡤࢀ性能ࡣ向ୖࡍ
 ࠋうࡻࡋ࡛ࡿ

 CDࡣࡓࡲ電子࣓࣮ࣝ࢖ࡽ࠿ンࡢࡵࡓࡿࡍ࣮ࣝࢺࢫ CD-ROM࢖ࡣࡓࡲࣈ࢖ࣛࢻンࢺࢵࢿ࣮ࢱ接⥆ 
 USB࣏࣮ࢺ㸦ࢭ࢖࣭ࣛࢡࢵࣟ࡟ࢻ࣮ࣀンࣙࢩࣉ࣭࢜ࢫン用ࢻࡢンࢆࣝࢢ使用ࡿࡍ場合㸧 
 ࣛࢭ࢖ン࣮ࣂ࣮ࢧࢫ㸦ࢺࢵࢿワ࣮ࢭ࢖࣭ࣛࢡンࣙࢩࣉ࣭࢜ࢫン用㸧ࡢ TCP/IP接⥆ 
 ࢲ࣮࣭ࣜࢺࢵࣂࣟࢡ࢔࣭ࣅࢻ࢔あࡿいࡣ PDF࣓ࣗ࢟ࢻンࢆࢺㄞࣙࢩ࣮ࢣࣜࣉ࢔ࡢࡵࡓࡴン 

Linux 

 ࢖ンࣝࢸMKL 11.0や࢖ࠊンࣝࢸ 64㸦RHEL 6+(CentOS 6+)...㸧ࡿࡍࢺ࣮࣏ࢧࢆ Linux 64ࢺࢵࣅ OS 
ࡢ௚ࡢࡑ Linux OSࠋࢇࡏࡲࢀࡋࡶ࠿ࡿࢀࡉࢺ࣮࣏ࢧࡶ 

 最ᑠ 4 GB RAM 
 最ᑠ 500MBࢫ࣮࣌ࢫ࣭ࢡࢫ࢕ࢹࢻ࣮ࣁ 
 Open GLࢻ࣮࢝ࢫࢡࢵ࢕ࣇࣛࢢࡿࡍࢺ࣮࣏ࢧࢆ 

OpenGL対応࡛ࢻ࣮࢝ࢫࢡࢵ࢕ࣇࣛࢢ࣭ࢱ࣮ࣞࣞࢭࢡ࢔࣭࢔࢙࢘ࢻ࣮ࣁࡢあࢫࢡࢵ࢕ࣇࣛࢢࡤࢀ性能ࡣ向ୖࡍ
 ࠋうࡻࡋ࡛ࡿ

 CDࡣࡓࡲ電子࣓࣮ࣝ࢖ࡽ࠿ンࡢࡵࡓࡿࡍ࣮ࣝࢺࢫ CD-ROM࢖ࡣࡓࡲࣈ࢖ࣛࢻンࢺࢵࢿ࣮ࢱ接⥆ 
 ࣛࢭ࢖ン࣮ࣂ࣮ࢧࢫ㸦ࢺࢵࢿワ࣮ࢭ࢖࣭ࣛࢡンࣙࢩࣉ࣭࢜ࢫン用㸧ࡢ TCP/IP接⥆ 
 ࢲ࣮࣭ࣜࢺࢵࣂࣟࢡ࢔࣭ࣅࢻ࢔あࡿいࡣ PDF࣓ࣗ࢟ࢻンࢆࢺㄞࣙࢩ࣮ࢣࣜࣉ࢔ࡢࡵࡓࡴン 

 変更点ࡢ࣮ࣝࢺࢫン࢖

 FEMtools 4࢘ࢲࠊࡣン࣮ࣟࢻあࡿいࠊࡣUSB࣓ࣔࣜや CD-ROMࠋࡍࡲࢀࡉࢫ࣮࡚ࣜࣜࡗࡼ࡟ 
 FEMtools࢜ࢻ࢔ン࣭࣐ࠊࡣ࣮ࣕࢪ࣮ࢿ空白ࢆ含ࢆ࣒࣮ࢿࢫࣃࡴ扱うࠋࡍࡲࡁ࡛ࡀ࡜ࡇ 
 新ࡋいࡀࢳࢵࣃあࡿ場合࡛࢜ࢻ࢔ࠊࡶン࣭࣐ࢆࣉࢵ࢔ࢺ࣮ࢱࢫࠊࡣ࣮ࣕࢪ࣮ࢿ起動ࠋࢇࡏࡲࡋ新ࡋい࢜ࢻ࢔ン

 ࠋࡍࡲࢀࡉ起動ࡀࣉࢵ࢔ࢺ࣮ࢱࢫ࡟ࡳࡢ場合ࡓࢀࡉ検知ࡀ
 ࠊࡣ࣮ࣕࢪ࣮ࢿ࣐࣭ࢪ࣮ࢣࢵࣃ利用ྍ能ࢭ࢖ࣛ࡞ン࡞ࡀࢫい新ࡋい࢜ࢻ࢔ンࢆࣉࢵ࢔ࢺ࣮ࢱࢫࡢ起動ࡏࡲࡋ
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 < 手動࡛㸦Add-onsࢆ࣮ࣕࢪ࣮ࢿ࣐࣭ࢪ࣮ࢣࢵࣃࡾ࠾࡝࡛ࡲ௒ࠊࡶい場合࡛࡞ࡽ࠿ࡘ見ࡀࢫンࢭ࢖ࣛࠋࢇ
Install/Remove Add-on㸧操作࢖ࠊࡾࡼ࡟࡜ࡇࡿࡍン࢜ࢻ࢔ࡢࢪ࣮ࢣࢵࣃ࣭࣮ࣝࢺࢫンࢆ確認ࡲࡁ࡛ࡀ࡜ࡇࡿࡍ
 ࠋࡍ

 ࢔ン࢖ン࣮ࣝࢺࢫ処理࡛ࠊࡣFEMtoolsࢺࣉࣜࢡࢫ࣭࣮ࢧࢵࢭࣟࣉࣜࣉ㸦uninstall_packages.bas㸧ࡀ最初ࢻ࢔࡟
࢜ン࣭࢔ࢆࢪ࣮ࢣࢵࣃン࢖ンࠊࡋ࣮ࣝࢺࢫ次ࡢࡑ࡟௚ࡢ手⥆࢔ࡀࡁン࢖ンࠋࡍࡲࢀࡉ࣮ࣝࢺࢫ 

 ࢖࣭ࢱ࣮ࢹン࡟ࢫ࢖࢙ࣇ࣮ࢱ関ࠊࡣࣝ࢖࢓ࣇ࣭ࢺࣉࣜࢡࢫࡿࡍ現ᅾ࣮ࢲ࢛ࣝࣇࡢ

㸦<installdir>/scripts/interfaces㸧࢖࡟ンࠋࡍࡲࢀࡉ࣮ࣝࢺࢫ各࢖ンࡢࢫ࢖࢙ࣇ࣮ࢱ専用ࡀ࣮ࢲ࢛ࣝࣇࣈࢧあࡲࡾ
ࡏࡲࡾ変わࡣ場所㸦<installdir>/scripts/drivers㸧ࡢࣝ࢖࢓ࣇ࣭ࢢン࢕ࢸࢵࢭびࡼ࠾ࢺࣉࣜࢡࢫ࣭ࣂ࢖ࣛࢻࠋࡍ
 ࠋࢇ

FEMtools 3.xࢻ࣮ࣞࢢࣉࢵ࢔ࡢ 

以ୗࠊࡣFEMtoolsᪧࣙࢪ࣮ࣂンࡽ࠿ FEMtools 4.0あࡿいࡣ FEMtools 4.1ࡢࡵࡓࡢ࣮ࢨ࣮ࣘࡿࡍࢻ࣮ࣞࢢࣉࢵ࢔࡟
情報࡛ࠋࡍ 

FEMtools 4ࡣ新ࡋい࢖࡟࣮ࣜࢺࢡࣞ࢕ࢹンࡀ࡜ࡇࡿࡍ࣮ࣝࢺࢫ推奨ࠋࡍࡲࢀࡉ 

 FEMtools 4.0ࡼ࠾び ࡣ࣮ࣜࢺࢡࣞ࢕ࢹ࣭࣮ࣝࢺࢫン࢖࣭ࢺ࢛ࣝࣇࢹࡢ4.0.1 c:\femtools\4࡛ࠊࡓࡲࠋࡍFEMtools 
 ࠋࡍc:\femtools\4.1࡛ࠊࡣ4.1࡛

 ࢻンࢡࢵࣟࢻ࣮ࣀࡿࡼ࡟ࣝࢢ㸦nodelocked㸧ࣛࢭ࢖ンࠊࡣࢫv3.3以降ࠊࡣ࡟ࡿࡍࢻ࣮ࣞࢢࣉࢵ࢔ࡽ࠿新ࡋいࣛ
期間対応ࠋࡍࡲࡋ࡜必ࢆࣝ࢖࢓ࣇ࣭ࢫンࢭ࢖ FEMtoolsࣛࢭ࢖ンࠊࡣ࡛ࣝ࢖࢓ࣇ࣭ࢫFEMtools 4ࢆ実行ࡓࡿࡍ
 ࠋࢇࡏࡲࡋ࡜必要ࢆࣝ࢖࢓ࣇ࣭ࢫンࢭ࢖いࣛࡋ新ࡢࡵ

 ࣙࢪ࣮ࣂࡢࡇンࢆ最初࡟起動ࡿࡍ時ࠊ新ࡋい࢕ࢸࢵࢭン࡟࣮ࣜࢺࢡࣞ࢕ࢹ࣒࣮࣍ࡀࣝ࢖࢓ࣇ࣭ࢢ作成࡛ࡿࢀࡉ

ࡣいࡿ401あࠊン番号㸦400ࣙࢪ࣮ࣂࡣࣝ࢖࢓ࣇ࣭ࢢン࢕ࢸࢵࢭࡢࡑࠋうࡻࡋ 410㸧ࢆ表わࡍ xyzࢆ備えࡓ
femtools_xyz.ini࡛ࠋࡍ 

 以前࢖ࡢン࢕ࢸࢵࢭ࣭࣮ࣝࢺࢫンࡢࣝ࢖࢓ࣇ࣭ࢢ修ṇ㡯目ࡢୖࣉࢵ࢔ࢺ࣮ࢱࢫࠊࡣ新ࡋい࢕ࢸࢵࢭン࢓ࣇ࣭ࢢ

 ࠋࡍࡲࢀࡉᥦ示࡟時ࣉࢵ࢔ࢺ࣮ࢱࢫࡢ最初ࡣࢀࡑࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ࣮ࣆࢥ࡟自動的࡟ࣝ࢖
 ᪧࣙࢪ࣮ࣂン中࡛使用࢕ࢸࢵࢭ࣭࣮ࣂ࢖ࣛࢻࡢࢺࣉࣜࢡࢫ࣭ࣂ࢖ࣛࢻࡓࢀࡉンࡼ࠾ࢢび࢝ࢬ࢖࣐ࢱࢫ設定ࠊࡣ

FEMtools 4ࡣ࡟自動的࡟設定࣒ࢱࢫ࢝ࡢࣂ࢖ࣛࢻࡢࡑࠋࢇࡏࡲࢀࡉ設定ࠊࡣINIࡼ࠾ࣝ࢖࢓ࣇび BAS࢖ࣛࢻ
ࡢࢺࣉࣜࢡࢫ࣭ࣂ FEMtools 4ࣙࢪ࣮ࣂン࠾࡟い࡚再設定࡞ࡽ࡞ࡤࢀࡅ࡞ࡋい࡛ࡻࡋうࠋ 
 ࠋࡍࡲࡋᏑᅾ࡟installdir>\scripts\drivers>ࠊࡣࣝ࢖࢓ࣇࡢࡽࢀࡇ

 FEMtools 4.x࣮ࣜࣜࡢࢺ࣮ࣀ࣭ࢫ FEMtools࣐ࢥンࢻ言語ࡢ࡬更新点ࡉࡔࡃ࡚ࡋࢡࢵ࢙ࢳࢆいࠋ必要࡞場合ࡣ
 ࠋいࡉࡔࡃ࡚ࡋ更新ࢆࢺࣉࣜࢡࢫ࣭ࢻン࣐ࢥ

 FEMtools 4.x࣮ࣜࣜࡢࢺ࣮ࣀ࣭ࢫ FEMtools APIࡢ࡬更新点ࡉࡔࡃ࡚ࡋࢡࢵ࢙ࢳࢆいࠋ必要࡞場合ࣛࢢࣟࣉࡣ
 ࠋいࡉࡔࡃ࡚ࡋ更新ࢆࢺࣉࣜࢡࢫ࣭࣒

 FEMtools 3.xࡣࣝ࢖࢓ࣇ࣭ࢺࢡ࢙ࢪࣟࣉ FEMtools 4࢖࡟ン࣏࣮ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍࢺ 

FEMtools 4ࢺ࣮ࢹࣉࢵ࢔ࡢ 

FEMtools 4ࣙࢪ࣮ࣂンࢆ最新ࣙࢪ࣮ࣂン࡟更新ࠊࡣ࡟ࡿࡍHelp > Check for Updates࣓࣐ࢥ࣭࣮ࣗࢽンࡢࢻ実行ࢆ推
奨ࠋࡍࡲࡋ 

ࡿあࢳࢵࣃ࣭ࢺ࣮ࢹࣉࢵ࢔ࡣ自動更新࡛ࠋいࡉࡔࡃ࡚ࡋ注意࡟࡜ࡇ࡞必要ࡀ⥆接ࢺࢵࢿ࣮ࢱン࢖ࡣ࡟自動更新ࡢࡑ

いࡣ利用ྍ能࢖࣭ࢻ࣮ࣞࢢࣉࢵ࢔࡞ンࡀ࣮࣮ࣛࢺࢫ示࢘ࢲࠊࢀࡉン࣮ࣟ࢖࡜ࢻンࡢ࣮ࣝࢺࢫ選択ྍࡀ能ࡲࡾ࡞࡟

ࡿࡍࢻン࣮ࣟ࢘ࢲࡽ࠿ࢺ࢖ࢧ࣭ࢺ࣮࣏ࢧFEMtoolsࠊࡣࢳࢵࣃび最新版ࡼ࠾࣮࣮ࣛࢺࢫン࢖࣭ࢻ࣮ࣞࢢࣉࢵ࢔ࠋࡍ
 ࠋࡍ能࡛ྍࡶ࡜ࡇ

FEMtools 4.0.1ࡼ࠾び FEMtools 4.1ࠊࡣFEMtools 4.0ྍࡀࢻ࣮ࣞࢢࣉࢵ࢔ࡢࡽ࠿能࡞場合࡛ࡢࡑࠊࡶ再࢖ン࣮ࢺࢫ
ࡢࡑࠋࡍࡲࡾ࡞࡟必要ࡀࣝ FEMtools 4.1࢖ンࠊࡣ࣮࣮ࣛࢺࢫFEMtools࢘ࢲࡽ࠿ࢺ࢖ࢧ࣭ࢺ࣮࣏ࢧン࣮ࣟࡇࡿࡍࢻ
 ࠋࡍࡲࡁ࡛ࡀ࡜

FEMtools 4.1࢖࣭ࢺ࢛ࣝࣇࢹࡢンࡣ࣮ࣜࢺࢡࣞ࢕ࢹ࣭࣮ࣝࢺࢫ c:\femtools\4.1࡛ࢥࡵࡓࡢࡑࠋࡍン࡟ୖࢱ࣮ࣗࣆ
FEMtools 4.0ࡼ࠾び   ࠋࡍ能࡛ྍࡶ࡜ࡇࡿࡍ維持ࢆ4.1
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FEMtools 4.0 更新情報 

FEMtools 4ࠊࢺ࣮ࢹࣉࢵ࢔ࡢ࣮ࣝࣗࢪࣔࡢ࡚࡭ࡍࠊࡣ標準 FEࡢ࣒ࣛࢢࣟࣉ最新ࣙࢪ࣮ࣂンࡼ࠾ࢺ࣮࣏ࢧࡢび過去
 ࠋࡍン࡛ࣙࢪ࣮ࣂ新࡞࣮ࣕࢪ࣓ࡓࡋ統合ࢆࢫ࣮࣭ࣜࣜࢫンࢼࢸン࣓ࡢ

 ࠋࡍ࡛ࡾ࠾࡜ࡢ以ୗࡣࢺ࢖ࣛ࢖ࣁࡢࢫ࣮ࣜࣜࡢࡇ

 と構成࣮ࣝࢺࢫン࢖

 Windows 64-bit࣒࣮࢛ࣇࢺࢵࣛࣉࡢ㸦710ࠊ8ࠊ㸧ࡼ࠾び Linux 64-bit RHEL6+ 対応 
 ࢘ࢲン࣮ࣟࢻ対応ࠊࡣࡓࡲUSBࠊ CD-ROMࢫ࣮ࣜࣜࡢ  
 Linuxࢥン࡛ୖࢱ࣮ࣗࣆ使用ྍ能࡞ Safenet HLࢻンࢺ࣮࣏ࢧࡢࣝࢢ 
 個別ࣛࢭ࢖ンࡢࢻ࣮ࢥ࣭ࢫ FE࢖࣭࣒ࣛࢢࣟࣉンࢫ࢖࢙ࣇ࣮ࢱ 
 ࣒ࣛࢢࣟࣉ自動ࢺ࣮ࢹࣉࢵ࢔用ࡢ新ࠕCheck for Updates࣮ࠖࣝࢶ 
 新ࡋいࣛࢭ࢖ンࢫ㸦ࢺࢵࢿࠊࢡࢵࣟࢻ࣮ࣀワ࣮ࡼ࠾ࢡび࣮࣑ࣟンࢢ㸧 

 ࢫ࢖࢙ࣇ࣮ࢱン࢖࣭࣮ࢨ࣮ࣘ

 新ࡋい࣋ࢥ࢖࢔ࡢࢫ࣮࣭࣋ࣝࢺࢡン㸦SVG㸧 
 高解像ᗘࣔࢱࢽ㸦4K㸧用ࡢ自動的࣮ࣜࢣࢫンࢥ࢖࢔࣭ࢢン 

 ࢡワ࣮࣒࣮ࣞࣇ

 MS Office㸦Excel, PowerPoint, Word㸧用࣐ࢥࡢンࢻ 
 新࢖ࠕンࠖࢱ࢕ࢹ࢚࣭ࣝࢹ࣭ࣔࢺࢫࢸ࣭ࣈ࢕ࢸࢡࣛࢱ 
 ࢟ࢵࣆ࣭ࢡࢵ࢕ࣇࣛࢢンࢢ機能㸦表示ࠊFace࢟ࢵࣆン࢟ࢵࣆ࣭ࢻࢳࢵࢱ࢔ࠊࢢンࢢ㸧ࡢ更新 
 DOF࣮ࣜࣞࣙࢩン用ࡢ新ࡋい࣐ࢥンࢻ 
 新ࡋいࣝࢱࢪࢹ信号処理㸦DSP㸧࣐ࢥンࢻ 
 時系列ࡼ࠾ࠖࣝࢿࣕࢳ࣭ࢱ࣮ࢹࠕび࢘࢕ン࢘ࢻ関数ࢆ定義ࡢࡵࡓࡿࡍ新ࡋい࣐ࢥンࢻ 

 ࢫ࢖࢙ࣇ࣮ࢱン࢖࣭ࢱ࣮ࢹ

 Abaqus 2016ࠊAbaqus 2017ࢺ࣮࣏ࢧࡢ 
 Abaqus SIMࣝ࢖࢓ࣇ新࢖ンࢫ࢖࢙ࣇ࣮ࢱ 
 MSC.Nastran 2018ࢺ࣮࣏ࢧࡢ 
 MSC.Nastran࣮ࣃ࣮ࢫ要素࢖ンࢺ࣮࣏ࢧࡢࢫ࢖࢙ࣇ࣮ࢱ 
 Ansys 18+ࢺ࣮࣏ࢧࡢ 
 LS-DYNA᭷限要素ࢪ࣮ࢣࢵࣃ新ࡋい࢖ンࢫ࢖࢙ࣇ࣮ࢱ 
 SAP2000 v19ࢺ࣮࣏ࢧࡢ 

動態解析 

 ࣓ࣔࣜ制御用新ࠕout-of-core solverࠖ࢜ࣙࢩࣉン 
 ࣐࣮ࢱࢫDOF選択用 K/M比計算ࡢࡵࡓࡢ新ࡋい࣐ࢥンࢻ 
 ࢫ࣮࣋ࢱ࣮ࢹ㸦MBA㸧࡟剛体࣮ࣔࡼ࠾ࢻび回転 DOFࢆ追加ࡢࡵࡓࡿࡍ新ࡋい࣐ࢥンࢻ 
 ࣮ࣔࢭ࢔࣭ࢫ࣮࣭࣋ࣝࢲンࣜࣈ㸦MBA㸧剛接⥆ࢺ࣮࣏ࢧࡢ 

 解析ࢺࢫࢸࣜࣉ

 質量荷重感ᗘ㸦MLS: Mass Loading Sensitivity㸧用ࡢ新ࡋい計算࣮ࣝࢶ 
 ่࣮ࣔࢻ激係数解析㸦MPA㸧ࡢ࣮ࣝࢶ更新 
 ่࣮ࣔࢻ激係数࣐ࣉࢵ㸦MPM㸧用ࡢ新ࡋい計算࣮ࣝࢶ 
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 FEࣔࡢࣝࢹ初期化用ࡢ新ࡋい࣮ࣘ࢕ࢸ࢕ࣜ࢕ࢸ 
 加振ࡼ࠾び支持఩置ࡢ選択用ࡢ新ࡋい࣮ࣝࢶ 
 ࢭン࣮ࢧ選択࢖ࢆン࣏࣮ࡢࡵࡓࡿࡍࢺ࣮࣏ࢫࢡ࢚ࠊࢺ新ࡋい࣐ࢥンࢻ 

相関分析 

 新ࡋい࢖ン࢔࣮ࣗࣅ࣭࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮࣭ࣔࣈ࢕ࢸࢡࣛࢱ 
 ่࣮ࣔࢻ激係数計算ࡢ改良 
 ࣮ࣔࣝࢲ直交係数㸦EVO㸧計算ࡢ改良 

感ᗘ解析とࣔ࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹンࢢ 

 新ࡋいࣉ࢖ࢱ࣭ࢱ࣮࣓ࣛࣃ㸦ࣜࣉࢫンࢢ剛性࣮ࣜࢣࢫンࢢ系数㸧ࢺ࣮࣏ࢧࡢ 

実験計画法 

 RSM逆算ࡼ࠾び検証ࡢࡵࡓࡢ新ࡋい࣐ࢥンࢻ 
 DOE࢖ࡢࢱ࣮ࢹン࣏࣮ࡢࡵࡓࡢࢺࢵࢭࣜࠊࢺ新ࡋい࣐ࢥンࢻ 

最適化 

 最ᑠ FRFࣞ࣋ࣝ設計ࡢ࣮ࣜࢺ࣓࣏ࢺࡢࡵࡓࡢ最適化 

 ンࣙࢩ࣮ࣞࢢ࢕ࣇコン、ࢫンࢭ࢖ࣛ、࣮ࣝࢺࢫン࢖

 ンࣙࢩ࣮ࣞࢺࢫン࢖

FEMtools 4࢘ࢲࡣン࣮ࣟࠊࢻUSBࢡࢵ࢕ࢸࢫあࡿいࡣ CD-ROM࡛࣮ࣜࣜࠋࡍࡲࢀࡉࢫ 

 FEMtools࢜ࢻ࢔ン࣭࣐ࠊࡣ࣮ࣕࢪ࣮ࢿ空白ࢆ含ࢆ࣒࣮ࢿࢫࣃࡴ扱うࠋࡍࡲࡁ࡛ࡀ࡜ࡇ 
 新ࡋいࢳࢵࣃ処理ࡢ開始時࢜ࢻ࢔࡟ン࣭࣐ࡣ࣮ࣕࢪ࣮ࢿ実行ࠋࢇࡏࡲࢀࡉ新ࡋい࢜ࢻ࢔ンࡀ検知ࡿࢀࡉ場合࡟

 ࠋࡍࡲࢀࡉ実行࡟自動的ࠊࡣ
 ࠊࡣ࣮ࣕࢪ࣮ࢿ࣐࣭ࢪ࣮ࢣࢵࣃ利用ྍ能ࢭ࢖ࣛ࡞ン࡞ࡀࢫい場合実行ࢭ࢖ࣛࠋࢇࡏࡲࢀࡉンࡀࢫ見ࡃ࡞ࡽ࠿ࡘ

手動࡛ࢆ࣮ࣕࢪ࣮ࢿ࣐࣭ࢪ࣮ࢣࢵࣃࠊࡣ࡟場合ࡿあࡀࢪ࣮ࢣࢵࣃン࣭ࣙࢩ࣮ࣞࢺࢫン࢖࡞利用ྍ能ࠊࡶ࡚

㸦Add-ons > Install/Remove Add-on㸧実行ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 
 ࢔ン࢖ン࣮ࣝࢺࢫ処理࡛࢔ࠊࡣン࢖ン࣮ࣝࢺࢫ手⥆ࡀࡁ始ࡿࡲ前ࢺࣉࣜࢡࢫ࣭࣮ࢧࢵࢭࣟࣉࣜࣉ࡟

㸦uninstall_packages.bas㸧FEMtools࢔ン࢖ン࢜ࢻ࢔ࡀ࣮ࣝࢺࢫン࣭࢖ࡢࢪ࣮ࢣࢵࣃンࢆ࣮ࣝࢺࢫ解除ࠋࡍࡲࡋ 
 ࢖࣭ࢱ࣮ࢹン࡜ࢫ࢖࢙ࣇ࣮ࢱ関係࣮ࢲ࢛ࣝࣇࠊࡣࣝ࢖࢓ࣇ࣭ࢺࣉࣜࢡࢫࡿࡍ<installdir>/scripts/interfaces࢖࡟ン

ン࢕ࢸࢵࢭびࡼ࠾ࢺࣉࣜࢡࢫ࣭ࣂ࢖ࣛࢻࠋࡍࡲࡾあࡀ࣮ࢲ࢛ࣝࣇࣈࢧࡢ用ࢫ࢖࢙ࣇ࣮ࢱン࢖各ࠊࢀࡉ࣮ࣝࢺࢫ

 ࠋࢇࡏࡲࡾ変わࡣ఩置㸦<installdir>/scripts/drivers㸧ࡢࣝ࢖࢓ࣇ࣭ࢢ

コ࣐ン࢖ࣛࢻン࣭ࢱ࣮࣓ࣛࣃ 

࣭ࣉࢵ࢔ࢺ࣮ࢱࢫࡀ変数ࡢࡽࢀࡑࠋࡓࡋࡲࢀࡽ加えࡅ付࡟ࡵࡓࡿࡍ定義ࢆ環境変数ࡀࢱ࣮࣓ࣛࣃン࣭࢖ࣛࢻン࣐ࢥ

ࣉࣜࢡࢫࠋࡍࡲࢀࡉ適用ࡀ環境変数ࡢࡇࠊ࡟直後ࡓࡋ実行ࢆFEMtoolsࠊ࡟うࡼࡿࡁい࡚利用࡛࠾࡟ࢺࣉࣜࢡࢫ
 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ使用ࢆࢢン࢕ࢸࢵࢭ構成ࢬ࢖࣐ࢱࢫ࢝ࡢࡑࠊࡣ࣐ࣛࢢࣟࣉ࣭ࢺ

 更新点ࡢ࣒ࣛࢢࣟࣉ

FEMtoolsࡣ定期的ࢺ࣮ࢹࣉࢵ࢔࡟情報ࡢࡑࠊࢀࡉࢡࢵ࢙ࢳࢆ情報ࣙࢪ࣮ࣂ࣭ࢺ࣮ࢹࣉࢵ࢔ࡣ࡟ンࡀᏑᅾࡿࡍ場所
や࣒ࢸࢫࢩ情報ࡀ含ࠊࡓࡲࠋࡍࡲࢀࡲ新࢜ࢻ࢔ࡓࢀࡉࢫ࣮ࣜࣜ࡟ࡓン࣭ࣔ࡟࣮ࣝࣗࢪ関ࡿࡍ通知ࡀあࡲࢀࡋࡶ࠿ࡿ

 ࠋࢇࡏ
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FEMtoolsࡣ  ࠋࡍࡲࡋᥦ供ࢆンࣙࢩࣉ࣭࢜ࢺ࣮ࢹࣉࢵ࢔ࡢࡘ2

 ࣉࢵ࢔ࢺ࣮ࢱࢫ時ࡢ通知：ࣉࢵ࢔ࢺ࣮ࢱࢫ時ࡢ࣒ࢸࢫࢩ࡟最新版ࢆ定期的࢘ࢲࠊࡋࢡࢵ࢙ࢳ࡟ン࣮ࣟ࢖࡜ࢻン

推࡟ࡵࡓࡃ࠾࡚ࡋ࡟最新ࢆ࢔࢙࢘ࢺࣇࢯࡣンࣙࢩࣉ࢜ࡢࡇࠋࡍࡲࢀࡉ通知ࡀ࡜ࡇࡿい࡚ࡁ࡛ࡀ準備ࡢ࣮ࣝࢺࢫ

奨ࠋࡍࡲࢀࡉ 
 ࣙࢪ࣮ࣂ࣭ࢺ࣮ࢹࣉࢵ࢔ン࢖ࡢンࡢ࣮ࣝࢺࢫ手動ࢆࢺ࣮ࢹࣉࢵ࢔ࡣ࣒ࢸࢫࢩ：ࢡࢵ࢙ࢳ自動࡛ࡋࢆࢡࢵ࢙ࢳࡣ

ࡿࡍ決定ࢆ࠿ࡁ࡭ࡍࢆࢺ࣮ࢹࣉࢵ࢔ࡘいࠊࡋ使用ࢆ㸦Help > Check for Updates㸧ࣉࣝ࣊ࠊ࡟ࡾ代わࠋࢇࡏࡲ
 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇ

 

FEMtoolsࡢ࡜࣮ࣂ࣮ࢧ࣭ࢺ࣮ࢹࣉࢵ࢔接⥆ࢆ確立࢖ࠊࡣ࡟ࡿࡍンࢺࢵࢿ࣮ࢱ接⥆ࡀ要求࡟࡜ࡇࡿࢀࡉ注意ࡃ࡚ࡋ
 ࠋいࡉࡔ

使ࢆンࢱConfigure࣎ࠊࡣ変更ࡢンࣙࢩࣉ࣭࢜ࢺ࣮ࢹࣉࢵ࢔ࠊい࡚࠾࡟以降ࠊࡾあࡀ応答指示࡟時ࣉࢵ࢔ࢺ࣮ࢱࢫ
用࡚ࡋ行うࠋࡍࡲࡁ࡛ࡀ࡜ࡇ 

 ࠋࡍࡲࡁ開ࢆࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲࡢ次ࡣࢀࡇ

 

࡟単ࡣ通知ࡢࣉࢵ࢔ࢺ࣮ࢱࢫ 7᪥間隔࡛作成࢕ࢸࢵࢭ࣭࣮ࢨ࣮ࣘࡣࢀࡇࠋࡍࡲࢀࡉンࣝ࢖࢓ࣇ࣭ࢢ㸦࣮࣭࣮ࣘ࣍ࢨ
ࡢෆ࣮ࣜࢺࢡࣞ࢕ࢹ࣒࣮ femtools_400.ini㸧࡛設定ࠊࢀࡉCheckDaysInterval࡛修ṇࡢࡑࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ値ࡋ࡜
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選ࢆンࣙࢩࣉ࢜…Manually checkࠊࡣࢀࡇࠋࢇࡏࡲࢀ行わࡣࢡࢵ࢙ࢳࡢࢺ࣮ࢹࣉࢵ࢔ࠊࡤࢀࢀࡉ設定ࡀ㈇࠿0ࠊ࡚
ぶ࡜࡜ࡇ等価࡛ࠋࡍ 

FEMtoolsࣛࢭ࢖ン࣭ࢫコン࣮ࢱ࣮ࣞࢢ࢕ࣇ 

FEMtoolsࣛࢭ࢖ンࢥ࣭ࢫン࣮ࢱ࣮ࣞࢢ࢕ࣇ㸦License Configurator㸧ࡣ更新ࢺࢵࢿࠊࢡࢵࣟࢻ࣮ࣀࠊࢀࡉワ࣮ࣟࠊࢡ
࣮࣑ンࢭ࢖ࣛࡢࢀࡒࢀࡑࡢࢢンࢆࢫ形成࡟ࡵࡓࡿࡍ使用ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍWindows࡛ࠊࡣHelp > License 
Configuratorࢆ使用࢖ࠊࡋン࣮࣮ࣛࢺࢫ㸦Start > All Programs > FEMtools 4 > FEMtools License Configurator㸧࡟
 ࠋいࡉࡔࡃ࡚ࡋ使用ࢆftlmࠊࡣLinux࡛ࠋࡍࡲࢀࡉࢫࢭࢡ࢔࡬ࢡンࣜ࡟FEMtools 4ࠊ࡚ࡗࡼ

 

FEMtools License Configurator 

 ࠋࡍࡲࡋ使用ࢆLicense settingsࠊࡣい࡚ࡘ࡟ࢫンࢭ࢖࣭ࣛࢡワ࣮ࢺࢵࢿ࡜ࢫンࢭ࢖࣭ࣛࢡࢵࣟࢻ࣮ࣀ
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Core Product Nameࡀ入力࡞ࢀࡉい場合ࣉࢵ࢔ࢺ࣮ࢱࢫࠊ時ࠊ࡟FEMtoolsࢭ࢖ࣛࡣンࡀࢫ利用ྍ能ྡࢺࢡࢲࣟࣉ࡞
 ࠋࡍࡲࡾ࡞࡟ྡࢺࢡࢲࣟࣉࡿࡼ࡟ࢡࢵ࢙ࢳ自動ࠊ場合ࡿあ࡛ࢫンࢭ࢖ࣛ࡞利用ྍ能ࡢ個別ࠋࡍࡲࡋᥦ示ࢆ

次ࢆࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲࡢ開ࠊࡣ࡟ࡃConfigure license roamingࢆ使用ࠋࡍࡲࡋ 

 

࣮࣑ࣟンࣙࢩࣉ࣭࢜ࢢンࡢ設定後ࢆࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲࡢࡇࠊ閉ࠊ࡚ࡌ選択ࡓࢀࡉ Core Product Nameࢭ࢖ࣛࡢン
࡟ࡵࡓࡿࡍࢡࢵ࢙ࢳࢆࢫ FEMtoolsࢆ再開ࡉࡔࡃ࡚ࡋいࢭ࢖ࣛࠋンࡀࢫ利用ྍ能࢜ࢻ࢔࡞ン࡚࡭ࡍࡶ自動的࢙ࢳ࡟
 ࠋࡍࡲࢀࡉࢡࢵ

 ࣝࢢンࢻ

FEMtoolsࠊࡣSafenet SuperPro࡟加えࠊLinuxࢥン࡛ୖࢱ࣮ࣗࣆ使用ྍ能࡞新ࡋい Safenet HLࢻンࡋࢺ࣮࣏ࢧࢆࣝࢢ
 ࠋࡍࡲࢀࡉ使用࡟共࡜ࢫンࢭ࢖࣭ࣛࢡࢵࣟࢻ࣮ࣀࡣࣝࢢンࢻࠋࡍࡲ

 変更ࢫンࢭ࢖ࣛ

FE࢖࣭࣒ࣛࢢࣟࣉンࢫ࢖࢙ࣇ࣮ࢱ㸦ࡼ࠾び࢜ࢻ࢔ン解析࢜ࣙࢩࣉン㸧ࡣ個別ࢭ࢖ࣛࡢン࢖࡚ࣛࡗࡼ࡟ࢻ࣮ࢥ࣭ࢫ
 ࠋࡍࡲࢀࡉࢫンࢭ
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 新ࡋい hostid UUIDࡀ利用ྍ能࡛ࡣࢀࡇࠋࡍ wrlmhostid.exe࣮࡛ࣘ࢕ࢸ࢕ࣜ࢕ࢸ示ࡢࡇࠊࢀࡉ UUIDࢻ࣮ࢥ
uuidࠕFt_HostInfo㸦ࠊࡣ 㸧ࠖ関数ࡶࡽ࠿࣒ࣛࢢࣟࣉ࡚ࡗࡼ࡟検索ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 

 引ࡁ数 Ft_ProductInfo㸦"server"㸧ࠊࡣFt_ProductInfo㸦"name"㸧࡜共࡟使用࡛ࡼࡿࡁう࡟加えࠋࡓࡋࡲࢀࡽ 

例 

Sub Main print "hostid(uuid) = "; Ft_HostInfo("uuid")  
print "ft_productinfo(server)=";ft_productinfo("server")  
print "ft_productinfo(name)=";ft_productinfo("name")  

End Sub  

 FEMtools 4ࢭ࢖ࣛࡣン࣓ࢪ࣮ࢿ࣐࣭ࢫン࡟ࡵࡓࡢࢺ RLM 12.2ࢆ使用ࠋࡍࡲࡋあࡢ࠾ヲ細࡞情報࡟関ࠊࡣ࡚ࡋ
RLM࣓ࣗ࢟ࢻンࢆࢺ参照ࡉࡔࡃ࡚ࡋいࠋ 

 RLM_ROAM環境変数ࡣ㸯᪥間ࢭ࢖ࣛࡢンࢆࢫ᭷効ࠊ࡟ࡵࡓࡿࡍ࡜”tiday”値ཷࢆ理ࡢࡇࠋࡍࡲࡋ機能ࠊࡣRLM 
v11.0+࢔࢖ࣛࢡンࡢ࣮ࣂ࣮ࢧ࡜ࢺ両方ࡢ設定࡟依Ꮡࠋࡍࡲࡋ 

 環境変数 RLM_QUEUEࡀࢺ࣮࣏ࢧࡢ加えࠊࢀࡽRLM_QUEUE環境変数ࡀᏑᅾࡿࡍ場合㸦重要࡛࡞い値㸧ࠊ
FEMtools࢖࣓ࡣン機能ࢺ࢘࢔ࢡࢵ࢙ࢳࡢ設定ྍࡀ能ࢭ࢖ࣛࠋࡍࡲࡾ࡞࡟ンཷࡀࢫ理࡞ࢀࡉい場合㸦௚࣮ࣘࡢ
ࠋࡍࡲࡕᚅࡣFEMtoolsࠊ࡛ࡲࡿ࡞࡟利用ྍ能ࡀࢫンࢭ࢖ࣛࡢࡑࠊ㸧ࢫンࢭ࢖ࣛࡿい࡚ࢀࡉ使用࡚ࡗࡼ࡟࣮ࢨ
RLM_QUEUE変数ࡀ設定࡚ࢀࡉい࡞い場合ࠊFEMtoolsࢭ࢖ࣛࡣンཷࢆࢫ理ࠋࢇࡏࡲࡋRLM_QUEUEࡣ
RLM_ROAM࡜非互換性࡛あ࡟࡜ࡇࡿ注意ࡉࡔࡃ࡚ࡋいࠋRLM_ROAM࣑࣮ࣟࡣンࡢࢢ準備࡚ࡁ࡛ࡀいࡿ場
合ࠊRLM_QUEUEࡣ非ࣈ࢕ࢸࢡ࢔化ࠋࡍࡲࢀࡉ言い࠿えࠊࡤࢀRLM_ROAM࡜ RLM_QUEUEࡢ両方ࢺࢵࢭࡀ
 ࠋࡍࡲࢀࡉ無視ࡣRLM_QUEUEࠊ場合ࡿࢀࡉ
ࡣ制限ࡢࡇ RLM v12.0ࠊ࡚ࡗࡼ࡟起動ࢥンࢆ࣮ࣝࣟࢺ強化ࢭ࢖ࣛࡣࢀࡇࠋࡍࡲࡋンཷࡀࢫ理ࡿࢀࡉ場合࡛
ࢀ࡞࡟᭷効ࡀࢫンࢭ࢖一᪦ࣛࠋࡍࡲࡋࢡࢵࣟࢆࢫンࢭ࢖ࣛࡢ࡛࣮ࢱ࣮ࣗࣆンࢥ࣭ࣝ࢖ࣂࣔࡀRLM_ROAMࠊࡶ
 ࠋࢇࡏࡲࡋや作動ࡣࡶࡣRLM_QUEUEࠊ࡛ࡢࡿ࡞࡟ࢫンࢭ࢖࣭ࣛࢡࢵࣟࢻ࣮ࣀࡀࢫンࢭ࢖ࣛࡢ࠾あࠊࡤ

 ࣛࢭ࢖ンࠊࡣ࡟ࣝ࢖࢓ࣇ࣭ࢫ‘customer’࡜‘contract’ࡀࢻ࣮ࣝ࢕ࣇࡢᏑᅾࢭ࢖ࣛࡢࡇࠋࡍࡲࡋンࢫ情報㸦Help > 
License Information㸧࡜࣮࣐ࢱࢫ࢝ࠊࡣ契約ࡢ情報ࢆ示ࠋࡍࡲࡋ起動ཷࡀ理ࡓࢀࡉ場合ࢥࠊン࢕࣭࣮࢘ࣝࢯン
ࡣ情報࣮࣐ࢱࢫ࢝ࠋࡍࡲࡋ出力ࢆ情報࣮࣐ࢱࢫ࢝ࡢࡑ࡟࢘ࢻ aboutࡶ࡛ࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ確認࡛ࠋࡍࡲࡁ 

 RLMࣜࡢ࡬ࢺ࢖ࢧ࣭ࢺ࣮࣏ࢧンࠊࡀࢡHelp࣓࣮ࣗࢽ㸦Help > RLM Support Site㸧࡟加えࠋࡓࡋࡲࢀࡽ 
 RLM࣐࣓ࢪ࣮ࢿンࣜࡢ࡬ࣝ࢔ࣗࢽ࣐࣭ࢺンࠊࡀࢡFEMtools License Configurator ࡟加えࠋࡓࡋࡲࢀࡽ 
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 変更点ࡢࢺキ࣓ࣗンࢻ

次ࡢ大変化࣓ࣗ࢟ࢻࡀン࡜ࢺ例࡟作ࡓࡋࡲࢀࡽ: 

 FEMtools࣓ࣗ࢟ࢻンࢫ࣮ࣜࣜࡢࡇࡣࢺ伴࡚ࡗ更新ࠋࡍࡲࢀࡉ 
 新規ࡢ LS―DYNA࢖ンࡀࢻ࢖࢞ࡢࣂ࢖ࣛࢻ࡜ࢫ࢖࢙ࣇ࣮ࢱ追加ࠋࡍࡲࢀࡉ 
 実験計画法㸦DOE:design of experiments㸧ࡢ基礎情報ࡼ࠾び࣏ࣞࢫンࣜࢹ࣭ࣔࢫ࢖࢙ࣇ࣭ࢫンࢢ㸦RSM:response 

surface modeling㸧ࠊࡣFEMtools Model Updating User’s Guide࡜ FEMtools Optimization User’s Guidࡽ࠿新ࡋい
FEMtools Sensitivity࡜ Design of Experiments࡟ࢻ࢖࣮࢞ࢨ࣮ࣘࡢ移動ࠋࡓࡋࡲࡋFEMtools Model Updating User’s 
Guide࡜ FEMtools Optimization User’s GuidࠊࡣFEMtools DOE/RSMࡢ使用方法ࡘ࡟い࡚ࡾࡼࡢ実際的࡞情報ࢆ
ᥦ供ࠋࡍࡲࡋ 

 個別࣮ࣜࢺ࣓࣏ࢺࡢ最適化ࡢ例題ࡢヲ細࡞記述ࠊࡀFEMtools Optimization User’s Guid࡟追加ࠋࡍࡲࢀࡉ 
 PointCloud࢜ ࣓ࣗ࢟ࢻ࡚ࡋ࡜関数ࢺࣉࣜࢡࢫࡣCreateObject関数ࠋࡍࡲࢀࡉ変更ࡀࢺン࣓ࣗ࢟ࢻࡢࢺࢡ࢙ࢪࣈ

ンࢺ化ࠊࡋࡔࡓࠋࡓࡋࡲࢀࡉFillࠊFindNearestࠊSearchRadiusࠊࡣPointCloud࢜ ࢻ࡚ࡋ࡜使用方法ࡢࢺࢡ࢙ࢪࣈ

࣓࢟ࣗンࢺ化ࠋࡓࡋࡲࢀࡉPointCloud࢜ ࣭ࣜࢺࣉࣜࢡࢫࠊࡣࢺࢡ࢙ࢪࣈい辞書࢜ࡋ新࡜使用方法ࡢࢺࢡ࢙ࢪࣈ

 ࠋࡍࡲࢀࡉ化ࣉ࣮ࣝࢢ࡟章ࡢ使用方法㸧ࠖࡢࢺࢡ࢙ࢪࣈObject Methods㸦࢜ࠕいࡋ新ࡢࣝ࢔ࣗࢽ࣐ࢫンࣞ࢓ࣇ
 ࣐ࢥンࢻ SENSITIVITY SOLVER࣓ࣗ࢟ࢻࡣンࢺ化࡚ࢀࡉい࣓ࣗ࢟ࢻࡣࢀࡑࠊࡀࡓࡋࡲンࡾྲྀࡽ࠿ࢺ除ࠊࢀ࠿

SENSITIVITY SOLVERࡣ SENSITIVITY METHOD char_val࡟替わ࡟࡜ࡇࡓࡗ注意ࡉࡔࡃ࡚ࡋいࠋ 

例題ࡢ変更点 

 次ࡢ例題ࡀ追加ࠋࡍࡲࢀࡉ 

 Calculix࢖ࡢンࣂ࢖ࣛࢻ࡜ࢫ࢖࢙ࣇ࣮ࢱ：..\examples\interfaces\calculix 
 LS-Dyna࢖ࡢンࣂ࢖ࣛࢻࡢࡵࡓࡢ：ࣂ࢖ࣛࢻ࡜ࢫ࢖࢙ࣇ࣮ࢱ:..\examples\interfaces\lsdyna 

 ࣎ࣝࢺ締ࢺ࣮ࣞࣉࡵ構造㸦“BoxBeam”㸧ࢺࢫࢸࣜࣉࡢ解析: ..\examples\pretest\boxbeam 
 ࡛࣎ࣝࢺ締ࢺ࣮ࣞࣉࡵ構造㸦“BoxBeam”㸧ࡢ FEMࢺࢫ࢟ࢸ相関ศ析: ..\examples\correlation \boxbeam 
 GVTࣙࢩ࣮࣑ࣞࣗࢩン࣭ࣔ࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔࡢࣝࢹンࢢ: ..\examples\updating\gvt 
 ࡛࣎ࣝࢺ締ࣝࢹ࣭ࣔࢺ࣮ࣞࣉࡵ㸦“JimBeam”㸧࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔࡢンࢢ:  

..\examples\updating\jimbeam 
 ࣜࣉࢫンࢢ要素ࢱ࣮࣓ࣛࣃ࣭ࢺ࣮ࢹࣉࢵ࢔ࡢ KT࡜ KRࡢ使用方法： 

..\examples\updating\plate_modal\run06ktr.cmd 
 ࣜࣉࢫンࢢ要素ࢱ࣮࣓ࣛࣃ࣭ࢺ࣮ࢹࣉࢵ࢔ࡢ Dࡢ使用方法： 

..\examples\updating\plate_modal\run06d.cmd 
 ࣏ࢫࣞࠊࢱ࣮࣓ࣛࣃ࡞ࢡࢵࣜࢿ࢙ࢪン࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔࡢ࣮ࣂࣝࢯࠊࢫンࢢ方法:  

..\examples\generic\excel (using MS Excel solver)  

..\examples\generic\frf (generic solver to driver PADEFRF and MODALFRF) 

..\examples\generic\modal 
 ࣏࣮ࣞࢺ例題：..\examples\reporting\updating 

 次ࡢ例題ࡀ࣮ࢲ࢛ࣝࣇ移動ࠋࡓࡋࡲࡋ 

 \fea\complex_modes࣮ࢲ࢛ࣝࣇࠊࡣ\dynamics\complex_modes࡟移動ࠋࡓࡋࡲࡋ 
 \fea\modal_solver࣮ࢲ࢛ࣝࣇࠊࡣ\dynamics\modal_solver࡟移動ࠋࡓࡋࡲࡋ 

 次ࡢ例題ࡀ更新ࠋࡓࡋࡲࢀࡉ 

 \dynamics\modal_solver 
 ..\examples\updating\generic\excel\demo.cmd 
 ..\examples\optimization\doe\spring\spring_doe_excel.bas 
 ..\examples\optimization\genetic\dmo\dmo_ga.cmd 

 inertia.basࡣࢺࣉࣜࢡࢫ࣭࣒ࣛࢢࣟࣉ࣭ࣔࢹ削除ࠋࡓࡋࡲࢀࡉ 
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FEMtools࣒࣮ࣞࣇワ࣮ࢡ 

FEMtools࣒࣮ࣞࣇワ࣮ࡢࢡ主࡞変更点ࢆ示ࠋࡍࡲࡋ 

FEMtoolsࢺࣉࣜࢡࢫ言語 

 Dictionary㸦辞書㸧࢜ࠋࡓࡋࡲࢀࡉࢺ࣮࣏ࢧࡀࢺࢡ࢙ࢪࣈDictionaryࠊࡣ様々ࢆࣉ࢖ࢱ࣭ࢱ࣮ࢹ࡞格納࣮ࢿ࣐ࡋ
 㸦Help > Helpࣉࣝ࣊ࠋࡍ࡛ࢺࢡ࢙ࢪࣈ࣭࢜ࢫ࣮࣋ࢱ࣮ࢹ࡞柔軟ࡿࡁ࡛ࡀ࡜ࡇࡿࡍ使用࡟ࡵࡓࡿࡍࢺン࣓ࢪ
Topics > Scripting Reference > Object Methods > Dictionary㸧ࡽ࠿ FEMtoolsࣞ࢓ࣇ࣭ࣜࢺࣉࣜࢡࢫンࣝ࢔ࣗࢽ࣐ࢫ
 ࠋいࡉࡔࡃ࡚ࡋ参照ࢆ

 ࠊࡣࣝ࢖࢓ࣇ࣭ࣝࢼ࣮ࣕࢪ”journal_FT<pid>.tmp”ࡼࡢうࠊ࡟現ᅾࣙࢩࢵࢭࡢンࢫࢭࣟࣉ pidࡀ付ࠋࡍࡲࢀࡽࡅ
複数ࡢ FEMtoolsࣙࢩࢵࢭンࢸࡌྠࡀン࣏ࣛࣜ࡟࣮ࢲ࢛ࣝࣇ࣭ࣝ࢖࢓ࣇ共᭷ࡿࢀࡉ場合ࡢ問題ࢆ回避ࠋࡍࡲࡋ 

 Calculix࢖ンࢫ࢖࢙ࣇ࣮ࢱとࣂ࢖ࣛࢻ 

 FRF࣮ࣜࠊࡣࢲ短いࡣࡓࡲ長い ASCII࡟ࡵࡓࡿࡍࢺ࣮࣏ࢧࢆࢺࢵ࣐࣮࢛ࣇ更新ࠋࡓࡋࡲࢀࡉ 
 ࢺࣉࣜࢡࢫ࣭࣒ࣛࢢࣟࣉ࣭ࣂ࢖ࣛࢻ㸦calculix.bas㸧ࠊࡣWindows࡜ Linuxࡢ両方࡟ࡵࡓࡢ更新ࠋࡓࡋࡲࢀࡉ 
 ࢥ࣭ࣂ࢖ࣛࢻンࣙࢩ࣮ࣞࢢ࢕ࣇン࢕ࢸࢵࢭࠊࡣンࣝ࢖࢓ࣇ࣭ࢢ calculix.ini中࡛設定ࠋࡍࡲࢀࡉ 
 例題ࡢ..\examples\interfaces\calculixࡀ追加ࠋࡓࡋࡲࢀࡉ 

 ࣂ࢖ࣛࢻとࢫ࢖࢙ࣇ࣮ࢱン࢖࣭ࣝ࢖࢓ࣇ࣭ࣝࢧ࣮ࣂࢽࣘ

 ࢖ࡢࢺ࢛ࣝࣇࢹン࢕ࢸࢵࢭ࣭ࢫ࢖࢙ࣇ࣮ࢱンࠊࡣ࡛ࢢ異࢖ࡽ࠿ࣝ࢖࢓ࣇࡿ࡞ン࣏࣮ࣉ࣮࢙ࢩࢻ࣮ࣔࡓࢀࡉࢺや

ODS࡟ࢫ࣮࣋ࢱ࣮ࢹࡀ追加࡞ࢀࡉいࠊ࠿既Ꮡୖ࡟ࢻ࣮ࣔࡢ書ࡼࡿࡍࡁう࡟修ṇࠋࡍࡲࢀࡉFRFࡘ࡟い࡚ࠊࡣ
append࣮ࣔ࢜ࡢࢻンࡢࡇࠋࡍ࡛ࢺ࢛ࣝࣇࢹࡀ振ࡿ舞いࠊࡣSET INTERFACE UFF࣐ࢥンࢻあࡿいࡣ変数
interface.uff.aflagsࡢ設定ࡾࡼ࡟修ṇࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 

 ࢺン࣓ࢪネ࣮࣐࣭ࢫ࣮࣋ࢱ࣮ࢹ

 ࣮࢜ࣛ࢖角㸦DEFINE EULER࣐ࢥンࢻ㸧ࢆ使用࣮ࣝ࢝ࣟࡓࡋᗙ標系ࡢ定義 
 新ࡋいࢱ࣮࣓ࣛࣃ D㸦材料ࡢ弾性࣐ࢫࢡࢵࣜࢺ係数ࣜࣉࢫ࡜ン࣮ࣝࢣࢫ࣭ࢢ係数㸧：࣒࣮ࣅࡣࢱ࣮࣓ࣛࣃࡢࡇ

やࣜࣉࢫンࢢ㸦࣭ࣞࣟࢮンࡶࢫࢢ含ࡴ㸧ྠ࡜様࢙ࣝࢩ࡟やࡢࢻࢵࣜࢯ特性ࢆ表わࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡍ次ࣔࢹࡢ

ンࣙࢩ࣮ࣞࢺࢫン例ࢆ参照ࡉࡔࡃ࡚ࡋいࠋ 
\examples\updating\plate_modal\run06d.cmd  

 新ࡋいࢱ࣮࣓ࣛࣃ KT࡜ KRࣜࣉࢫࠊࡣンࢢ並進剛性ࣜࣉࢫ࡜ンࢢ回転剛性࡟関࣮ࣝࢣࢫࡿࡍ係数࡛ࠋࡍ次ࡢ
 ࠋいࡉࡔࡃ࡚ࡋ参照ࢆン例ࣙࢩ࣮ࣞࢺࢫンࣔࢹ
\examples\updating\plate_modal\run06ktr.cmd 

 PARAMETER TEXTࠊࡣNastranࡢࣝ࢖ࢱࢫ倍精ᗘࢺࢵ࣐࣮࢛ࣇ㸦例え7.17+10ࠊࡤ㸧ࢆㄞࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡴ
以前࡚ࡋ࡜7.17ࠊࡣㄞ࡚ࢀࡲい7.17ࠊࡀࡓࡋࡲE+10࡚ࡋ࡜ㄞࡳ込ࠋࡍࡲࢀࡲ 

 CLEAR SHAPES࣐ࢥンࡀࢻ改善࣐ࢥࡢࡇࠋࡓࡋࡲࢀࡉンࡀࢻ実行ࡓࢀࡉ場合ࡢ警告࣓ࡶࢪ࣮ࢭࢵ改善ࡲࢀࡉ
 ࠋࡓࡋ

 ࣏ࡽ࠿࣮ࣗࢽ࣓࣭ࣉࢵ࢔ࣉࢵ重力荷重㸦Gravity Loads㸧ࢆ実行ࡓࡋ場合ࠊGravity Loads࡟ࣝࣈ࣮ࢸ追加ࢀࡉ
 ࠋࡓࡋࡲࡋ改善ࢆい問題࡞

 ࣐ࢥンࢻMODIFY FRFࡀ更新ࡾࡼࠊࢀࡉ多ࣙࢩ࣮ࣞ࣌࢜ࡢࡃンࡀ解析ࡼ࠾びࡢࢺࢫࢸ FRF࡟対࡚ࡋ実行ࢀࡉ
 ࠋࡍࡲ

 ANALYZE[KEYWORD=VALUE,...࣐ࢥンࠊࡣࢻ総体的࡞解析特性ࢆ指定࡟ࡵࡓࡿࡍ使用ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ
ࡢࡑ API関数 Ft_GetProperties("analyze")ࢆࡽࢀࡑࡣ検索࡟ࡵࡓࡿࡍ使用ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 

 ࢫ࢖࢙ࣇ࣮ࢱン࢖࣭࣮ࢨ࣮ࣘ

FEMtools࣮ࣘ࢖࣭࣮ࢨンࡢࢫ࢖࢙ࣇ࣮ࢱ変更点ࡘ࡟い࡚概ㄝࠋࡍࡲࡋ 
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 ࢘ࢻン࢕ン࣭࢘ࣙࢩ࣮ࢣࣜࣉ࢔ン࣭࢖࣓

 ࡣࣝ࢖ࢱࢫ࣭ࢺ࢛ࣝࣇࢹ白い背景㸦white background㸧࡟変わࠋࡓࡋࡲࡾFEMtools 3࡛ ࣝ࢖ࢱࢫ࣭ࢺ࣮࣏ࣞࠊࡣ
㸦report.sty㸧࡚ࡋ࡜知࡚ࢀࡽいࠊࡀࢀࡇࠋࡓࡋࡲdefault.styࠊࡾ࡞࡟report.styࡣ削除ࠋࡓࡋࡲࢀࡉ 

 新ࡋいࠊ࡚ࡋ࡜ࣝ࢖ࢱࢫFEMtools 4ࢆࣝ࢖ࢱࢫ FEMtools 3ࡢࡵࡓࡿࡍࢺࢵࢭࣜ࡟ ft3.styࡀ追加ࠋࡓࡋࡲࢀࡉ 

ツールバー 

 新ࡋい࣋ࢥ࢖࢔ࡢࢫ࣮࣭࣋ࣝࢺࢡン㸦SVG㸧 
 高解像ᗘࣔࢱࢽ㸦4K㸧対応ࡢ自動的࣮ࣜࢣࢫンࢥ࢖࢔࣭ࢢン 

コンソ࣮࣭ࣝ࢘࢕ン࢘ࢻ 

 一般ࠊ࡟実行࣓࣮ࣗࢽ関数࡚ࡗࡼ࡟生成ࡿࢀࡉ FEMtools࣐ࢥンࡣࢻᑠ文Ꮠࡀ࣮ࢱࢡࣛࣕ࢟ࡢ使用ࠋࡍࡲࢀࡉ
ࡣࢻン࣐ࢥࡢ࡚࡭ࡍࠊࢀࡉ改善ࡀࢀࡇࠋࡓࡋࡲい࡚ࢀࡉ生成ࡀࢻン࣐ࢥࡢ大文Ꮠࡣ࡟࣮ࣗࢽ࣓ࡢ少数ࠊࡋ࠿ࡋ

ᑠ文Ꮠ࢟ࣕࣛࢆ࣮ࢱࢡ使用࡚ࡋ生成ࠋࡍࡲࢀࡉ 

 ࣮࣮ࣛࣟࣉࢫࢡ࢚࣭ࢫ࣮࣋ࢱ࣮ࢹ

 ࠋࡍࡲࢀࡉ表示࡚ࡋ࡜ࣉ࣮࢙ࢩ࣭࣮ࢱンࢥࠊࡃ࡞ࡣ࡛࡚ࡋ࡜ࣉ࣮࢙ࢩや変形ࡣࡶࠊࡣ変形ࡢ解析ࢺࢫࢸࣜࣉ

 ࢢキンࢵࣆ࣭ࢫࢡࢵ࢕ࣇࣛࢢ

ࡲࢀࡉᑟ入ࡀ機能ࡢࡵࡓࡢ操作ࢢン࢟ࢵࣆࡿࡼ࡟࣒ࢬࣜࢦࣝ࢔いࡋ新ࠊࢀࡉ更新ࡀࢫ࢖࢙ࣇ࣮ࢱン࢖࣭ࢢン࢟ࢵࣆ

 ࠋࡓࡋ

Graphics࢘࢕ン࡞ࣈ࢕ࢸࢡ࢔ࡀ࢘ࢻ場合ࡢୖ࣮ࣂ࣮ࣝࢶࠊ Picking࣎ࢱン࡟࣮ࣗࢽ࣓ࣈࢧࠊࡣ変わࠊ࡚ࡗPicking
 ࠋࡍࡲࡋࢺ࣮࣏ࢧࡀ機能ࡢ次ࠊࡣࣝࢿࣃPickingࠋࡍࡲࡁ開ࢆࣝࢿࣃ

 節点࡜要素࢖࣏ࠊン࢖ࣛࢫ࣮ࣞࢺ࡜ࢺン࢟ࢵࣆࡢンࢆࢢ選択ࡢࡑࠋࡍࡲࡋ機能ࠊࡣ現ᅾ表示࡚ࢀࡉいࢩࢵ࣓ࡿ

ࣗ㸦FEࢺࢫࢸࡣࡓࡲ㸧࡟ࣉ࢖ࢱ依Ꮡࠋࡍࡲࡋ 
 Single Pick, Polygon Pick, Pick by Face, Pick by Attached ࡢ࡝࡞選択ྍࡀ能࡛ࠋࡍ 
 ࡢ࣒ࢸ࢖࢔追加ࡢ࣒ࢸ࢖࢔ࠊ削除࢟ࢵࣆࠊンࡢࢻ࣮࣭ࣔࢢ選択ྍࡀ࡝࡞能࡛ࠋࡍ 
 ࢟ࢵࣆンࢢ操作ࡢ開始ࠊ中断ྍ࡝࡞⥆⥅ࠊ能࡛ࠋࡍ 
 ࡛ࢺࢵࢭ選択ࢆ࣒ࢸ࢖࢔ࡓࢀࡉ保Ꮡྍࡀ能࡛ࠋࡍ 
 ࢆࢱࣝ࢕ࣇ࣭ࢫ࣮࣋ࢱ࣮ࢹ使用ࢡࢵࣆࠊࡋ選択ࢆ初期化ྍࡀ࡜ࡇࡿࡍ能࡛ࠋࡍ 
 隠ࢥࢆ࣮ࣗࣅࡢ࣒ࢸ࢖࢔ࢀンࠊ࡟ࡵࡓࡿࡍ࣮ࣝࣟࢺSee-through Element Highlight Mode㸦透明要素࢖ࣛ࢖ࣁࡢ

 ࠋࡍ能࡛ྍࡀ࡜ࡇࡿࡍ選択ࢆ㸧ࢻ࣮࣭ࣔࢺ
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Pickingࣝࢿࣃ 

Node-point࣌࢟ࢵࣆ࣭࢔ンࠊࡣࢢPickingࡣ࡛ࣝࢿࣃ利用࡛ࠋࢇࡏࡲࡁ 

Node-Point Pairingࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ㸦Tools > Correlation Analysis > Node-Point Pairs㸧ࡀ追加ࠋࡓࡋࡲࢀࡉ 

 ࢔࣮ࣗࣅ࣭࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮ࣔ

ࡀ࢔࣮ࣗࣅ࣭࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮࣭ࣔࣈ࢕ࢸࢡࣛࢱン࢖ Tools > Correlation Analysis࣓࡟࣮ࣗࢽ追加ࠊࢀࡉTools > 
Correlation Analysis > Mode Shape Pair Viewerࢆ使用ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 
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 ࢔࣮ࣗࣅ࣭࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮࣭ࣔࣈ࢕ࢸࢡࣛࢱン࢖

更新ࢆ࢖ࣞࣉࢫ࢕ࢹ࣭ࢫࢡࢵ࢕ࣇࣛࢢࠊ࡜ࡿࡍ選択ࢆ࢔࣌ࠋࡍࡲࡋ示ࢆ࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮ࣔࡢ現ᅾࡣ࡟ࣝࣈ࣮ࢸ

 ࠋࡍࡲࡋ化ࢺ࢖ࣛ࢖ࣁࢆMAC値ࡢ中࣮ࣗࣅࢫࢡࢵࣜࢺ࣐ࠊࡋ

伴ࢆ白い輪郭ࡣࢻ࣮࣭ࣔ࢔࣌ࠋいࡉࡔࡃ࡚ࡋࢡࢵࣜࢡࢆMAC値ࡢ任意࡟ࡵࡓࡿࡍ更新ࢆ࣮ࣗࣅ࣭ࣉ࣮࢙ࢩࢻ࣮ࣔ
 ࠋࡍࡲࢀࡉ表示࡛ࢇ並ࡶࢻ࣮࣭ࣔ࢔非࣌ࠋࡍࡲࢀࡉ表示࡛ࢢン࣮ࣜࢣࢫ࡞適ษࡣࣉ࣮࢙ࢩࢻ࣮ࣔࠊࢀࡉ識別࡚ࡗ

 

非࣌ࣉ࣮࢙ࢩࢻ࣮࣭ࣔ࢔㸦࢖ン࢔࣮ࣗࣅ࣭࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮࣭ࣔࣈ࢕ࢸࢡࣛࢱ㸧 

更ࡀࢫࢡࢵ࢕ࣇࣛࢢ࡜ࣝࣈ࣮ࢸ࡜ࡿࡍࠋࡍࡲࡋ使用ࢆンࢱCreate Pair࣎ࠊࡣ࡟ࡿࡍ強調ࢆ࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮ࣔ
新ࠋࡍࡲࢀࡉ 

Delete Pairࠊ Clear AllࠊAuto Pairࢆ使用ࣉ࣮࢙ࢩࢻ࣮ࣔࠊࡋ結果ࢥࢆンࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ࣮ࣝࣟࢺ 
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ࡉࡔࡃ࡚ࡋࢡࢵࣜࢡࢆンࢱClose࣎ࠊࡣ࡟ࡿࡌ閉ࢆࣝࢿࣃ࣭࢔࣮ࣗࣅ࣭࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮࣭ࣔࣈ࢕ࢸࢡࣛࢱン࢖
いࠋ 

 ࢻコ࣐ン࣭࣮ࣗࢽ࣓

次࣐ࢥ࣭࣮ࣗࢽ࣓ࡢンࡀࢻ FEMtools 4࡟加えࠋࡓࡋࡲࢀࡽ 

 Database > Test Model Editor：࢖ࡢࣝࢹ࣭ࣔࢺࢫࢸンࢆࣝࢿࣃ࣭ࢱ࢕ࢹ࢚࣭ࣈ࢕ࢸࢡࣛࢱ開ࠋࡍࡲࡁ 
 Tools > Pretest Analysis > Mode Participation Maps：ࢺࢫࢸࣜࣉ解析่ࢻ࣮ࣔࡢ激࣐ࢆࣉࢵ計算ࠋࡍࡲࡋ 
 Tools > Pretest Analysis > Excitation Location Selection：ࢺࢫࢸ構造ࣔࡢࣝࢹ最適加振ࣞࢆࢺ࢘࢔࢖᥈索ࣃࡿࡍ

 ࠋࡍࡲࡁ開ࢆࣝࢿ
 Tools > Pretest Analysis > Support Location Selection：ࢺࢫࢸ構造ࣔࡢࣝࢹ支持方法や࣌ࢫࢧンࢻ最適方法ࢆ見

 ࠋࡍࡲࡋ表示ࢺࢵࣟࣉ࡟ࡵࡓࡿࡅࡘ
 Tools > Correlation Analysis > Mode Shape Pair Viewer：࢖ン࢔࣮ࣗࣅ࣭࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮࣭ࣔࣈ࢕ࢸࢡࣛࢱ

 ࠋࡍࡲࡁ開ࢆ
 Help > License Configurator：ࣛࢭ࢖ンࢥ࣭ࢫン࢖ࢧ࢔ࢆ࣮ࢱ࣮ࣞࢢ࢕ࣇンࠋࡍࡲࡋ 
 Help > FEMtools Support Site：FEMtoolsࢆࢪ࣮࣌ࢺ࣮࣏ࢧ開ࠋࡍࡲࡁ 
 Help > RLM Support Site：RLMࢆࢪ࣮࣌ࢺ࣮࣏ࢧ開ࠋࡍࡲࡁ 
 Help > Check for Updates：最新ࣙࢪ࣮ࣂンࠋࡍࡲࡋࢡࢵ࢙ࢳࢆ 

次࣐ࢥ࣭࣮ࣗࢽ࣓ࡢンࡀࢻ FEMtools 4࠾࡟い࡚ࠊ削除ࠋࡓࡋࡲࢀࡉ 

 View > Graphical Pickingࠊࡣ࣮ࣗࢽ࣓ࣈࢧView > Graphical Picking࣓࡚ࡗࡼ࡟࣮ࣗࢽ開ࠊࡃPicking Panel࡟替
えࠋࡓࡋࡲࢀࡽ 

 ࣓࢕࣭࢘ࣗࢩࢵンࡢ࣮ࣗࢽ࣓࣭ࣉࢵ࢔ࣉࢵ࣏ࡢ࢘ࢻGraphical Pickingࣗࢽ࣓࣭ࣉࢵ࢔ࣉࢵ࣏ࠊࡣ࣮ࣗࢽ࣓ࣈࢧ
 ࠋࡓࡋࡲࢀࡽ替え࡟Picking Panelࠊࡃ開࡚ࡗࡼ࡟࣮ࣗࢽGraphical Picking࣓ࡢ࣮

 ࣮ࣂ࣮ࣝࢶ࣭ࢫࢡࢵ࢕ࣇࣛࢢ中ࡢpicking࣎ࢱンࡣ࣮ࣗࢽ࣓ࣈࢧࡢ削除ࢱ࣎ࡢࡑࠊࢀࡉンࠊࡣPickingࢆ開ࡲࡁ
 ࠋࡍ

 ࢫࢡࢵ࢕ࣇࣛࢢ

FRFࡢ࢖ࣞࣉࢫ࢕ࢹ࣭ࢺ࢛ࣝࣇࢹ改善：以前ࣙࢪ࣮ࣂン࡛0ࠊࡣ振幅値ࡀ検知ࡓࢀࡉ場合ࠊY軸࣮ࣜࢣࢫンࢆࢢ固
定࡚ࢀࡉいࡀࢀࡑࠋࡓࡋࡲ改善࣮ࣜࢣࢫࡢࡑࠊࢀࡉンࡣࢢ中間値ࡣࡓࡲ STD࣮࣋ࢢࣟࠋࡍࡲࡾ࡞࡟ࢫ㸦FRF㸧࢝
ࡢࢺ࢛ࣝࣇࢹ࣭ࣈ࣮ Y軸ୗ限値ࢢࣟࡣ㸦FRF㸧値ࣞࡢンࢪ外消去ᢏ術࡟基࡙いࡓ中間値㸦log(FRF)㸧-10*std
㸦log’(FRF)㸧以ୗࡼࡿ࡞࡟う࡟決定ࠋࡍࡲࢀࡉ 

 ࢢン࢕ࢸ࣮࣏ࣞ

FEMtoolsࡢࢫ࣮࣋ࢱ࣮ࢹ情報ࢆ直接的࡟MSWordࠊPowerpointࠊExcelࡣࡓࡲࠊ ASCIIࢺ࣮࣏ࣞ࡟ࣝ࢖࢓ࣇࢺࢫ࢟ࢸ
 ࠋࡍ必要࡛ࡀOffice2013以ୖࠊࡣ࡚ࡋ࡜動作条件ࡢࡑࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ

次ࡢ機能࣐ࢥࡀンࠋࡍࡲࢀࡉࢺ࣮࣏ࢧ࡚ࡗࡼ࡟ࢻ 

 新ࡋいࣙࢩࢵࢭンࡢ開始：ProgramNameࡀWORDࠊPOWERPOINTࠊEXCELࡢ場合࣐ࢥࠊンࢻ REPORT 
ProgramName LAUNCHࢆ使用ࠋࡍࡲࡋ 

 既Ꮡ࣓ࣗ࢟ࢻンࡢࢺ開ࡃ：ProgramNameࡀWORDࠊPOWERPOINTࠊEXCELࠊTEXTࡢ場合࣐ࢥࠊンࢻ
REPORT ProgramName OPENࢆ使用ࠋࡍࡲࡋ 

 新ࡋい࣓ࣗ࢟ࢻンࢆࢺ作成：ProgramNameࡀWORDࠊPOWERPOINTࠊEXCELࠊTEXTࡢ場合࣐ࢥࠊンࢻ
REPORT ProgramName NEWࢆ使用ࠋࡍࡲࡋ 

 ࣙࢩࢡࢭンࡢࣝࢺ࢖ࢱ࣭ࢻ࢖ࣛࢫࡣࡓࡲ追加：ProgramNameࡀWORDࠊPOWERPOINTࠊEXCELࠊTEXTࡢ場
合࣐ࢥࠊンࢻ REPORT ProgramName TITLEࢆ使用ࠋࡍࡲࡋ 

 ࢺ࣮࣏ࢫࢡ࢚ࡢࣝࣈ࣮ࢸࠊࢡࢵ࢕ࣇࣛࢢ：ProgramNameࡀWORDࠊPOWERPOINTࠊEXCELࠊTEXTࡢ場合ࠊ
ࢻン࣐ࢥ REPORT ProgramName MODELࢆ使用ࠋࡍࡲࡋ 
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 ࣉ࣮࢙ࢩࠊ࡚ࡋ࡜ࣝࣈ࣮ࢸࠊࢡࢵ࢕ࣇࣛࢢ情報㸦例えࣉ࣮࢙ࢩࢻ࣮ࣔࠊࡤ㸧ࢺ࣮࣏ࢫࢡ࢚ࡢ：ProgramName
ࢻン࣐ࢥࠊ場合ࡢTEXTࠊEXCELࠊPOWERPOINTࠊWORDࡀ REPORT ProgramName SHAPEࢆ使用ࠋࡍࡲࡋ 

 新規ࡢࢻ࢖ࣛࢫ追加：࣐ࢥンࢻ REPORT POWERPOINT ADDSLIDEࢆ使用ࠋࡍࡲࡋ 
 ࣌࢔情報㸦ࠊࢻ࣮ࣀDOF࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮ࣔࠊ㸧ࢺ࣮࣏ࢫࢡ࢚ࡢ：ProgramNameࡀWORDࠊ

POWERPOINTࠊEXCELࠊTEXTࡢ場合࣐ࢥࠊンࢻ REPORT ProgramName PAIRࢆ使用ࠋࡍࡲࡋ 
 ࢫࢡࢵࣜࢺ࣐ࠊ࡚ࡋ࡜ࣝࣈ࣮ࢸࠊࢡࢵ࢕ࣇࣛࢢ㸦例えࠊࡤMAC࣐ࢫࢡࢵࣜࢺ㸧ࢺ࣮࣏ࢫࢡ࢚ࡢ：

ProgramNameࡀWORDࠊPOWERPOINTࠊEXCELࠊTEXTࡢ場合࣐ࢥࠊンࢻ REPORT ProgramName MATRIX
 ࠋࡍࡲࡋ使用ࢆ

 ෆ部࢕ࢸࢵࢭン࣐ࢥ：ࢺ࣮࣏ࢫࢡ࢚ࡢࢢンࢻ REPORT TEXT VARIABLEࢆ使用ࠋࡍࡲࡋ 
 ࣓ࣗ࢟ࢻンࡢࢺ保Ꮡ：ProgramNameࡀWORDࠊPOWERPOINTࠊEXCELࡢ場合࣐ࢥࠊンࢻ REPORT 

ProgramName SAVEࢆ使用ࠋࡍࡲࡋ 
 ࣓ࣗ࢟ࢻンࢆࢺ閉ࡿࡌ：ProgramNameࡀWORDࠊPOWERPOINTࠊEXCELࠊTEXTࡢ場合࣐ࢥࠊンࢻ REPORT 

ProgramName CLOSEࢆ使用ࠋࡍࡲࡋ 
 ࣙࢩࢵࢭンࢆ閉ࡿ：ProgramNameࡀWORDࠊPOWERPOINTࠊEXCELࡢ場合࣐ࢥࠊンࢻ REPORT 

ProgramName QUITࢆ使用ࠋࡍࡲࡋ 
 ࣏࣮ࣞ࢕ࢸンࢢ過程࡚ࡗࡼ࡟生成ࢸࡓࢀࡉン࣏ࣛࣜࡢࣝ࢖࢓ࣇ削除：ProgramNameࡀWORDࠊ

POWERPOINTࠊEXCELࡢ場合࣐ࢥࠊンࢻ REPORT ProgramName RMFࢆ使用ࠋࡍࡲࡋ 

参ࢆ㸧ࢫンࣞ࢓ࣇࣜࢻン࣐ࢥFEMtools Command Reference㸦ࠊࡣい࡚ࡘ࡟ヲ細ࡢい࡚ࡘ࡟ࢻン࣐ࢥいࡋ新ࡢࡽࢀࡇ
照ࡉࡔࡃ࡚ࡋい࢕ࢸ࣮࣏ࣞࠋンࡢࢢ例題ࠊࡣ../examples/reporting/updating ࡛࣮ࢲ࢛ࣝࣇ見ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡅࡘ 

 生成ࣗࢩࢵ࣓

Lattice㸦格子㸧࣓࢖࣏ࡢࣗࢩࢵンࢺ間ࣙࢩ࣮ࣞࣜࡢンࢆ追加ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 

 ࣮ࣜࣞࣙࢩンࠊࡣDEFINE FMDRELATION࣐ࢥン࡚ࡗࡼ࡟ࢻ追加ࠋࡍࡲࢀࡉ 
 ࣮ࣜࣞࣙࢩンࠊࡣCLEAR FMDRELATION࣐ࢥン࡚ࡗࡼ࡟ࢻ削除ࠋࡍࡲࢀࡉ 
 既Ꮡࣙࢩ࣮ࣞࣜࡢン情報ࠊࡣEXTRACT FMDRELATION࣐ࢥン࡚ࡗࡼ࡟ࢻ確認࡛ࠋࡍࡲࡁ 

 ࢱ࢕ࢹ࢚࣭ࣝࢹ࣭ࣔࢺࢫࢸ

開ࡽ࠿Database > Test Model Editorࠊࡣࢀࡇࠋࡓࡋࡲࢀࡉ追加ࡀࣝࢿࣃ࣭ࢱ࢕ࢹい࢚ࡋ新ࡢࡵࡓࡢࣝࢹ࣭ࣔࢺࢫࢸ
 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡃ

 

 ࣝࢿࣃ࣭ࢱ࢕ࢹ࢚࣭ࣝࢹ࣭ࣔࢺࢫࢸ
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ࡲࢀࡉ構成࡛ࡘ㸰ࡢ㸦右㸧࢔࢚࣭ࣜ࢖ࣞࣉࢫ࢕ࢹ࣭ࢫࢡࢵ࢕ࣇࣛࢢ࡜㸦左㸧ࣝࣈ࣮ࢸࡓࢀࡽࡅࡘࡀࣈࢱࠊࡣࣝࢿࣃ

 ࠋࡍࡲい࡚ࢀࡉ意ᅗ࡟うࡼࡿࡍ編集ࢆ⥆び接ࡼ࠾ᗙ標系ࠊᗙ標ࢺン࢖࣏ࠊࡣࢀࡑࠋࡍ

ࡉࢫࢭࢡ࢔ࡽ࠿㸧ࢡࢵࣜࢡෆ࡛右ࣝࣈ࣮ࢸ㸦࣮ࣗࢽ࣓࣭ࣉࢵ࢔ࣉࢵ࣏ࡣンࣙࢩ࣮ࣞ࣌࢜ࡢ࡚࡭ࡍびࡼ࠾ࣈࢱࡢࡘ4
 ࠋࡍࡲࡋ記述࡟以ୗࠊい࡚ࡘ࡟ࣈࢱ各ࠋࡍࡲࡋ依Ꮡ࡟ࣈࢱࡓࢀࡉ選択ࡣ࣮ࣗࢽ࣓ࡢࡑࠋࡍࡲࢀ

Measurement Points㸦測定࣏࢖ンࢺ㸧 

新ࡋい測定࣏࢖ン࡟ࣝࣈ࣮ࢸࡀࢺ入力ࠋࡍࡲࢀࡉAppend new pointࢆ使用ࠊࡋ新ࡋい࣏࢖ンࢆࢺ追加ࡲࠋࡍࡲࡋ
ࡲࡋ使用ࢆCreate new point(s)ࠊࡣ࡟ࡿࡍ生成ࢆࢺン࢖い࣏ࡋ新ࡢ用ࢫ࢖࢙ࣇ࣮ࢧ࣭ࢺ࣮ࣞࣉࡣいࡿンあ࢖ࣛࠊࡓ
 ࠋࡍ

ࢽSelect࣓ࠊ࠿ࡿࡍ選択ࢆࢺン࢖࣏ࠊࡾࡼ࡟࡜ࡇࡿࡍࢡࢵࣜࢡࢆ࣮࣮࣐࣭࢝ࢺン࢖࣏ࡢࢺࢵࣟࣉ࣭ࢫࢡࢵ࢕ࣇࣛࢢ
 ࠋࡍ能࡛ྍࡶ࡜ࡇࡿࡍ使用ࢆࢻン࣐ࢥ࣭࣮ࣗ

既Ꮡࡢᗙ標系定義ࠊࡣ選択ࡋࢡࢵࣜࢡࢆࣝࢭ編集ࡢ࡚࡭ࡍࠊ࠿ࡿࡍ選択࡞ࣝࣂ࣮ࣟࢢ࡟ࣝࢭ変更ࢆ加え࡜ࡇࡿ

ࡢࣝࢭࡓࢀࡉ選択ࠊ選択後ࣝࢭࠊࡣ࡚ࡋ࡜編集操作ࠋࡍࡲࡁ࡛ࡀ ࣭࣎ࢻCtrl࣮࣮࢟࣎ࠊࡋࢡࢵࣜࢡࣝࣈࢲࢆࡘ1
ࡋ示ࢆ値ࡌྠࡣࣝࢭࡢ࡚࡭ࡍࡓࢀࡉ選択ࠋࡍࡲࡋࢡࢵࣜࢡࢆンࢱン࣭࣮࣎ࢱ࡚ࣜࡋ編集ࢆෆ容ࠊࡋ保持ࢆンࢱ

 Editࠊࡣࡓࡲࠋࡍࡲࡾࡲࡣ当࡚࡟ࣝࣈ࣮ࢸࡢ࡚࡭ࡍࡢࢱ࢕ࢹ࢚࣭ࣝࢹ࣭ࣔࢺࢫࢸࠊࡣ舞いࡿ振ࡢࡇࠋࡍࡲ
Selected Points࣓࣐ࢥ࣭࣮ࣗࢽンࢆࢻ使用ࡉࡔࡃ࡚ࡋいࠋ 

 Number points, Delete Selection, Sort all points, Renumber all points and Recordࠊࡣ࡚ࡋ࡜ンࣙࢩ࣮ࣞ࣌࢜ࡢ௚ࡢࡑ
point selection in setࠋࡍࡲࢀࡉࢺ࣮࣏ࢧࡀ࡝࡞  

 

Measurement Pointsࡢࣈࢱ右࣮ࣗࢽ࣓࣭ࢡࢵࣜࢡ 
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Add Pointsࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ 

Coordinate Systems㸦ᗙ標系㸧ࣈࢱ 

新ࡋいᗙ標系定義࡟ࣝࣈ࣮ࢸࢆ入力ࠊࡣ࡟ࡿࡍAppend new itemࢆ使用ࠊࡣࡓࡲࠋࡍࡲࡋ各࣏࢖ン࡟ࢺ対応ࡿࡍ
Generate a unique CSࠊ࠿Define CS referenced by pointsࢆ使用ࠋࡍࡲࡋ 

既Ꮡࡢᗙ標系ࡢ定義ࡣ各ࣝࢭ中ࡾࡼ࡟࡜ࡇࡿࡍࢡࢵࣜࢡࢆ編集ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ補語࢕ࢸࣃࣟࣉࡢ㸦System, 
Position & DirectionsࠊRotation groups㸧ࡶ編集ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 

CSࡀ定義࢖࣏ࡓࢀࡉンࡢࢺ矢印࣐࣮࣮࢝ࢆ見ࣝࣈ࣮ࢸࠊࡣ࡟ࡿ中ࡢ CS行ࢺ࢖ࣛ࢖ࣁࢆ化࢖࣏ࠊࡋンࢵࣜࢡࢆࢺ
ࡀ࣮࣮࣐࢝ࡢࡑࠊ場合ࡿい࡚ࢀࡉ定義ࡀCSࠋࡍ能࡛ྍ࡚ࡗࡼ࡟࡜ࡇࡿࡍࢡ CS IDࢆ共᭷࢖࣏ࡢ࡚࡭ࡍࡿࡍン࡟ࢺ
現わࠋࡍࡲࢀ 

Sort all item(s)ࡼ࠾び Renumber all item(s) respectivelyࢆ使用ࠊࡋ行ࠊࡋࢺ࣮ࢯࡣ再番号付ࡲࡁ࡛ࡀ࡜ࡇࡿࡍࡅ
 ࠋࡍ

 

Coordinate Systemࡢࣈࢱ右࣮ࣗࢽ࣓࣭ࢡࢵࣜࢡ 
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Connectivities㸦結線㸧ࣈࢱ 

新ࡋい結線ࡢ定義方法ࢻ࣮࣎ࣉࢵࣜࢡࠊࡣ࡚ࡋ࡜㸦例えࠊࡤMS Excel࡛ࡢ定義㸧ࡿ㈞ࡽ࠿付࡟ࣝࣈ࣮ࢸࠊࡾࡓࡅ
入力ࠊࡣ࡟ࢀࡑࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍPaste from clipboard ࡜ Insert after Selectionࢆ使用ࠋࡍࡲࡋ 

既Ꮡࡢ結線ࡢ編集方法ࠊ࠿ࡿࡍࢡࢵࣜࢡࢆࣝࢭࠊࡣ࡚ࡋ࡜あࡿいࡣ Number connectivitiesࠊSort all connectivitiesࠊ 
Renumber all item(s)ࢆ࡝࡞使用ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 

行番号㸦第ࡢࣝࣈ࣮ࢸ 1࣒࢝ࣛ㸧ࢡࢵࣜࢡࢆ選択ࢆࢡࢵࣜࢡࡢࡑࠊࡋ維持ࠊࡲࡲࡓࡋCtrl࡜ Shiftࢱ࣮࣎࢟ࡢンࢆ
一緒ࠊ࠿ࡿࡍࢡࢵࣜࢡ࡟あࡿい࢕࣭࢘ࢫࢡࢵ࢕ࣇࣛࢢࡣン࢘ࢻෆ࢖ࡢンࣈ࢕ࢸࢡࣛࢱ選択ࠊ࡚ࡗࡼ࡟複数ࡢ結線ࢆ

選択ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 

結線࣓ンࢆࣉ࣮ࣝࢢ࣭࣮ࣂ設定ࣉ࣮ࣝࢢࠊࡣ࡟ࡿࡍ IDࢆ編集ࡢࡑࠊ࠿ࡿࡍ結線ࢆ選択ࠊࡋAssign groupࢆ使用ࡋ
選択ࢆ結線ࡿࡍ࡟࣮ࣂン࣓ࠊࡋ選択ࢆࣉ࣮ࣝࢢ࣭ࢺࢵࢤ࣮ࢱࡽ࠿ࢫࢡࢵ࣎ࢺࢫGroup Selectionࣜࠊࡓࡲࠋࡍࡲ
 ࠋࡍࡲࡁ࡛ࡶ࡜ࡇࡿࡍ設定ࠊࡋࢡࢵࣜࢡࢆRecordࠊࡋ

 ࠋࡍࡲࡁ࡛ࡶ࡜ࡇࡿࡍ使用ࢆRecord connectivity selection in a setࠊ࡟ࡽࡉ

 

結線ࡢࣈࢱ右࣮ࣗࢽ࣓࣭ࢡࢵࣜࢡ 

Connectivity Groups㸦結線ࣉ࣮ࣝࢢ㸧ࣈࢱ 

ࡢࣉ࣮ࣝࢢ結線ࠊࡣ࡛ࣝࣈ࣮ࢸࡢࡇ IDࡀ࡝࡞ࣝ࣋ࣛࠊ―࣮ࣛ࢝ࠊ編集࡛ࠋࡍࡲࡁIDࠊࡣConnectivitiesࣈࢱ中࡛使
用ࣉ࣮ࣝࢢࡿࢀࡉ ID࡟相当ࠊࡣࣉ࣮ࣝࢢࠋࡍࡲࡋAppend New Item࣓࣐ࢥ࣭࣮ࣗࢽン࡛ࢻ追加ࡲࡁ࡛ࡀ࡜ࡇࡿࡍ
ࠊࡣ࡟ࡿࡍ選択ࢆ結線ࠋࡍࡲࢀࡽ当࡚ࡾ割࡟ࣉ࣮ࣝࢢࡓࢀࡉ追加ࡃࡋ新ࡀ―࣮ࣛ࢝ࡢࢺ࢛ࣝࣇࢹࠋࡍ
Connectivitiesࢆࣈࢱ使用࣓ࡢࣉ࣮ࣝࢢࡢࡑࠊࡋンࢆ࣮ࣂ作成ࠋࡍࡲࡋ 
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結線ࡢࣈࢱ࣭ࣉ࣮ࣝࢢ右࣮ࣗࢽ࣓࣭ࢡࢵࣜࢡ 

 信号処理㸦DSP㸧ࣝࢱࢪࢹ

DSP機能ࠊࡣ以ୗࡼࡢう更新ࠋࡓࡋࡲࢀࡉ 

 ࡣ࡟ࢺࢵࣟࣉ FIT補完関数ࡀ使用ࠋࡍࡲࢀࡉ信号ࡀ DC成ศࢆ持ࡘ場合ࡢࡑࠊ信号ࡣ適ษࡲࢀࡉࢺࢵࣟࣉ࡟
 ࠋࡍ

 DSP CURVE࣐ࢥン࡛ࢻ生成࡛࣮࣮ࣛࣟࣉࢫࢡ࢚࣭ࢫ࣮࣋ࢱ࣮ࢹࠊࡣࣈ࣮࢝ࡓࢀࡉ生成ྠ࡜ࣈ࣮࢝ࡓࡋ一࢖ࢱ
 ࠋࡍࡲࡾ࡞࡟ࣝࢺ

 ࣐ࢥンࢻ DSP RESAMPLE࡜ DSP UPSAMPLEࡀ追加ࠋࡍࡲࢀࡉ 

FEMtoolsソ࣮ࣝࣂ 

 ࣮ࣔࢻ解析࢔ࢥ࣭ࣈ࣭࢜ࢺ࢘࢔ࡢ࣮ࣂࣝࢯ㸦out-of-core㸧ࢺ࣮࣏ࢧࡢ 

あࡀ制限࡟RAM容量ࠊࡵࡓࡢࡑࠋࡍ࡛࣮ࣂࣝࢯ㸦in-core㸧࢔ࢥン࣭࢖ࡣ࣮ࣂࣝࢯFEMtoolsࠊࡣ࡛ࢺ࢛ࣝࣇࢹ
解析㸦Lanczosࢻ࣮ࣔࠊࡤ例えࠋࡓࡋࡲࡾあࡀ場合ࡿࡌ生ࡀ࣮࢚ࣛࡿࡍ関࡟容量࣓ࣜࣔࠊࡣ࡛ࢱ࣮ࣗࣆンࢥࡿ
 ࠋࡓࡋࡲࡌ生ࡀ࣮࢚ࣛ࡞典型的࡞うࡼࡢ次ࠊい࡚࠾࡟㸧࣮ࣂࣝࢯ

ERROR : Numerical factorization failed [-2] : Not enough memory 
ERROR : SOLVER failed : No result file. 

ࢫ࢕ࢹ࡟ࡵࡓࡿࡍࣉンࢲࢆ記憶ෆ容࡟部ศ的ࠊࡣ࣮ࣂࣝࢯ࣭࢔ࢥ࣭ࣈ࣭࢜ࢺ࢘࢔ࠊ࡟ࡵࡓࡿࡍ克服ࢆ制限ࡢࡇ

依Ꮡ࡟性能ࡢࢫࢭࢡ࢔࣭ࢡࢫ࢕ࢹࠊࡣ解析速ᗘࡢࢬ࢖ࢧࣝࢹ大規模ࣔࠊ場合ࡢࡑࠋࡍࡲࡋ使用ࢆࢫ࣮࣌ࢫ࣭ࢡ

ࢡࢫ࢕ࢹࡢࡃ多ࠊࡣ࡟場合ࡿࡍ使用ࡢࢻ࣮࣮ࣔࣂࣝࢯ࣭࢔ࢥ࣭ࣈ࣭࢜ࢺ࢘࢔ࠊࡵࡓࡢࡑࠋࡍࡲࡋ I/O࡟応えࡿ
 ࠋࡍࡲࢀࡉ推奨ࡀ࡜ࡇࡿࡍ使用ࡢࢡࢫ࢕ࢹ࡞高速ࡾࡼࠊ࡟ࡵࡓ

ṇ規࣮ࣔࢻ解析㸦Lanczos࣮ࣂࣝࢯ㸧࠾࡟い࡚ࠊ㸰ࡢࡘ新ࡋいࡀࢻ࣮࣭ࣔ࢔ࢥ࣭ࣈ࣭࢜ࢺ࢘࢔追加ࡋࡲࢀࡉ
 ࠋࡓ

 選択的࢔ࢥ࣭ࣈ࣭࢜ࢺ࢘࢔解析㸦必要ࡿࢀࡉ࡜超過࣓ࣔࣜࡢ動的割ࡾ当࡚㸧 
 ࢔ࢥ࣭ࣈ࣭࢜ࢺ࢘࢔解析࣮ࣔ࡟ࢻ固定 

ࢻン࣐ࢥࡣࢻ࣮࣭ࣔ࢔ࢥ࣭ࣈ࣭࢜ࢺ࢘࢔ SET DYNAMICあࡿいࡣ DYNAMIC࡛選択ࠋࡍࡲࢀࡉ 
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SET DYNAMIC ... COREMODE int_val .... CORESIZE int_val ...  
DYNAMIC ... COREMODE int_val .... CORESIZE int_val ...  
COREMODE = 1 ：選択的࢔ࢥ࣭ࣈ࣭࢜ࢺ࢘࢔解析 
COREMODE=2： ࢔ࢥ࣭ࣈ࣭࢜ࢺ࢘࢔解析࣮ࣔ࡟ࢻ固定 

選択的ࡣ࢔ࢥ࣭ࣈ࣭࢜ࢺ࢘࢔ CORESIZEࢆ使用ࢫࢡࢵࣜࢺ࣐ࠋࡍࡲࡋ係数ࡢ格納࡟必要࡞総࣓ࣔࣜ㸦࣓࢞ࣂ
ࡓࢀࡉ指定ࠊࡀ単఩㸧ࢺ࢖ CORESIZE値未満࡛あࡿ場合࢖ࡣン࣭ࡀ࣮ࣂࣝࢯ࣭࢔ࢥ使用ࠋࡍࡲࢀࡉ 

 ࢫࢡࢵࣜࢺ࣐࣭࣒ࢸࢫࢩ縮ᑠ機能ࡢ改善 

 ࢡࢵ࣑ࢼ࢖ࢲ解析ࢡࢵ࣑ࢼ࢖ࢲࠊ IRS解析ࡢ縮ᑠ機能ࡀ適ษ࡟処理ࡓࡗ࠿࡞ࢀࡉ問題ࡀ改善ࡋࡲࢀࡉ
 ࠋࡓ

 GUI࢖ンࡢࢫ࢖࢙ࣇ࣮ࢱ一㈏性࡟࡝࡞関ࡿࡍ問題ࡀ改善ࠋࡓࡋࡲࢀࡉ 
 標準 IRS࡜཯復 IRSࣙࢩࣉ࢜ࡢンࡢ組ࡳ合わྍࡀࡏ能ࠋࡓࡋࡲࡾ࡞࡟標準ࡢ཯復 IRSࡢ縮ᑠࢆ行࡞うࡓ

 ࠋࡍࡲࡋ使用ࢆNumber of Iterations = 1ࠊࡣ࡟ࡵ

 ࢫࢡ࣑ࢼ࢖ࢲ

 ࣐࣮ࢱࢫDOF選択࡟利用࡛ࡿࡁ K/M比ࢆ計算ࡿࡍ新ࡋい࣐ࢥンࢻ 

 要素解析࣮ࣃ࣮ࢫ

 CONDENSE࣐ࢥンࢥࡢࢻンࡀࢡࢵࣂࢻ࣮࢕ࣇ࣭࣮ࣝࢯ改善ࠋࡓࡋࡲࢀࡉ 

 㸦MBA:Modal-Based Assembly㸧ࣜࣈンࢭ࢔࣭ࢫ࣮࡭࣭ࣝࢲ࣮ࣔ

 ࣮ࣔࢭ࢔࣭ࢫ࣮࡭࣭ࣝࢲンࢥࠊࡣࣜࣈン࣏࣮ࢿンࢺ間ࡢ剛結合ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆ剛結合ࠊࡣRigid 
Connections as Coupling Method in the Modal Based Assembly Settings࢕࣭࢘ࢢࣟ࢔࢖ࢲン࢘ࢻ㸦࣓࢖ン࣭࣓ࢽ
ࠊࡋ使用ࢆࢻン࣐ࢥSET MBA COUPLING RIGIDࠊࡣいࡿTools > Modal Based Assembly > Settings㸧あࡢ࣮ࣗ
ࣉࣜࢡࢫࢆ使用方法ࡢࢢンࣜࣉࢵ剛結合࢝ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ࡟ࣈ࢕ࢸࢡ࢔

 FEMtools Dynamicsࠊࡣ例題ࡢࡑࠋࡍࡲࡋexamples/dynamic/mba/fea_substructure/ mba_fea_rigid.cmd࡛例証/..ࢺ
User’s Guide㸦ࢻ࢖࣮࢞ࢨ࣮࣭ࣘࢫࢡ࣑ࢼ࢖ࢲ㸧࡛解ㄝࠋࡍࡲࢀࡉ 

 解析と相関分析ࢺࢫࢸࣜࣉ

 解析ࢺࢫࢸࣜࣉ

 ࣮ࣝࢶ選択࣮ࢧンࢭ

 EIM࣮࣋ࢭࡢࢫン࣮ࢧ選択ࡀ改善ࠋࡓࡋࡲࡲࢀࡉ 

 安定化手⥆ࡁ㸦stability procedure㸧ࢭࠊࡣン࣮ࢧ数ࡢࢻ࣮ࣔࡀ数ࡾࡼ少࡞い場合࡟ࡵࡓࡢ改善ࡋࡲࢀࡉ
 ࠋࡓ

 ࢭン࣮ࢧ数ࡀ  ࠋࡍࡲࡋ出力ࢆࢪ࣮ࢭࢵ࣓࣮࢚ࣛࠊ場合ࡢ0

 SEAMAC࣮࣋ࢭࡢࢫン࣮ࢧ選択ࡀ改善ࠋࡓࡋࡲࢀࡉ 

 SEAMAC࣮࣋ࢭࡢࢫン࣮ࢧ選択1ࠊࡣ軸ࢭンࡣࡓࡲࡳࡢ࣮ࢧṇ規表面ࢭࡢン࡛࣮ࢧ適応ࠋࡍࡲࢀࡉ 

 IGR࣮࣋ࢭࡢࢫン࣮ࢧ選択ࡀ改善ࠋࡓࡋࡲࢀࡉ 

 IGR手⥆ࢭࠊࡣࡁン࣮ࢧ数ࡀ  ࠋࡍࡲࡋ出力ࢆࢪ࣮ࢭࢵ場合࢚࣮࣓ࣛࡢ0
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 NMD࣮࣋ࢭࡢࢫン࣮ࢧ選択ࡀ改善ࠋࡓࡋࡲࢀࡉ 

 NMD࣮࣋ࢭࡢࢫン࣮ࢧ選択ࡣṇ規表面ࢭࡢン࠾࡟࣮ࢧい࡚適応ࠋࡍࡲࢀࡉ 
 CLEAR NMD࣐ࢥンࡀࢻ改善ࠋࡓࡋࡲࢀࡉ 

 NKE࣮࣋ࢭࡢࢫン࣮ࢧ選択ࡀ改善ࠋࡓࡋࡲࢀࡉ 

 ṇ規表面ࡢ NKEࡢ計算࠾࡟ࣝࢹ࣭࢙ࣔࣝࢩࡀい࡚ࠋࡍࡲࢀࡉࢺ࣮࣏ࢧ 
 CLEAR NKE࣐ࢥンࡀࢻ改善ࠋࡓࡋࡲࢀࡉ 

手動ࡼ࠾び自動ࢭࡢン࣮ࢧ選択 

次ࡢ修ṇࠊࡀManual Sensor Selection ࣝࢿࣃ 㸦Tools > Pretest Analysis > Manual Sensor Selection㸧࡟行わࡋࡲࢀ
 ࠋࡓ

 Show Sensor Node Numbering࢜ࣙࢩࣉンࡀPlot Settings࡟追加ࡣࢀࡇࠋࡓࡋࡲࢀࡉ選択ࢭࡓࢀࡉン࣮ࢧ఩置ࡢ
 ࠋࡍࡲࡋ࡟能ྍࢆ࡜ࡇࡿࡍ識別࡟迅速ࢆ番号ࢻ࣮ࣀ

次ࡢ修ṇࡼ࠾びᣑ張ࠊࡀAutomated Sensor Selection ࣝࢿࣃ㸦Tools > Pretest Analysis > Automated Sensor 
Selection㸧࡟行わࠋࡓࡋࡲࢀ 

 maximum’ metric࢜ࣙࢩࣉンࡀ削除ࣙࢩࣉ࢜ࡢࡇࠋࡓࡋࡲࢀࡉンࠊࡣ単࡟支持࣌ࢫࢧࡣࡓࡲンࣙࢩンࡢ఩置選
択࡟利用࡛ࠋࡓࡋࡲࡁ 

 Candidate Sensor Location㸦候補ࢭン࣮ࢧ఩置㸧ࡢPreview࣎ ࡋࡲࢀࡽ替え࡟ンࢱShow Candidates࣎ࠊࡣンࢱ
ࡢ最ᑠ距離࡜選択ࢻ࣮ࣀࠊ場合㸧࡞㸦適用ྍ能ࢡࢵࣜࢺ࣭ࢺࢫࢸࣜࣉࠊᢏ術ࢺࢫࢸࣜࣉࡓࡋ選択ࠊࡣࢀࡇࠋࡓ

指定࡟基࡙ࡃ選択候補఩置数ࢆ確認ྍࡀ࡜ࡇࡿࡍ能ࠋࡓࡋࡲࡾ࡞࡟ 
 Show Sensor Node Numbering࢜ࣙࢩࣉンࠊࡀPlot Settingsࣙࢩࢡࢭン࡟追加ࡣࢀࡇࠋࡓࡋࡲࢀࡉ選択ࢭࡓࢀࡉ

ン࣮ࢧ఩置ࢻ࣮ࣀࡢ番号ࢆ迅速࡟識別ྍࢆ࡜ࡇࡿࡍ能ࠋࡍࡲࡋ࡟ 

 刺激解析㸦MPA:Mode Participation Analysis㸧ࢻ࣮ࣔ

 ่࣮ࣔࢻ激解析㸦MPA㸧ࡀ改善ࠋࡓࡋࡲࢀࡉ 
 多ࡢࡃ入力 DOFࢆ考慮ࡿࡍ場合࣓ࣜࣔࠊ容量࡜ CPU時間ࡢ縮ᑠྍࢆ能ࠊࡵࡓࡿࡍ࡟MPA࢖ࡢン࣓ࣜࣉンࢸ

 ࠋࡓࡋࡲࢀࡉ改善ࡀンࣙࢩ࣮
 EXAMINE MPA࣐ࢥンࢥࡢࢻン࣮ࣝࢯ出力ࡀ改善ࠋࡓࡋࡲࢀࡉMPAࡢࡘ5ࠊࡣࢱ࣮ࢹ入力 DOFࢡࢵࣟࣈࡢ中

࡛示ࠊࡣࢀࡇࠋࡍࡲࢀࡉ多ࡢࡃ入力 DOFࢆ考慮ࡿࡍ場合ࢱ࣮ࢹࡢ検査ࢆ容易ࠋࡍࡲࡋ࡟ 
 ่࣮ࣔࢻ激解析ࡢࢻ࣮ࣔࠊࡣ特定࡟ࢺࢵࢭ対࡚ࡋ実行ࠊࡣࢀࡇࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍMode Participation 

Analysisࡢࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲCandidate Modes࢘ࢲࣉࢵࣟࢻンࣜࢆࢺࢫ使用ࠊ࠿ࡿࡍEXAMINE MPA࣐ࢥン
 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇ行う࡚ࡋ使用ࢆいMODE補語ࡋ新ࡢࢻ

 MPA結果࡟基࡙いࡓ自動ࢺࢵࢭ生成࢖࣭࣮ࢨ࣮ࣘࡀンࠊࡣ࡟ࢀࡑࠋࡍࡲࢀࡉࢺ࣮࣏ࢧ࡛ࢫ࢖࢙ࣇ࣮ࢱCreate 
Target Mode Select Setsࢺࢵࢭࠊࡋࢡࢵ࢙ࢳࢆࢫࢡࢵ࣎ࢡࢵ࢙ࢳ生成基準ࢆ選択ࠋࡍࡲࡋ 

 ࡢ࡚࡭ࡍࡣࢀࡑ並進DOFࢆ使用࡚ࡗࡼ࡟ࢺࢵࣟࣉ࣭ࣗࢩࢵ࣓ࠊࡓࡲࠊࡋ結果ࢆ確認ࠊࡋMPAࢆ実行࡜ࡇࡿࡍ
 Tools > Pretest Analysis > Mode Participationࡽ࠿࣮ࣗࢽン࣭࣓࢖࣓ࠊࡣࣉࢵ激่࣐ࢻ࣮ࣔࡢࡑࠋࡍࡲࡁ࡛ࡀ
Map (MPM) ࢆ選択ࠊ࠿ࡿࡍEXAMINE MPM࣐ࢥンࢆࢻ使用࡚ࡗࡼ࡟࡜ࡇࡿࡍ計算่ࢻ࣮ࣔࠋࡍࡲࢀࡉ激࣐ࢵ
ࢻン࣐ࢥEXTRACT MPMࡣMPM結果ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ使用࡟ࡵࡓࡿࡍ識別ࢆ加振఩置ࣝࣕࢩンࢸ࣏ࡣࣉ
消去࡚ࡋ使用ࢆࢻン࣐ࢥCLEAR MPMࠊࡓࡲࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ出力࡟࢘ࢻン࢕࣭࣮࢘ࣝࢯンࢥ࡚ࡋ使用ࢆ
 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ

 新ࡋい EXAMINE SPAMPA࣐ࢥンࠊࡣࢻ最適ࡢ加振఩置ࢆ識別่ࢻ࣮ࣔ࡟ࡵࡓࡿࡍ激࣐ࢆࣉࢵ使用ࠋࡍࡲࡋ 

Excitation Location Selection㸦加振位置選択㸧ࡢ新ࡋい࣮ࣝࢶ 

Excitation Location Selectionࣝࢿࣃ㸦Tools > Pretest Analysis > Excitation Location Selection㸧ࡀ追加ࠋࡓࡋࡲࢀࡉ
 ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆ機能ࡢ次ࡣࣝࢿࣃࡢࡇ
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 NMDࠊNKEࠊMPA࣐࡟ࣉࢵ基࡙いࡓ最適加振఩置ࢆ識別ࠋࡍࡲࡋ 
 手動࡛既Ꮡࡢ加振఩置選択ࢆ微調整ࠊ࠿ࡿࡍ手動࡛ FE࣓࢟ࢵࣆࡢୖࢺࢵࣟࣉ࣭ࣗࢩࢵンࢢ DOF操作࡚ࡗࡼ࡟

加振఩置選択ࢆ作成ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 
 ่࣮ࣔࢻ激解析㸦MPA㸧ࢆ使用ࠊࡋ現ᅾࡢ加振఩置選択ࢆ評価ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 

最適ࢺ࣮࣏ࢧ選択用ࡢ新ࡋい࣮ࣝࢶ 

 最適ࢺ࣮࣏ࢧ఩置選択࣐ࢆࣉࢵ供給ࡿࡍ NMD࡜ NKEࢆࢱ࣮ࢹࡢ処理ࡿࡍ新ࡋいࡀ࣮ࣝࢶ追加ࠋࡓࡋࡲࢀࡉ
Tools > Pretest Analysis > Support Location Selectionࠊࡽ࠿࣮ࣗࢽン࣭࣓࢖࣓ࠊࡣ࡟ࡿࡍ生成ࢆࣉࢵ࣐ࡢࡽࢀࡇ
ࡣいࡿあࠊ࠿ࡿࡍ選択ࢆ EXAMINE SUPPORT࣐ࢥンࢆࢻ使用ࠋࡍࡲࡋ 

相関分析 

 EXAMINE MPF࣐ࢥンࡀࢻ改善ࠋࡓࡋࡲࢀࡉ 

 FILE補語ࡣ削除ࡢࡇࠋࡓࡋࡲࢀࡉ補語ࡣ௚࣐ࢥࡢンࢩࡢࢻン࡜ࢫࢡࢵࢱ一致࡚ࡋいࠋࡓࡋ࡛ࢇࡏࡲ結果
 ࠋいࡉࡔࡃ࡚ࡋ使用࡟ࡾ代わࢆࢻン࣐ࢥEXPORT MATRIXࠊࡣ࡟ࡿࡍࢺ࣮࣏ࢫࢡ࢚ࢆ

 FRFࡢᏑᅾࢆ確認ࡣࢡࢵ࢙ࢳࡿࡍ加えࠋࡓࡋࡲࢀࡽ 
 ࢥンࡀࢡࢵࣂࢻ࣮࢕ࣇ࣭࣮ࣝࢯ改善ࠋࡓࡋࡲࢀࡉ 

 EXAMINE NSE࣐ࢥンࡀࢻ改善ࠋࡓࡋࡲࢀࡉ 

 ྡࢺࢵࣟࣉ前ࡀ修ṇࠊࢀࡉNodal Strain EnergyࡀFEA Normal Modes࡚ࡗྲྀ࡟代わࠋࡓࡋࡲࡾ 
 ࢥンࡣࢡࢵࣂࢻ࣮࢕ࣇ࣭࣮ࣝࢯ改善ࠋࡓࡋࡲࢀࡉ 

 EXTRACT NKE࣐ࢥンࡀࢻ修ṇࠋࡓࡋࡲࢀࡉ 

 FEMtools࣐ࢥンࢻ言語࡜一致࡚ࡋいࡢࡑࠊࡵࡓࡓࡗ࠿࡞ UPPER࡜ LOWERࡢ補語ࡣ削除ࠋࡓࡋࡲࢀࡉ 

 EXTRACT NMD࣐ࢥンࡀࢻ修ṇࠋࡓࡋࡲࢀࡉ 

 FEMtools࣐ࢥンࢻ言語࡜一致࡚ࡋいࡢࡑࠊࡵࡓࡓࡗ࠿࡞ UPPER࡜ LOWERࡢ補語ࡣ削除ࠋࡓࡋࡲࢀࡉ 

 ࢟ࢵࣆ࣭ࢡࢵ࢕ࣇࣛࢢン࢖࣏/ࢻ࣮ࣀࡿࡼ࡟ࢢン࢔࣭࣌ࢺ定義ࠊࡀNode-Point Pair࡟追加ࡣࢀࡇࠋࡓࡋࡲࢀࡉ
࢔࣭࣌ࢺン࢖࣏/ࢻ࣮ࣀࠋ࡚ࡋ௓ࢆࢢン࢟ࢵࣆ࣭ࢡࢵ࢕ࣇࣛࢢࠋࢇࡏࡲࡁや利用࡛ࡣࡶࡣ࡛࣮ࣗࢽࢢン࢟ࢵࣆ
開ࢆ㸦Tools > Correlation Analysis > Node-Point Pairs㸧ࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲNode-Point Pairࠊࡣ࡟ࡿࡍ作成ࢆ
ン࢟ࢵࣆࡣࢀࡇࠋࡍࡲࡋࢡࢵࣜࢡࢆンࢱOK࣎ࠊࡋ選択ࢆンࣙࢩࣉGraphical Picking of Node-Point Pairs࢜ࠊࡁ
ࣀ࡟最初ࠊࡣ࡟ࡿࡍ作成ࢆ࢔࣭࣌ࢺン࢖࣏/ࢻ࣮ࣀいࡋ新ࠋࡍࡲࡁ開ࢆࢺࢵࣟࣉNode/Point Pair࡛ࢻ࣮࣭ࣔࢢ
ࣟࣉ࣭࢔࣭࣌ࢺン࢖࣏/ࢻ࣮ࣀ࡟単ࠊࡣ࡟ࡿࡍ中断ࢆࢢン࢟ࢵࣆࠋࡍࡲࡋ選択ࢆࢺン࢖࣏࡟次ࠊࡋ選択ࢆࢻ࣮
 ࠋいࡉࡔࡃ࡚ࡌ閉ࢆࢺࢵ

 Auto-EVOࡢ計算࣐ࢥࠊࡣンࢻEXAMINE EVOࢆ使用ࠊ࠿ࡿࡍあࡿいࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲࡣ㸦Database > 
Verify > Auto-EVO…㸧ࡽ࠿実行࣮ࢱࢫ࣐ࠋࡍࡲࢀࡉDOFࠊࡣ࡚ࡋ࡜縮ᑠࡓࢀࡉFEA-to-FEA㸦非࣌࢔DOF㸧ࡀ
必要ࠊࡓࡲࠋࡍࡲࡾ࡞࡟Normalize࣎  Use Normalizedࡢ㸦=NORMALIZE ON㸧ࢺ࢛ࣝࣇࢹࠊࢀࡉ削除ࡣンࢱ
Mode Shapesࡀ使用ࠋࡍࡲࢀࡉ 

 手動࡛ࣜ࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮ࣔࡢン࢖ࠊࡣࢢン࡛࢔࣮ࣗࣅ࣭࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮࣭ࣔࣈ࢕ࢸࢡࣛࢱ定義ࡇࡿࡍ

 ࠋࡍࡲࡋ使用ࢆTools > Correlation Analysis > Mode Shape Pair Viewerࠊࡣ࡟ࢀࡑࠋࡍࡲࡁ࡛ࡀ࡜
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 ࢢン࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔ

感ᗘ解析とࣔ࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹンࢢ 

 新ࡋいࢱ࣮࣓ࣛࣃ D㸦材料ࡢ弾性࣐ࢫࢡࢵࣜࢺ係数ࣜࣉࢫ࡜ン࣮ࣝࢣࢫ࣭ࢢ係数㸧：࣮ࣅࠊࡣࢱ࣮࣓ࣛࣃࡢࡇ
次ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡍ表わࢆ࢕ࢸࣃࣟࣉࡢࢻࢵࣜࢯ࡜࢙ࣝࢩびࡼ࠾㸧ࡴ含ࢆࢫࢢン࣭ࣞࣟࢮ㸦ࢢンࣜࣉࢫ࡜࣒

 ࠋいࡉࡔࡃ࡚ࡋ参照ࢆン例ࣙࢩ࣮ࣞࢺࢫンࣔࢹࡢ
\examples\updating\plate_modal\run06d.cmd  

 新ࡋいࢱ࣮࣓ࣛࣃ KT࡜ KRࣜࣉࢫࠊࡣンࢢ並進剛性ࡼ࠾࡜びࣜࣉࢫンࢢ回転剛性࣮ࣝࢣࢫࡢ係数ࢆ表ࡲࡋ
 ࠋいࡉࡔࡃ࡚ࡋ参照ࢆン例ࣙࢩ࣮ࣞࢺࢫンࣔࢹࡢ次ࠋࡍ
\examples\updating\plate_modal\run06ktr.cmd  

Design of Experiments㸦実験計画法㸧 

 ࣝ࢖࢓ࣇࢺࢫ࢟ࢸ㸦Tools > Design of Experiments > Export DOE Data㸧࡟関ࡿࡍDOEࢧンࢺ࣮࣏ࢫࢡ࢚ࡢࣝࣉ
 ࠋࡓࡋࡲࢀࡉ改善ࡀ

Optimization㸦最適化㸧 

 ࠋࡓࡋࡲࢀࡉ改善ࡀ࣮ࣝࣗࢪ最適化ࣔࡢ㸦topometry㸧࣮ࣜࢺ࣓࣏ࢺ

 ࡢ࣮ࣜࢺ࣓࣏ࢺ最適化ࡢ例題ࡢヲ細ࠊࡀFEMtools Optimization User’s Guide㸦最適化࣮ࣘࢻ࢖࣮࢞ࢨ㸧࡟追加ࡉ
 ࠋࡓࡋࡲࢀ

 ศ散厚ࡢ࣮ࣜࢺ࣓࣏ࢺࡢࡉ最適化ࠊࡣ最ᑠ FRFࣞ࣋ࣝ設計問題࡟利用ྍ能࡛ࠋࡍ 
 ࡢ࣮ࣜࢺ࣓࣏ࢺ最適化࢜ࢺࢫ࣏ࠊࡣ࣮ࢨ࢖࣐࢕ࢸࣉ処理࠾࡟い࡚ࡢ初期厚ࡉ値ࡀ許ྍࡓࢀࡉ厚ࡉ範ᅖୖࡢ限࡜

 ࠋࢇࡏࡲࡋ生成ࢆ࣮࢚ࣛࡿࡍ関࡟結果ࡢ場合ࡓࡗࡔࡌྠ
 ࢥン࣮ࣝࢯ出力࡛報告ࡓࢀࡉศ散品質指数ࡀ改善ࠋࡓࡋࡲࢀࡉ 

ABAQUS࢖ンࢫ࢖࢙ࣇ࣮ࢱとࣂ࢖ࣛࢻ 

 ABAQUS࢖ンࠊࡣࣂ࢖ࣛࢻ࡜ࢫ࢖࢙ࣇ࣮ࢱfemtools_abaqusࢭ࢖࣭ࣛࢻ࣮ࢥࢺࢡࢲࣟࣉンࢆࢫ要求ࠋࡍࡲࡋ
FEMtools 3 ࡢ ABAQUSࢭ࢖࣭ࣛࢻ࣮ࢥࢺࢡࢲࣟࣉンࡀࡽࢀࡑࡣࢫ終了࡛ࡲ᭷効࡛ࠋࡍ 

 Abaqus 2016࡜ Abaqus 2017ࢺ࣮࣏ࢧࡢ 
 *TRANSFORM࣮࢝ࢻ㸦節点࣮ࣝ࢝ࣟࡢᗙ標系㸧ࢺ࣮࣏ࢧࡢ 

 
*TRANSFORM,NSET=nset,TYPE=type 
a1,a2,a3,b1,b2,b3 

ࡀࣉ࢖ࢱࠊ࡛ࡇࡇ RࠊSࠊ Tࡢ場合ࠊ㸦a1ࠊa2ࠊa3㸧㸦b1ࠊb2ࠊb3㸧࢖࣏ࠊࡣンࢺ a࡜ b ࡢᗙ標定義 
nsetࠊࡣ*TRANSFORM asࡀ適用ࠋࡍ࡛ࢺࢵࢭ࣭ࢻ࣮ࣀࡿࢀࡉ 

 補語 SIM=NOࡀ Abaqus 2016や Abaqus 2017࡛使用ࡿࢀࡉ*FREQUENCY࣮࢟ワ࣮࡟ࢻ追加ࠋࡓࡋࡲࢀࡉ 
 ࣮ࣃ࣮ࢫ要素ࡢ࡚ࡋ࡜剛性࡜質量ࢫࢡࢵࣜࢺ࣐ࡢ㸦.mtxࢺࢵ࣐࣮࢛ࣇ㸧࢖ࢆン࣏࣮ࡿࡍࢺ新ࡋいࡀࢺࣉࣜࢡࢫ

加えࡘ࡟ࢀࡇࠋࡓࡋࡲࢀࡽい࡚ࠊࡣ<installdir>\scripts\interfaces\abaqus\abqrselemx.basࢆ参照ࡉࡔࡃ࡚ࡋいࠋ 
㸦ྡ称ࢫࢡࢵࣜࢺ剛性࣐ࡢࡑࠊ࡟ࡵࡓࡿࡍࢺン࣏࣮࢖ࢆ要素࣮ࣃ࣮ࢫ xxx_STIF1.mtx㸧࢖ࢆン࣏࣮ࠊ࡜ࡿࡍࢺ
対応ࡿࡍ質量࣐ࢫࢡࢵࣜࢺ㸦ྡ称 xxx_MASS1.mtx㸧ࡶ自動的࢖࡟ン࣏࣮ࠋࡍࡲࢀࡉࢺabqrselem.bas࡛ࢫࠊࡣ
 ࠋࡍࡲࢀࡉ生成ࠊࢀࡉ定義ࡀࢻ࣮ࣀࡓࢀࡽࡅ参照付࡟要素࣮ࣃ࣮

 ABAQUSࡢ剛体࣮ࣔࢻ計算࡛࣮ࣂࣝࢯ࣭ࢫ࣮࣌ࢫࣈࢧࠊࡣ実行࣮ࣂࣝࢯ࣭ࢫ࣮࣌ࢫࣈࢧࠊࡋ࠿ࡋࠋࡍࡲࢀࡉ
ࡿࡍ対応࡟ࣝࢹ㸦未拘束㸧࣮ࣔࣜࣇࡣ 0値あࡿいࡣ最ᑠ周波数ཷࢆ理࡞ࡋいࠊࡵࡓFEMtoolsࡣ自動的࡟ 0࡛
指定ࢆ値ࢺ࢛ࣝࣇࢹࡢ最ᑠ周波数ࠊࡀࡓࡋࡲࢀࡉ固定࡟1E-3ࠊࡣ値ࡢࡇࠋࡍࡲࡋ変更࡟最ᑠ周波数ࡢい値࡞
い設定ࡋ新ࡢࡵࡓࡿࡍ interface.abaqus.fminfreeࡀ加え࢕ࢸࢵࢭࡢࡇࠋࡓࡋࡲࢀࡽンࡣࢢ Edit > Settings > Data 
Interfaces > ABAQUS > Minimum Frequency for Free Models࡛変更ࢺ࢛ࣝࣇࢹࡢࡑࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ値ࡣ
1E-3࡛ࠋࡍ 
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 いࡢ࠿ࡘࡃ ABAQUS警告࣓ࡣ࡟ࢪ࣮ࢭࢵ単語ࢆ࣮࢚ࠖࣛࠕ含࡛ࢇいࢪ࣮ࢭࢵ࣓࣮࢚ࣛࡢࡑࠋࡍࡲ例ࡣ次࡜ࡢ
 ࠋࡍ࡛ࡾ࠾
'HIGH CURVATUREࠊIT MAY LEAD TO SURFACE AREA INTEGRATION ERRORS 
ࠋࡓࡋࡲࡏࡉ中断ࢆࢫࢭࣟࣉࡢFEMtoolsࠊࢀࡉ解釈࡚ࡗ誤࡚ࡋ࡜ࢪ࣮ࢭࢵ࣓࣮࢚ࣛࠊࡣࢪ࣮ࢭࢵ࣓ࡢࡽࢀࡇ
ࡉ修ṇࡀࢫ࢖࢙ࣇ࣮ࢱン࢖ABAQUSࠊ࡟うࡼい࡞ࡏࡉ中断ࢆࢫࢭࣟࣉ࡚ࡗࡼ࡟ࢪ࣮ࢭࢵ࣓࣮࢚ࣛ࡞うࡼࡢࡑ
 ࠋࡍࡲࢀ

 FEMtools ABAQUSࡣࣂ࢖ࣛࢻ実例࡚ࡋࢺ࣮࣏ࢧࢆいࠋࢇࡏࡲ実例࡚ࡋ࡜ ABAQUSࣔࢹ࣭ࣔࢺࢵࣛࣇࠕࡢࣝࢹ
࢖࢙ࣇ࣮ࢱン࢖ABAQUSࠊࡣࡁ⥆手ࡢࡇࠋࡓࡋࡲࢀࡽ加え࡟ࢺン࣓ࣗ࢟ࢻFEMtoolsࠊࡀࡁ⥆手ࡿ変え࡟ࠖࣝ
࢙ࣇ࣮ࢱン࢖࣭ࣝ࢖࢓ࣇ࣭ࢱ࣮ࢹABAQUSࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡅࡘ見࡛ࢻ࢖࣮࢞ࢨ࣮ࣘࡢࣂ࢖ࣛࢻびࡼ࠾ࢫ
 ࠋいࡉࡔࡃ࡚ࡋ参照ࢆンࣙࢩࢡࢭࡢ保Ꮡࡢࢫ࢖

ANSYS࢖ンࡼ࠾ࢫ࢖࢙ࣇ࣮ࢱびࣂ࢖ࣛࢻ 

 ANSYS࢖ンࠊࡣࣂ࢖ࣛࢻ࡜ࢫ࢖࢙ࣇ࣮ࢱfemtools_abaqusࢭ࢖࣭ࣛࢻ࣮ࢥࢺࢡࢲࣟࣉンࢆࢫ要求ࠋࡍࡲࡋ
FEMtools 3 ࡢ ANSYSࢭ࢖࣭ࣛࢻ࣮ࢥࢺࢡࢲࣟࣉンࡀࡽࢀࡑࡣࢫ終了࡛ࡲ᭷効࡛ࠋࡍ 

 ANSYS v18+ࢺ࣮࣏ࢧࡢ 
 CDB࣮ࣜࠊࡣࢲKEYOPT࡜ KEYOPࡢ変数ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆANSYS࢖ࡣン࣏࣮ࢺ時ࡢ KEYOP࡜ KEYOPT

ࡣKEYOPTࠋࡍࡲࡋࢺ࣮࣏ࢧࢆ ANSYS以外ࡢ CDB࡚ࣛࡗࡼ࡟࣮ࢱ࢖生成ࠋࢇࡏࡲࢀࡋࡶ࠿ࡿࢀࡉ 

LS-DYNA࢖ンࢫ࢖࢙ࣇ࣮ࢱとࣂ࢖ࣛࢻ 

 新ࡋい࢜ࢻ࢔ン࣭ࠊ࡚ࡋ࡜࣮ࣝࢶLS-DYNA᭷限要素࢖ࡢ࡜࢔࢙࢘ࢺࣇࢯンࠊࢀࡉࢺ࣮࣏ࢧࡀࢫ࢖࢙ࣇ࣮ࢱ感
ᗘ解析ࡼ࠾びࣔ࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹンࡢࡵࡓࡢࢢ外部࡚ࡋ࡜࣮ࣂࣝࢯ LS-DYNAࢆ使用ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ
ࡉࡔࡃ࡚ࡋ参照ࢆࢻ࢖࣭࣮࢞ࢨ࣮࣭࣮ࣘࣂ࢖ࣛࢻびࡼ࠾ࢫ࢖࢙ࣇ࣮ࢱン࢖LS-DYNAࠊࡣい࡚ࡘ࡟ヲ細ࡾࡼ
いࠋ 

 LS-DYNA࢖ンࢻ࣮ࢥࢺࢡࢲࣟࣉࠊࡣࣂ࢖ࣛࢻ࡜ࢫ࢖࢙ࣇ࣮ࢱ femtools_lsdynaࢭ࢖ࣛࡢンࢆࢫ要求ࠋࡍࡲࡋ 

NASTRAN࢖ンࢫ࢖࢙ࣇ࣮ࢱとࣂ࢖ࣛࢻ 

 MSC.Nastran 2017ࢺ࣮࣏ࢧࡢ 
 NASTRAN࢖ンࢻ࣮ࢥࢺࢡࢲࣟࣉࠊࡣࣂ࢖ࣛࢻ࡜ࢫ࢖࢙ࣇ࣮ࢱ femtools_nastranࢭ࢖ࣛࡢンࢆࢫ要求ࠋࡍࡲࡋ

FEMtools 3ࡢ ANSYSࢭ࢖࣭ࣛࢻ࣮ࢥࢺࢡࢲࣟࣉンࡀࡽࢀࡑࡣࢫ終了࡛ࡲ᭷効࡛ࠋࡍ 
 呼び出࡚ࡋ࡜ࣝ࢖࢓ࣇࡋ別࡟࣮ࢲ࢛ࣝࣇࡢ఩置࢖ࡢࣝ࢖࢓ࣇࡿࡍンࠋࡍࡲࢀࡉࢺ࣮࣏ࢧࡀࢫ࢖࢙ࣇ࣮ࢱ 
 routput4.basࠊࡣࢺࣉࣜࢡࢫSC.Nastran࡚ࡗࡼ࡟作成ࡓࢀࡉ OUTPUT4࢖ࢆࣝ࢖࢓ࣇン࣏࣮ࡲࡁ࡛ࡀ࡜ࡇࡿࡍࢺ

いࡋ新ࡣࢀࡇࠋࡍ int64ࢆࣉ࢖ࢱ࣭ࢱ࣮ࢹ利用ࠋࡍࡲࡋ 
 NASTRANࡣࣂ࢖ࣛࢻ縮ᑠࠊ࡚ࡋ࡜࣮ࣂࣝࢯNX Nastran࡟ࡵࡓࡿࡍࢺ࣮࣏ࢧࢆ修ṇࠋࡓࡋࡲࢀࡉ 
 MSC.Nastran 2016ࢥンࣙࢩ࣮ࣞࢢ࢕ࣇン࣭ࣝ࢖࢓ࣇ㸦nastxxxxx.rcf㸧中ࡢMODE࢕ࢸࢵࢭンࢺ࢛ࣝࣇࢹࡢࢢ値

ࡽ࠿i4ࠊࡀ i8࡟変わࠊࡣࢀࡇࠋࡓࡋࡲࡾFEMtools NASTRAN࡟ࣂ࢖ࣛࢻ関ࡿࡍ問題ࢆ引ࡁ起ࠋࡍࡲࡋࡇ 

 FEMtoolsࠊࡽ࠿MSC.Nastran2016ࠊࡣ࡟ࡿࡍࢺ࣮ࢱࢫࢆnastran.iniࣝ࢖࢓ࣇ中࡟ࢢࣛࣇࡢ'mode=i4'ࢆ追加
ࡢࡇࠋࢇࡏࡲࡾ࡞ࡤࢀࡅ࡞ࡋ i4࣮ࣔࢻ指定ࡀࢻ࣮ࣔࠊࡣ NASTRANࢥンࣙࢩ࣮ࣞࢢ࢕ࣇン࣭ࣝ࢖࢓ࣇ中
ࡢ i4࡜等࡞ࡃࡋい場合ࡢ問題ࢆ回避ࠋࡍࡲࡋ 

 検証手⥆ࡀࡁ NASTRAN࡟ࣂ࢖ࣛࢻ加えࠋࡓࡋࡲࢀࡽMODEࡀ i4࡜等࡞ࡃࡋい場合ࠊ診断࣮ࣔࢻ㸦Edit 
> Run Mode > Diagnostics Mode㸧࡛実行ࡿࢀࡉ場合ࡢࡇࠊ手⥆ࡣࡁ警告ࢆ生成ࡣࢀࡇࠋࡍࡲࡋ FEMtools中
 ࠋࡍࡲࡾ࡞࡟᭷用࡟ࡢࡿࡍ識別ࢆ問題ࡢ場合ࡿࡍ実行ࢆMSC.Nastranࠊࡽ࠿

 ࢕ࢸࢵࢭ࣭࣮ࣂ࢖ࣛࢻンࣝ࢖࢓ࣇࠊࢢ<installdir>\scripts\drivers\nastran.iniࠊࡣMSC.Nastran࡜ NX Nastran࣮ࣂ
 ࠋࡍࡲい࡛ࢇ含ࢆン࢖追加ࣛࡿࡍ識別ࢆ形成方法ࡢンࣙࢪ

 SOL200中࡛適ษ࡟ࢱ࣮࣓ࣛࣃ࡞参照付ࣜࣉࢫࠊ࡟ࡵࡓࡿࡅンࢢ要素ࠊࡣCELAS2ࡢ代わ࡟ࡾ CELAS1/PELAS
 ࠋࡍࡲࢀࡉࢺ࣮࣏ࢫࢡ࢚࡚ࡋ࡜ࢻ࣮࢝

 BGSET࣮࢝ࠋࡍࡲࢀࡉࢺ࣮࣏ࢧ࡟ࣂ࢖ࣛࢻࡀࢻ 
 要素剛性࣐࢖ࡢࢫࢡࢵࣜࢺン࣏࣮ࢺ時ࠕࢪ࣮ࢭࢵ࣓࣮࢚ࣛࡢMatrices are too large to store㸦࣐ࡀࢫࢡࢵࣜࢺ大ࡁ

過࡛ࡢࡿࡂ格納࡛ࠋࢇࡏࡲ㸧ࠖ  ࠋࡍࡲࡋ解決ࡾࡼ࡟࡜ࡇࡿࡏࡉ増大ࢆࢫ࣮࣌ࢫࡢෆ部記憶装置ࠊࡣ
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SAP2000࢖ンࢫ࢖࢙ࣇ࣮ࢱとࣂ࢖ࣛࢻ 

 SAP2000࢖ンࢻ࣮ࢥࢺࢡࢲࣟࣉࠊࡣࣂ࢖ࣛࢻ࡜ࢫ࢖࢙ࣇ࣮ࢱ femtools_sap2000ࢭ࢖ࣛࡢンࢆࢫ要求ࠋࡍࡲࡋ 
 SAP2000 v18ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆSAP2000 v18࢖ン࢕ࢸࢵࢭ࣭࣒ࢱࢫ࢝ࡣࢫ࢖࢙ࣇ࣮ࢱンࢆࢢ必要ࠋࡍࡲࡋ࡜

SAP2000 v18ࡢ FEMtoolsࢥンࣙࢩ࣮ࣞࢢ࢕ࣇン手⥆ࠊࡣࡁSAP2000࢖ンࢨ࣮࣭࣮ࣘࣂ࢖ࣛࢻ࡜ࢫ࢖࢙ࣇ࣮ࢱ
 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡅࡘ見࡛ࢻ࢖࣭࣮࢞

 FEMtools࡞ࢀࡉࢺ࣮࣏ࢧ࡟࣮ࣂࣝࢯい࡞ࣈ࢕ࢸࢡ࢔ DOF選択ࢆ備え࢖ࡀࣝࢹࣔࡓン࣏࣮ࡿࢀࡉࢺ場合ࠊs2k
 ࠋࡍࡲࡋ生成ࢆࢪ࣮ࢭࢵ警告࣓ࡣࢲ࣮࣭ࣜࣝ࢖࢓ࣇ

 OAPI࢖ンࠊࡣࢫ࢖࢙ࣇ࣮ࢱ以ୗࡢ新ࡋいࠋࡍࡲࡋࢺ࣮࣏ࢧࢆࢱ࣮࣓ࣛࣃ 

 ࢚ࣜ࢔特性ࢱ࣮࣓ࣛࣃ：薄膜曲ࡆ f11㸦mf11㸧ࠊ薄膜曲ࡆ f22㸦mf22㸧ࠊ薄膜曲ࡆ f12㸦mf12㸧ࠊ曲ࡆ m11
㸦bm11㸧ࠊ曲ࡆ m22㸦bm22㸧ࠊ曲ࡆ m11㸦bm11㸧ࠊ曲ࡆ m22㸦bm22㸧ࠊ曲ࡆ m12㸦bm12㸧ࢇࡏࠊ断 v13
㸦sv13㸧ࢇࡏࠊ断 v23㸦sv23㸧ࠊ質量㸦m㸧ࠊ重量㸦w㸧 

 ࣝࣈ࣮ࢣ特性ࢱ࣮࣓ࣛࣃ：軸断面積㸦csa㸧ࠊ質量㸦m㸧ࠊ重量㸦w㸧 
 ColdC࣒࣮ࣞࣇ断面ࢱ࣮࣓ࣛࣃ：外ᚄ縦幅㸦ａ㸧ࠊ外ᚄᶓ幅㸦b㸧ࣉࢵࣜࠊ厚ࡉ㸦c㸧ࠊ角半ᚄ㸦r㸧ࠊ断面厚

 㸦t㸧ࡉ
 ColdHat࣒࣮ࣞࣇ断面ࢱ࣮࣓ࣛࣃ：外ᚄ縦幅㸦ａ㸧ࠊ外ᚄᶓ幅㸦b㸧ࣉࢵࣜࠊ厚ࡉ㸦c㸧ࠊ角半ᚄ㸦r㸧ࠊ断面厚

 㸦t㸧ࡉ
 ColdZ࣮࣒ࣞ断面ࢱ࣮࣓ࣛࣃ：外ᚄ縦幅㸦ａ㸧ࠊ外ᚄᶓ幅㸦b㸧ࣉࢵࣜࠊ厚ࡉ㸦c㸧ࠊ角半ᚄ㸦r㸧ࠊ断面厚ࡉ

㸦t㸧 
 連結ࣜࣉࢫンࢢ剛性ࢱ࣮࣓ࣛࣃ：U1-U1ࣜࣉࢫンࢢ剛性㸦11㸧ࠊU1-U2ࣜࣉࢫンࢢ剛性㸦12㸧ࠊU2-U2ࣉࢫ

ࣜンࢢ剛性㸦22㸧ࠊU1-U3ࣜࣉࢫンࢢ剛性㸦13㸧ࠊ…ࠊU6―U6ࣜࣉࢫンࢢ剛性㸦66㸧 
 DoubleAngle࣒࣮ࣞࣇ断面ࢱ࣮࣓ࣛࣃ：外側背々距離㸦dist㸧ࠊ外ᚄ深ࡉ㸦t2㸧ࠊ外ᚄ幅㸦t3㸧ࠊ水ᖹ脚厚ࡉ

㸦tf㸧ࠊ垂直脚厚ࡉ㸦tw㸧 
 DoubleChannel࣒࣮ࣞࣇ断面ࢱ࣮࣓ࣛࣃ：外側背々距離㸦dist㸧ࠊ外ᚄ深ࡉ㸦t2㸧ࠊ外ᚄ幅㸦t3㸧ࣛࣇࠊンࢪ

厚ࡉ㸦tf㸧ࠊ壁厚ࡉ㸦tw㸧 
 ࣒࣮ࣞࣇ特性ࢱ࣮࣓ࣛࣃ：軸断面積㸦csa㸧2ࠊ方向ࢇࡏ断࢚ࣜ࢔㸦sa2㸧3ࠊ方向ࢇࡏ断࢚ࣜ࢔㸦sa3㸧ࡌࡡࠊ

 重量㸦w㸧ࠊ質量㸦m㸧ࠊ㸦moi3㸧ࢺ3軸間慣性࣮࣓ࣔンࠊ㸦moi2㸧ࢺ2軸間慣性࣮࣓ࣔンࠊ定数㸦tc㸧ࢀ
 ࢺࢫࣕ࢟ࣞࣉ I࣒࣮ࣞࣇ断面ࢱ࣮࣓ࣛࣃ：水ᖹ断面寸法㸦b1ࠊ…ࠊb4㸧ࠊ底ࣛࣇンࢪ溝角㸦f㸧ࠊ縦断面寸

法㸦d1ࠊ…ࠊd6㸧ࠊ壁厚ࡉ寸法㸦tࠊt2㸧 
 ࢺࢫࣕ࢟ࣞࣉ U࣒࣮ࣞࣇ断面ࢱ࣮࣓ࣛࣃ：水ᖹ断面寸法㸦b1ࠊ…ࠊb6㸧ࠊ縦断面寸法㸦d1ࠊ…ࠊd7㸧 
 長方形࣒࣮ࣞࣇ断面ࢱ࣮࣓ࣛࣃ：断面幅㸦t2㸧ࠊ断面深ࡉ㸦t3㸧 
 T࣒࣮ࣞࣇ断面ࣛࣇ:ࢱ࣮࣓ࣛࣃンࢪ幅㸦t2㸧ࠊ断面深ࡉ㸦t3㸧ࣛࣇࠊンࢪ厚ࡉ㸦tf㸧ࠊ壁厚ࡉ㸦tw㸧 
 ྎ形࣒࣮ࣞࣇ断面ࡢࣉࢵࢺ：ࢱ࣮࣓ࣛࣃ断面幅㸦t2㸧ࠊ底断面幅㸦t2b㸧ࠊ断面深ࡉ㸦t3㸧 

 ࡣࢱ࣮࣓ࣛࣃ値ࡀ無指定ࡢ場合࡛ࡶ定義ࡢࡑࠋࡍࡲࢀࡉ場合ࢱ࣮࣓ࣛࣃࡢ値ࡣ SAP2000ࣔࡽ࠿ࣝࢹ検索ࢀࡉ
 ࠋࡍࡲ

 ࣐ࢥンࢻ SET INTERFACE SAPࡣ SAP2000࢖࣭ࢱ࣮ࢹン࢕ࢸࢵࢭ࣭ࢫ࢖࢙ࣇ࣮ࢱンࢆࢢ定義࡟ࡵࡓࡿࡍ付ࡅ
加えࠋࡓࡋࡲࢀࡽ 

 ン࢜ࢻ࢔࣭࣮ࢱࢡࣛࢺࢫࢡ࢚࣭ࢱ࣮࣓ࣛࣃ࣭ࣝࢲ࣮ࣔ

ࢡワ࣮࣒࣮ࣞࣇFEMtoolsࠊࡣࢻン࣐ࢥࡢwindowingࠊࣝࢿンࣕࢳ࡜ンࣙࢩDOF࣮ࣜࣞࠊ信号処理㸦DSP㸧ࣝࢱࢪࢹ
࡛含ࠊࢀࡲFEMtools MPEࢭ࢖ࣛࡢン࡛ࡋ࡞ࢫ利用ྍ能࡛ࡣࢀࡇࠋࡍ以ୗ࣐ࢥࡢン࡟ࢻ関係ࠋࡍࡲࡋ 

DSP CURVE, DSP DECIMATE, DSP DETREND, DSP FILTER, DSP FINDDEADCHANNELS, DSP FINDREFERENCES, 
DSP INFO, DSP RESAMPLE, DSP SPECTRUM, DSP UPSAMPLE, DSP WINDOW, DSP XPS, APPLY DOF RELATION, 
CLEAR DOF RELATION, DEFINE DOF RELATION, EXTRACT DOF RELATION CLEAR CHANNEL, CLEAR 
WINDOW, DEFINE CHANNEL, DEFINE WINDOW, EXTRACT CHANNEL, EXTRACT WINDOW 

APPLY DOF RELATIONࠊCLEAR DOF RELATIONࠊDEFINE DOF RELATION㸦EXTRACT DOF RELATION㸧 

CLEAR CHANNEL, CLEAR WINDOW, DEFINE CHANNEL, DEFINE WINDOW, EXTRACT CHANNEL, EXTRACT 
WINDOW 
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剛体特性࢚࢜ࢻ࢔࣭࣮ࢱࢡࣛࢺࢫࢡン 

 ࣮ࣘ࢖࣭࣮ࢨン࡟ࢫ࢖࢙ࣇ࣮ࢱ次ࡢ修ṇࡀ加えࠋࡓࡋࡲࢀࡽ 

 周波数ࣞンࡀࢪ修ṇࡓࢀࡉ場合ࠊ加振ࡢࣝࣈ࣮ࢸ RB࢚࣮ࣛ係数ࡶ更新ࠋࡍࡲࢀࡉ 
 ࣏ࣞࢫンࢫ選択ࡀ変更ࡓࢀࡉ場合ࠊ加振ࡢࣝࣈ࣮ࢸ条件番号ࡶ更新ࠋࡍࡲࢀࡉ 
 FRFࡢୖࢺࢵࣟࣉ周波数ࣞンࢪ選択ࠊࡣ加振選択ࡢ修ṇࡶ࡚ࡗࡼ࡟消えࠋࢇࡏࡲ 
 非ࡢࣈ࢕ࢸࢡ࢔加振ࡀ復活ࡓࡋ場合࣏ࢫࣞࠊンࢫ選択ࡶ回復ࠋࡍࡲࢀࡉ 
 加振࡚࡭ࡍࡀ非ࡓࡗ࡞࡟ࣈ࢕ࢸࢡ࢔場合࣏ࢫࣞࠊンࡣࣝࣈ࣮ࢸ࣭ࢫ無効ࠋࡍࡲࡾ࡞࡟ 

 選択 FRFࠊ࡟ࡵࡓࡿࡍࢺ࣮࣏ࢧࢆRBPE COMPUTE࣐ࢥン࡟ࢻ追加ࠋࡓࡋࡲࢀࡉ 
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コ࣐ンࢻ 

FEMtools࣐ࢥンࢻ言語ࡣいࡢ࠿ࡘࡃ新ࡋい࣐ࢥンࡀࢻᣑ張ࠊࡓࡲࠋࡍࡓࡋࡲࢀࡉ既Ꮡ࣐ࢥࡢンࡀࢻ増強ࡋࡲࢀࡉ
ࡢࣉFEMtools࣊ࣝࠊい࡚ࡘ࡟情報ࡢ࡚࡭ࡍࡢࡑࠋࡓ FEMtools Command Reference࡛参照ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 

新ࡋいコ࣐ンࢻ 

 ࠋࡍࡲࡋい࡚記述ࡘ࡟ࢻン࣐ࢥいࡋ新࡞FEMtools 4࡛利用ྍ能ࠊࡣンࣙࢩࢡࢭࡢࡇ

CLEAR FMDRELATION ࣗࢩࢵ࣓࣮ࣜࣇ変形㸦FMD㸧࣮ࣜࣞࣙࢩンࢆ消去ࠋࡍࡲࡋ 

CLEAR MPM ่࣮ࣔࢻ激࣐ࢆࣉ࣮࢙ࢩࣉࢵ消去ࠋࡍࡲࡋ 

CLEAR NKE Normalized Kinetic Energy㸦ṇ規化運動࢚ࢠࣝࢿ㸧ࢆࣉ࣮࢙ࢩ消去
 ࠋࡍࡲࡋ

CLEAR NMD Normalized Modal Displacement㸦ṇ規化࣮ࣔࣝࢲ変఩㸧ࣉ࣮࢙ࢩ
 ࠋࡍࡲࡋ消去ࢆ

DEFINE FMDRELATION ࣗࢩࢵ࣓࣮ࣜࣇ変形㸦FMD㸧࣮ࣜࣞࣙࢩンࢆ定義ࠋࡍࡲࡋ 

DEFINE EULER ࣮࢜ࣛ࢖角ᗘࢆ使用࣮ࣝ࢝ࣟࡓࡋᗙ標系ࢆ定義ࠋࡍࡲࡋ 

DSP RESAMPLE 再ࢧンࣜࣉンࢢ時้歴 

DSP UPSAMPLE  ࢧ࣭ࣉࢵ࢔ンࣜࣉンࢢ時้歴 

EXAMINE MPM 加振఩置選択用่ࢻ࣮ࣔࡢ激࣐ࢆࣉࢵ計算ࠋࡍࡲࡋ 

EXAMINE SPAMPA ่࣮ࣔࢻ激解析࣐ࢆࣉࢵ使用ࡓࡋ最適加振఩置ࢆ識別ࠋࡍࡲࡋ 

EXAMINE SUPPORT 最適支持఩置選択用࣐ࢆࣉࢵ生成ࠋࡍࡲࡋ 

EXTRACT FMDRELATION ࣗࢩࢵ࣓࣮ࣜࣇ変形㸦FMD㸧情報ࢆ出力ࠋࡍࡲࡋ 

EXTRACT MPM ่࣮ࣔࢻ激࣐ࣉࢵ結果ࢆ出力ࠋࡍࡲࡋ 

FORMࠋࡍࡲࡋࢻ࣮ࣟࢆ࣒࣮࢛ࣇ ࠊ 

REPORT EXCEL CLOSE MS EXCEL࣓ࣗ࢟ࢻンࢆࢺ閉ࠋࡍࡲࡌ 

REPORT EXCEL LAUNCH 新ࡋいMS EXCELࣙࢩࢵࢭンࢆ開始ࠋࡍࡲࡋ 

REPORT EXCEL MATRIX ࡞ࣈ࢕ࢸࢡ࢔MS EXCEL࣓ࣗ࢟ࢻンࢆࢫࢡࢵࣜࢺ࣐࡟ࢺ出力ࡋ
 ࠋࡍࡲ

REPORT EXCEL MODEL ࡞ࣈ࢕ࢸࢡ࢔MS EXCEL࣓ࣗ࢟ࢻンࢆࣝࢹࣔ࡟ࢺ出力ࠋࡍࡲࡋ 

REPORT EXCEL NEW 新ࡋいMS EXCEL࣓ࣗ࢟ࢻンࢆࢺ作成ࠋࡍࡲࡋ 

REPORT EXCEL OPEN 既ᏑࡢMS EXCEL࣓ࣗ࢟ࢻンࢆࢺ開ࠋࡍࡲࡁ 
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REPORT EXCEL PAIR ࡞ࣈ࢕ࢸࢡ࢔MS EXCEL࣓ࣗ࢟ࢻン࢔࣌࡬ࢺ情報ࡾ㈞ࢆ付ࡲࡅ
 ࠋࡍ

REPORT EXCEL QUIT MS EXCELࣙࢩࢵࢭンࢆ閉ࠋࡍࡲࡌ 

REPORT EXCEL SAVE ࡞ࣈ࢕ࢸࢡ࢔MS EXCEL࣓ࣗ࢟ࢻンࢆࢺ保Ꮡࠋࡍࡲࡋ 

REPORT EXCEL SHAPES ࡞ࣈ࢕ࢸࢡ࢔MS EXCEL࣓ࣗ࢟ࢻンࢆࣉ࣮࢙ࢩ࡬ࢺ出力ࡲࡋ
 ࠋࡍ

REPORT EXCEL TITLE ࡞ࣈ࢕ࢸࢡ࢔MS EXCEL࣓ࣗ࢟ࢻンࢆࣝࢺ࢖ࢱ࡟ࢺ加えࠋࡍࡲ 

REPORT POWERPOINT ADDSLIDE 新ࡋい空ࢆࢻ࢖ࣛࢫࡢ加えࠋࡍࡲ 

REPORT POWERPOINT CLOSE MS POWERPOINT࣭࣓ࣗ࢟ࢻンࢆࢺ閉ࠋࡍࡲࡌ 

REPORT POWERPOINT LAUNCH 新ࡋいMS POWERPOINTࣙࢩࢵࢭンࢆ開始ࠋࡍࡲࡋ 

REPORT POWERPOINT MATRIX ࢮࣞࣉ࡞ࣈ࢕ࢸࢡ࢔ンࣙࢩ࣮ࢸンࢆࢫࢡࢵࣜࢺ࣐࡟出力ࠋࡍࡲࡋ 

REPORT POWERPOINT MODEL ࢮࣞࣉ࡞ࣈ࢕ࢸࢡ࢔ンࣙࢩ࣮ࢸンࢆࣝࢹࣔ࡟出力ࠋࡍࡲࡋ 

REPORT POWERPOINT NEW 新ࡋいࢮࣞࣉンࣙࢩ࣮ࢸンࢆ作成ࠋࡍࡲࡋ 

REPORT POWERPOINT OPEN 既Ꮡࢮࣞࣉࡢンࣙࢩ࣮ࢸンࢆ開始ࠋࡍࡲࡋ 

REPORT POWERPOINT PAIR ࢮࣞࣉ࡞ࣈ࢕ࢸࢡ࢔ンࣙࢩ࣮ࢸン࢔࣌ࡢ࡬情報ࢆ出力ࠋࡍࡲࡋ 

REPORT POWERPOINT QUIT MS POWERPOINTࣙࢩࢵࢭンࢆ閉ࠋࡍࡲࡌ 

REPORT POWERPOINT RMF ࣏࣮ࣞ࢕ࢸンࢢ過程ࢸࡢン࣏ࣛࣜࢆࣝ࢖࢓ࣇ削除ࠋࡍࡲࡋ 

REPORT POWERPOINT SAVE ࢮࣞࣉ࡞ࣈ࢕ࢸࢡ࢔ンࣙࢩ࣮ࢸンࢆ保Ꮡࠋࡍࡲࡋ 

REPORT POWERPOINT SHAPES ࢮࣞࣉ࡞ࣈ࢕ࢸࢡ࢔ンࣙࢩ࣮ࢸンࢆࣉ࣮࢙ࢩ࡬出力ࠋࡍࡲࡋ 

REPORT POWERPOINT TITLE 現ᅾࠋࡍࡲࡋࢺࢵࢭࢆࣝࢺ࢖ࢱࡢࢻ࢖ࣛࢫࡢ 

REPORT TEXT CLOSE ASCII࣓ࣗ࢟ࢻンࢆࢺ閉ࠋࡍࡲࡌ 

REPORT TEXT MATRIX ࡞ࣈ࢕ࢸࢡ࢔ ASCII࣓ࣗ࢟ࢻンࢆࢫࢡࢵࣜࢺ࣐࡟ࢺ出力ࠋࡍࡲࡋ 

REPORT TEXT MODEL ࡞ࣈ࢕ࢸࢡ࢔ ASCII࣓ࣗ࢟ࢻンࢆࣝࢹࣔ࡟ࢺ出力ࠋࡍࡲࡋ 

REPORT TEXT NEW 新ࡋい ASCII࣓ࣗ࢟ࢻンࢆࢺ作成ࠋࡍࡲࡋ 

REPORT TEXT OPEN 既Ꮡࡢ ASCII࣓ࣗ࢟ࢻンࢆࢺ開ࠋࡍࡲࡁ 

REPORT TEXT PAIR ࡞ࣈ࢕ࢸࢡ࢔ ASCII࣓ࣗ࢟ࢻン࢔࣌࡬ࢺ情報ࢆ出力ࠋࡍࡲࡋ 

REPORT TEXT SHAPES ࡞ࣈ࢕ࢸࢡ࢔ ASCII࣓ࣗ࢟ࢻンࢆࣉ࣮࢙ࢩ࡬ࢺ出力ࠋࡍࡲࡋ 

REPORT TEXT TITLE ࡞ࣈ࢕ࢸࢡ࢔ ASCII࣓ࣗ࢟ࢻンࢆࣝࢺ࢖ࢱ࡟ࢺ加えࠋࡍࡲ 
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REPORT TEXT VARIABLE ࡞ࣈ࢕ࢸࢡ࢔ ASCII࣓ࣗ࢟ࢻン࡟ࢺෆ部࢕ࢸࢵࢭンࢆࢢ出力ࡲࡋ
 ࠋࡍ

REPORT WORD CLOSE MS Word࣓ࣗ࢟ࢻンࢆࢺ閉ࠋࡍࡲࡌ 

REPORT WORD LAUNCH 新ࡋいMS Wordࣙࢩࢵࢭンࢆ開始ࠋࡍࡲࡋ 

REPORT WORD MATRIX ࡞ࣈ࢕ࢸࢡ࢔MS Word࣓ࣗ࢟ࢻンࢆࢫࢡࢵࣜࢺ࣐࡟ࢺ出力ࡲࡋ
 ࠋࡍ

REPORT WORD MODEL ࡞ࣈ࢕ࢸࢡ࢔MS Word࣓ࣗ࢟ࢻンࢆࣝࢹࣔ࡟ࢺ出力ࠋࡍࡲࡋ 

REPORT WORD NEW 新ࡋいMS Word࣓ࣗ࢟ࢻンࢆࢺ作成ࠋࡍࡲࡋ 

REPORT WORD OPEN 既ᏑࡢMS Word࣓ࣗ࢟ࢻンࢆࢺ開ࠋࡍࡲࡁ 

REPORT WORD PAIR ࡞ࣈ࢕ࢸࢡ࢔MS Word࣓ࣗ࢟ࢻン࢔࣌࡬ࢺ情報ࢆ出力ࠋࡍࡲࡋ 

REPORT WORD QUIT MS Wordࣙࢩࢵࢭンࢆ閉ࠋࡍࡲࡌ 

REPORT WORD RMF ࣏࣮ࣞ࢕ࢸンࢢ過程ࢸࡢン࣏ࣛࣜࢆࣝ࢖࢓ࣇ削除ࠋࡍࡲࡋ 

REPORT WORD SAVE ࡞ࣈ࢕ࢸࢡ࢔MS Word࣓ࣗ࢟ࢻンࢆࢺ保Ꮡࠋࡍࡲࡋ 

REPORT WORD SHAPES ࡞ࣈ࢕ࢸࢡ࢔MS Word࣓ࣗ࢟ࢻンࢆࣉ࣮࢙ࢩ࡬ࢺ出力ࠋࡍࡲࡋ 

REPORT WORD TITLE ࡞ࣈ࢕ࢸࢡ࢔MS Word࣓ࣗ࢟ࢻンࢆࣝࢺ࢖ࢱ࡟ࢺ加えࠋࡍࡲ 

SET INTERFACE SAP SAP2000࢖࣭ࢱ࣮ࢹン࢖࣭ࢱ࣮ࢹࡢࡵࡓࡢࢫ࢖࢙ࣇ࣮ࢱンࣇ࣮ࢱ
 ࠋࡍࡲࡋ定義ࢆࢢン࢕ࢸࢵࢭ࣭ࢫ࢖࢙

修正済ࡢコ࣐ンࢻ 

 ࠋࡍࡲࡋい࡚記述ࡘ࡟変更点ࡢ࡬ࢻン࣐ࢥࠊࡣンࣙࢩࢡࢭࡢࡇ

DEFINE SELEM 補語 GEࠊALPHAࠊBETAࡀ構造㸦Structural㸧減衰ࡼ࠾び࣮ࣞࣜ
࣮粘性㸦Rayleigh viscous㸧減衰ࢆ定義࡟ࡵࡓࡿࡍ付ࡅ加えࡲࢀࡽ
 ࠋࡓࡋ

DEFINE SET 補語 ATTACHEDࡣ現ᅾ࡟࣒ࢸ࢖࢔ࡢ選択ࢆ࣒ࢸ࢖࢔追加ࡲࡋ
 ࠋࡍ

EXAMINE MPA  補語MODEࢻ࣮ࣔࡀ選択ࢆ指定࡟ࡵࡓࡿࡍ追加ࠋࡍࡲࢀࡉ 

EXAMINE MPF 補語 FILEࡣᪧ式ࡵࡓࡢ削除ࠋࡍࡲࢀࡉ 

EXTRACT NKE  補語 UPPER࡜ LOWERࡣ削除ࠋࡍࡲࢀࡉ 

EXTRACT NMD  補語 UPPER࡜ LOWERࡣ削除ࠋࡍࡲࢀࡉ 

GUI ࣝ࢖ࢱࢫ SGIࠊMOTIFPLUSࠊPLATINUMࠊTITANIUMࠊXPࠊࡣ
 ࠋࢇࡏࡲࢀࡉࢺ࣮࣏ࢧやࡣࡶ
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ࣝ࢖ࢱࢫ CLEANLOOKSࠊPLASTIQUEࠊWINDOWSVISTAࡼ࠾
びWINDOWSXPࡀ加えࠋࡓࡋࡲࢀࡽ 

MODIFY MBA SUBSTRUCTURE 補語 Bࠊࡣ吸཰器ࡢ減衰特性ࢆ修ṇ࡟ࡵࡓࡿࡍ追加ࠋࡍࡲࢀࡉ
 ࠋࡍࡲࡾ࡞࡟別ྡࡢDAMPING補語ࠊࡣࢀࡑ

MODIFY MBA SUBSTRUCTURE 補語 B1ࠊB2ࠊB4ࠊB5ࡀ減衰修ṇ要素㸦ࣛࢢンࢻ間㸧ࡢ減衰特
性ࢆ修ṇ࡟ࡵࡓࡿࡍ追加ࠋࡓࡋࡲࢀࡉ 

MODIFY MBA SUBSTRUCTURE  補語 K1ࠊK2ࠊK4ࠊK5ࣜࣉࢫࡀンࢢ修ṇ要素㸦ࣛࢢンࢻ間㸧ࡢ
剛性特性ࢆ修ṇ࡟ࡵࡓࡿࡍ追加ࠋࡓࡋࡲࢀࡉ 

SET MBA  補語 COUPLING࡟伴う SET MBA A RIGID値ࡀ追加ࠋࡓࡋࡲࢀࡉ 

FEMtoolsࢺࣉࣜࢡࢫ 

FEMtoolsࢺࣉࣜࢡࢫ言語ࡣ新ࡋい機能ࢆ伴࡚ࡗᣑ張ࠋࡓࡋࡲࢀࡉ全࡚ࡢ情報ࠊࡣFEMtools࣊ࣝࡢࣉ FEMtools API
 ࠋࡍࡲࡁ参照࡛ࢆࢫンࣞ࢓ࣇࣜ

新ࡋいࢺࣉࣜࢡࢫ関数 

いࡋ新ࡣンࣙࢩࢡࢭࡢࡇ FEMtoolsࢺࣉࣜࢡࢫ関数ࡘ࡟い࡚記述ࠋࡍࡲࡋ 

一般関数 

Do … Loop  Do࣮ࣝࢆࣉ追加ࠋࡿࡍ 

For … Next  For繰ࡾ返ࢆࡋ追加ࠋࡿࡍ 

ScreenSize  ࣮ࣔࣜࢡࢫ࣭࣮ࢱࢽンࢬ࢖ࢧࣝࢭࢡࣆࡢ(x,y)ࢆ返ࠋࡍࡲࡋ 

Dictionary Object㸦辞書࢜ࢺࢡ࢙ࢪࣈ㸧 

.Add 辞書࢜ࢆ࣒ࢸ࢖࢔࡟ࢺࢡ࢙ࢪࣈ追加ࠋࡍࡲࡋ 

.CompareMethod 辞書࢜ࢺࢡ࢙ࢪࣈ中ࡢ比較ࣜࢺࢫンࡢ࣮࣭࢟ࢢ比較方法ࢆ設定ࡲ

 ࠋࡍࡲࢀࡉ実行ࡀ検索ࡣࡓ

.Count 辞書中࣒ࢸ࢖࢔ࡢ数ࢆ数えࠋࡍࡲ 

.Exists 辞書ࡀ࣒ࢸ࢖࢔Ꮡᅾ࠿ࡿࡍ否࠿識別ࠋࡍࡲࡋ 

.Item 辞書࢜ࢆ࣒ࢸ࢖࢔ࡢࢺࢡ࢙ࢪࣈ修ṇࡣࡓࡲ検索ࡀ実行ࠋࡍࡲࢀࡉ 

.Items 辞書࡚࢜࡭ࡍࢆ࣒ࢸ࢖࢔ࡽ࠿ࢺࢡ࢙ࢪࣈ検索ࠊࡋ異ࡿ࡞配列ࡑ࡟

 ࠋࡍࡲࡋ格納ࢆࡽࢀ

.Key ࢆ࣮࢟ࡢ࣒ࢸ࢖࢔修ṇࠋࡍࡲࡋ 

.Keys 辞書࢜࡟ࢺࢡ࢙ࢪࣈ格納ྡࡢ࣒ࢸ࢖࢔ࡢ࡚࡭ࡍࡓࢀࡉ前ࢺࢫࣜࡢ

 ࠋࡍࡲࡋ返ࢆ
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.Load Matlab 5࡜互換ࡢࣝ࢖࢓ࣇ࣭ࢱ࣮ࢹ辞書ࠋࡍࡲࡋࢻ࣮ࣟࢆ 

.Remove 辞書࢜ࡾྲྀࢆ࣒ࢸ࢖࢔ࡽ࠿ࢺࢡ࢙ࢪࣈ除ࠋࡍࡲࡁ 

.RemoveAll 辞書࢜ࡾྲྀ࡚࡭ࡍࢆ࣒ࢸ࢖࢔ࡽ࠿ࢺࢡ࢙ࢪࣈ除ࠋࡍࡲࡁ 

.Save Matlab 5࡜互換ࡢࣝ࢖࢓ࣇ࣭ࢱ࣮ࢹ辞書ࢆ保Ꮡࠋࡍࡲࡋ 

修正済ࢺࣉࣜࢡࢫ関数 

 ࠋࡍࡲࡋい࡚記述ࡘ࡟変更点ࡢ関数ࢺࣉࣜࢡࢫFEMtoolsࠊࡣンࣙࢩࢡࢭࡢࡇ

CreateObject 辞書࢜ࢆࢺࢡ࢙ࢪࣈ作成ࡢࡵࡓࡿࡍ入力値’dictionary’ࢺ࣮࣏ࢧࢆ
 ࠋࡍࡲࡋ

RmDir ࣓ࢺ࣮ࢸࢫンࢺあࡿいࡣ関数࡚ࡋ࡜呼び出ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡍ 

FEMtools API 

FEMtools APIࡢいࡢ࠿ࡘࡃ新ࡋい関数ࡀᣑ張ࠊࡓࡲࠊࢀࡉ既Ꮡࡢ関数ࡀ増強ࠋࡓࡋࡲࢀࡉ全࡚ࡢ情報࡟関ࠊࡣ࡚ࡋ
FEMtools࣊ࣝࡢࣉ FEMtools API Referenceࡽ࠿参照ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 

新ࡋい FEMtools API関数 

Ft_CheckOutFeature 解析機能ࢭ࢖ࣛࡢンࡀࢫ᭷効࡝࠿うࠋࡍࡲࡋࢡࢵ࢙ࢳ࠿ 

Ft_FormCommand ࣐ࢥ࡟࣒࣮࢛ࣇンࢆࢻ㏦ࠋࡍࡲࡾ 

Ft_GetForm ࡽ࠿࣒࣮࢛ࣇ情報ࢆ得ࠋࡍࡲ 

Ft_GetProperties ANALYSE࣐ࢥンࡢ࡬ࢻ引ࡁ数ࢆ渡ࠋࡍࡲࡋ 

Ft_LoadForm ࢆࣝࢿࣃ࠿ࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲࡢࢫ࣮࣒࣮࢛࣋ࣇ開ࠋࡍࡲࡁ 

Ft_SetForm ࡟࣒࣮࢛ࣇ情報ࢆ㏦ࠋࡍࡲࡾ 

修正済ࡢ FEMtools API関数 

 ࠋࡍࡲࡋい࡚記述ࡘ࡟変更点ࡢFEMtools API関数ࠊࡣンࣙࢩࢡࢭࡢࡇ

Ft_GetItemList ࡢࡇ関数ࡀ返ࡿࡁ࡛ࡀ࡜ࡇࡍ要素ࣜ࡟ࢺࢫ基࡙ࢆࢺࢫࣜࢻ࣮ࣀࡃ

返ࠋࡍࡲࡋFt_GetItemList(ST_NODE, "ELEMENT", elist)ࡼࡢう࡟
使用ࠋࡍࡲࡋ 

Ft_HasFeature ࡢࡇ関数ࡣࡶࠊࡣや重要࡞機能࡛ࡣあࠊࡋࡔࡓࠋࢇࡏࡲࡾ利用ྍ

能ࢭ࢖ࣛ࡞ンࢫ数࡝࠿0<ࡀうࠊࡣࢀࡇࠋࡍࡲࡋࢡࢵ࢙ࢳࢆ࠿単
ࠋࡍࡲࢀࡉ使用࡟ࢡࢵ࢙ࢳ࡞うࡼࡿࡍ計算ࢆ数ࡢ機能࡞᭷効࡟

Ft_HasFeatureࡣ常࡟真値㸦True㸧ࢆ返ࠊࡋ機能ࣙࢩࢵࢭࡀン間
࡛᭷効࡝࠿うࠋࡍࡲࡋࢡࢵ࢙ࢳ࠿ 

Ft_HostInfo 付属ࡢ Safenet HASP HLࢻンࣝࢢ情報ࡢࡵࡓࡿࡍࢺ࣮࣏ࣞࢆ引
数’hl’ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆ 
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Ft_ProductInfo 引数’server’ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆ 

Ft_SendWindowCommand 引数’Activate’ࢺࢵࢤ࣮ࢱࡀMDI࢘࢕ンࡿࡍ࡟ࣈ࢕ࢸࢡ࢔ࢆ࢘ࢻ
 ࠋࡍࡲࢀࡽ加えࡅ付࡟ࡵࡓ

Ft_SetGUIStyle GUIࠊ࡚ࡋ࡜ࣝ࢖ࢱࢫsgi, motifplus, platinum, titanium, xpࡣࡶࠊࡣ
やࢺ࣮࣏ࢧ対象外࡛ࠊࡀࡍcleanlooks, plastique, windowsvista and 
windowsxpࡀ加えࠋࡓࡋࡲࢀࡽ 

新ࡋい API環境変数 

 ࢢンࣜࢺࢫと࣮ࣛ࢝ࢫ

interface.abaqus.fminfree ABAQUSࢆ࣮ࣂࣝࢯ࣭ࢫ࣮࣌ࢫࣈࢧࡢ使用ࠊࡋ剛体࣮࢙ࣔࢩࢻ
 ࠋࡍࡲࡋ指定ࢆ最ᑠ周波数ࡢࡵࡓࡿࡍ計算ࢆࣉ࣮

interface.show.extra FEࣙࢩ࣮ࢣࣜࣉ࢔ン㸦Algor, Femap, MSC.Marc,…㸧ࣝ࢖࢓ࣇࡢ
࣭ࢺン࣏࣮࢖ࣝ࢖࢓ࣇࡣᣑ張子ࡢࡽࢀࡑࠋࡍࡲࡋ出力ࢆᣑ張子ࡢ

ࡽࢀࡑࠊࡣ࡛ࢺ࢛ࣝࣇࢹࠋࡍࡲい࡚ࢀࡲ含࡟ࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ

 ࠋࢇࡏࡲい࡚ࢀࡉ定義ࡣ
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FEMtools 4.0.1 更新情報  

ࡣ更新情報ࡢࡇ FEMtools 4.0.1.1850ࣙࢪ࣮ࣂン࡟対応ࡾࡼࠋࡍࡲࡋヲ細ࡘ࡟い࡚ࠊࡣFEMtools 4.0.1࣓ンࢼࢸン
 ࠋいࡉࡔࡃ࡚ࡋ参照ࢆࢺ࣮ࣀࢫ࣮࣭ࣜࣜࢫ

以ୗ࣓ࣗ࢟ࢻࡢン࡜ࢺ例題࡟関ࡿࡍ変更点ࡘ࡟い࡚解ㄝࠋࡍࡲࡋ 

 変更点ࡢࢺキ࣓ࣗンࢻ

ࡢ࡚࡭ࡍ FEMtools࣓ࣗ࢟ࢻンࡀࢺ更新ࠋࡓࡋࡲࢀࡉ 

 追加情報ࠊ࡚ࡋ࡜USBࢻン࢖࣭ࣂ࢖ࣛࢻࡢࣝࢢン࣮ࣝࢺࢫ方法࡟関ࡀࣝ࢔ࣗࢽ࣐ࡿࡍ追加࡚ࢀࡉいࡲࠋࡍࡲ
ࢺࢵࢭࡢび環境変数ࡼ࠾࣮ࣕࢪ࣮ࢿ࣐࣭ࢫンࢭ࢖FEMtoolsࣛࠊࡣい࡚ࡘ࡟使用方法ࡢࣝࢢンࢻFEMtoolsࠊࡓ
方法ࢆ参照ࡉࡔࡃ࡚ࡋいࠋ 

 ࡢࡑࠊࡓࡲ௚ࡢ追加情報ࠊ࡚ࡋ࡜FEMtools Getting Started㸦入門㸧࣐ࢆࣝ࢔ࣗࢽ参照ࡉࡔࡃ࡚ࡋいࠋ 
 Test Model Editor㸦ࢱ࢕ࢹ࢚࣭ࣝࢹ࣭ࣔࢺࢫࢸ㸧ࡢ使用方法࡟関ࡿࡍ新ࡋい章ࡀ FEMtools࣓࣮ࢨ࣮࣭ࣘࣗࢩࢵ

 ࠋࡍࡲい࡛ࢇ含ࢆ定義方法例ࡢび࣮ࣟ࢝ࣝ෇柱ᗙ標系ࡼ࠾記述ࡢࣝࢿࣃࡣࢀࡑࠋࡓࡋࡲࢀࡉ追加࡟ࢻ࢖࢞
 ANSYS ࣮ࣃ࣮ࢫ要素ࡢ処理ࡘ࡟い࡚ࣙࢩࢡࢭࡢンࡀ ANSYS࢖ンࡼ࠾ࢫ࢖࢙ࣇ࣮ࢱび࡟ࢻ࢖࢞ࡢࣂ࢖ࣛࢻ追

加ࠋࡓࡋࡲࢀࡉ 

例題ࡢ変更点 

 新ࡋい例題࣮ࢲ࢛ࣝࣇࡀࣝ࢖࢓ࣇ..\examples\mesh\test_model_editor.࡟追加ࠋࡓࡋࡲࢀࡉ 
 SIM࡜接⥆ࡢ࡜ࡇࡿࡍ新ࡋい例ࡣ..\examples\interfaces\abaqus.࡟追加ࠋࡓࡋࡲࢀࡉ 

 新ࡋい例題ࡣ࣮ࢲ࢛ࣝࣇ FRF࡜ HRAࡢ検証例題࡚ࡋ࡜追加ࡋࡲࢀࡉ
 ࠋいࡉࡔࡃ࡚ࡋ参照ࢆexamples\dynamic\harmonic\verification\..ࠋࡓ

 新ࡋい例題࣮ࢲ࢛ࣝࣇ..\examples\dynamic\selem\nastranࡀ追加ࠋࡓࡋࡲࢀࡉ 
 新ࡋい例題ࡀ࣮ࢲ࢛ࣝࣇMEFࡢ計算ࢆ実証ࡘ࠿ࠊࡋ結果ࢆ NASTRAN࡜比較࡟ࡵࡓࡿࡍ追加ࡋࡲࢀࡉ

 ࠋいࡉࡔࡃ࡚ࡋ参照ࢆexamples\pretest\mef\.ࠋࡓ
 新ࡋい例題࡚ࡋ࡜஧次近似係数ࢆ推定ࡢࡵࡓࡿࡍ高精ᗘ࣮࣮࢜ࢲ関数㸦曲線適合㸧実証例ࡀ追加ࡋࡲࢀࡉ

 ࠋいࡉࡔࡃ࡚ࡋ参照ࢆexamples\nlp\fit\..ࠋࡓ
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FEMtools࣒࣮ࣞࣇワ࣮ࢡ 

FEMtools࣒࣮ࣞࣇワ࣮ࡢࢡ変更点ࢆ概ㄝࠋࡍࡲࡋ 

一般機能 

 SQLiteࠊࡀࣂ࢖ࣛࢻFEMtools࣐ࢥン࢖ࣛࢻン࣭ࣙࢪ࣮ࣂン㸦FTCMD㸧࡛ࠋࡓࡋࡲࢀࡉࢺ࣮࣏ࢧ 
 24時間ࢆ越えࡿ時間ࡓࡗ࠿࠿解析ࡢṇ確࣑࢖ࢱ࡞ンࢢ情報ࠋࡍࡲࡋࢺ࣮࣏ࣞࢆ 

 生成ࣗࢩࢵ࣓

ࡀい章ࡋ新ࡿࡍ関࡟使用方法ࡢࢱ࢕ࢹ࢚࣭ࣝࢹ࣭ࣔࢺࢫࢸ FEMtools࣓࡟ࢻ࢖࣮࢞ࢨ࣮࣭ࣘࣗࢩࢵ追加ࡋࡲࢀࡉ
ࡣࣝ࢖࢓ࣇい例題ࡋ新ࡢࡑࠋࡍࡲい࡛ࢇ含ࢆ定義方法例ࡢび࣮ࣟ࢝ࣝ෇柱ᗙ標系ࡼ࠾ヲ細記述ࡢࣝࢿࣃࡣࢀࡑࠋࡓ

 ࠋࡍࡲࢀࡉ追加࡟examples\mesh\test_model_editor\..࣮ࢲ࢛ࣝࣇ

 ࣉࢵࢺࢡࢫࢹ

 ࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲと࣮ࣗࢽ࣓

 複数ࢆࢫࣃ指定࣮ࢲ࢛ࣝࣇ࣭ࢫࣃ࣭ࢪ࣮࣓࢖ࡿࡍ㸦path.image㸧ࢆ設定ࡿࡍ場合ࡢ潜ᅾ的࡞問題ࡀ解決ࡲࢀࡉ
 ࠊࡤ例えࠋࡓࡋ
 
path.image=c:\femtools\4\images;d:\home\ft4\new_images  
 
ࡋ࡛ࢇࡏࡲࡁ࡛ࡀ࡜ࡇࡿࡅࡘ見ࢆࣝ࢖࢓ࣇ࣭ࢫࢡࢵ࢕ࣇࣛࢢࡿࡍᏑᅾ࡟ࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲࡢ複数ࠊ場合ࡢࡇ

関数ࠊࡣ࡟解決ࢆ問題ࡢࡇࠋࡓ Ft_LocateFileࠊࡀBuildPathࡢ代わ࡟ࡾ使用ࠋࡍࡲࢀࡉ 
 Only add spring components for the blocked BC ࢆ示ࡼࡍう࡟ Convert Boundary Conditions to Springs࣎ࢢࣟ࢔࢖ࢲ

一࡛ྠ࡜ࢻン࣐ࢥBC2SPRINGࠊࡣ舞いࡿ振ࡢࡑࠋࡍࡲࢀࡉ使用࡚ࡋ࡜ࢺ࢛ࣝࣇࢹࡀࢀࡇࠊࢀࡉ修ṇࡀࢫࢡࢵ
 ࠋࡍ

 ࢘ࢻン࢕࣭࢘ࢱ࢕ࢹ࢚

 Edit > Decrease Indent㸦Ctrl+[㸧࣐ࢥンࡀࢻṇ常࡟動作ࠋࡍࡲࡋ 

 ࢫ࣮࣋ࢱ࣮ࢹ

 ࣮ࣟ࢝ࣝᗙ標ࡀ使用ࡿࢀࡉ場合ࡢ RBE2ෆ部処理࡟関ࡿࡍ DOFࡢࣝࣂ࣮ࣟࢢࡽ࠿࣮ࣝ࢝ࣟࡢᗙ標系ࡢ࡬変換
計算ࡀṇ常化ࠋࡓࡋࡲࢀࡉ 

 ࣮ࣔࠊࡣࣉ࣮࢙ࢩࢻSORT࣐ࢥン࡛ࢻ共振周波数ࢆ並࡭替えࡣࢀࡇࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿ昇㡰࡚ࡗ࡞࡟い࡞い࢖
ン࣏࣮࡟࡝࡞ࢻ࣮࣭ࣔࢺࢫࢸࢺ使用ࠋࡍࡲࢀࡉ 

 ࣝࣈ࣮ࢸ

ࡢࣝࣈ࣮ࢸ Create/Editࡿࡅ࠾࡟ࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲMove Up/Down࣎ࢱン操作ࡀ࣮࢚ࣛࡢ修ṇࠋࡓࡋࡲࢀࡉ 

Parametersࢆ࣭ࣝ࣋ࣛࢱ࣮࣓ࣛࣃࡢࣝࣈ࣮ࢸ編集ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 

 ࢫࢡࢵ࢕ࣇࣛࢢ

ࡇࡓࢀ現ࡀ࢘ࢻン࢕࣭࢘ࢫࢡࢵ࢕ࣇࣛࢢ黒いࡤࡋࡤࡋࠋࡓࡋࡲࢀࡉ修ṇࡀ࣮࢚࣭ࣛࣗࢩࢵࣞࣇ࣭ࣜࢫࢡࢵ࢕ࣇࣛࢢ

 ࠋࡓࡋࡲࢀࡉ修ṇࡀ࡜
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 信号処理ࣝࢱࢪࢹ

 DSP FILTER࣐ࢥンࡣࢻ ZEROPHASEࣜࢱࣝ࢕ࣇン࡟ࡵࡓࡢࢢ新ࡋい࢜ࣙࢩࣉンࢆ追加0ࠋࡓࡋࡲࡋ఩相࢕ࣇ
పいࡾࡼࡣい場合࡞ࢀࡉ補間ࡀࢀ఩相遅ࠋࡍࡲࢀࡉ補間ࡀࢀ఩相遅ࠊࡾࡼ࡟࡜ࡇࡿࡍ࡟ン࢜ࢆࢢンࣜࢱࣝ

ORDER番号ࢆ使用ࡉࡔࡃ࡚ࡋいࠋ 
 非ࢧンࣜࣉンࠊࢢ縮ᑠࢧンࣜࣉンࡼ࠾ࢢび再ࢧンࣜࣉンࡢࡵࡓࡢࢢ DSP࣐ࢥンࣉࢵ࢔ࢺ࣮ࢱࢫࠊࡣࢻ時ࡼ࠾

び終了時ࡢ過渡現象ࢆ縮ᑠࡓࡲࠊࡋ振幅࣮ࣜࢣࢫンࢆࢢ保Ꮡ࡟ࡵࡓࡿࡍ使用ࠋࡍࡲࢀࡉ 

FEMtools Dynamic 

ソ࣮ࣝࣂ 

 ࢔ࢥ外解析ࢥࢆン࢕ࢸࢵࢭࡿࡍ࣮ࣝࣟࢺン࡟ࢢ関࣓ࣗ࢟ࢻࡿࡍンࡀࣉࣝ࣊ࠊࢺ追加ࠋࡓࡋࡲࢀࡉ 

SET DYNAMIC COREMODE  
SET DYNAMIC CORESIZE  
DYNAMIC COREMODE  
DYNAMIC CORESIZE 

周波数解析と調和応答解析 

 調和応答解析㸦Harmonic response analysis㸧ࣝࢲ࣮ࣔࠊࡣ法࡜直接法ࢆṇ確࡟使用࡟ࡵࡓࡿࡍ改善ࡋࡲࢀࡉ
 ࠋࡓ

 FRF࡜HRAࡢ検証例ࠊ࡚ࡋ࡜新ࡋい例題࣮ࢲ࢛ࣝࣇ：..\examples\dynamic\harmonic\verificationࡀ追加ࡋࡲࢀࡉ
 ࠋࡓ

 要素࣮ࣃ࣮ࢫ

 NASTRAN࢖࣭ࢫࢡࢵ࣑࡜࣮ࣜࣇン࣮ࣃ࣮ࢫ࣭ࢫ࢖࢙ࣇ࣮ࢱ要素ࠊࡽ࠿既࡟支持ࠊ拘束࢖ࡓࢀࡉン࢖࢙ࣇ࣮ࢱ
࡜࣮ࣜࣇࡢࡽࢀࡇࠊࡣ࣮ࣂࣝࢯFEMtoolsࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍࡁ書ࡳㄞ࡟DMIGࠊ加え࡚࡟要素࣮ࣃ࣮ࢫ࣭ࢫ
ࡵࡓࡢ目的ࡢࡇࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ計算ࢆࢻṇ規࣮ࣔࡓ備えࢆ要素࣮ࣃ࣮ࢫ࣭ࢫ࢖࢙ࣇ࣮ࢱン࢖࡞ࢫࢡࢵ࣑

 ࠋࡓࡋࡲࢀࡉ更新ࡀࣂ࢖ࣛࢻࡢcdsolver.bas࡜nastran.basࠊ࡟
 ANSYS ࣮ࣃ࣮ࢫ要素ࢫࢭࣟࣉ㸦Processing ANSYS Superelements㸧ࣙࢩࢡࢭࡢンࠕࠊࡀANSYS࢖ン࢖࢙ࣇ࣮ࢱ

 ࠋࡍࡲࢀࡉ追加࡟ࠖࢻ࢖࣭࣮࢞ࢨ࣮࣭࣮ࣘࣂ࢖ࣛࢻ࡜ࢫ

 解析ࢺࢫࢸࣜࣉ

 選択࣮ࢧンࢭ࣭ࣝ࢔ࣗࢽ࣐

 RBEࡀࢻ࣮ࣀ選択ྍ能ࠋࡓࡋࡲࡾ࡞࡟ 
 ࢻ࣮ࣀ選択࡟ࢻ࣮ࣀ࣭ࢫ࢖࢙ࣇ࣮ࢧࠊࡣ制限ࠋࢇࡏࡲࢀࡉ 

 ᭷効質量㸦MEF:Modal Effective Mass㸧ࣝࢲ࣮ࣔ

MEFࡢ計算ࠊࡣ剛体࣮ࣔࢻ質量ࢆ計算࡟ࡁ࡜ࡿࡍ非拘束 DOFࢺࢵࢭ㸦A-Set㸧࡟制限ࡓࢀࡉ剛体࣮ࣔࡶ࡟ࢻ実行ࡉ
 ࠋࡍࡲࢀ

新ࡋい例題ࠊࡀ࣮ࢲ࢛ࣝࣇMEFࡢ計算ࢆ実証ࡘ࠿ࠊࡋ結果ࢆ NASTRAN࡜比較࡟ࡵࡓࡿࡍ付ࡅ加えࡲࢀࡽ
 ࠋいࡉࡔࡃ࡚ࡋ参照ࢆexamples\pretest\mef\.ࠋࡍ
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 刺激解析㸦MPA: Mode Participation Analysis㸧ࢻ࣮ࣔ

Mode Participation Analysisࡢࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ Edit ࡜ Deleteࢱ࣎ࡢンࡀṇࡃࡋ動作ࠋࡍࡲࡋ 

 ン編集࢖ࣛࢫ࣮ࣞࢺ

ࢸࢵࢭいࡋ新ࠊ࡟ࡵࡓࡍ示ࢆࢺࢵࣟࣉ࣭࢔࣌ࢺン࢖࣏࣭ࢻ࣮ࣀ࡟ࡾ代わࡢࢺࢵࣟࣉ࣭ࣝࢹ࣭ࣔࢺࢫࢸ࣭ࢺ࢛ࣝࣇࢹ

ࡣࢀࡇࠋࡍࡲࢀࡉ追加࡟ࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲEdit Tracelinesࠊࡀࢢン࢕ FEࣔࢆࣝࢹ表示࢖ࣛࢫ࣮ࣞࢺࠊࡋンࡢ生
成や編集࡟ࢫࢭࣟࣉࡢ᭷用࡛ࠋࡍ 

ࢆUse Node-Point Pairs Plotࠊࡁ開ࢆࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲࠊTools > Pretest Analysis > Edit Tracelines࡛ࠊࡣ࡟ࢀࡑ
࢜ンࠋࡍࡲࡋ࡟ 

 

相関分析 

EVO計算と修正 

 ࡢࢫࢡࢵࣜࢺ࣐࣭࣒ࢸࢫࢩ縮ᑠࠊࡣ常࣮ࣝ࢝ࣟࠊ࡟ᗙ標系࡛実行ࠋࡍࡲࢀࡉ 
 ࣮ࣟ࢝ࣝᗙ標系ࠊࡀFEMtoolsࡼ࠾びNASTRANࡢ࣮ࣂࣝࢯ両方ࡢ中ࡢ参照CS ID-1࡟関࡚ࡋ強化ࠋࡍࡲࢀࡉ以前

ࡋࡲࡾあࡀ࡜ࡇࡍࡇ起ࡁ引࡟୙ṇ使用ࡢCS࣮ࣝ࢝ࣟࠊࡵࡓࡢ1ࠊࡣNASTRAN࡛ࠊࡾ0࡛あࠊࡣFEMtools࡛ࠊࡣ
 ࠋࡓ

 ࣮ࣟ࢝ࣝࡢMPCࠋࡍࡲࢀࡉࢺ࣮࣏ࢧࡀ 
 縮ᑠ࣐࡜ࢫࢡࢵࣜࢺ縮ᑠࡀࣉ࣮࢙ࢩ互換性ࡼࡘࡶࢆう࣮ࢱࢫ࣐ࠊ࡟DOF࣮࢜࢔࣌࡜࣮ࢲDOF࣮࢜ྠࡀ࣮ࢲ期ࡉ

 ࠋࡍࡲࢀࡽࡏ
 ࣐࣮ࢱࢫDOFࡀ境界条件あࡿいࡣ孤立ࡼࡢࢻ࣮ࣀࡓࡋう࡟非ࣈ࢕ࢸࢡ࢔DOF࡚ࡋ࡜定義ࡿࢀࡉ場合ࢳࡣࢀࡑࠊ

 ࠋࢇࡏࡲࢀࡉや許ࡣࡶࠊࢀࡉࢡࢵ࢙
 複素ࡀࢺ࣮࣏ࢧࡢࢻ࣮࣭ࣔࢺࢫࢸ追加ࠋࡍࡲࢀࡉ 

 ࢢン࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔ

 選択ࡢࢫン࣏ࢫとࣞࢱ࣮࣓ࣛࣃ

 ࣙࢩ࣮࣭ࣞࣜࢱ࣮࣓ࣛࣃン࡟関࣓ࣗ࢟ࢻࡿࡍンࡀࢺ改訂ࠊࢀࡉ多ࡢࡃ例証࡛ᣑ張ࠋࡍࡲࢀࡉ 
 総括的࡚ࡋ࡜ࢱ࣮࣓ࣛࣃ使用࣐ࢥ ࡢࢺࣉࣜࢡࢫ࣭ࢫࢭࣟࣉࡿࢀࡉンࢻSET PARAMETER SCRIPTࡀSHOW 

PARAMETER࡛表示ࠋࡍࡲࢀࡉ 
 ࣐ࢥンࢻMODIFY PARAMETERࠊࡣLABELࠋࡍࡲࡋࢺ࣮࣏ࢧࢆ 
 ࣝࣈ࣮ࢸ࣭ࢱ࣮࣓ࣛࣃࠊࡣ࣭ࣝ࣋ࣛࢱ࣮࣓ࣛࣃ中࡛編集ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 
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感ᗘ解析 

 感ᗘ࣮࢝ࣛ―࣭ࢥンࠊࡣࢺࢵࣟࣉ࣭࣮ࢱ総括的࡟ࢱ࣮࣓ࣛࣃ作用ࠋࢇࡏࡲࡋ材料あࡿいࡣ幾何学的࡞要素ࣟࣉ
 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇ選ぶ࡟ࢺࢵࣟࣉ࣭࣮ࢱンࢥ࣭―࣮ࣛ࢝ࡀࡳࡢࢱ࣮࣓ࣛࣃࡿࡍ関係࡟࢕ࢸࣃ

 ࡢ࣒࣮ࣅIYࠊIZࡼ࠾びࣜࣉࢫンࡢࢢKTࠊKRࡢࢱ࣮࣓ࣛࣃࡢṇ規化感ᗘ値࡟0ࠊࡣ設定ࡢࡽࢀࡑࠋࡍࡲࢀࡉ初
期値0࡛ࡀࢱ࣮࣓ࣛࣃあࡿ場合0ࡢࡇࠊ値ࠊ࡚ࡗࡼ࡟NaNࡀⓎ生ࢆ࡜ࡇࡿࡍ回避ࠋࡍࡲࡋ 

 値ࡢࢱ࣮࣓ࣛࣃࡢ番号࡟関ࡿࡍ警告ࠕWarning : … zero valued parameter(s) were detected, starting at parameter 
 ࠋࡓࡋࡲࢀࡉ追加ࡀࠖ.The corresponding sensitivities are set to zeroࠕࠊࠖ…

最適化解析 

NLP 

新ࡋい例題ࡀ高次関数㸦࣮࢝ࢺࢵ࢕ࣇࣈ㸧ࡢ஧次近似係数ࢩࡿࡼ࡟ンࢺࢡ࢙ࢪࣈ࣭࢜ࣝࢢ最適化問題ࢆ実証ࡓࡿࡍ

 ࠋいࡉࡔࡃ࡚ࡋ参照ࢆexamples\nlp\fit\..ࠋࡍࡲࢀࡽ加えࡅ付࡟ࡵ

ABAQUS࢖࣭ࢱ࣮ࢹンࢫ࢖࢙ࣇ࣮ࢱとࣂ࢖ࣛࢻ 

SIMࣝ࢖࢓ࣇ 

新ࡋい࢖ンࠊ࡚ࡋ࡜ࢫ࢖࢙ࣇ࣮ࢱSIMࠊࢀࡉࢺ࣮࣏ࢧࡀࣝ࢖࢓ࣇ要素࣐࢖ࢆࣉ࣮࢙ࢩࢻ࣮ࣔ࡜ࢫࢡࢵࣜࢺン࣏࣮ࢺ
 ࠋࡍࡲࢀࡉ生成࡚ࡋ࡜.ᣑ張子.simࣝ࢖࢓ࣇ࡚ࡗࡼ࡟ABAQUSࠊࡣࣝ࢖࢓ࣇࡢࡽࢀࡇࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ

ࡢ次ࠊ࡚ࡋ࡜ࣝ࢖࢓ࣇ࣭ࢢン࢕ࢸࢵࢭFEMtoolsࠊ࡟ࡵࡓࡴ込ࡳㄞࢆࣉ࣮࢙ࢩࢻ࣮ࣔ࡜ࢫࢡࢵࣜࢺ要素࣐ࡢࡽࢀࡑ
 ࠋࡍࡲࢀࡉ追加ࡀsimᣑ張子設定.࡞うࡼ

STIFFNESS.ABAQUS.RB=ABAQUS (Binary):*.fil;*.sim 
MASS.ABAQUS.RB=ABAQUS (Binary):*.fil;*.sim 
MODE.ABAQUS.RB=ABAQUS (Binary):*.fil;*.odb;*.sim 

SIMࡢࣝ࢖࢓ࣇ生成方法 

次ࡼࡢうࡀࣉࢵࢸࢫ࡞ INP࡟ࣝ࢖࢓ࣇ追加ࠋࢇࡏࡲࡾ࡞ࡤࢀࡅ࡞ࡋ 

*STEP  
*MATRIX GENERATE, ELEMENT BY ELEMENT, STIFFNESS, MASS  
*END STEP 

入力ࡀྡࣝ࢖࢓ࣇ jobname.inpࡢ場合ࢫࢡࢵࣜࢺ࣐ࠊ出力ࣉࢵࢸࢫ数࡟応ࢆࣉࢵࢸࢫࡓࡌ伴う
 ࠋࡍࡲࢀࡉ生成ࡀࣝ࢖࢓ࣇࡓࢀࡽࡅ前付ྡ࡜jobname_X<step>.simࠖ"ࠕ

SIMࢆࣉ࣮࢙ࢩࢻ࣮ࣔࡢࢺࢵ࣐࣮࢛ࣇ生成ࠊࡣ࡟ࡿࡍ解析࡛ࣉࢵࢸࢫ"*RESTART, WRITE"࣐ࢥンࢆࢻ指定ࡲࡋ
 ࠊࡤ例えࠋࡍ

*STEP  
*FREQUENCY, EIGENSOLVER=LANCZOS, NORMALIZATION=MASS  
50, 10, 1e+030  
*RESTART,WRITE *END STEP 

ࡢいうྡ࡜jobname.simࠖࠕࠊ࡟最初ࠊࡋ追加出力ࢆࣉ࣮࢙ࢩࢻ࣮ࣔ࡟࡜ࡈࣉࢵࢸࢫࡿࡍ対応ࠊࡣࢀࡇ SIMࣝ࢖࢓ࣇ
 ࠋࡍࡲࡋ生成ࢆࣝ࢖࢓ࣇいう࡜ "<jobname_X<step"ࠊ࡟࡜ࡈࣉࢵࢸࢫࡃ⥆ࠊࡋ出力ࢆ

Abaqus 6.12ࡼ࠾ 6.14ࠊ6.13ࠊび現ᅾ㸦2016 &2017㸧ࣙࢪ࣮ࣂࡢンࠋࡍࡲࢀࡉࢺ࣮࣏ࢧࡀ 
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SIMと ODBࣉ࣮࢙ࢩࢻ࣮ࣔࡢ 

SIMࢆࢻ࣮࡚ࣔࡋ࡜出力ࠊࡣ࡜ࡇࡿࡍODB࡜比較࡚ࡋ長所ࡀあࠋࢇࡏࡲࡾ 

SIMࠊࡣࢱ࣮ࢹODBࡼࡢう࡞複素࣮࣮ࣔࣝ࢝ࣟࡣࢻ࣮ࣔࠊࡓࡲࠋࢇࡏࡲࡋࢺ࣮࣏ࢧࢆࢻᗙ標系࡛出力ࠋࡍࡲࢀࡉ
 ࠋࡍࡲࡾ࡞࡟必要ࡀ補足処理ࡿࡼ࡟写像ࠊࡣ࡟ࡿࡍ変換࡬ᗙ標ࣝࣂ࣮ࣟࢢࢆᗙ標系࣮ࣝ࢝ࣟࡢࡑ

格ࡣ࡟FEMtoolsࠊࡀࡍࡲい࡚ࢀࡉࢺ࣮࣏ࢧ࡚ࡗࡼ࡟ࢫ࢖࢙ࣇ࣮ࢱン࢖SIMࠊࡣ᭷効質量ࠊ激係数่ࠊ質量ࢻ࣮ࣔ
納ࠋࢇࡏࡲࢀࡉ 

SIM࣮ࣔࡢࢻ要素ෆ部 DOF㸦C3D8iࡼࡢう࡞㸧ࣝࢲ࣮ࣔࡢ変఩ࡣㄞࡳ込ࠊࡀࡍࢀࡲ実際ࡢ物理的ࡣ࡟ࢻ࣮ࣀ࡞写
像ࡢࡽࢀࡑࠋࡓࡋ࡛ࢇࡏࡲࢀࡉෆ部 DOFࠊ࡟ࡵࡓࡿࡍࢺ࣮࣏ࢧࢆࢱ࣮ࢹ要素࣐࡟ࢫࢡࢵࣜࢺ写像ࠊࢀࡉDOF計算
㡯ࡢ.sim࣐࡜ࢫࢡࢵࣜࢺ完全࡞互換性ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆ 

SIMと要素࣐ࢫࢡࢵࣜࢺ用ࡢ FILࡢ比較 

SIMࡽ࠿ㄞࡳ込ࡣࢫࢡࢵࣜࢺ࣐ࡿࢀࡲいࡢ࠿ࡘࡃ長所ࢆ持ࠋࡍࡲࡕ 

 FILࡣࡶࠊࡣࢺࢵ࣐࣮࢛ࣇやᪧ式ࠋࡍ࡛ࢺࢵ࣐࣮࢛ࣇࡢ 
 FILࠊࡣࢺࢵ࣐࣮࢛ࣇFEM解析ࡀ実行࡞ࢀࡉい場合࡟生成ࠊࡀࢇࡏࡲࢀࡉSIMࡢࡑࠊࡣ࡛ࢺࢵ࣐࣮࢛ࣇ生成ࡀ

 ࠋࡍࡲࢀࡉࢺン࣓ࣜࣉン࢖࡟㸦abaqus.bas㸧中ࣂ࢖ࣛࢻ方法࡛ABAQUSࡢ次ࡣࢀࡇࠋࡍࡲࢀࡉࢺ࣮࣏ࢧ
 
'FEM Derivation  
Case 4  
Call Dgn_TimeStamp("abaqus", "Write FEM derivation tmp  
data.")  
If UCase(MatrixFormat) = "SIM" Then  
Print #1, "*STEP"  
Print #1, "*MATRIX GENERATE, ELEMENT BY ELEMENT,  
STIFFNESS, MASS"  
Print #1, "*END STEP"  
Else ...  
Because there is no need 
 
解࡞ࡓ新ࠊࡶい࡚࠾࡟NASTRANやANSYSࠋࢇࡏࡲࡋ࡜必要ࢆ時間࡞ࡓ新ࡿ࠿࠿࡟保Ꮡࡢ解析時࡚ࡗࡼ࡟ࢀࡇ
析ࢆ必要࡞ࡋ࡜い個別ࢫࢡࢵࣜࢺ࣐ࡢ出力ࠋࡍࡲࢀࡉࢺ࣮࣏ࢧࡀ 
 
FILࠊࡣ࡛ࢺࢵ࣐࣮࢛ࣇ解析ࢆ行࡞わࢆࢱ࣮ࢹ࣭ࢫࢡࢵࣜࢺ࣐ࠊ࡟ࡎ出力ࣙࢩ࣮ࣗࣜࢯࡿࡍンࢀࡉࢺ࣮࣏ࢧࡣ
 ࠋࢇࡏࡲ

 ࡢ࡚࡭ࡍ要素࣐ࠊࡀࢫࢡࢵࣜࢺSIM࠾࡟い࡚利用ྍ能࡛あࠊࡾFIL࣐ࡣ࡟ࣝ࢖࢓ࣇ࣭ࢫࢡࢵࣜࢺ出力࡞ࢀࡉい
DOFࠋࡍࡲࢀࡉࢺ࣮࣏ࢧࡀFEMtools SIM࢖ンࠊࡣࢫ࢖࢙ࣇ࣮ࢱ必要࡟応࡚ࡌ要素DOF㸦C3D8i㸧ࡢᅽ縮ࢆ行࡞
いࠋࡍࡲ 

 ࣐࢖࣭ࢫࢡࢵࣜࢺン࣏࣮ࢫࢭࣟࣉࡢࢺ情報ࢆ示ࠋࡍࡲࡋ 
 将来的ࠊࡣ࡟*MATRIX GENERATEࠊELSET=要素ࢫࢡࢵࣜࢺ࣐࡚ࡗࡼ࡟ྡࢺࢵࢭ要素ࢆᢳ出ྍࡀ࡜ࡇࡿࡍ能

 ࠋࡍࡲࡾ࡞࡟能ྍࡀ࡜ࡇࡿࡍࢫࢭࢡ࢔࡟ࢫࢡࢵࣜࢺ࣐ࡢ指定ࠊ࡚ࡗࡼ࡟ࢫࢡࢵࢹン࢖SIM要素ࡢࡇࠋࡍ࡛

例 

SIM࢖ン࡟ࢫ࢖࢙ࣇ࣮ࢱ関ࡿࡍ新ࡋい次ࡢ例題ࠊࡀ..\examples\interfaces\abaqus࡟追加ࠋࡓࡋࡲࢀࡉ 

FE Model: small_plate*.inp  
Modes : small_plate*.sim  
Stiffness and Mass Element Matrices: small_plate*_X2.sim 
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 ࢢン࢕ࢸࢵࢭ࣭࣮ࣂ࢖ࣛࢻࡢ用ࢺࢵ࣐࣮࢛ࣇ࣭ࢫ࢖࢙ࣇ࣮ࢱン࢖࣭ࢺ࢛ࣝࣇࢹ

SIM࢖ンࠊࡣࢫ࢖࢙ࣇ࣮ࢱᪧ FIL࡟ࢺࢵ࣐࣮࢛ࣇ代わࡿ要素࣐࢖ࡢࢫࢡࢵࣜࢺン࣏࣮࢖࣭ࢺ࢛ࣝࣇࢹ࡟ࡵࡓࡢࢺン
࡜ࡇࡿࡍ࡟ࢺࢵ࣐࣮࢛ࣇࡢࢺ࢛ࣝࣇࢹࢆFILࠊࡋ使用ࢆࣝ࢖࢓ࣇFILࠊࡋࡔࡓࠋࡍࡲࢀࡉ設定࡚ࡋ࡜ࢫ࢖࢙ࣇ࣮ࢱ
 ࠋࡍ能࡛ྍࡶ

࡜ࢫࢡࢵࣜࢺ要素࣐ࠊࡋ࠿ࡋࠋࡍ࡛ࢺ࢛ࣝࣇࢹࡀࢺࢵ࣐࣮࢛ࣇODBࠊ࡚ࡗ代わ࡟FILࠊࡣい࡚ࡘ࡟ࣉ࣮࢙ࢩࢻ࣮ࣔ
ྠ様ࠊ࡟FIL࡚ࡋ࡜ࢺ࢛ࣝࣇࢹࢆ設定ྍࡶ࡜ࡇࡿࡍ能࡛ࠋࡍ 

ࡽ加えࡅ付࡟ࣝ࢖࢓ࣇscripts\drivers\abaqus.ini\..ࡀࣜࢺン࢚࡞うࡼࡢ次ࠊࡣ࡟ࡿࡍ設定ࢆࢺࢵ࣐࣮࢛ࣇࡢࢺ࢛ࣝࣇࢹ
 ࠋࡍࡲࢀ

ifile.format=odb  
matrix.format=sim  

"file.format" can be set to FIL or ODB  
"matrix.format" can be set to FIL or SIM 

ABAQUSࠊࡣࣂ࢖ࣛࢻabaqus.iniࡢࡽࢀࡇ࡟ࣝ࢖࢓ࣇ変更࡟ࡵࡓࡿࡍࢺ࣮࣏ࢧࢆ修ṇࠋࡍࡲࢀࡉ 

修正さࢀた ODBࣉࢵࢸࢫ選択 

interface.abaqus.step変数ࡣ次ࢆࡢࡶࡢㄞࡴ込ࢆࣉࢵࢸࢫࡴ指定࡟ࡵࡓࡿࡍ使用ࠋࡍࡲࢀࡉ 

 ṇࡢ値ࠊࡣ先頭ࡢࡽ࠿昇㡰ࢆࣉࢵࢸࢫ示ࠋࡍ 
 ㈇ࡢ値ࠊࡣ最終ࡢࡽ࠿降㡰ࢆࣉࢵࢸࢫ示ࠋࡍ 

-1=最終2-ࠊࣉࢵࢸࢫ=最終ࡽ࠿㸰番目࡝࡞ࣉࢵࢸࢫࡢ 
 0ࡀ指定ࡓࢀࡉ場合࢖ࠊン࣏࣮ࢱ࣮ࢹࡁ࡭ࡿࡍࢺ最終ࡀࣉࢵࢸࢫ示ࠋࡍࡲࢀࡉ 

 ࠋࡓࡋࡲࢀࡉ変更࡟0ࠊࡀࡓࡋ1࡛-ࡣ以前ࠊࡣࢺ࢛ࣝࣇࢹ

例 

静的ࠊࣉࢵࢸࢫṇ規࡜複雑ࡢࢻ࣮ࣔࡢ解析 

Step 1 : 'Step-1' (StaticStep)  
Step 2 : 'Step-2' (StaticStep)  
Step 3 : 'Step-3' (FrequencyStep)  
Step 4 : 'Step-4' (ComplexFrequencyStep)  

FEMtools࣐ࢥンࢻ 

search mode format abaqus 

 ࠊࡣࢻン࣐ࢥࡢ次ࠊࢀࡉ使用ࡀStep 4(ComplexFrequencyStep)ࠊࡣࢀࡇ

search displacement format abaqus 

Step 2  (StaticStep)ࡀ使用ࠋࡍࡲࢀࡉ 

関連付࡟ࣉࢵࢸࢫࡢࢱ࣮ࢹい静的線形࡞ࡲ含ࢆ関連情報ࡢ.odbࠊࡣࡽࢀࡑࠊ場合ࡿࢀࡉ出力࡟sim.ࡀࢫࢡࢵࣜࢺ࣐
 ࠋࡍࡲࢀࡽࡅ

例えࠊࡤ次ࢆࣉࢵࢸࢫࡢ含ࡴ解析࡛ࠊࡣ 
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Step 1 : 'Step-1' (FrequencyStep)  
Step 2 : 'Step-2' (StaticLinearPerturbationStep) 

 ࠋࡍࡲࡋ指ࢆstep=1㸦frequencystep㸧ࠊࡣstep=0ࠊࡁ࡜ࡿࢀࡉࢺン࣏࣮࢖ࡀࢻ࣮ࣔࠊ場合ࡢࡇ

ANSYS࢖࣭ࢱ࣮ࢹンࢫ࢖࢙ࣇ࣮ࢱとࣂ࢖ࣛࢻ 

 ANSYS ࣮ࣃ࣮ࢫ要素ࢫࢭࣟࣉ㸦Processing ANSYS Superelements㸧ࣙࢩࢡࢭࡢンࠕࠊࡀANSYS࢖ン࢖࢙ࣇ࣮ࢱ
 ࠋࡍࡲࢀࡉ追加࡟ࠖࢻ࢖࣭࣮࢞ࢨ࣮࣭࣮ࣘࣂ࢖ࣛࢻ࡜ࢫ

NASTRAN࢖࣭ࢱ࣮ࢹンࢫ࢖࢙ࣇ࣮ࢱとࣂ࢖ࣛࢻ 

 MSC.Nastran 2018ࢺ࣮࣏ࢧࡢ 
 NASTRAN࢖࣭ࢫࢡࢵ࣑࡜࣮ࣜࣇン࣮ࣃ࣮ࢫ࣭ࢫ࢖࢙ࣇ࣮ࢱ要素ࠊࡽ࠿既࡟支持ࠊ拘束࢖ࡓࢀࡉン࢖࢙ࣇ࣮ࢱ

࡜࣮ࣜࣇࡢࡽࢀࡇࠊࡣ࣮ࣂࣝࢯFEMtoolsࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍࡁ書ࡳㄞ࡟DMIGࠊ加え࡚࡟要素࣮ࣃ࣮ࢫ࣭ࢫ
ࡵࡓࡢ目的ࡢࡇࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ計算ࢆࢻṇ規࣮ࣔࡓ備えࢆ要素࣮ࣃ࣮ࢫ࣭ࢫ࢖࢙ࣇ࣮ࢱン࢖࡞ࢫࢡࢵ࣑

 ࠋࡓࡋࡲࢀࡉ更新ࡀࣂ࢖ࣛࢻࡢcdsolver.bas࡜nastran.basࠊ࡟
 新ࡋい例題ࠊࡣ࣮ࢲ࢛ࣝࣇ..\examples\dynamic\selem\nastran࡟追加ࠋࡓࡋࡲࢀࡉ 
 PSOLIDࠊࡣࢻ࣮࣭࢝ࢱ࣮ࢹ࣭ࢡࣝࣂIN㸦BUBBLEࠊTWOࠊTHREE㸧࡟保Ꮡࠊࡓࡲࠊࢀࡉ冗長的࡟形成ࡓࢀࡉ

要素ࢆ࣮࢚ࣛࡿࡼ࡟回避ࠊ࡟ࡵࡓࡿࡍISOP㸦REDUCEDࠊFULL㸧ࡀࢢࣛࣇ᥇用ࠋࡓࡋࡲࢀࡉ 
 HVM1ࠊHVM2㸦Hencky-VonMises㸧ࡢCTRIA6࡜CQUAD8ࡢ要素ࠊࡣOP2࢖ࡽ࠿ࣝ࢖࢓ࣇン࣏࣮ࠋࡍࡲࢀࡉࢺ 
 MSC.Nastran࡜NX Nastranࡢ互換性ࠊ࡟ࡵࡓࡢALTER࣓ࢺ࣮ࢸࢫンࠊࡣࢺNASTRANࣂ࢖ࣛࢻ中࡛修ṇࡲࢀࡉ

 ࠋࡍ

SAP2000࢖࣭ࢱ࣮ࢹンࢫ࢖࢙ࣇ࣮ࢱとࣂ࢖ࣛࢻ 

 SAP2000 v19ࢺ࣮࣏ࢧࡢ 
 ࣮ࣔࡀࣉ࣮࢙ࢩࢻSAP2000結果࡛ࣝ࢖࢓ࣇ見࡞ࡽ࠿ࡘい場合ࡀ࣮࢚ࣛࠊ示ࠋࡍࡲࢀࡉ 
 改善ࡓࢀࡉ構造㈈産࢖ン࣏࣮ࡼ࠾ࢺび構造ࡢࡵࡓࡢ資料割ࡾ当࡚ࠋ 
 ࢱ࣮࣓ࣛࣃ：LINK/SUPPORT LINEAR ("linklinear"), K11...K66 B11...B6㸦組ࡳ合わࠊࡏ非組ࡳ合わࡏ㸧࣮࣏ࢧࡢ

 ࢺ
 ࢱ࣮࣓ࣛࣃ：FRAMEMODIFIER処理ࡢ修ṇ 
 SAP2000࢖ン࣮ࣗࣅࣞࡢࢻ࢖࣭࣮࢞ࢨ࣮࣭࣮ࣘࣂ࢖ࣛࢻ࡜ࢫ࢖࢙ࣇ࣮ࢱ 

剛体࣮ࢱࢡࣛࢺࢫࢡ࢚࣭࢕ࢸࣃࣟࣉ㸦RBPE㸧 

 FRFࡢ選択ࠊ非選択ࡀṇࡃࡋ考慮ࠋࡍࡲࢀࡉ 

コ࣐ンࢻ 

新ࡋいコ࣐ンࢻ 

SORT ࣮ࣔࡢࡽࢀࡑࠊࡋࢺ࣮ࢯࢆࢻ共振周波数㡰ࡀ付ࠋࡍࡲࢀࡽࡅ 

修正コ࣐ンࢻ 

DSP FILTER 補語 ZEROPHASE0ࠊࡀ఩相ࣜࢱࣝ࢕ࣇン࡟ࡵࡓࡢࢢ追加ࠋࡓࡋࡲࢀࡉ 

MODIFY PARAMETER 補語 LABELࡀ追加ࠋࡓࡋࡲࢀࡉ 
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FEMtools 4.0.1࣓ンࢼࢸンࢫ࣮࣭ࣜࣜࢫ 

FEMtools 4.0.1.1851㸦2018年 1᭶ 5日㸧 

 ࡀࣝ࢖࢓ࣇ࣭ࢺࢵࢤ࣮ࢱ：ࢺࣉࣜࢡࢫ既࡟Ꮡᅾࡿࡍ場合ࡢ FileCopy関数ࢆ実行࡟前ࣝ࢖࢓ࣇ࣭ࢺࢵࢤ࣮ࢱ࡟
 ࠋࡍࡲࡋ削除ࢆ

FEMtools 4.0.1.1860㸦2018年 2᭶ 23日㸧 

 相関ศ析：RBE2 DOF中࣮ࢱࢫ࣐࡟DOFࢆ備えࡓ EVOࢆ実証ࡢࡵࡓࡿࡍ新ࡋい例題ࢆ追加ࠋࡓࡋࡲࡋ 
 RBPE：࣮ࣟ࢝ࣝᗙ標系ࡢࢺ࣮࣏ࢧࡢ改良 
 ࣓ࣗ࢟ࢻンࡢࣝ࢔ࣗࢽ࣐：ࢺ改訂 

FEMtools 4.0.1.1861㸦2018年 3᭶ 13日㸧 

 MMU：Strainࡼ࠾び総括的࣏ࣞࢫンࡢࢫMMUࢺ࣮࣏ࢧࡿࡼ࡟ 
 ࣐ࢥンࢻ COPY FEM FRFࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲࡢ㸦Database > Copy FEM and Database > Copy Test㸧対応 
 MMU：mmu.basࡢࢺࣉࣜࢡࢫ修ṇ 
 ANSYS࢖ンࢫ࢖࢙ࣇ࣮ࢱ：大࡞ࡁ RST࢖ࡢࣝ࢖࢓ࣇン࣏࣮ࢭ࢖ࣛࢆࢺンࡿࡍࢫ  ࢺ࣮࣏ࢧࡢ࣮ࢱン࢖64࣏

FEMtools 4.0.1.1862㸦2018年 4᭶ 26日㸧 

 ABAQUS࢖ンࣂ࢖ࣛࢻ࡜ࢫ࢖࢙ࣇ࣮ࢱ：古い ABAQUSࣙࢪ࣮ࣂンࡢ࡜互換性ࢆ保証ࡢࡵࡓࡿࡍ修ṇ 
 NASTRAN࢖ンࣂ࢖ࣛࢻ࡜ࢫ࢖࢙ࣇ࣮ࢱ：Strain࣏ࣞࢫンࡢࡵࡓࡿࡍࢺ࣮࣏ࢧࢆࢫ QUAD4要素用࡜࣒ࢺ࣎ࡢ

 ࢺ࣮࣏ࢧࡢ࣮ࣂ࢖࢓ࣇ࣭ࣉࢵࢺ
 ࣐ࢥンࢻ RESPONSE STRAIN：ࢥン࣏࣮ࢿンࢺ成ศࡢ  ࢺ࣮࣏ࢧࡢ値ࡢࡘ6
 ࣮࣎ࣂ࢖࢓ࣇࡢࣉࢵࢺ࡜࣒ࢺStrainࢆ指定ࡿࡍ例題：..\updating\strain 
 ࢕ࢸࢵࢭンࢢ：ABAQUS file.format࡜ matrix.formatࡢ改善 
 FRFࢩン࡚ࡋ࡜ࢺ࢛ࣝࣇࢹࢆࢫ࣮࣭࣋ࣝࢲ࣮ࣔ：ࢫࢩࢭ使用ࠋࡿࡍ 
 ࣓ࣗ࢟ࢻンࡢࣝ࢔ࣗࢽ࣐：ࢺ改訂 

FEMtools 4.0.1.1880㸦2018年 8᭶ 28日㸧 

 ࡀࢺࢡ࢙ࢪࣟࣉ FEMtools最新ࣙࢪ࣮ࣂン࡛生成࢖ࢆࣝ࢖࢓ࣇ࣭ࢺࢡ࢙ࢪࣟࣉࡓࢀࡉン࣏࣮ࡓࡋࢺ場合࣏ࣞ࡟
 ࠋࡍࡲࡋࢺ࣮

 材料特性࡜幾何学特性ࢭ࢔࣭ࢫ࣮࣭࣋ࣝࢲ࣮ࣔࢆンࣜࣈ㸦MBA㸧࡟ࢱ࣮࣓ࣛࣃ使用ࡢࡵࡓࡿࡍ修ṇ 
 ࣮ࣔࢭ࢔࣭ࢫ࣮࣭࣋ࣝࢲンࣜࣈ㸦MBA㸧ࡢ改良 
 DEFINE MBA SUBSTRUCTURE࡜ EXTRACT MBA SUBSTRUCTURESࡢ修ṇ：FEM要素ࡀࣉ࢖ࢱ修ṇ要素ࡢ

場合ࢆࣉ࢖ࢱࣈࢧࡢ格納࡚ࡋᢳ出 
 MPE例題ࠕCalibrationࠖࢆ࣮ࢲ࢛ࣝࣇ damping࣒࣮ࢿ࡚ࣜࡋ࡜ 
 ABAQUS࢖ンࢫ࢖࢙ࣇ࣮ࢱ：剛性࣐ࢡࢵ࢙ࢳࡢࢫࢡࢵࣜࢺ 
 ANSYS࢖ンࢫ࢖࢙ࣇ࣮ࢱ：ᣑ張子 DATࢺ࣮࣏ࢧࡢࣝ࢖࢓ࣇ㸦CDBࡢ追加㸧 
 SAP2000࢖ンࢫ࢖࢙ࣇ࣮ࢱ：SAP BACKUP࣐ࢥンࡢࢻ修ṇ 
 RBPE࢜ࢻ࢔ン࣭࣮ࣔࣝࣗࢪ：࣮ࣟ࢝ࣝᗙ標系ࢺ࣮࣏ࢧࡢ 
 ࣓ࣗ࢟ࢻンࡢࣝ࢔ࣗࢽ࣐：ࢺ改訂 

FEMtools 4.0.1.1885㸦2019年 4᭶ 19日㸧 

 ࢺࢫ࣭ࣜࣝ࢖࢓ࣇ：重複ࢆྡࣝ࢖࢓ࣇ非表示ࡢࢢࣂ修ṇ 
 ࣓ࣙࢩ࣮࣓ࢽ࢔：࣮ࣗࢽ࣓࣭ࢫࢡࢵ࢕ࣇࣛࢢ࣭ࣗࢩࢵンࡢ修ṇࡼ࠾び୚え࢕ࢸࢵࢭࡿンࢢ 
 ANSYS࢖ンࢫ࢖࢙ࣇ࣮ࢱ：大࡞ࡁ入力ࣛ࢖ン長㸦200文Ꮠ180ࠊ前㸧ࢆ CDBࡢࣝ࢖࢓ࣇ新ࡋい㸦19i10㸧

EBLOCKࡢ࡬ࢺࢵ࣐࣮࢛ࣇ変換ࢺ࣮࣏ࢧࡢ㸦ansys.dll㸧 
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 NASTRAN࢖ンࢫ࢖࢙ࣇ࣮ࢱ：ply定義ࢱ࣮ࢹ㸦PCOMP㸧࢖ࡢン࣏࣮ࢺ࣮࣏ࢧࡢࢺ㸦nastran.dll㸧 
 NASTRAN࢖ンࢺࢵࢭࣇ࢜：ࢫ࢖࢙ࣇ࣮ࢱ慣性ࢆ࢕ࢸࣃࣟࣉ持ࡘ集中質量㸦CONM2㸧ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆ

CONM2࢖ࡣン࡚ࡗࡼ࡟ࢫ࢖࢙ࣇ࣮ࢱ CONM1࡚ࡋ࡜変換ࡢࡑࠊࡀࡍࡲࢀࡉࢺ࣮࣏ࢫࢡ࢚ࢀࡉ CONMࢻ࣮ࣀ
ࢱ࣮ࢹ慣性ࠊࢀࡉ使用࡟計算ࡀ軸࣮ࣝ࢝ࣟࡢ原点ࡢ෇筒ᗙ標系ࢆࢁࡇ࡜ࡁ࡭ࡿࢀࡉ使用ࡀ計算ࡢ軸࣮ࣝ࢝ࣟ࡟

 ࠋࡓࡋ୙ṇ確࡛ࡣ変換ࡢ
 ࣐ࡢࣝ࣋ࣛ：ࢺ࣮࣏ࢫࢡ࢚ࡢࢫࢡࢵࣜࢺ修ṇ㸦row ࡜ columnࡀࣝ࣋ࣛࡢษࡾ替え㸧㸦EXPORT MATRIX 

FORMAT MATRIX; File > Export > FEMtools Matrices㸧 
 ࣮ࣔࢻ解析：࣐࣮ࢱࢫDOFࡢ縮ᑠࡀ選択࡚ࢀࡉいࡿ場合ࠊ要素࣐ࢫࢡࢵࣜࢺ Kࡼ࠾び㸦ࡣࡓࡲ㸧Mࢱ࣮ࢹࡀ

 ࠋࡍࡲࢀࡉ計算࡚ࡋ使用ࢆࢢン࢕ࢸࢵࢭ࣭ࢺ࢛ࣝࣇࢹࠊい場合࡞ࡋᏑᅾ࡟ࢫ࣮࣋
 DFRFࡢ代わ࡟ࡾ DIRECTFRF࣐ࢥンࢆࢻ使用ࡓࡋ dynamic\frf\pade\pade_sms_beam.cmd例題ࡢ修ṇ：࣐ࢥンࢻ

DFRFࡣᪧ式࡛ࠋࡍ 
 例題：ࣝ࢖࢓ࣇ updating\jimbeam\2D_SI\jimbeam.pdfࡢ修ṇ 
 例題：..\updating\text_parametersࡢࣂ࢖ࣛࢻ࣭࣮ࣂࣝࢯ࣭࣒ࢱࢫ࢝ࡢ修ṇࠊࡋࡔࡓࠊ相関性結果ࡣ更新ࡲࢀࡉ

  ࠋࢇࡏ
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FEMtools 4.1 更新情報  

FEMtools 4.1ࠊࡣFEMtools࣒࣮ࣞࣇワ࣮ࡼ࠾ࢡびࢺࢫࢸࣜࣉ解析ࢆࢻ࣮ࣞࢢࣉࢵ࢔ࡢ࣮ࣝࢶ含ࡴ新ࣙࢪ࣮ࣂン࡛
 ࠋࡍ

FEࢺࢫࢸ相関ศ析ࠊ感ᗘ解析࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔࠊンࠊࡣࢢStrain㸦歪ࡳ㸧࣏ࣞࢫンࡲࠋࡍࡲࡋࢺ࣮࣏ࢧࢆࢫ
最新ࠊࡀࣂ࢖ࣛࢻ࡜ࢫ࢖࢙ࣇ࣮ࢱン࢖࣭ࢱ࣮ࢹFEࠊࡓ FE࡟ࡵࡓࡢࢺ࣮࣏ࢧࡢ࣒ࣛࢢࣟࣉ更新ࠋࡍࡲࢀࡉ 

 ࠋࡍࡲࡋ要約࡟以ୗࢆࢺ࢖ࣛ࢖ࣁࡢࢫ࣮ࣜࣜࡢࡇ

 ンと構成ࣙࢩ࣮ࣞࢺࢫン࢖

新ࡋい Sentinel HL Pro Driverlessࡀࢺ࣮࣏ࢧࡢ追加ࢻࡢࡇࠋࡓࡋࡲࢀࡉンࠊࡣࣝࢢWindowsࡼ࠾び Linux OSୖࣀࡢ
 ࠋࡍࡲࢀࡉ使用࡟共࡜ࢫンࢭ࢖࣭ࣛࢡࢵࣟࢻ࣮

 㸦Framework㸧ࢡワ࣮࣒࣮ࣞࣇ

 一次要素ࡽ࠿஧次要素ࡢ࡬変換機能ࡢ追加 
 ࢖ࣛࢫ࣮ࣞࢺࡢࣝࢹ࣭ࣔࢺࢫࢸン㸦tracelines㸧ࡢࡽ࠿表面要素ࡢ自動生成 
 ࢺ࣮ࢹࣉࢵ࢔ࡢࣉ࣮࢙ࢩࢻ࣮࣭ࣔࢺࢫࢸ 
 ࢖ンࢺ࣮ࢹࣉࢵ࢔ࡢࢱ࢕ࢹ࢚࣭࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮࣭ࣔࣈ࢕ࢸࢡࣛࢱ 
 Strain࡜ Stressࢸࡢンࡢࣝࢯෆ部計算࡟伴う FEMtools࢖࣭ࢱ࣮ࢹࡓࡲࠊࢺ࣮࣏ࢧࡢࢫ࣮࣋ࢱ࣮ࢹン࢖࢙ࣇ࣮ࢱ

 ࢺ࣮࣏ࢧࡢ機能ࢺン࣏࣮࢖ࡢࢫ
 ࡢ࡛ୖࣝࣈ࣮ࢸ Strain࡜ Stressࢸࡢンࢺ࣮࣏ࢧࡢࣝࢯ 
 長いࣜࢺࢫ㸦例えࠊࡤ要素ࣜࢺࢫ㸧ࢆ選択ྍࡀ࡜ࡇࡿࡍ能ࢥ࡞ン࣎࣎ࡀࢫࢡࢵ使用ࡢࡑࠊࢀࡉ操作ࡿࡅ࠾࡟迅

速性ࡀ計ࠋࡍࡲࢀࡽ 
 新ࡋいࢻ࣮࣎ࣉࢵࣜࢡࡀ࣮ࣝࢶ࣭࣮ࣕࢳࣉ࣭ࣕ࢟ࢫࢡࢵ࢕ࣇࣛࢢあࡿいࡿࡍ࣮ࣆࢥ࡬ࣝ࢖࢓ࣇࡣ前࢕ࣇࣛࢢ࡟

 ࠋࡍࡲࢀࡉ追加࡟ࡵࡓࡿࡍࢆ変更ࢬ࢖ࢧや࣮ࣕࢳࣉࣕ࢟ࡢ࢘ࢻン࢕࣭࢘ࢡࢵ
 回転㸦ࢡࢵ࣑ࢼ࢖ࢲ㸧中心ࢆ設定ࡢࡵࡓࡿࡍ新ࡋい࣎ࢱン࡟࣮ࣂ࣮ࣝࢶ࣭ࢫࢡࢵ࢕ࣇࣛࢢࡀ追加ࠋࡓࡋࡲࢀࡉ 
 新ࡋいࣙࢩ࣮࣓ࢽ࢔ン࣭ࢥンࣉࢵࢸࢫࠊࣉࢵࢺࢫ／ࢺ࣮ࢱࢫࡀࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ࣭࣮ࣝࣟࢺ前進／後㏥ࡓࡢ

ࡲࡾ࡞࡟能ྍࡶ࡜ࡇࡿࡍ࣮ࣝࣟࢺンࢥࢆ࣮ࣝࢣࢫび振幅ࡼ࠾ン速ᗘࣙࢩ࣮࣓ࢽ࢔ࠊࡓࡲࠋࡓࡋࡲࢀࡉ追加࡟ࡵ

 ࠋࡓࡋ
 ࣮࢝ࡢࢻ࣮࣮࣎࢟ࡣ࣮࢝ࢵࣛࢺࣈ矢印࣎ࢱンࢆ使用ࠊࡋ移動ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 
 ࣙࢩ࣮࣓ࢽ࢔࣭ࣉ࣮࢙ࢩンࡀ࣮ࣛ࢝ࡢ変形振幅࡟応࡚ࡌ設定ྍ能ࠋࡓࡋࡲࡾ࡞࡟ 
 ࢥン࡟ࢺࢵࣟࣉ࣭࣮ࢱ使用ࡿࢀࡉ間隔数ࡼ࠾び凡例࣮࢝ࣛࢆ指定ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 
 10࡛ࡲ㸦毎秒㸧ࣉࢵ࢔ࢻ࣮ࣆࢫࡢ係数ࢆ指定ࡼࡿࡍうࡢࢻ࣮ࢥ࡞最適化࡟対応ࢼ࢖ࢲࡾࡼ࡟ࢀࡇࠋࡓࡋࡲࡋ

 ࠋࡍࡲࡋ回避ࢆపୗࡢ表示機能ࢡࢵ࣑
 ࡣ࢔࣮ࣗࣅ࣭ࢫࢡࢵ࢕ࣇࣛࢢ Strain࡜ Stressࢸࡢンࣝࢯ表示ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆ 
 QUAD8要素公式ࡢ改善ࡾࡼ࡟安定性࡜高速化ࡀ計ࠋࡓࡋࡲࢀࡽ 
 FEMtoolsࡣ࣮ࣂࣝࢯ ILP64㸦8ࢺ࢖ࣂ㸧整数࢖ンࢫࢡࢵࢹ付ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆࡅILP64ᣑ張࣏࢖ン࢖࣭࣮ࢱ

ンࢫࢡࢵࢹ付ࡾࡼ࡚ࡗࡼ࡟ࡅ大࡟ࢺࢵࢭࢱ࣮ࢹ࡞ࡁ対応ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 
 静解析ࣝࢲ࣮ࣔࠊ Stressࡼ࠾び Strainࡢ計算ࡀᣑ張2ࠊࢀࡉD࡜ 3Dࡢ要素ࠋࡍࡲࢀࡉࢺ࣮࣏ࢧࡀStrainࡣ節点

ࡢ࡚࡭ࡍࠊࢀࡉ計算࡚ࡋ࡜値ࡢび要素中心ࡼ࠾ Strainࢸンࢥ࣭ࣝࢯン࣏࣮ࢿンࡀࢺ計算ࠊࢀࡉ所定ࡢᗙ標系࡬
ࡣ変更ࡢࡽࢀࡇࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡏࡉ回転ࢆࣝࢯンࢸ Strain࣮࣋ࡢࢫ FEࢺࢫࢸ相関性ྍࢆ能࡟ࡵࡓࡿࡍ࡟
必要࡞条件ࠋࡍࡲࡾ࡞࡟ 

 Strain࣏ࣞࢫンࡢࢫ選択ࢥࠊࡣ࡟ン࣏࣮ࢿンࢺ㸦ṇ規方向㸧࡜ Faceࡢ選択ࡀ必要ࡢࡑࠋࡍࡲࡾ࡞࡟ᗙ標系ࡢ指
定࡛ࡣ自動࣮ࣔࢆࢻ使用ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 

 ࢺࣉࣜࢡࢫ開Ⓨࡢ25ࠊ࡟ࡵࡓࡿࡍࢺ࣮࣏ࢧࢆ新ࡋい FEMtools API関数ࡀ追加ࡢࡽࢀࡑࠋࡍࡲࢀࡉうࡢࡕ ࡣ15
࡜㸦Stressࣝࢯンࢸ Strain㸧࡟ࡵࡓࡢ使用ࠋࡍࡲࢀࡉ 

 ࢫ࢖࢙ࣇ࣮ࢱン࢖࣭ࢱ࣮ࢹ

 Abaqus 2019ࢺ࣮࣏ࢧࡢ 
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 Ansys 19.4㸦2019R2㸧ࢺ࣮࣏ࢧࡢ 
 MSC.Nastran 2019ࢺ࣮࣏ࢧࡢ 
 静的変఩ࠊStrain解析࡟ࢺ࣮࣏ࢧࡢ伴いࠊAbaqusࠊAnsysࠊNastran࢖ンࡀࣂ࢖ࣛࢻ࡜ࢫ࢖࢙ࣇ࣮ࢱᣑ張ࡲࢀࡉ

 ࠋࡓࡋ
 Nastran࢖ンྠ࡜ࢫ࢖࢙ࣇ࣮ࢱ様ࠊ࡟AbaqusࠊAnsys࢖ンࢼ࣭ࢻ࣮ࣔࡀࢫ࢖࢙ࣇ࣮ࢱン࡜࣮ࣂ周波数ࣞン࡟ࢪ基

࡙い࢖ࡢࣉ࣮࢙ࢩࢻ࣮ࣔࡓン࣏࣮ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆࢺ 
 SAP2000 v20ࢺ࣮࣏ࢧࡢ 

動解析㸦Dynamic Analysis㸧 

 ࣮ࣔࢭ࢔࣭ࢫ࣮࣭࣋ࣝࢲンࣜࣈ㸦MBA㸧ࡢ改良 

 解析ࢺࢫࢸࣜࣉ

 ࢖ࣛࢫ࣮ࣞࢺン自動生成ࡣ࣮ࣝࢶ新ࡋい࡚ࡗࡼ࡟࣒ࢬࣜࢦࣝ࢔ᣑ張ࡢࡑࠋࡓࡋࡲࢀࡉ結果ࡣ改善ࡾࡼࠊࢀࡉ多

ࢩࢵ࣓࡞密ࠊࡋ増ࡀ処理速ᗘ࡟ࡵࡓࡿࡍ対応࡟ࢺン࢖࣏ࡢࡃ多࡟特ࠋࡓࡋࡲࡾ࡞࡟能ྍࡀ࣮ࣝࣟࢺンࢥࡢࡃ

࣮ࢹ定義ࢫ࢖࢙ࣇ࣮ࢧࡿࡼ࡟ン装置ࣕ࢟ࢫ࣮ࢨ࣮ࣞࠊࡤ例えࠋࡍࡲࡁ使用࡛ࡶ࡟処理ࡢࢱ࣮ࢹ࣭ࢻࢵࣜࢢࠊࣗ

 ࠋࡍࡲࢀࡉ使用ࡶ࡟ࢱ
 FE࣮ࣔࡢࣉ࣮࢙ࢩࢻ計算࢖ࡣࡓࡲン࣏࣮ࠊࡃ࡞࡜ࡇࡿࡍࢺFEࣔࢭ࣭ࣝ࢔ࣗࢽ࣐ࡢୖࣝࢹンࢆ࣮ࢧ選択ࡇࡿࡍ

 ࠋࡍࡲࡁ࡛ࡀ࡜
 FEࣔࡼ࠾ࣝࢹび࣮ࣔ࢖ࢆࣝࢹ࣭ࣔࢺࢫࢸࠊࡶ࡚ࡃ࡞࡟ࢫ࣮࣋ࢱ࣮ࢹࡀࣉ࣮࢙ࢩࢻン࣏࣮ࠊࡋࢺRotateࢭンࢧ

 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ使用ࢆࣝࢿࣃ࣭࣮
 既Ꮡࢆࣝࢹ࣭ࣔࢺࢫࢸࡢ使用ࠊࡋFEࣔࢆࢀࡑ࡟ࣝࢹ写像࢔࣌ࡢ࡚ࡋ࡜ࣝࢹ࣭ࣔࢺࢫࢸࣜࣉࠊࡋ DOFࢆ使用ࡋ

ン࢖ࣛࢫ࣮ࣞࢺ࡟任意ࠋࡍࡲࡁ࡛ࡀ編集ࡢ࡝࡞移動ࠊ削除ࡢ࣮ࢧンࢭࠊ追加ࡣࣝࢹ࣭ࣔࢺࢫࢸࣜࣉࡢࡑࠋࡍࡲ

 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ追加ࢆ
 自動ࢭン࣮ࢧ選択方法㸦ṇ規表面఩置ࠊ統計計算ࠊ最大MAC表記ࠊ固定ࢭン࣮ࢧ఩置ࡢ使用方法࡝࡞㸧ࡀ修

ṇࠋࡓࡋࡲࢀࡉ 

相関分析 

 静的変఩ࡼ࠾び Strain࣮࣋ࡢࢫ相関ศ析࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔ࡜ンࡢࢢ新ࡋい例題ࡀ追加ࠋࡓࡋࡲࢀࡉ 

感ᗘ解析とࣔ࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹンࢢ 

 Strain࣏ࣞࢫンࡀࢺ࣮࣏ࢧࡢࢫ追加ࠋࡓࡋࡲࢀࡉ 
 いࢫࢭࣟࣉࢺࢫ࣏ࡀࢺࣉࣜࢡࢫ࣭࢕ࢸ࢕ࣜ࢕ࢸ࣮ࣘࡢ࠿ࡘࡃ感ᗘ解析用࡟追加ࠋࡓࡋࡲࢀࡉ例えࡣࡽࢀࡑࠊࡤ

感ᗘࣞ࣋ࣝ࡟基࡙い࣏ࢫࣞࡓンࢆࢱ࣮࣓ࣛࣃ࡜ࢫ削除ࠊࡋあࡿいࡣ感ᗘ࡟基࡙いࡓ要ࢆࢺࢵࢭࡢ作成ࠋࡍࡲࡋ 
 静的変఩࣮࣋࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔࡢࢫン࡟ࢢ伴いࠊFEMtoolsࠊAnsysࠊAbaqusࠊNastranࢺ࣮࣏ࢧ࡛࣮ࣂࣝࢯ

 ࠋࡓࡋࡲࢀࡉ
 静的 Strain࣮࣋࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔࡢࢫンࠊࡀࢢFEMtoolsࠊAnsysࠊAbaqusࠊNastranࡉࢺ࣮࣏ࢧ࡛࣮ࣂࣝࢯ

   ࠋࡓࡋࡲࢀ
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 変更ࡢࢫンࢭ࢖ンとࣛࣙࢩ࣮ࣞࢺࢫン࢖

 ࠋࢇࡏࡲࡾあࡣ変更࡟特࡚ࡋ関࡟必要条件࣒ࢸࢫࢩࡢ最ᑠࠊࡁ⥆手࣮ࣝࢺࢫン࢖

 ࠋいࡉࡔࡃ࡚ࡋ参照ࢆ構成ࠖ࡜ࢫンࢭ࢖ࣛࠊンࣙࢩ࣮ࣞࢺࢫン࢖ࠕࠊࡣい࡚ࡘ࡟ヲ細ࡾࡼ

FEMtools 3.xࠕࠊࡣࢻ࣮ࣞࢢࣉࢵ࢔ࡢࡽ࠿FEMtools 3.xࢆࠖࢻ࣮ࣞࢢࣉࢵ࢔ࡢ参照ࡉࡔࡃ࡚ࡋいࠋ 

FEMtools 4.0.xࠕࠊࡣࢻ࣮ࣞࢢࣉࢵ࢔ࡢࡽ࠿FEMtools 4ࢆࠖࢺ࣮ࢹࣉࢵ࢔ࡢ参照ࡉࡔࡃ࡚ࡋいࠋ 

 㸦License Configurator㸧࣮ࢱ࣮ࣞࢢ࢕ࣇコン࣭ࢫンࢭ࢖ࣛ

FEMtools License Configuratorࡀࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ修ṇࠋࡓࡋࡲࢀࡉ 

 License Settings࣎ࢱンୖࡀ部࡟移動ࠋࡓࡋࡲࢀࡉ 
 ࢺࢵࢿワ࣮ࢭ࢖࣭ࣛࢡン࢔࢖ࣛࢡ࣭ࢫンࣙࢩࢡ࢔࣭ࢺン࢔࢖ࣛࢡ࣭ࢡࢵࣟࢻ࣮ࣀࠊンࣙࢩࢡ࢔࣭ࢺンࡼ࠾びࢿ

 ࠋࡓࡋࡲࢀࡉ化ࣉ࣮ࣝࢢ࡟ンࣙࢩࢡ࢔࣭࣮ࣂ࣮ࢧࢫンࢭ࢖࣭ࣛࢡワ࣮ࢺࢵ

 

FEMtools License Configuratorࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ 

 FEMtools最新版࡟࣮ࣂ࣮ࢧ接⥆ࡿࡍ場合࢝ࢭ60000࣑ࣜࠊンࢻ㸦60 secs㸧ࢺ࢘࢔࣒࢖ࢱ࣭ࢺ࢛ࣝࣇࢹࡢ値ࡀ使
用ࢡࢵ࢙ࢳࡢࡇࠋࡍࡲࢀࡉ間隔᪥数ࠊࡶCheck for Updates Settings࡛ࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ形成ࡁ࡛ࡀ࡜ࡇࡿࡍ
 ࠋࡍࡲ
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Check for Updates Settingsࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ 

 追加情報㸦環境変数ࡢ設定方法࡝࡞㸧ࡘ࡟い࡚ࠊࡣFEMtools Getting Started㸦入門㸧࣐࡟ࣝ࢔ࣗࢽ記述ࡲࢀࡉ
参ࢆ章ࡢ使用方法㸦Using the FEMtools Dongle㸧ࡢࣝࢢンࢻࠊ管理㸦License Management㸧ࢫンࢭ࢖ࣛࡢࡑࠋࡍ
照ࡉࡔࡃ࡚ࡋいࠋ 

 ࣝࢢンࢻ

 新ࡋい Sentinel HL Pro Driverless構成ࡀࢺ࣮࣏ࢧࡢ追加ࢻࡢࡇࠋࡓࡋࡲࢀࡉンࡣࣝࢢWindowsࡼ࠾び Linux OS
 ࠋࡍࡲࢀࡉ使用࡟共࡜ࢫンࢭ࢖࣭ࣛࢡࢵࣟࢻ࣮ࣀࡢୖ

 追加情報㸦USBࢻンࣝࢢ用࢖ࢆࣂ࢖ࣛࢻン࣮ࣝࢺࢫ方法࡝࡞㸧ࡘ࡟い࡚ࠊࡣFEMtools Getting Started㸦入門㸧
 使用方法㸦Using theࡢࣝࢢンࢻࠊ管理㸦License Management㸧ࢫンࢭ࢖ࣛࡢࡑࠋࡍࡲࢀࡉ記述࡟ࣝ࢔ࣗࢽ࣐
FEMtools Dongle㸧ࡢ章ࢆ参照ࡉࡔࡃ࡚ࡋいࠋ 

 変更ࢺキ࣓ࣗンࢻ

ࡢ࡚࡭ࡍ FEMtools 4࣓ࣗ࢟ࢻンࡢࡇࡣࢺ  ࠋࡍࡲࢀࡉ伴い更新࡟ࢫ࣮ࣜࣜࡢ4.1

例題ࡢ変更 

 新ࡋい࣓ࣗࢩࢵ例題..\examples\mesh\generation\diskࡀ追加ࠋࡓࡋࡲࢀࡉ 
 DFRFࡢ代わ࡟ࡾ DIRECTFRF࣐ࢥンࢆࢻ使用ࡿࡍ..\examples\dynamic\frf\pade\pade_sms_beam.cmdࡀ修ṇࢀࡉ

ࢻン࣐ࢥࠋࡓࡋࡲ DFRFࡣᪧ式࡛ࠋࡍ 
 例題࣮ࢲ࢛ࣝࣇ..\examples\updating\doe_beamࡣ\doe_beamࠋࡓࡋࡲࢀࡉ࣒࣮ࢿࣜ࡟新ࡋい DOE例

題..\examples\updating\doe\doe_plate.cmdࡀ ortho2d࢕ࢸ࣮ࢹࣉࢵ࢔ࡢ࢕ࢸࣃࣟࣉンࢆࢢ示࡟ࡵࡓࡍ追加ࡋࡲࢀࡉ
 ࠋࡓ

 ..\examples\updating\text_parametersࡀࣂ࢖ࣛࢻ࣭࣮ࣂࣝࢯ࣭࣒ࢱࢫ࢝ࡢ修ṇࡢࡑࠋࡓࡋࡲࢀࡉ相関ศ析結果ࡣ
更新ࡣࢀࡇࠋࢇࡏࡲࢀࡉMACࡀ各཯復࡛更新ࠊࡵࡓࡓࡗ࠿࡞ࢀࡉ཰束࡟影響ࠋࡓࡋࡲࡋ 

 ࣔ࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹンࡢࢢ新ࡋい例題..\examples\updating\cweldࡀ追加ࡢࡇࠋࡓࡋࡲࢀࡉ例題ࠊࡣNASTRAN 
CWELDࢆࢺ࣮ࢹࣉࢵ࢔ࡢࢱ࣮࣓ࣛࣃ実証ࠋࡍࡲࡋ選択ࡣࢱ࣮࣓ࣛࣃ弾性係数㸦FEMtoolsࣛ࣋ࣝ E㸧࡜直ᚄ
㸦FEMtoolsࣛ࣋ࣝ OD㸧࡛ࠋࡍCWELD要素ࠊࡣPARTPATࠊELPATࠊELEMIDࠊGRIDIDࠊALIGNࢆࣝ࢖ࢱࢫ
 ࠋࡓࡋࡲࢀࡉࢺ࣮࣏ࢧࡶ࡟ࢫ࢖࢙ࣇ࣮ࢱン࢖NASTRANࠊࡋࢺ࣮࣏ࢧ

 新ࡋい例題࣐ࢥンࢺࣉࣜࢡࢫ࣭ࢻ run05_angle.cmd࣮ࣖ࢖࡚ࣞࡋ࡜ࢱ࣮࣓ࣛࣃ࣭ࢺ࣮ࢹࣉࢵ࢔ࡀ㸦ᒙ㸧角ᗘࢆ
使用ࡿࡍ例題..\examples\updating\cylinder࡚ࡋ࡜追加ࠋࡓࡋࡲࢀࡉ 

 静的変఩࣮࣋࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔࡢࢫンࢢ例題..\examples\updating\strain
 ࠋࡓࡋࡲࢀࡉ࣒࣮ࢿࣜ࡟examples\updating\static_strain_1\..ࠊࡀ

 静的変఩࣮࣋ࡼ࠾ࢫび Strain࣮࣋࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔࡢࢫンࡢࢢ FEMtoolsࠊAnsysࠊAbaqusࠊNastranࣂࣝࢯ
ࡉ追加ࡀい例題..\examples\updating\static_strain_2\static_strain_2ࡋ新ࡓ備えࢆࢺࣉࣜࢡࢫ࣭ࢻン࣐ࢥࡢࡵࡓࡢ࣮
 ࠋࡓࡋࡲࢀ
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 静的 Strain࣮࣋࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔࡢࢫンࡢࢢ FEMtoolsࠊAnsysࠊAbaqusࠊNastran࣐ࢥࡢࡵࡓࡢ࣮ࣂࣝࢯン
 ࠋࡓࡋࡲࢀࡉ追加ࡀい例題..\examples\updating\static_strain_3ࡋ新ࡓ備えࢆࢺࣉࣜࢡࢫ࣭ࢻ

 Ansys࡜ Abaqusࢆ࣮ࣂࣝࢯࡢ使用࣐ࢥࡿࡍンࠊࡀࢺࣉࣜࢡࢫ࣭ࢻ..\examples\updating\static_1 
 ࠋࡓࡋࡲࢀࡉ追加࡟examples\updating\static_2\..࡜

FEMtools Framework 

 ࠋࡍࡲࡋい࡚概ㄝࡘ࡟変更点ࡢࢡワ࣮࣒࣮ࣞࣇFEMtoolsࠊンࣙࢩࢡࢭࡢࡇ

 管理ࢫ࣮࣋ࢱ࣮ࢹ

 拡張ࡢࣉ࣮࢙ࢩࢻ࣮࣭ࣔࢺࢫࢸ

ࡣいࡿあࢻン࣐ࢥᣑ張㸦EXPANDࡢࢱ࣮ࢹ࣭ࢺࢫࢸ Database > Truncate/Expand > Expand Test Data㸧ࡀ修ṇࠊࢀࡉ以
ୗࡢ特徴ࢆ含ࠋࡍࡲࢀࡲ 

 DOF࣐࣌ࢥࡀ࢔ン࡚ࡗࡼ࡟ࢻ追加ࡿࢀࡉ場合ࠊ警告࣓ࢆࢪ࣮ࢭࢵ示ࠋࡍࡲࡋ 
 SEREPࡢ࢔࣌ࡀ DOF数࡜共࡟ FE࣮ࣔࢻ数ࡾࡼపい場合ࠊ警告࣓ࢆࢪ࣮ࢭࢵ示ࠋࡍࡲࡋ 
 SEREP࠾࡟い࡚使用࣮ࣔࢆࢻ選択ྍࡿࡍ能性ࡀ追加ࠋࡓࡋࡲࢀࡉ 
 ࡣࡓࡲ0ࠊࡣࢀࡑ一定ࡢ中央周波数ࢡࢵ࣑ࢼ࢖ࢲࡿࡼ࡟ᣑ張操作ࢆ行うࡢ0ࠋࡍࡲࡁ࡛ࡀ࡜ࡇ中央周波数ࢆ使

用ࠊࡣ࡜ࡇࡿࡍGuyan࣮࣋ࡢࢫ縮ᑠ法࡜等価࡛ࠋࡍ 
 ࡀࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ新ࡋい࢜ࣙࢩࣉンࢆ含࡟ࡵࡓࡿࡵ修ṇࠋࡓࡋࡲࢀࡉ 

ARTeMIS࢖ンࢫ࢖࢙ࣇ࣮ࢱ 

 6ࡼ࠾び い࡞ࡢ7࣒࢝ࣛ CFGࣕࢳࡽ࠿ンࣝࢿ定義ࢆㄞࡴ ARTeMIS READCFG࣐ࢥンࡢࢻ修ṇ 
 ࣉ࢖ࢱ࣭ࣝ࢖࢓ࣇ ARTeMIS構成ࣝ࢖࢓ࣇ㸦*.cfg㸧࢖ࡢࣝࢹ࣭ࣔࢺࢫࢸࡀン࣏࣮ࡼ࠾ࢺび࢚࢖ࡢࢺ࣮࣏ࢫࢡン

 ࠋࡍࡲࢀࡉ中࡛示ࢺࢫ࣭ࣜࢫ࢖࢙ࣇ࣮ࢱ
 ..\scripts\interfacesࡢ新ࡋいࠕ࣮ࢲ࢛ࣝࣇࣈࢧartemisࠖࣝ࢖࢓ࣇ࣭ࣝ࢖࢓ࣇ࡟ impcfg.bas࡜ expcfg.basࡀ追加ࡉ

ࡲࢀࡉ使用࡟File > Import Test Model and Shapesࠊࢀࡉ選択ࡀࣝ࢖࢓ࣇARTeMIS構成ࠊࡣࡽࢀࡇࠋࡓࡋࡲࢀ
 ࠋࡍ

 参照ࡀ CFG࡚ࡗࡼ࡟ࣝ࢖࢓ࣇ参照付ࡿࢀࡽࡅ場合ࠊARTeMIS CFG࢖ࢆࣝࢹ࣭ࣔࢺࢫࢸࡽ࠿ン࣏࣮ࡁ࡜ࡿࡍࢺ
 ࠋうࡻࡋ࡛ࡿࡍࢺン࣏࣮࢖ࡶ時้歴࡟

要素ᗙ標系㸦ECS㸧 

 ECSࡣ Stress࡜ Strain࡟ࢻ࣮ࣝ࢕ࣇࡢ関連付ࡢࢀࡒࢀࡑࠋࡍࡲࢀࡽࡅ数値ࢸࡣン࡚ࡋ࡜ࢱ࣮ࢹ࣭ࣝࢯ格納ࡉ
ࡽ࠿ࢫ࣮ࢯࡌྠࠊࢀ Stress࡜ Strainࡀ推定ࠋࡍࡲࢀࡉ 

 ECSࡢ表示࢚ࣜ࢜ࡣンࣙࢩ࣮ࢸンࢆ決定付ࡿࡅ第 ࡢ1 Stress／Strainࢆࢻ࣮ࣝ࢕ࣇ使用ࡢࡑࠋࡍࡲࡋ Customize 
Meshࡣࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ要素ᗙ標系㸦ECS㸧ࢆ表示࢕ࢸࢵࢭࡢࡵࡓࡿࡍンࢆࢢ含࡛ࢇいࠋࡍࡲ 

 ECSࠊࡣNASTRAN/ANSYS/ABAQUSࡽ࠿ Stress／Strainㄞ࢖࡟ࡁ࡜ࡴン࣏࣮ࠊ࠿ࡿࢀࡉࢺあࡿいࡣ FEMtools
ࡢ Strain／Stressࡢ計算࡟応࡚ࡌ定義ࠋࡍࡲࢀࡉ 

 Strain／Stressࡣ要素質量中心ࡓࡲ各要素ࡢ節点࡟関࡚ࡋ格納ࠋࡍࡲࢀࡉ節点ࢆ共᭷ࡿࡍ要素ࡣ節点用࡜異ࡿ࡞
ECSࢆ持ࠋࢇࡏࡲࢀࡋࡶ࠿ࡘ 

 ECSࡼ࠾࢙ࣝࢩࡣびࡢࢻࢵࣜࢯ要素࡟ࣉ࢖ࢱ利用ࡣࡽࢀࡑࠋࡍࡲࢀࡉ自動的ࣝࣂ࣮ࣟࢢ࡟ᗙ標系ࡏࡲࡾ࡞ࡣ࡟
 ࠋࢇ

 ࢺࣉࣜࢡࢫ..\scripts\tools\project_strain.bas࣮ࣝ࢝ࣟࡀ要素ᗙ標系ࡢ Strainࢸンࢆࣝࢯ生成࡟ࡵࡓࡿࡍ追加ࡲࢀࡉ
 ࠋࡍࡲࡋ類似ࡢࡶࡿࢀࡉ使用࡛ࢺ࢛ࣝࣇࢹࡢABAQUSࠊࡣࢀࡇࠋࡍ

 ࣮ࣝ࢝ࣟࡢࢺ࢛ࣝࣇࢹ 1方向ࣝࣂ࣮ࣟࢢࡢୖࢫ࢖࢙ࣇ࣮ࢧࡣ x軸ࡢ方向࡛ࣝࣂ࣮ࣟࢢࠋࡍ x軸ࢫ࢖࢙ࣇ࣮ࢧࡀ
ࡢࡑࡣࡓࡲ垂直࡟ 0.1ᗘ以ෆ࡛あࡿ場合࣮ࣝ࢝ࣟࠊ ࣝࣂ࣮ࣟࢢࡢୖࢫ࢖࢙ࣇ࣮ࢧࡣ方向ࡢ1 z軸ࡢ方向࡛ࠋࡍ
場合࣮ࣟ࢝ࣝࡢࡑ ࣮ࣝ࢝ࣟࡣ方向ࡢ2 ࣮ࣝ࢝ࣟࠊ結果ࡢࡑࠋࡍࡲࡾ࡞࡟直角࡜方向ࡢ1 ࣮ࣝ࢝ࣟ࡜1 方向ࡢ2
要࡚ࡗࡼ࡟右手回転࣮ࣝࣝࡢࡾ節点周ࡢ要素ࡣṇ方向ࡢࡑࠋࡍࡲࡾྲྀ࡟ṇࢆࢫ࢖࢙ࣇ࣮ࢧࡿࢀࡉ右手系࡛表ࡣ

素࡟定義ࠋࡍࡲࢀࡉ 
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 変更ࡢ他ࡢそࡢ管理ࢫ࣮࣋ࢱ࣮ࢹ

 静的0.0ࠕࠊࡣࣝ࣋ࣛࡢࣉ࣮࢙ࢩHzࠖࢆ示ࠋࢇࡏࡲࡋ 
 FEMtoolsࡣࢫ࣮࣋ࢱ࣮ࢹ Strain࡜ Stressࢸࡢンࡢࣝࢯෆ部計算࢖࣭ࢱ࣮ࢹࠊࡓࡲࠊࡋࢺ࣮࣏ࢧࢆン࢖࢙ࣇ࣮ࢱ

 ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆࢺン࣏࣮࢖ࡢࡽࢀࡑࡿࡼ࡟使用ࡢࢫ
 ࣮ࣟ࢝ࣝ z軸ࢆ備え࣮ࣝ࢝ࣟࡓᗙ標系ࢆ定義ࣔࢹࡢࡵࡓࡿࡍンࣙࢩ࣮ࣞࢺࢫン࣭ࢺࣉࣜࢡࢫ defcsnts.bas

 ࠋࡓࡋࡲࢀࡉ追加࡟scripts\demo\..ࡀ
 0ࣝࢲ࣮ࣔࡢ変఩ࢆ備え࢖࣏࣭ࢺࢫࢸࡓンࢆࢺ削除ࣔࢹࡢࡵࡓࡿࡍンࣙࢩ࣮ࣞࢺࢫン࣭ࢺࣉࣜࢡࢫ

compress_test.basࡀ....\scripts\demo࡟追加ࠋࡓࡋࡲࢀࡉ 
 ࡽ࠿ࢻ࣮࣭ࣔࢺࢫࢸ K࡜Mࡢ計算ࢆ実証ࣔࢹࡢࡵࡓࡿࡍンࣙࢩ࣮ࣞࢺࢫン࣭ࢺࣉࣜࢡࢫ

compute_matrices_from_modes.basࡀ..\scripts\demo࡟追加ࠋࡓࡋࡲࢀࡉ 
 ࣐ࢥンࢻ DSP SWAPCHANNELSࡀ追加ࠋࡓࡋࡲࢀࡉ㸦以前ࡣMPE SWAPCHANNELS㸧 
 ᪧࡢࢺࢵ࣐࣮࢛ࣇ࣭ࢱ࣮ࢹ SNFࠊNEUTRALࠊFREEࡢ言及ࡾྲྀࡽ࠿ࣝ࢔ࣗࢽ࣐ࡣ除ࡣࡽࢀࡇࠋࡓࡋࡲࢀ࠿古

いࣙࢪ࣮ࣂンࡢ FEMtools㸦v3.1以前㸧࡛ࢺࢵ࣐࣮࢛ࣇ使用࡚ࢀࡉいࠋࡓࡋࡲ 
 ࣒ࢸࢫࢩ情報㸦Help > System Informatio㸧ࡣMB࡛࣓ࣔࣜ容量ࢆ示ࠋࡍࡲࡋ 
 FEMtoolsࢺࣉࣜࢡࢫ関数 OSInfoࡢ࡜混乱ࢆ回避ࢺࣉࣜࢡࢫ࡟ࡵࡓࡿࡍ....\scripts\tools\osinfo.basࡣ meminfo.bas

 ࠋࡓࡋࡲࡋ࣒࣮ࢿࣜ࡜

 ࢫ࢖࢙ࣇ࣮ࢱン࢖࣭࣮ࢨ࣮ࣘ

 ࠋࡍࡲࡋい࡚概ㄝࡘ変更点ࡢࢫ࢖࢙ࣇ࣮ࢱン࢖࣭࣮ࢨFEMtools࣮ࣘࠊࡣンࣙࢩࢡࢭࡢࡇ

 ࣮ࣛࣟࣉࢫࢡ࢚

 ࣛࣈンࢆࢡ備え࣮ࢨ࣮ࣘࡓ定義࣐ࡀྡࢫࢡࢵࣜࢺ許容ࠋࡍࡲࢀࡉ従来ࢫࢡࣜࢺ࣐࡜ࣝࣈ࣮ࢸࡢࡽࢀࡑࠊ表示࡛

 ࠋࡓࡋࡲࡋࡇ起ࡁ引ࢆ࣮࢚ࣛࡣ
 生成࣐ࢥンࢻ㸦ࣈ࣮࢝ࠊࣗࢩࢵ࣓ࠊࢫࢡࢵࣜࢺ࣐ࠊࣝࣈ࣮ࢸ㸧࡟ࣝ࢖࢓ࣇ࣭ࣝࢼ࣮ࣕࢪࡣ出力ࠋࡍࡲࢀࡉ 

 ࣮ࣂ࣮ࣝࢶ

 回転中心ࢆ設定ࢥ࢖࢔ࡢࡵࡓࡿࡍン࡟࣮ࣂ࣮ࣝࢶ࣭ࢫࢡࢵ࢕ࣇࣛࢢࡀ追加ࠋࡍࡲࢀࡉ 

 ࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ

 要素ࡼࡢࢺࢫ࣭ࣜࢺࢵࢭう࡟非常࡟長い࡟ࢱ࣮ࢹ対応ࢥࡢࡵࡓࡿࡍン࣎࣎ࡀࢫࢡࢵ最適化ࢥࡢࡑࠋࡓࡋࡲࢀࡉ

ン࣎࣎ࠊࡣ࡛ࢫࢡࢵ迅速ྍࢆࢫࢭࢡ࢔࡞能ࢱ࣮ࢹ࡟ࡵࡓࡿࡍ࡟構造ࢆࣝࢹࣔࠊ割ࡾ当࡚手法ࡲࢀࡉࢺ࣮࣏ࢧࡀ

 ࠋࡓࡋ
 FRFࢆࡳࡢ選択ࡿࡍ場合ࡢ Copy FEA Database to Test Databaseࡼ࠾ࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲび COPY FEM࣐ࢥンࢻ

 ࠋࡓࡋ必要࡛ࡀ選択ࡢࢫࢡࢵ࣎ࢡࢵ࢙ࢳCopy FE Mesh Dataࠊࡣ従来ࠋࡓࡋࡲࢀࡉ修ṇࠊ追加ࡀ
 Strainࠊ࡟ࡵࡓࡿࡍࢺ࣮࣏ࢧࢆCreate Responseࡀࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ修ṇࠋࡓࡋࡲࢀࡉ 
 Customize Meshࠊࡣࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ要素ᗙ標系㸦ECS㸧ࢆ表示࢕ࢸࢵࢭࡢࡵࡓࡿࡍンࢆࢢ含࡛ࢇいࠋࡍࡲ 
 Export Matrixࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ㸦File > Export > FEMtools Matrices㸧ࡀ修ṇ࣐࣮࢛ࣇ࣭ࣝ࢖࢓ࣇࠋࡓࡋࡲࢀࡉ

ࡣࢺࢵ 2段目࡟移動࡟ࣝ࢖࢓ࣇ࣭ࣝࢼ࣮ࣕࢪࡣࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲࡢࡑࠊࡋ EXPORT MATRIX࣐ࢥンࢥࡢࢻ
࣐ン࢖ࣛࢻンࢆ生成ࠋࡍࡲࡋ 

 Expand Test Mode Shapesࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ㸦(Database > Truncate/Expand > Expand Test Data㸧ࡀ修ṇࡋࡲࢀࡉ
 ࠋいࡉࡔࡃ࡚ࡋ参照ࢆᣑ張ࠖࡢࣉ࣮࢙ࢩࢻ࣮࣭ࣔࢺࢫࢸࠕࠋࡓ

 Check for Updates –Settingsࡀࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ修ṇࠋࡓࡋࡲࢀࡉ 

 ࢻコ࣐ン࣭࣮ࣗࢽ࣓

 File > Import㸦ࡼ࠾び Toolbar > Import㸧ࡀ FEAࡢ Strain࡜ Stress࡟ࢱ࣮ࢹ関࡚ࡋᣑ張ࠋࡓࡋࡲࢀࡉ 
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FEAࡢ Strain࡜ Stress࢖ࢆࢱ࣮ࢹン࣏࣮ࡿࡍࢺ新ࡋい࣐ࢥン࢖࡜ࢻン࣏࣮࣮ࣗࢽ࣓ࢺ 

 View > Dynamic Viewing࣓ࠊࡣ࣮ࣗࢽPin Rotation Center࣐ࢥンࢆࢻ含ࠋࡍࡲࡳ 
 View > XY-Curves࣓ࠊࡣ࣮ࣗࢽMove Tracker to Left ࡜ Move Tracker to Right࣐ࢥンࢆࢻ含࡛ࢇいࠋࡍࡲ 
 Help > Manuals࣓ࢭ࢖ࣛࠊࡣ࡟࣮ࣗࢽンࡀࢫ利用ྍ能ࡀࣝ࢔ࣗࢽ࣐ࡢ࡚࡭ࡍࠊࡃ࡞ࡣ࡛ࡅࡔࡢࡶ࡞示ࣛࠊࢀࡉ

ࡿࡼ࡟構成ࢫンࢭ࢖ LAN/WANࣛࢭ࢖ンࡢࢫ཯応性ࢆ改善ࠋࡍࡲࡋ 
 ࣓࣐ࢥ࣭࣮ࣗࢽンࠊ࡚ࡋ࡜ࢻGenerate Tracelines, Edit Tracelines, Generate Surfaces, Test Model Editorࡀ Database > 

Mesh Tools࣓࡟࣮ࣗࢽ追加ࠋࡓࡋࡲࢀࡉ 
 ࣓࣐ࢥ࣭࣮ࣗࢽンࢻ Test Model Editorࡀ Tools > Pretest Analysis࣓࡟࣮ࣗࢽ追加ࠋࡓࡋࡲࢀࡉ 
 Tools > Pretest Analysis࣐ࢥࡢ࣮ࣗࢽ࣓ࣈࢧࡢンࢆࢻ使用ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍFEࣔࠊࣝࢹ幾何学特性ࠊ材料

特性ࡢ未定義あࡿいࡣࣉ࣮࢙ࢩࢻ࣮ࣔࡣ利用ྍ能࡛࡞い場合ࡶ࡟使用ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ例えࠊࡤFE࣮ࣔ
 ࠋࡍ能࡛ྍࡣ選択࣮ࢧンࢭ࣭ࣝ࢔ࣗࢽ࣐ࡶ࡚ࡃ࡞࡟ࢫ࣮࣋ࢱ࣮ࢹࡀࣉ࣮࢙ࢩࢻ

 ࣓࣐ࢥ࣭࣮ࣗࢽンࡢࢻ Tools > Pretest > Modal Effective MassࠊࡣTools > Pretest > Modal Effective Mass Fraction 
(MEF)ࡼࡢうࠋࡓࡋࡲࢀࡉ࣒࣮ࢿࣜ࡟ 

 ࣓࣐ࢥ࣭࣮ࣗࢽンࡢࢻ Tools > Correlation Analysis > Mode Shape Pair ViewerࠊࡣTools > Correlation Analysis > 
Mode Shape Pairs Editorࡼࡢうࠋࡓࡋࡲࢀࡉ࣒࣮ࢿࣜ࡟ 

 ࢻコ࣐ン࣭࣮ࣗࢽ࣓࣭ࣉࢵ࢔ࣉࢵ࣏

 ࣓࢕࣭࢘ࢫࢡࢵ࢕ࣇࣛࢢ࣭ࣈ࣮࢝ࠊࢫࢡࢵࣜࢺ࣐ࠊࣗࢩࢵンࠊࡣ࡟࣮ࣗࢽ࣓࣭ࣉࢵ࢔ࣉࢵ࣏ࡢ࢘ࢻCaptureࢥ
࣐ンࡀࢻ追加࣐ࢥࡢࡇࠋࡓࡋࡲࢀࡉン࡟ࣝ࢖࢓ࣇࡣࡓࡲ࣮ࣆࢥ࡟ࢻ࣮࣎ࣉࢵࣜࢡࡣࢻ保Ꮡࡿࡍ前ࢵ࢕ࣇࣛࢢ࡟

使࡚ࡋ࡜ࡾ代わࡢ㸧ࣉࢵ࣐ࢺࢵࣅ㸦࣮ࣆࢥࠊࡁ開ࢆCapture Toolࠖࠕࡢࡵࡓࡿࡍ変更ࢬ࢖ࢧࢆ࢘ࢻン࢕࣭࢘ࢡ
用ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍࡋ 

 Save As, Use Maximized Windows, Close࣐ࢥンࢻ用ࢥ࢖࢔ࡢンࡀ追加ࠋࡓࡋࡲࢀࡉ 
 ࣓࢕࣭࢘ࢫࢡࢵ࢕ࣇࣛࢢ࣭ࣗࢩࢵンࡢ࣮ࣗࢽ࣓࣭ࣉࢵ࢔ࣉࢵ࣏ࡢ࢘ࢻ Dynamic Viewing࡟࣮ࣗࢽ࣓ࣈࢧ Pin 

Rotation Center࣐ࢥンࡀࢻ追加ࠋࡓࡋࡲࢀࡉ 
 ࣮࢝࢕࣭࢘ࢫࢡࢵ࢕ࣇࣛࢢ࣭ࣈンࠊ࡟࣮ࣗࢽ࣓࣭ࣉࢵ࢔ࣉࢵ࣏ࡢ࢘ࢻMove Tracker to Left ࡜ Move Tracker to 

Right࣐ࢥンࡀࢻ追加ࠋࡓࡋࡲࢀࡉ 

 ࢺࢵ࢝ࢺ࣮ࣙࢩ

ࡲࡾ࡞࡟ࢺࢵ࢝ࢺ࣮ࣙࢩࡢࢻン࣐ࢥࡢMove Tracker to Right࡜ Move Tracker to Leftࠊࡣ矢印ࡢ左右ࡢࢻ࣮࣮࣎࢟
 ࠋࡍ

 ࣝࣈ࣮ࢸ

 ࡣࣝࣈ࣮ࢸ Strainࡼ࠾び Stressࢸࡢンࡢࣝࢯ表示ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆStrain࡜ Stressࠊࡣࣝࣈ࣮ࢸࡢExplorer > 
Tables.ࡽ࠿開ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡃ 
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 ࢫࢡࢵ࢕ࣇࣛࢢ

࣮࢝ࣛ表示ࢬ࢖࣐ࢱࢫ࢝ࡢ 

い࣮࣭ࣛ࢝ࣗࢩࢵ࣓࣭ࢫࢡࢵ࢕ࣇࣛࢢࡢ࠿ࡘࡃ表示機能ࡀ追加ࠋࡓࡋࡲࢀࡉ 

 ࣙࢩ࣮࣓ࢽ࢔࣭ࣉ࣮࢙ࢩン࡛ࡣ変形振幅࡟応ࢆ࣮ࣛ࢝ࡓࡌ設定ࠋࡍࡲࡋ 
MESH … FOLLOW … あࡿいࠊࡣEdit > Settings > Style > Mesh Graphics > Colors > Contours Colors Followingࢆ使
用ࠋࡍࡲࡋ 

 凡例値ࡢ補間࢜ࣙࢩࣉン 
MESH…ROUNDING…ࢆ使用ࠋࡍࡲࡋ 

 ࢥン࡟ࢺࢵࣟࣉ࣭࣮ࢱ使用ࡿࢀࡉ間隔値 
MESH … INTERVAL …あࡿいࠊࡣEdit > Settings > Style > Mesh Graphics > Colors > Number of Legend Intervalsࢆ
使用ࠋࡍࡲࡋ 

 凡例࣮࢝ࣛࢆ指定ࡣ࣮ࣛ࢝ࡢࡑࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ INIࡢࣝ࢖࢓ࣇ graphic.customcolormap.colornn変数ࡋ࡜
࡚定義ࠊࡣࣉࢵ࣐࣮࣭࣒ࣛ࢝ࢱࢫ࢝ࠋࢇࡏࡲࡾ࡞ࡤࢀࡅ࡞ࡋMESH…CMAP CUSTOM…࡛選択ࠋࡍࡲࢀࡉ 

 ࣮࣭࢝ࣛ࢕ࢹ࣮࢙ࢩン࢕ࢹ࣮࢙ࢩ࣭ࢺࢵࣛࣇ：ࢢンࢢ機能ࡣ࡚ࡋ࡜連⥆的ࣂ࡜ンࡲࢀࡉࢺ࣮࣏ࢧࡀࢻ࣮ࣔࡢࢻ

 ࠋいࡉࡔࡃ࡚ࡋ参照ࢆびMATRIXࡼ࠾MESHࡢࠖࢻン࣐ࢥModified Commandsࠕࠊࡓࡲࠋࡓࡋ

回転原点ࡢ変更 

ンࢥ࢖࢔いࡋ新ࠊ࡟ࡵࡓࡿࡍ設定ࢆ回転原点ࢡࢵ࣑ࢼ࢖ࢲ  ࠋࡓࡋࡲࢀࡉ追加࡟࣮ࣂ࣮ࣝࢶ࣭ࢫࢡࢵ࢕ࣇࣛࢢࡀ 

ࡣいࡿあ࣮ࣗࢽ࣓࣭ࣉࢵ࢔ࣉࢵ場合㸦࣏࡞ࣈ࢕ࢸࢡ࢔ࡀンࢱ࣎ࡢࡇ View > Dynamic Viewing࣓࣮ࣗࢽ㸧࣭ࢫ࣐࢘ࠊ
 ࠋࡍࡲࡋ選択ࢆᗙ標ࢢン࢟ࢵࣆ࡚ࡋ࡜い原点ࡋ新ࡿࡍ回転ࢆࣗࢩࢵ࣓ࠋࡍࡲࡾ変わࡀࣝࢯ࣮࢝

 

回転原点ࢆ変更ࣆࡢࡵࡓࡿࡍン࣭࣎ࢱンࡢ使用例 
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᭷効࡞఩置ࣝࣂ࣮ࣟࢢ࡜ࡿࢀࡉࢡࢵࣜࢡࡀᗙ標系ࡢ新ࡋい回転原点ᗙ標ࢥࡀン࡟࣮ࣝࢯ出力ࠋࡍࡲࢀࡉ 

例えࠊࡤ 

Selected new rotation center at (+5.34302E+00, +3.85077E+00, 9.23082E-03) 

回転࡜࣮ࣗࣅ࣭ࢺ࢛ࣝࣇࢹࡢ原点ࢆ回復࢕࣭࢘ࢺࢵ࢕ࣇࠊࡣ࡟ࡿࡍンࢥ࢖࢔࣭࢘ࢻン  ࠋࡍࡲࡋࢡࢵࣜࢡࢆあࡽ
ࡲࡾ࡞࡟ࢻ࣮࣭ࣔࢡࢵ࢕ࣇࣛࢢࠊࡋ終了ࢆࢻ回転࣮ࣔࢡࢵ࣑ࢼ࢖ࢲࠊ場合ࡓࢀࡉ選択ࡀンࣙࢩࢡ࢔ン࣭ࣆ࡚ࡵࡓ

 ࠋࡍ

回転ࢺ࢛ࣝࣇࢹࡢ原点࣮ࣗࣅࡣᗙ標系ࣝࢹࣔࡢ境界࣎ࡢࢫࢡࢵ中央ࠋࡍࡲࡾ࡞࡟ 

 ࣮ࣝࣟࢺン࣭コンࣙࢩ࣮࣓ࢽ࢔

Start࡜ Stopࢱ࣎ࡢンࡼ࠾び Step ForwardࠊStep BackwardࠊGoto LastࠊGoto First buttons࣎ࢱンࢆ備えࡓ新ࡋいࢥン
࣓ࢽ࢔ࠊࡓࡲࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ࣮ࣝࣟࢺンࢥࢆン表示ࣙࢩ࣮࣓ࢽ࢔ࠊࡋ使用ࢆࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ࣭࣮ࣝࣟࢺ

 ࠋࡍࡲࡁ࡛ࡶ࡜ࡇࡿࡍ࣮ࣝࣟࢺンࢥࢆࢢン࣮ࣜࢣࢫ振幅࡜ン速ᗘࣙࢩ࣮

 

Animation Controlࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ 

 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡃ方法࡛開ࡢ以ୗࡣࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ࣭࣮ࣝࣟࢺンࢥࡢࡇ

• Mesh࣏࣮ࣗࢽ࣓࣭ࣉࢵ࢔ࣉࢵ㸦࣓࢕࣭࢘ࢫࢡࢵ࢕ࣇࣛࢢ࣭ࣗࢩࢵン࢘ࢻ中࡛右ࡉࡔࡃ࡚ࡋࢡࢵࣜࢡい㸧ࡽ࠿
ࡢ Animation > Animation Controlࢆ選択ࠋࡍࡲࡋ 

• View > Animation > Animation Controlࢆ選択ࠋࡍࡲࡋ 

開ࢆンࣙࢩ࣮࣓ࢽ࢔ࡣࢀࡑࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ利用ࢆࢻン࣐ࢥ࣭࣮ࣗࢽ࣓ࡢࡇࠊ場合ࡿい࡚ࢀࡉ表示ࡀࣉ࣮࢙ࢩ

始࡟ࡵࡓࡿࡍ使用ࠊ࠿ࡿࡍあࡿいࣙࢩ࣮࣓ࢽ࢔ࡣンࡀ実行࡚ࢀࡉいࡿ場合㸦Animate࣎ࢱンࢆ実行ࣗࢽ࣓ࠊ࠿ࡿࡍ
 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡃ開ࠊ㸧ࠋࡍࡲࡋ使用ࢆࢻン࣐ࢥ࣭࣮

Step ForwardࠊStep BackwardࠊGoto Last and Goto First࣎ࢱンࣙࢩ࣮࣓ࢽ࢔ࡣンࡀ実行中࠿休Ṇ࡚ࡋい࡟ࡁ࡜ࡿ作動
 ࠋࡍࡲࡋ

 㸦Tracker Control㸧࣮ࣝࣟࢺコン࣭࣮࢝ࢵࣛࢺ

ࣇࣛࢢ࣭ࣈ࣮࢝ࡣ࣮ࣝࣟࢺンࢥࡢࡑࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ矢印࡛移動ࢻ࣮࣮࣎࢟ࡢ左／右ࡣ࣮࢝ࢵࣛࢺࡢ中ࣈ࣮࢝

びࡼ࠾࣮ࣗࢽ࣓࣭ࣉࢵ࢔ࣉࢵ࣏࣭࢘ࢻン࢕࣭࢘ࢫࢡࢵ࢕ View > XY-Curves࣓ࡲࡁ࡛ࡀ࡜ࡇࡿࡍࢫࢭࢡ࢔ࡽ࠿࣮ࣗࢽ
 ࠋࡍ
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キ࣮ࣕࣝࢶ࣭࣮ࣕࢳࣉ㸦Capture Tool㸧 

Capture Tool࢕࣭࢘ࢫࢡࢵ࢕ࣇࣛࢢ࣭ࣈ࢕ࢸࢡ࢔ࡣンࢥࡢ࢘ࢻンࢸンࢆࢶ示࢖ࡣࢀࡑࠋࡍ࡛ࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲࡍ
ࠋࡍࡲࢀࡉ使用࡟ࡵࡓࡿࡍ変更ࢬ࢖ࢧ࡟前ࡿࡍ保Ꮡ࡟ࣝ࢖࢓ࣇࡣࡓࡲࠊ࡟前ࡿࡍ࣮ࣆࢥ࡟ࢻ࣮࣎ࣉࢵࣜࢡࢆࢪ࣮࣓

びࡼ࠾㸧࡚ࡋ࡜ࣉࢵ࣐ࢺࢵࣅCopy㸦ࠊࡣࢻン࣐ࢥࡢࡇ Save Asࡢ代わ࡚ࡋ࡜ࡾ使用ࢢࡣࢀࡑࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ
 ࡍࡲࢀࡉࢫࢭࢡ࢔ࡽ࠿࣮ࣗࢽ࣓࣭ࣉࢵ࢔ࣉࢵ࣏ࡢ࢘ࢻン࢕࣭࢘ࢫࢡࢵ࢕ࣇࣛ

 

ࡢ࣮ࣗࢽ࣓࣭ࣉࢵ࢔ࣉࢵ࣏࣭࢘ࢻン࢕࣭࢘ࣗࢩࢵ࣓ Capture࣐ࢥンࢻ 

ࢬ࢖ࢧ࣭ࢪ࣮࣓࢖ࠊࡓࡲࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ修ṇࡾࡼ࡟ࢢࢵࣛࢻࡢࢪࢵ࢚࣭࢘ࢻン࢕࢘ࡣࢬ࢖ࢧ࣭ࢡࢵ࢕ࣇࣛࢢ

࡟ࡵࡓࡿࡍ変更ࢆࢬ࢖ࢧ࣭ࢡࢵ࢕ࣇࣛࢢࠊࡋ指定ࢆ数ࣝࢭࢡࣆ࡟中ࢫࢡࢵ編集࣎ࡢప部左隅ࠊࡣ Apply࣎ࢱンࢆᢲ
 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡍ

Copy࣎ࢱンࢆᢲࢬ࢖ࢧ࡟ࢻ࣮࣎ࣉࢵࣜࢡࡾࡼ࡟࡜ࡇࡍ変更ࠊ࠿ࡿࡍ࣮ࣆࢥࢆࢪ࣮࣓࢖ࡓࢀࡉあࡿいࡣ Save As࣎ࢱ
ンࢆ使用࡟ࣝ࢖࢓ࣇ࡚ࡋ保Ꮡࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 



      FEMtools 4 Release Notes - 63  

Capture Tool࢘࢕ンࢆ࢘ࢻ閉࡟ࡵࡓࡿࡌ Closeࢆ使用ࠋࡍࡲࡋ 

 

 ࣮ࣝࢶ࣭࣮ࣕࢳࣉࣕ࢟

Strainと Stressࢸࡢンソࣝ㸦Strain and Stress Tensors㸧ࡢ表示 

 ࡣ࢔࣮ࣗࣅ࣭ࢫࢡࢵ࢕ࣇࣛࢢ Strain࡜ Stressࢸࡢンࡢࣝࢯ表示ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆ 

 

静的要素 Stress㸦左㸧࡜変఩㸦右㸧࣮ࣛ࢝ࡢศᕸࢺࢵࣟࣉ 

 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ選択ࢆ㸧࣮ࣂ࢖࢓ࣇࠊ中央ࠊప部ࠊ㸦ୖ部ࢺンࢿン࣏࣮ࢥࡢࡘ4ࠊࡣ表示ࣝࢯンࢸ

 ࠋࡍࡲい࡚ࢀࡽ伝え࡚ࡋ࡜௙様ࡢANSYSࠊࡣࢀࡇࠋࡍࡲࡾあࡶい場合࡞ࡁ利用࡛࣮ࣂ࢖࢓ࣇ࡜中央ࠊࡋࡔࡓ



64 - FEMtools 4 Release Notes  

ࣞンࡢࢫࢡࢵ࢕ࣇࣛࢢ࣭࣮ࢲ改良 

 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ࣮ࣝࣟࢺンࢥࢆࢻ࣮ࣆࢫ表示ࡾࡼ࡟設定ࢻ࣮ࢥࡢ࡛ࡲ10

 ࠋࡓࡋࡲࢀࡉ改善ࡀ投射ᅗ法࡟ࡵࡓࡿࡍ回避ࢆ࡜ࡇࡿ࡞࡟非表示ࡀ一部ࡢࣝࢹࣔࡿࡼ࡟ࢢン࣑࣮ࢬ

重ࡡ合わࣗࢩࢵ࣓ࡏ㸦FE+ࢻ࣮࣭ࣔࢺࢫࢸ㸧ࡢ画質ࡀ改善ࠋࡓࡋࡲࢀࡉ 

ᥥ画࡟使用࢔ࡓࢀࡉンࢩ࢔ࣜ࢖࢚ࢳンࢢ法ࢥࢆンࡢࡵࡓࡿࡍ࣮ࣝࣟࢺ新ࡋい࢕ࢸࢵࢭンࡀࢢ INI࡟ࣝ࢖࢓ࣇ追加ࡉ
ࡿࢀࡉࢺ࣮࣏ࢧFEMtools࡛ࠋࡍࡲࢀ OpenGL࢖ࣛࡢン࣭࢔ンࢩ࢔ࣜ࢖࢚ࢳンࢢ法ࡣ࡟  ࠋࡍࡲࡾあࡀ方法ࡢࡘ2

1. Line smooth：ࡣࢀࡇ少数ࡢ線ศࢆࣝࢹࣔࡿࡼ࡟適ษ࡟ᥥ画ࡿࡍ手法࡛ࡣࢀࡑࠋࡍ一般的ࠊ࡟多ࡢࡃ線ศࡼ࡟ࢆ
 ࠋࡍ࡛ࢢン࢕ࢸࢵࢭ࣭ࢺ࢛ࣝࣇࢹࡣࢀࡇࠋࡍࡲࡾ࡞ࡃ遅ࡣᥥ画࡛ࡢࣝࢹࣔ࡞複雑ࡿ

2. Multisampling：ࣝࢭࢡࣆ࣭ࣈࢧࡣࢀࡇ原点࡜ᖹ均化࡟基࡙い࡚ࢆࢪ࣮࣓࢖ᥥ画࢔࢙࢘ࢻ࣮ࣁࡿࡍᢏ術࡛ࠋࡍ 

変数 graphic.antialiaslimitࢧࢳ࣐ࣝࡣンࣜࣉン࡟ࢢ変更ࡿࡍ前࢔࡟ンࢩ࢔ࣜ࢖࢚ࢳンࢢ法࡛効率的࡟ᥥ画ࡿࡍ
wireframe線ศࡢ最大数ࢆ指定ࢺ࢛ࣝࣇࢹࠋࡍࡲࡋ値ࡣ ࡣࢀࡑࠊࡁ指定࡛࡛ࡲ8192 INIࣝ࢖࢓ࣇ中࡛指定࡜ࡇࡿࡍ
 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ設定࡛ࢻン࣐ࢥ࡞うࡼࡢ次ࡣࢀࡑࠋࡍࡲࡁ࡛ࡀ

SET VARIABLE graphic.antialiaslimit int_val 

 改善ࡢࢢン࢖࣮ࣗࣅ࣭࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮ࣔ

重ࡡ合わࢆ࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮ࣔࡏ表示ࡿࡍ場合 180ᗘࡢ఩相ࢺࣇࢩ値ࢆ適用ྍࡀ࡜ࡇࡿࡍ能࡛ࡣࢀࡇࠋࡍṇ規ࣔ
ࣔࠊ࡟共࡜ࢻン࣐ࢥMESH PAIRࠊࡣ࡟ࡿࡍ適用ࢆ変更ࡢࡑࠋࡍࡲࢀࡉ適用࡟ࣉ࣮࢙ࢩࢻ複素࣮ࣔ࡜ࣉ࣮࢙ࢩࢻ࣮
 ࠋࡍࡲࡋ使用ࢆ番号࢔࣭࣌ࢻ࣮

ࡓࡋ使用ࢆ࣮࣭ࣛ࢝ࢺࢫࣛࢺンࢥࠊ࣒࣮ࣞࣇ࣮ࣖ࢖ワࠊࢪࢵ࢚ࠊࡣ㸧ࣝࢹ࣭ࣔࢺࢫࢸ+㸦FE࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮ࣔ
ワࠊࢪࢵ࢚ࠊ一方ࠊࢀࡉ赤色࡛表示࡟常ࠊࡣࣝࢹ࣭ࣔࢺࢫࢸࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍᥥ画࡛࡝࡞表示ࢢン࢕ࢹ࣮࢙ࢩ

ࡣ表示ࡢ࣒࣮ࣞࣇ࣮ࣖ࢖ FEࣔࣝࢹ要素ࡀ࣮ࣛ࢝ࡢ割ࡾ当࡚࢖࣭ࣛࢪࢵ࢚ࠊࡓࡲࠋࡍࡲࢀࡽンࢆࡳࡢ使用ࠊࡋFEࣔ
ࡢࡇࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ表示ࢆࣝࢹ FEࣔ࢖ࣛࢺ࢘࢔ࡢࣝࢹン࣭࡜ࣝࢹ࣭ࣔࢺࢫࢸࡣࢺࢵࣟࣉ相似ࠋࡍࡲࡋ 

  

  

異࢕ࢸࢵࢭࡿ࡞ン࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮ࣔࡿࡼ࡟ࢢ 
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 ࢱ࢕ࢹ࢚࣭࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮ࣔ

いࡢ࠿ࡘࡃ改良࢖ࡀンࣈ࢕ࢸࢡࣛࢱMode Shape Pairs Editor࣮ࣝࢶ㸦Tools > Correlation Analysis > Mode Shape Pair 
Editor㸧࡟行わࠋࡍࡲࢀ 

• 交互࡟観察ࡢࡵࡓࡿࡍMap FE on Testࡢࢫࢡࢵ࣎ࢡࢵ࢙ࢳ追加 
ࡢࡵࡓࡿ替わࡾษࢆ࣮ࣗࣅ࣭ࢻࢵࣜࢯ࡜࣮ࣗࣅ࣭࣐࣮ࣝࣀ • Solid Viewࡢࢫࢡࢵ࣎ࢡࢵ࢙ࢳ追加ࠋ以前ࢵࣜࢯࡣ

 ࠋࡓࡋ機能࡛ࡢ唯一ࡀ࣮ࣗࣅ࣭ࢻ
• 追加࢔࣌ࠊࡣ࣮ࣙࢩ DOFࡢ఩置ࡼ࠾び方向ࢆ示ࢆ࣮࣮࣐࢝ࡍ加えࡢࡵࡓࡿ Show Paired DOFsࢡࢵ࣎ࢡࢵ࢙ࢳ

 ࠋ追加ࡢࢫ
 ࠋࡍ能࡛ྍࡀࢢン࢕ࢸࢵࢭwireframeࠊtransparencyࠊPhotoࠊ࡜ࡿࡍ変更ࢆ࢔࣭࣌ࢻ࣮ࣔࣈ࢕ࢸࢡ࢔ •

 ࠋいࡉࡔࡃ࡚ࡋ注意࡟࡜ࡇࡓࢀࡤ呼࡜Mode Shape Pairs Viewer࡟以前ࡀࢱ࢕ࢹ࢚ࡢࡇ

 

 ࢱ࢕ࢹ࢚࣭࢔࣭࣌ࣉ࣮࢙ࢩࢻ࣮ࣔ

Customizing Changes  

• Customize Meshࡢࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ変更 
• 要素ᗙ標系㸦ECS: Element Coordinate System㸧࢕ࢸࢵࢭンࡢࢢ表示 
࡛ࢺン࣓ࣜࢡン࢖ࡢࣉࢵࢸࢫ0.1 • ン࡛背࢖ࣛࡢ1㸦0.5㸧>ࡉ厚ࠋࡍࡲࡁ設定࡛ࢆࡉ厚࣮ࣖ࢖範ᅖ࡛ワࡢ10～0.1

景࡟対࢔࡚ࡋンࢩ࢔ࣜ࢖࢚ࢳンࡓࡋࢢ薄い線ࢆᥥ画࡟ࡢࡿࡍ᭷用࡛ࠋࡍ 
• Customize Matrixࠊࡣࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲRow／Columnࣛ࣋ࣝࢆ設定ࡢࡵࡓࡿࡍ新規ࢆࢻ࣮ࣝ࢕ࣇ含࡛ࢇいࡲ

 ࠋࡍ
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Customize Matrix Displayࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ 

 ࣮ࣝࢶ࣭ࣗࢩࢵ࣓

一次要素ࡽ࠿二次要素ࡢ࡬変換 

Element Type Conversionࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ㸦Database > Mesh Tools > Element Type Conversion㸧࡛ࠊࡣTRIA3ࠊ
QUAD4ࠊTETR4ࠊPENT6ࠊHEXA8ࡼࡢう࡞一次要素ࢆ஧次要素ࡢ TRIA6ࠊQUAD8ࠊTET10ࠊPEN15ࠊHEX20࡟
変換ࡿࡍ新ࡋい機能ࡀ追加ࠋࡓࡋࡲࢀࡉ但ࡢࡑࠊࡋ変換࡟ LINE2ࡣ含ࠋࢇࡏࡲࢀࡲ 

 ࠋࡍ要素࡛ࡢ࡚࡭ࡍࡣ変換対象ࡣ࡛ࢺ࢛ࣝࣇࢹࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ指定ࢆࢺࢵࢭび要素ࡼ࠾ࣉ࢖ࢱ変換ࡢ௚ࡢࡑ

 

Element Type Conversionࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ 

 ࠋࡍGENERATE CONVERT…TYPE QUAD࡛ࠊࡣࢻン࣐ࢥ相当ࡢࡑ
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஧次要素ࡢ࡬変換前 

 

஧次要素ࡢ࡬変換後 

 要素生成ࢫ࢖࢙ࣇ࣮ࢧࡢࡽ࠿ン㸦Tracelines㸧࢖ࣛࢫ࣮ࣞࢺ

࡜TRIA3ࠊࡽ࠿ン࢖ࣛࢫ࣮ࣞࢺ QUAD4ࡢ要素ࢆ生成ࡿࡍ新ࡋいࡀ࣮ࣝࢶ追加ࡣ࣮ࣝࢶࡢࡇࠋࡓࡋࡲࢀࡉ高機能ࢢ
 ࠋࡍࡲい࡚ࡋ意ᅗࢆ࡜ࡇࡿࡍ利用ࢆ要素ࢫ࢖࢙ࣇ࣮ࢧࡢࣝࢹ࣭ࣔࢺࢫࢸ࡛ୖ࢖ࣞࣉࢫ࢕ࢹ࣭ࣝ࢝࢕ࣇࣛ

開ࢆࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲElement Type Conversionࠊࡽ࠿Database > Mesh Tools > Element Type Conversionࠊࡣ࡟ࢀࡑ
 ࠋࡍࡲࡋ選択ࢆGenerate surface elements from tracelinesࠊࡁ
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 ࠋࡍࡲࡁ࡛ࡶ࡜ࡇࡿࡍࢫࢭࢡ࢔ࡽ࠿࣮ࣗࢽ࣓ࡢ次ࡣࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲࡢࡇ

Database > Mesh Tools > Generate Surfaces 

Model Updating࣓࣮ࣗࢽ構成 
Tools > Pretest Analysis > Generate Surfaces Pretest Analysis࣓࣮ࣗࢽ構成 
Tools > Generate Surfaces    

 ࠋࡍGENERATE CONVERT…TYPE SURFACE࡛ࠊࡣࢻン࣐ࢥ相当ࡢࡑ

 ࠋࡍࡲࡋ示ࢆ例ࢪ࣮࣓࢖ࡢࡑ

 

 変換前ࡢ࡬要素ࢫ࢖࢙ࣇ࣮ࢧ
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 変換後ࡢ࡬要素ࢫ࢖࢙ࣇ࣮ࢧ

要素公式 

QUAD8要素公式ࡾࡼࡣ安定性࡜高速化࡟ࡵࡓࡢ改善ࡢࡑࠋࡓࡋࡲࢀࡉ要素ࡣෆ部剛性対応ࡢ 3x3࢞࢘࢖࣏࣭ࢫン
 ࠋࡍࡲࡋ使用ࢆࢺ

内部ソ࣮ࣝࣂ㸦線形静解析と࣮ࣔࢻ解析㸧 

FEMtoolsෆ部ࠊ࡚ࡋ࡜࣮ࣂࣝࢯILP64㸦8ࢺ࢖ࣂ㸧整数࢖ンࠊࡣࢻ࣮ࣔࡢࡇࠋࡍࡲࡋࢺ࣮࣏ࢧࢆࢫࢡࢵࢹfta.exeࢯ
 ࠋࡍࡲࢀࡉ化ࣈ࢕ࢸࢡ࢔ࡾࡼ࡟࡜ࡇࡿࡍ指定ࢆ"数"-8ࡁ引࡟起動時ࡢ࣒ࣛࢢࣟࣉ࣮ࣂࣝ

 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ࡟ࣈ࢕ࢸࢡ࢔ࢆILP64ࠊ࡚ࡗࡼ࡟ࢻン࣐ࢥࡢ次ࠊࡓࡲ

SET ILP64 ON 

FEMtoolsࠕࠊࡣࣂ࢖ࣛࢻ࣭࣮ࣂࣝࢯILP64࣮ࠖࣝࣈ変数࡟関ࡿࡍ ILP64ࢺ࣮࣏ࢧ関数ࢆ使用ࢺ࣮ࢹࣉࢵ࢔࡟ࡵࡓࡿࡍ
 ࠋࡍcbsolver.bas࡛ࠊexpand.basࠊlib_reduction.basࠊfemtools.basࠊࡣࣂ࢖ࣛࢻ修ṇࡢࡑࠋࡓࡋࡲࢀࡉ

ILP64ࡣᣑ張࣏࢖ン࢖࣭࣮ࢱンࡾࡼ࡚ࡗࡼ࡟ࢫࢡࢵࢹ大ྍࢆࢺ࣮࣏ࢧࡢࢺࢵࢭࢱ࣮ࢹ࡞ࡁ能64ࠊࡋࡔࡓࠋࡍࡲࡋ࡟-
bit整数ࡀ 多ࡾࡼ࡟逆ㄝ的ࡣILP64ࠊࡵࡓࡢࢫࢡࢵࣜࢺ࣐ࡿࢀࡉ使用࡚ࡋ࡜ࢫࢡࢵࢹン࢖࡟ࡾ代わࡢ整数ࢺࢵࣅ32
ࡣࢀࡑ㸦࣮ࣟࣇ࣮ࣂ࣮࢜ࡢ整数ࢺࢵࣅ32ࠊ࡚ࡗࡀࡓࡋࠋࡍࡲࡋ使用ࢆ࣓ࣜࣔࡢࡃ DOF数࡜関係ࠋࡍࡲࡋ㸧ࡀ生ࡿࡌ
場合ࢆ考慮ࠊࡋILP64ࡢ使用ࠋࡓࡋࡲࢀࡉࢺ࣮࣏ࢧࡀ 

Strainと Stress解析㸦Strain and Stress Analysis㸧 

Stress࡜ Strainࡢ計算ࡢ修ṇ点／ᣑ張点ࢆ以ୗ࡟示ࠋࡍࡲࡋ 

 2D࡜ 3Dࡢ要素ࠋࡍࡲࢀࡉࢺ࣮࣏ࢧࡀ 
 Strainࡣ要素節点置ࡼ࠾び要素中心఩置ࡢ値࡚ࡋ࡜計算ࠋࡍࡲࢀࡉ 
 節点ᖹ均値ࡣ計算ࠋࢇࡏࡲࢀࡉ 
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 ࡢ࡚࡭ࡍ Strainࢸンࢥ࣭ࣝࢯン࣏࣮ࢿンࡀࢺ計算ࢸ࡚ࡗࡼ࡟ࢀࡇࠋࡍࡲࢀࡉンࢆࣝࢯ任意ࡢᗙ標系࡬回転ࡏࡉ
 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿ

ࢻン࣐ࢥ STRESS࡜ STRAINࢩࡢンࡀࢫࢡࢵࢱ修ṇࠊࢀࡉFEMtools 4.0࡛使用ࢩࡓࢀࡉンࡣ࡜ࢫࢡࢵࢱ互換性ࡀあ
 ࠋࢇࡏࡲࡾ

ࡀࣝࣈ࣮ࢸ࡜ࢫࢡࢵ࢕ࣇࣛࢢ Strain࡜ Stress࡟ࡵࡓࡢࢺ࣮࣏ࢧࡢ修ṇࠋࡓࡋࡲࢀࡉ 

ࢻン࣐ࢥ EXTRACT TENSORࢥࡀンࢸ࡟࣮ࣝࢯンࣝࢯ値ࢆ出力࡟ࡵࡓࡿࡍ追加ࠋࡓࡋࡲࢀࡉ 

Strainࡣ相関ศ析ࠊ感ᗘ解析࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔࠊン࣏ࢫࣞࡢࢢン࡚ࡋ࡜ࢫ使用ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 

静解析㸦Static Analysis㸧 

Staticࠊࡣࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲFEMtoolsࠊABAQUSࠊANSYSࠊNASTRAN࡟ࢫࢭࢡ࢔ࡿࡼ࡟ࣂ࢖ࣛࢻ対応ࠋࡍࡲࡋ
 ࠋࡓࡋࡲࢀࡉ追加ࡀࢫࢡࢵ࣎ࢡࢵ࢙ࢳStrains / Stressࠊ࡟ࡵࡓࡢ計算ࡢࡽࢀࡑ

 

Staticࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ 

FEMtoolsソࣝࡢ࣮ࣂそࡢ他ࡢ変更 

 FEMtools࡟࣮ࣂࣝࢯ関ࡿࡍ静的変఩࡜ Strainࡢ解析ࡀࣂ࢖ࣛࢻ更新ࠋࡓࡋࡲࢀࡉ 

FEMtoolsࣂ࢖ࣛࢻ࣭࣮ࣂࣝࢯ㸦femtools.bas㸧ࣈ࢕ࢸࢡ࢔ࠊࡣ DOF࣮ࣂࣝࢯࡀ方程式࡟使用ࡲࡋࢡࢵ࢙ࢳ࠿ࡿࢀࡉ
ࡢ࡚࡭ࡍࡾࡼ࡟ࢀࡇࠋࡍ DOF࡟関ࡢࢪ࣮ࢭࢵ࣓࣮࢚ࣛࡿࡍ出力ࢆ回避ࠋࡍࡲࡋ 

FEMtools Dynamics 

 ࡢࢫࢡࢵࣜࢺ࣐࣭࣒ࢸࢫࢩࡢࢻ࣮࣭ࣔࢺࢫࢸ K࡜Mࡢ計算ࢆ実証ࣔࢹࠊ࡟ࡵࡓࡿࡍンࣙࢩ࣮ࣞࢺࢫン࣭ࢡࢫ
ࢺࣉࣜ compute_matrices_from_modes.basࡀ....\scripts\demo࡟追加ࠋࡓࡋࡲࢀࡉ 

 ࣮ࣔࢭ࢔࣭ࢫ࣮࣭࣋ࣝࢲンࣜࣈ㸦MBA㸧ࠊࡣࣝࢿࣃMBAࡢ現ᅾ値ࢆ使用࢕ࢸࢵࢭࠊࡋンࢆࢢ計算ࠋࡍࡲࡋ 
 DEFINE MBA SUBSTRUCTURE࡜ EXTRACT MBA SUBSTRUCTURESࡢ修ṇ：FEM要素ࡀࣉ࢖ࢱ修ṇ要素ࡢ

場合ࢆࣉ࢖ࢱࣈࢧࠊ格納ࠊࡋᢳ出ࠋࡍࡲࡋ 
 ࣓ࣗ࢟ࢻンࠊࡣ࡟ࢺMBA COMPUTE࣐ࢥンࠕࡢࢻnumber of modes㸦࣮ࣔࢻ数㸧ࠖ ࡋ記述ࢆ意味ࡢࢢン࢕ࢸࢵࢭ

ࣔࡢ࣒ࢸࢫࢩ修ṇ済ࡿࢀࡉ中࡛維持ࢫ࣮࣋ࢱ࣮ࢹࡃ࡞ࡣ数࡛ࢻ࣮ࣔࡿࢀࡉ使用࡚ࡗࡼ࡟MBAࠊࡣࢀࡑࠋࡍࡲ
ࡋ維持ࢆࢻい࣮ࣔ࡞少ࠋࡍ数࡛ࢻ初期࣮ࣔࣝࢲ࣮ࣔࡢ未変更ࡣnumber of modesࠖࠕࡢࢺ࢛ࣝࣇࢹࠋࡍ数࡛ࢻ࣮
 ࠋࢇࡏࡲࡾ࡞ࡤࢀࡅ࡞ࡋ指定ࢆ値ࡢࡑࡣ࣮ࢨ࣮ࣘࠊࡳࡢい場合࡞ࡽ࡞ࡤࢀࡅ࡞
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FEMtoolsࢺࢫࢸࣜࣉ解析と相関分析  

 ン㸦Traceline㸧自動生成࢖ࣛࢫ࣮ࣞࢺ

ࢺンࢥࡢࡃ多ࡾࡼࠊࢀࡉ改善ࡶ結果ࡢࡑࠋࡓࡋࡲࢀࡉ修ṇ࡛࣒ࢬࣜࢦࣝ࢔いࡋ新ࡣ࣮ࣝࢶン自動生成࢖ࣛࢫ࣮ࣞࢺ

密ࠊࡣ࣮ࣝࢶいࡋ新ࡢࡇࠋࡍࡲࡋ対応ࡶ࡟ࢺン࢖࣏ࡢࡃ多ࠊࢀ行わ࡟迅速ࡣ処理ࡢࡑࠋࡓࡋࡲࡾ࡞࡟能ྍࡀ࣮ࣝࣟ

ࡉ使用࡟ࡵࡓࡢࢱ࣮ࢹ࣭ࢫ࢖࢙ࣇ࣮ࢧࡓࢀࡉン装置࡛生成ࣕ࢟ࢫ࣮ࢨ࣮ࣞࠊࡤ例えࠊࡋ対応ࡶ࡟処理ࡢࢻࢵࣜࢢ࡞

 ࠋࡍࡲࢀ

࢓ࣇ外部ࡣいࡿあࠊࢱ࣮ࢹ群ࢺン࢖࣏ࡢࢺン࢖࣏࣭ࢺࢫࢸࡓࢀࡽ選択࡛得࣮ࢧンࢭࡢ手動ࡣࡓࡲ自動ࡣ࣮ࣝࢶࡢࡇ

使用ࢆࣝࢹ࣭ࣔࢺࢫࢸࡢ既Ꮡࡓ備えࢆン࢖ࣛࢫ࣮ࣞࢺࠋࡍࡲࡋ使用ࢆࢱ࣮ࢹ࣭ࢺン࢖࣏ࡓࢀࡉࢺン࣏࣮࢖ࡽ࠿ࣝ࢖

 ࠋࡍࡲࡁ࡛ࡶ࡜ࡇࡿࡍ再編集ࢆン࢖ࣛࢫ࣮ࣞࢺࡢ既Ꮡࠊ場合ࡢࡇࠋࡍࡲࡁ࡛ࡶ࡜ࡇࡿࡍ

い࢕ࢸࢵࢭࡢ࠿ࡘࡃンࢢ㸦࢖ࣛࢫ࣮ࣞࢺンࡢ角ᗘ࢖࣏ࠊンࢺ間ࡢ最大距離࡝࡞㸧࢖ࣛࢫ࣮ࣞࢺࠊ࡚ࡗࡼ࡟ン࣮࢜ࣂ

 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ回避ࢆࣉࢵ࣮ࣛ

Tools > Pretest Analysis > Generate Tracelines ࠊࡽ࠿Generate Tracelinesࢆࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ開ࠋࡍࡲࡁ 

 

Generate Tracelinesࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ 

 ࠋࡍGENERATE TRACELINES࡛ࠊࡣࢻン࣐ࢥ相当ࡢࡑ

 ࠋいࡉࡔࡃ࡚ࡋ参照ࢆࣝ࢔ࣗࢽ࣐࣭ࢫンࣞ࢓ࣇࣜࢻン࣐ࢥࡣࡓࡲ情報ࣉࣝ࣊ࠊࡣヲ細ࡢい࡚ࡘ࡟ࢢン࢕ࢸࢵࢭࡢࡑ

以ୗ࡟いࢪ࣮࣓࢖ࡢ࠿ࡘࡃ例ࢆ示ࠋࡍࡲࡋ 
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自動࢖ࣛࢫ࣮ࣞࢺン生成例㸦左ᅗ：࢜ࣜ࢖࣏࣭ࣝࢼࢪンࢺ群ࠊ右ᅗ：生成ࣝࢹ࣭ࣔࢺࢫࢸ㸧 

生成࢖ࣛࢫ࣮ࣞࢺン࢖࣏࡟ࣝࢹ࣭ࣔࢺࢫࢸࠊࡣンࢺ接⥆ࢆ追加ࢺ࣮ࢱࢫࡢࡇࠋࡍࡲࡋ方法ࠊ࡚ࡋ࡜Tools > Pretest 
Analysis > Edit Tracelines, Tools > Pretest Analysis > Generate Surfaces あࡿいࠊࡣDatabase > Mesh Tools > Test Model 
Editorࢆ使用ࠋࡍࡲࡋ 

 必要条件ࢱ࣮ࢹࡢためࡢ解析ࢺࢫࢸࣜࣉ

Tools > Pretest Analysis࣐ࢥࡢୖ࣮ࣗࢽ࣓ࣈࢧンࠊࡣࢻFEࣔࡀࣝࢹ無い場合ࠊ幾何学特性ࡣࡓࡲ材料特性ࡀ未定義
 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ使用ࡶい場合࡛࡞ࡁ利用࡛ࡣࣉ࣮࢙ࢩࢻ࣮ࣔࡣいࡿ場合あࡢ

ࢻン࣐ࢥ PRETEST ADDࠊPRETEST MOVEࠊPRETEST REMOVEࡀࢱ࣮ࢹࢻ࣮ࣔࠊࡣ無ࡀࡳࡢࣝࢹ࣭ࣔࢺࢫࢸࠊࡃ
Ꮡᅾࡿࡍ場合ࠋࡍࡲࡋࢺ࣮࣏ࢧࡶ 

新ࡋい補語ࡢ DOF PAIREDࠊࡀDOF࣌࡟ࣝࢹ࣭ࣔࢺࢫࢸࣜࣉࢆࣝࣈ࣮ࢸ࣭࢔変換ࡿࡍ PRETEST ADD࣐ࢥン࡟ࢻ
追加ࠋࡍࡲࢀࡉ 

 ࠋࡍࡲࡋ࡟能ྍࢆ以ୗࡣ変更ࡢࡽࢀࡇ

ࢧンࢭRotateࠊࡶ࡚ࡃ࡞ࡋᏑᅾ࡟ࢫ࣮࣋ࢱ࣮ࢹࡀࣉ࣮࢙ࢩࢻび࣮ࣔࡼ࠾ࣝࢹFEࣔࠊࡋࢺン࣏࣮࢖ࢆࣝࢹ࣭ࣔࢺࢫࢸ
࢔࣌ࠊࢢンࣜ࢔DOF࣌ࠊ࣮ࣆࢥࡢ࡬FEMࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ使用ࢆࣝࢿࣃ࣭࣮ DOF࡟基࡙いࢭࡓン࣮ࢧ生成ࡀ
自動的࡟実行࢘ࣛࢢࢡࢵࣂࡢࡵࡓࡿࢀࡉンࣙࢩ࣮࣭ࣞ࣌࢜ࢻン࢕ࢸࢵࢭ࣭ࢺ࢛ࣝࣇࢹࡣンࢆࢢ使用࢛ࣇࢹࠋࡍࡲࡋ

 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ手動࡛設定ࡣ場合ࡿࡍ使用ࢆ以外ࢢン࢕ࢸࢵࢭ࣭ࢺࣝ

FE࣮ࣔࡀࣉ࣮࢙ࢩࢻ利用ྍ能࡛࡞い場合ࠊManual Sensor Selectionࢭࡢࣝࢿࣃンࢆ࣮ࢧ削除࠿ࡿࡍ移動ࡔࡃ࡚ࡏࡉ
 ࠋいࡉ

ࡉࡔࡃ࡚ࡗ行ࢆ選択࣮ࢧンࢭ࣭ࣝ࢔ࣗࢽ࣐ࡢୖࣝࢹFEࣔࠊ無い場合ࡀ必要ࡿࡍࢺン࣏࣮࢖ࡣࡓࡲ計算ࢆࣉ࣮࢙ࢩ
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いࠋ 

既Ꮡࢆࣝࢹ࣭ࣔࢺࢫࢸࡢ使用ࠊࡋFEࣔࢆࢀࡑ࡟ࣝࢹ写像࢔࣌ࡢ࡚ࡋ࡜ࣝࢹ࣭ࣔࢺࢫࢸࣜࣉࠊࡋ DOFࢆ使用ࡃ࡚ࡋ
 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿ加えࢆン࢖ࣛࢫ࣮ࣞࢺ࡟任意ࠊࡓࡲࠋいࡉࡔ

Test Model Editor㸦Database > Mesh Tools ࡣࡓࡲ Tools > Pretest Analysis ࣓࣮ࣗࢽ㸧ࡶ使用࡛࡟࡜ࡇࡿࡁ注意ࡔࡃ࡚ࡋ
 ࠋいࡉ

 変更点ࡢ他ࡢそࡢ解析ࢺࢫࢸࣜࣉ

 統計計算㸦statistics㸧ࢥ࡜ンࡢࢺ࣮࣏࣭࣮ࣞࣝࢯᣑ張ࡀ自動ࢭン࣮ࢧ選択用ࡢ SEAMAC࡜ EIM法࡟追加ࢀࡉ
 ࠋࡓࡋࡲ

 Fixed Sensor locations㸦固定ࢭン࣮ࢧ఩置㸧ࡀ新ࡋいࢭンࡢ࣮ࢧ最ᑠࢭン࣮ࢧ距離ࢆ決定࡟ࡵࡓࡿࡍ考慮ࢀࡉ
 ࠋࡓࡋ能࡛ྍࡀࢢンࣜࢱࢫࣛࢡࡢ間࣮ࢧンࢭいࡋ新࡜࣮ࢧンࢭ固定ࡣ以前ࠋࡓࡋࡲ

 いࡢ࠿ࡘࡃ自動ࢭン࣮ࢧ選択方法㸦normal-tosurface placement; EIM statistics, Maximum MAC Alias,…㸧ࡀ修ṇ／
ᣑ張ࠋࡓࡋࡲࢀࡉ例えࠊࡤ最పMAC値ࡽ࠿0%ࠊࡣ  ࠋࡓࡋࡲࢀࡉ変更࡟1%

 Excitation Location Selection㸦加振఩置ࡢ選択㸧形式ࡀ修ṇࠋࡓࡋࡲࢀࡉ以前ࠊࡣShow Candidatesࣈ࢕ࢸࢡ࢔ࡀ
 ࠋࡓࡋ࡛ࢇࡏࡲࡾあࡣ࡛

 ࢻコ࣐ン࣭࢕ࢸ࢕ࣜ࢕ࢸ相関分析࣮ࣘࢫࢭࣟࣉࢺࢫ࣏

次ࡀࢺࣉࣜࢡࢫ࣭࢕ࢸ࢕ࣜ࢕ࢸ࣮ࣘࡢ..\scripts\utilities࡟追加ࠋࡓࡋࡲࢀࡉ 

csc13ob.bas  1/3࢜ࣂࣈ࣮ࢱࢡンࢻ用ࡢ CSC FRF相関関数ࢆ計算ࠋࡍࡲࡋ  

checkfrfpair.bas  ࣌࢔ FRFࡢ DOF࢖ࢧンࠊࡋࢡࢵ࢙ࢳࢆ必要࡟応࡚ࡌ自動的࢖ࢧ࡟ンࢆ
ษࡾ替えࠋࡍࡲ 

相関分析ࡢそࡢ他ࡢ変更点 

 いࡢ࠿ࡘࡃ改良࢖ࡀンࣈ࢕ࢸࢡࣛࢱMode Shape Pairs Editor࣮ࣝࢶ㸦Tools > Correlation Analysis > Mode Shape 
Pair Viewer㸧࡟行わࠋࡓࡋࡲࢀヲ細ࠕࠊࡣMode Shape Pairs Editorࠖࢆ参照ࡉࡔࡃ࡚ࡋいࠋ 

 静的変఩ࡼ࠾び Strain࣮࣋ࡢࢫ相関ศ析ࡼ࠾びࣔ࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹンࡢࢢ例題ࡀ追加ࠋࡓࡋࡲࢀࡉ 
ヲ細ࠕࠊࡣ例題ࡢ変更ࠖࢆ参照ࡉࡔࡃ࡚ࡋいࠋ 
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 選択ࡢࢱ࣮࣓ࣛࣃとࢫン࣏ࢫࣞ

Strain㸦歪み㸧࣏ࣞࢫンࡢࢫ計算 

FEMtools 4.1ࡣ相関ศ析ࠊ感ᗘ解析ࡼ࠾びࣔ࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹンࡢࡵࡓࡢࢢ Strain࣏ࣞࢫンࡲࡋࢺ࣮࣏ࢧࢆࢫ
 ࠋࡍ

Strain࣏ࣞࢫン࡟ࢺ࣮࣏ࢧࡢࢫ応ࠊ࡚ࡌCreate Responseࠊࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲRESPONSE STRAIN࣐ࢥンࡼ࠾ࢻび
Responsesࡶࣝࣈ࣮ࢸ更新ࠋࡓࡋࡲࢀࡉ 

Create Responseࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ 

Strain用ࡢ Create Responseࢥࡣࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲン࣏࣮ࢿン࡜ࢺ Face࡟ࡵࡓࡿࡍࢺ࣮࣏ࢧࢆ修ṇࠋࡓࡋࡲࢀࡉ 

 

Create Responseࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ㸦左ᅗ：ࠊࣉ࢖ࢱ右ᅗ：࢕ࢸࣃࣟࣉ㸧 

RESPONSE STRAINコ࣐ンࢻ 

RESPONSE STRAIN࣐ࢥンࡣࢻ新ࡋい引ࡁ数ࡢ追加ࡾࡼ࡟修ṇࠋࡓࡋࡲࢀࡉ 

RESPONSE STRAIN   

<  
ELEMENT element_id,   
COMPONENT (SX | SY | TXY | int_val),  
FACE (TOP | BOTTOM | int_val),   
CS (GLOBAL | LOCAL | AUTOMATIC | int_val),   
LOAD int_val,   
SCATTER real_val,   
VALUE real_val  
>  

 DIRECTIONࡣ COMPONENTࡾྲྀ࡜替えࠊࡋࡔࡓࠋࡓࡋࡲࢀࡽDIRECTIONࠋࡍࡲࢀࡉࢺ࣮࣏ࢧࡔࡲࡣ 
 SXࠊSYࠊTXYࢥࡢン࣏࣮ࢿンࢺ定義࡜整数値ࡿࡼ࡟定義ࠊࡣSX=1ࠊSY=2ࠊTXY=3࡛指定࡛ࠋࡍࡲࡁ 
 FACE補語ࡀ追加ࢻࢵࣜࢯࡣࢀࡇࠋࡓࡋࡲࢀࡉ要素ࡢ Faceあࡿいࡣ 2D要素ࡢ Faceࢆ指定ࠋࡍࡲࡋ 
 ࡞ࡁ࡛ࢫࢭࢡ࢔い࠿見え࡞いࢻࢵࣜࢯ要素 FACEࡀ選択࡚ࢀࡉいࡿ場合ࡀࢪ࣮ࢭࢵ࣓࣮࢚ࣛࠊ出力ࠋࡍࡲࢀࡉ 

    



      FEMtools 4 Release Notes - 75  

 
Faceࡀ選択࡞ࢀࡉい場合： 

ࡢࡘ1ࠊࡣ要素࡛ࢻࢵࣜࢯ - Faceࡀࡳࡢ見えࡿ場合ࡢࡑࠊ Faceࡀ自動的࡟選択ࡑࠊࢀࡉう࡛࢚ࣛࡤࢀࡅ࡞
 ࠋࡍࡲࢀࡉ出力ࡀࢪ࣮ࢭࢵ࣓࣮
 

 ࠋࡍࡲࢀࡉ選択࡚ࡋ࡜ࢺ࢛ࣝࣇࢹࡀFace㸦TOP=1㸧࣮ࣂ࢖࢓ࣇࡢ部ୖࠊࡣ要素࡛࢙ࣝࢩ -
 
TOP=1, BOTTOM=2   

 AUTOMATICࡣ選択ࡓࢀࡉ Face࡟垂直࡞ Z軸ࡼ࠾び Faceᖹ面ୖࣝࣂ࣮ࣟࢢࡢ X軸ࢆ CSࡢ X軸ࡼࡿࡍ࡜う࡟
定義ࣝࣂ࣮ࣟࢢࠋࡍࡲࡋ X軸ࠊࡀFace࡟垂直㸦0.1ᗘࡢ許容角㸧࡞場合ࣝࣂ࣮ࣟࢢࠊࡣ Z軸ࡀ使用ࠋࡍࡲࢀࡉ 

 ࡣࢀࡇ Abaqus࢚࣭࢙ࣜ࢜ࣝࢩ࣭ࢺ࢛ࣝࣇࢹࡢンࣙࢩ࣮ࢸン法࡟準ᣐࠊࡋ直観的࡟最適࣮ࣝ࢝ࣟ࡞軸ࢆ生成ࡋ
ࡢࢻࢵࣜࢯࡀࢀࡑࡣFEMtools࡛ࠋࡍࡲ Face࡟ࡵࡓࡢ使用ࠋࡍࡲࢀࡉ 

 ࣝࣂ࣮ࣟࢢࡢୖࢫ࢖࢙ࣇ࣮ࢧ軸ࡢࢀࡒࢀࡑࠊࡣ軸࣋ࡢࣝࢺࢡ積࡚ࡗࡼ࡟決定ࠋࡍࡲࢀࡉ 
 
GLOBAL=0, LOCAL=-1, AUTOMATIC=-2   
 
 要素例㸦static_strain_3 helix example㸧ࢻࢵࣜࢯ
 

 ࢻࢵࣜࢯ要素ࡢ ࡢ645 Faceࡀ見えࡿ場合ࡢ࣮ࣝ࢝ࣟࠊ SX測定方向ࢆ定義࡟ࡵࡓࡿࡍ自動࣮ࣟ࢝ࣝᗙ標系ࢆ使
用ࠊࡋSX=-2.207E-6ࡢ Strain値ࢆ指定ࠋࡍࡲࡋ 
 
response strain load 10 element 645 component 1 face 0 as auto value -2.2070E-06 scatter 1 

 ࣝࣈ࣮ࢸ࣭ࢫン࣏ࢫࣞ

 ࣏ࣞࢫンࣝࣈ࣮ࢸ࣭ࢫ㸦TABLE RESPONSE㸧ࡣ Strain࣏ࣞࢫンࢫ情報ࢆ表示࡟ࡵࡓࡿࡍ更新ࠋࡓࡋࡲࢀࡉ 
 
例：Index/Source/Load/Element/Component/Face/CS/Scatter 

 

Strain࣏ࣞࢫンࢆࢫ示࣏ࢫࣞࡍンࣝࣈ࣮ࢸ࣭ࢫ 
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Strain࣏ࣞࢫンࢆࢫ示࣏ࢫࣞࡍンࣝࣈ࣮ࢸ࣭ࢫ 

EXTRACT RESPONSE࣐ࢥンࡣࢻヲ細情報ࢆ表示ࠋࡍࡲࡋ 

例 

Source  Load  Element  Component Face  CS  Scatter (%)  Value  
1 Test  10  94  TXY  3037  1001  1  -2.30440E-04  
2 Test  20  3117  SX  3037  1002  1  5.24840E-04  
3 Test  20  3117  TXY  3037  1002  1  1.36680E-04  
4 Test  30  3117  SX  3037  1002  1  2.31240E-04  
5 Test  30  3117  TXY  3037  1002  1  4.75640E-05 

 変更ࡢ他ࡢそࡢ選択ࢫン࣏ࢫࣞ

 ࣏ࣞࢫンࢫ定義࣐ࢥンࢆ࣮࢚࡛ࣛࢻ引ࡁ起ࡓࡋࡇ場合࡛࣏ࢫࣞࡶンࣝࣈ࣮ࢸ࣭ࢫ全体ࢆ破壊ࡣ࡜ࡇࡿࡍあࡲࡾ

 ࠋࢇࡏ
 ࡢࢺ࢛ࣝࣇࢹ Scatter値0ࠊ࡚ࡋ࡜あࡿいࡣ㈇ࡢ値ࡀ定義࡛ࠋࡍࡲࡁ 
 重複࣏ࣞࢫンࢫ定義ࠊࡣ最後ࡢ定義࣏ࢫࣞࡓࢀࡉンࡀࢫ維持ࠋࡍࡲࢀࡉ 
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FEMtoolsࣔ࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹンࢢ 

 ࢻコ࣐ン࣭࢕ࢸ࢕ࣜ࢕ࢸ感ᗘ解析࣮ࣘࢫࢭࣟࣉࢺࢫ࣏

次ࡀࢺࣉࣜࢡࢫ࣭࢕ࢸ࢕ࣜ࢕ࢸ࣮ࣘࡢ..\scripts\࣮ࣘ࡟࢕ࢸ࢕ࣜ࢕ࢸ追加ࡍࡲࢀࡉ: 

delparamsens.bas  delparamsens.basࠊࡣ感ᗘࣞ࣋ࣝ࡟基࡙いࠊࡓ選択࣭ࢱ࣮࣓ࣛࣃࡓࢀࡉ
ࢫࢡࢵࢱンࢩࠊࢻン࣐ࢥࡢࡇࠋࡍࡲࡋ削除ࢆࢱ࣮࣓ࣛࣃࡽ࠿ࣝࣈ࣮ࢸ

ࢱࢆHELP DELRESPSENSࠊ࡟ࡵࡓࡿࡍ参照ࢆヲ細情報ࡢび例証ࡼ࠾
 ࠋいࡉࡔࡃ࡚ࡋࣉ࢖

defsetsens.bas  defsetsens.basࠊࡣ感ᗘࣞ࣋ࣝ࡟基࡙いࢆࢺࢵࢭࡓ作成ࠋࡍࡲࡋ感ᗘ間
隔࡟基࡙いࢆࢺࢵࢭࡓ作成ࠊ࠿ࡿࡍあࡿいࠊࡣ例えࢆ0.1%ࠕࡤ越えࡿ
E変更感ᗘࢆ備えࡢ࡚࡭ࡍࡓ要素ࠖࡼࡢうࢆࢺࢵࢭ࡞作成ࡀ࡜ࡇࡿࡍ
ࠋࡍࡲࡋ対応࡟㸧࡜ࡈ㸦要素ࢱ࣮࣓ࣛࣃ࣭࣮ࣝ࢝ࣟࠊ現ᅾࠋࡍࡲࡁ࡛

ࡍ参照ࢆヲ細情報ࡢい࡚ࡘ࡟び例証ࡼ࠾ࢫࢡࢵࢱンࢩࠊࢻン࣐ࢥࡢࡇ

 ࠋいࡉࡔࡃ࡚ࡋࣉ࢖ࢱࢆHELP DELPARAMSENSࠊ࡟ࡵࡓࡿ

静的変位࣮࣋࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔࡢࢫンࢢ 

FEMtoolsࠊ࡟ࡶ࡜࡜࣮ࣂࣝࢯ静的変఩࣮࣋࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔࡢࢫンࠊࡀࢢAnsysࠊAbaqusࠊNastran࡛࣮ࣂࣝࢯ
 ࠋࡓࡋࡲࢀࡉࢺ࣮࣏ࢧ

 ࠋࡓࡋࡲࢀࡉ追加ࡀ例題ࡢ次࡟ࡵࡓࡿࡍ実証ࢆࢢン࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔࡢࡑ

..\examples\updating\static_1  

..\examples\updating\static_2 ..\examples\updating\static_strain_2  

Strain㸦歪み㸧࣮࣋࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔࡢࢫンࢢ 

Strain࣮࣋࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹࣔࡢࢫンࠊࡣࢢFEMtoolsࠊAnsysࠊAbaqusࠊNastranࡋࡲࢀࡉࢺ࣮࣏ࢧ࡛࣮ࣂࣝࢯ
ࢫStrainࣞࠋࡍࡲࡋ動作࡟様ྠ࡜ࣉ࢖ࢱ࣭ࢺ࣮ࢹࣉࢵ࢔ࡢ࡚࡭ࡍࡢ௚ࡢࡑࡶ場合ࡿࢀࡉ選択ࡀࢫン࣏ࢫStrainࣞࠋࡓ
࣏ンࡣࢫ᭷限要素࡟ࢫ࢖࢙ࣇ࣮ࢧ関࡚ࡋ計算ࠊࢀࡉ静的荷重変形࡟起因ࡿࡍ面ෆ Strain値㸦sxࠊsyࠊtxy㸧࡛ࡇࠋࡍ
ࡢ要素ࢻࢵࣜࢯࡣࢀ Face2ࠊD要素ࡢ Faceあࡿいࡢ࣮ࣂ࢖࢓ࣇࡣ Top／Bottom࡛生成ࠋࡍࡲࢀࡉ 

࡟特ࠊࡣࡽࢀࡑࠋࢇࡏࡲࡾ違いあ࡟ࡿ物理特性࡛あࡢ要素࡞うࡼࡢࡉ厚ࢺ࣮ࣞࣉࡣいࡿ材料特性あࠊࡣࢱ࣮࣓ࣛࣃ

要素 Strainࡣ࡟高感ᗘ࡛ࠋࡍ 

次ࢺ࣮ࣞࣉࠊ࡟厚ࡢࡉ Strain࣮࣋ࢺ࣮ࢹࣉࢵ࢔ࡢࢫ例ࢆ示࣮ࣜࢡࢫࡢࡑࠋࡍࡲࡋンࡣࢺࢵࣙࢩ཰束࣮࢝ࣈ㸦ୖ左
ᅗ㸧ࠊ静的変఩㸦ୖ右ᅗ㸧ࠊ静的要素 Strain㸦ୗ左ᅗ㸧ࢱ࣮࣓ࣛࣃࠊ変更㸦ୗ右ᅗ㸧ࢆ示ࠋࡍࡲࡋ 
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Strain࣮࣋ࢺ࣮ࣞࣉࡢࢫ厚ࢺ࣮ࢹࣉࢵ࢔ࡢࡉ例 

新ࡋいࢺ࣮ࢹࣉࢵ࢔解析ࢆ実証ࡿࡍ例題ࡀ追加ࠋࡍࡲࢀࡉ 

..\examples\updating\static_strain_1  

..\examples\updating\static_strain_2  

..\examples\updating\static_strain_3  

ABAQUS࢖࣭ࢱ࣮ࢹンࢫ࢖࢙ࣇ࣮ࢱとࣂ࢖ࣛࢻ 

 Abaqus 2019ࢺ࣮࣏ࢧࡢ 
 静的変఩࡜ strain解析ࢺ࣮࣏ࢧࡢ 
 ࣮ࣔࢻ番号࡜周波数ࣞン࡟ࢪ基࡙い࢖ࢆࢻ࣮ࣔࡓン࣏࣮ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍࢺ関連ࠊ࡚ࡋ࡜SEARCH 

MODE࣐ࢥンࢆࢻ参照ࡉࡔࡃ࡚ࡋいࠋ 
 大࡞ࡁ.SIMࣝ࢖࢓ࣇ㸦10GBࢆࢬ࢖ࢧ実証㸧࢖ࢆン࣏࣮ࡼࡿࡁ࡛ࢺう࡟改善ࠋࡓࡋࡲࢀࡉ 

ANSYS࢖࣭ࢱ࣮ࢹンࢫ࢖࢙ࣇ࣮ࢱとࣂ࢖ࣛࢻ 

 ANSYS/2019R2 19.4ࢺ࣮࣏ࢧࡢ 
 RSTࡣࢲ࣮࣭ࣜࣝ࢖࢓ࣇ大ࣝ࢖࢓ࣇ࡞ࡁ㸦ILP64㸧ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆ 
 静的変఩࡜ strain解析ࢺ࣮࣏ࢧࡢ 
 ࣮ࣔࢻ番号࡜周波数ࣞン࡟ࢪ基࡙い࢖ࢆࢻ࣮ࣔࡓン࣏࣮ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍࢺ関連ࠊ࡚ࡋ࡜SEARCH 

MODE࣐ࢥンࢆࢻ参照ࡉࡔࡃ࡚ࡋいࠋ 
 ᣑ張子 DATࡣࣝ࢖࢓ࣇࡢ CDBࡌྠ࡜方法࡛᥈索ࠋࡍࡲࢀࡉ 
 FEM準ᣐࡢ場合ࠊࡣ࡟ANSYS࡟ࣂ࢖ࣛࢻ EMATWRITE࣓ࢺ࣮ࢸࢫンࢆࢺ追加ࡣࢀࡇࠋࡍࡲࡋ自動的࡟ EMAT

い࡞࠿書ࢆ ANSYS 18+࡟ࡵࡓࡢ必要ࠋࡍࡲࡾ࡞࡟警告：ansys.runࡣ EMATWRITEࢆ含࡛ࢇいࡀࡓࡋࠋࢇࡏࡲ
ࡢ既Ꮡࠊ࡚ࡗ ansys.run࡜一緒࡟ ansys.basࢆ実行ࡿࡍ場合ࠊANSYS 18+ࢆࢫࢡࢵࣜࢺ࣐࡟出力ࠋࢇࡏࡲࡋ 

 CDWRITEࡓࢀࡉࢺ࣮࣏ࢫࢡ࢚࡚ࡗࡼ࡟ ANSYS CDBࠊࡣࣝ࢖࢓ࣇᪧࣙࢪ࣮ࣂンࡢ 180文Ꮠ／ࣛ࢖ン࡜異ࡿ࡞
190文Ꮠ／ࣛ࢖ンࢆ使用ࡣࢀࡇࠋࡍࡲࡋ主࡚ࡋ࡜ HEXA8要素࢖ࡢン࣏࣮࡟ࢺ影響ࠋࡍࡲࡋCDB࣮ࣜࡢࡇࡣࢲ
長いࣛ࢖ン長ཷࢆ理࡟ࡵࡓࡿࡍ修ṇࠋࡓࡋࡲࢀࡉ 

 ࢚ࡓࢀࡉࢺ࣮࣏ࢫࢡ CDBࣝ࢖࢓ࣇ中ࡢ節点ᗙ標精ᗘࠊࡣANSYS࡟生成ࡓࢀࡉ CDB࡚ࡗࡼ࡟ࣝ࢖࢓ࣇ使用ࡉ
 ࠋࡓࡋࡲࢀࡉ変更࡟ࣝ࣋ࣞࡌྠ࡜ࡢࡿࢀ

 ANSYSࠊࡣࣂ࢖ࣛࢻ結節点ࡢ変఩ࢆࡳࡢ必要ࡿࡍ࡜場合ࠊ要素ࡢࢱ࣮ࢹ出力ࢆ回避ࠊࡋStrain出力ࢆ検知ࡲࡋ
出࡟常ࡀ力㸧ࠊ㸦Stress／Strainࢱ࣮ࢹ要素ࡃࡘ結び࡟ࣝ࢖࢓ࣇ࡞ࡁ大ࡢ必要以ୖࠊࡣ࡛ࢺ࢛ࣝࣇࢹࡢ以前ࠋࡍ
力ࠋࡓࡋࡲࢀࡉ 



      FEMtools 4 Release Notes - 79  

 ANSYSࡿࡼ࡟ࣂ࢖ࣛࢻᅽ縮 RSTࡢࣝ࢖࢓ࣇ生成ࢆ回避ࠊ࡟ࡵࡓࡿࡍ/FCOMP RST 0ࡀ実行࡟ࣝ࢖࢓ࣇ追加ࡉ
 ࠋࡍࡲࢀ

 解析結果࡚ࡋ࡜生成ࡿࢀࡉ荷重ࣝ࢖࢓ࣇ࣭ࢫ࣮ࢣ㸦inter.s***㸧ࡣ作業ࡽ࠿࣮ࣜࢺࢡࣞ࢕ࢹ削除ࠋࡍࡲࢀࡉ 

NASTRAN࢖࣭ࢱ࣮ࢹンࢫ࢖࢙ࣇ࣮ࢱとࣂ࢖ࣛࢻ 

 MSC.Nastran 2019ࢺ࣮࣏ࢧࡢ 
 静的変఩࡜ strain解析ࢺ࣮࣏ࢧࡢ 
 要素ࢺࢵࢭ定義࡟対応ࠊࡓࡲࠊ外部要素 IDࡀෆ部 IDࡣ࡜異ࡿ࡞場合ࡢ修ṇ 
 ASET1入力ࣛࣈࡢンࢺ࣮࣏ࢧࡢࢻ࣮ࣝ࢕ࣇ࣭ࢡ 
 PCOMP࣮࢝ࢻ中ࣛࣈࡢン࡟ࢡ遭遇ࡓࡋ場合࢖ࠊンࡣࢫ࢖࢙ࣇ࣮ࢱ終了࡚ࡋいࠋࡓࡋࡲ現ᅾࣛࣈࠊン࡟ࢡ遭遇

 ࠋࡍࡲࢀࡉࣉࢵ࢟ࢫࡣ場合ࡓࡋ
 ෇筒ᗙ標系ࡢ中心軸࡟近い節点࢚ࣜ࢜ࡢンࣙࢩ࣮ࢸンࡀ修ṇࡢࡇࠋࡍࡲࢀࡉ場合࢚ࣜ࢜ࠊンࣙࢩ࣮ࢸンࡣ曖昧

ࢆンࣙࢩ࣮ࢸン࢚࣭ࣜ࢜ࢺ࢛ࣝࣇࢹࠊࡋ認識ࢆ状況ࡀ許容値ࠊ࡚ࡗࡀࡓࡋࠋࢇࡏࡲࢀࡋࡶ࠿ࡓい࡚ࢀࡉ決定࡟

適用࡟ࡵࡓࡿࡍ必要ࡢࡑࠋࡍࡲࢀࡉ࡜許容値ࡣMSC.NASTRAN࡚ࡗࡼ࡟使用ࠋࡍࡲࡾ࡞࡟ࡌྠ࡜ࡢࡶࡿࢀࡉ 
 CONM1ࢺࢵࢭࣇ࢜ࡢ慣性値ࢆ備えࡓ CONM2ࡢ変換ࡢࡑࡣ慣性値࡚ࡗࡼ࡟修ṇࠋࡍࡲࢀࡉCONM節点࡟ᣑ張

 ࠋࡍࡲࢀࡉ使用࡟ࡵࡓࡢ計算ࡀ軸࣮ࣝ࢝ࣟࡢ෇筒ᗙ標系原点ࠊ場合ࡿࡍ࡜軸࣮ࣝ࢝ࣟࡓࢀࡉ
 PBEAMLࠕࡢLࠖࣙࢩࢡࢭンࡽ࠿ PBEAMࡢ࡬変換ࡣMSC.NASTRANࣜࣞ࢓ࣇンࡢࣝ࢔ࣗࢽ࣐࣭ࢫ定式ࢆ使

用࡚ࡋ再実行ࠋࡍࡲࢀࡉ以前ࡢ変換ࡾࡼṇ確࡟変換ࠋࡍࡲࢀࡉ 

SAP2000࢖࣭ࢱ࣮ࢹンࢫ࢖࢙ࣇ࣮ࢱとࣂ࢖ࣛࢻ 

 SAP2000 v20ࢺ࣮࣏ࢧࡢ 

 㸦MPE㸧࣮ࢱࢡࣛࢺࢫࢡ࢚࣭ࢱ࣮࣓ࣛࣃ࣭ࣝࢲ࣮ࣔ

 異ࡿ࡞周波数帯࣮࣏ࣝࡢ㸦極㸧値ࠊࡣRemoving unextracted pole(s)࢜ࣙࢩࣉン࡛灰色㸦࣮ࣞࢢ表示㸧ࡲࡾ࡞࡟
 ࠋࡍ

 ࢚࣮࣓ࣛࠕࢪ࣮ࢭࢵNot enough frequency lines available to compute specified model order ..㸦ࣔࡢ࣮ࢲ࣮࣭࢜ࣝࢹ
指定ࡀ୙十ศ..㸧ࠖ ࡍࢡࢵࣜࢡࢆンࢱExtract Poles࣎ࠊࡋ修ṇࢆࢢン࢕ࢸࢵࢭࠊン࢖周波数ࣛࡢࡑࠊ伴う場合ࢆ
 ࠋࡍࡲࡾ࡞࡟ࣈ࢕ࢸࢡ࢔再びࡀ実行ࡢ計算ࠊ࡚ࡗࡼ࡟࡜ࡇࡿ

 ୖ限࡜ୗ限ࣗࢹࢪࣞࡢ㸦残余値㸧ࡢ計算ࡀ追加ࠋࡍࡲࢀࡉ 
 ࣐ࢥンࢻMPE SWAPCHANNELSࡣ DSP SWAPCHANNELSࡾྲྀ࡜替えࠋࡍࡲࢀࡽ 

剛体特性࢚࣮ࢱࢡࣛࢺࢫࢡ㸦RBPE㸧 

 ࣮ࣟ࢝ࣝ軸ࡀࢺ࣮࣏ࢧࡢ追加ࠋࡓࡋࡲࢀࡉ 
 ࣮ࣟ࢝ࣝ CSࡼ࠾びࣝࣂ࣮ࣟࢢ CSࡢ使用ࢆ実証ࡢࡵࡓࡿࡍ修ṇ࣐ࢥンࢺࣉࣜࢡࢫ࣭ࢻ

 ࠋࡓࡋࡲࢀࡉ追加࡟example\rbpe\engine\..ࠊࡀ
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コ࣐ンࢻ 

新ࡋいコ࣐ンࢻ 

CLEAR TENSOR  ࢸンࢱ࣮ࢹ࣭ࣝࢯ㸦Stress／Strain㸧ࢆ削除ࠋࡍࡲࡋ 
DSP SWAPCHANNELS  以前ࠊࡣMPE SWAPCHANNELS࡛ࠋࡓࡋ  
EXTRACT TENSOR  Stressࡣࡓࡲ Strainࢸンࢆࢱ࣮ࢹ࣭ࣝࢯ示ࠋࡍࡲࡋ 

GENERATE TRACELINE  自動的࢖࣏࡟ンࢺ群中࢖࣏ࡢンࢺ間࢖ࣛࢫ࣮ࣞࢺ࡟ンࢆ生成ࡋ

ࠊ最ᑠ角ᗘࡢン࢖ࣛࢫ࣮ࣞࢺ㸦ࢢン࢕ࢸࢵࢭࡢ࠿ࡘࡃいࠋࡍࡲ

ࣂ࣮࢜ࡢン࢖ࣛࢫ࣮ࣞࢺࠊࡣ㸧࡝࡞最大距離ࡢン࢖ࣛࢫ࣮ࣞࢺ

 ࠋࡍࡲࢀࡉ利用࡟ࡵࡓࡿࡍ回避ࢆࣉࢵ࣮ࣛ

SET CUSTOM COLORMAP  ࣮࣭࢝ࣛࢻ࣮ࢥ化ࢆࢺࢫ࣭࣮ࣜࣛ࢝ࡢࡵࡓࡢ指定ࣛ࢝ࠋࡍࡲࡋ

ࡣࡓࡲ標準色ࣛ࣋ࣝࡣ࣮ RGB࡚ࡗࡼ࡟ࢺࢵࣞࣉࣜࢺ表わࢀࡉ
 ࠋࢇࡏࡲࢀࡋࡶ࠿ࡿ

例：࢝ࣉࢵ࣐࣮࣭࣒ࣛ࢝ࢱࢫ㸦黒褐色：0 250 240㸧 

STRAIN  

 

要素 Strainࢆ計算ࠋࡍࡲࡋ 

修正さࢀたコ࣐ンࢻ 

EXAMINE MEF  新ࡋい補語 KEEPࠊALLࠊSETࡀ追加ࠋࡓࡋࡲࢀࡉ  
EXPAND  ࢩンࢫࢡࢵࢱ変更ࡾࡼࠊヲ細ࡢࣉ࣮࢙ࢩࢻ࣮࣭ࣔࢺࢫࢸࠕࠊࡣᣑ

張ࠖࢆ参照ࡉࡔࡃ࡚ࡋいࠋ 

GENERATE CONVERT  QUADࡢ一次要素ࡽ࠿஧次要素ࡢ࡬変換࢖ࣛࢫ࣮ࣞࢺࠊンࡽ࠿
2D要素ࡢ生成ࡢ機能ࡀ追加ࠋࡓࡋࡲࢀࡉ 

MATRIX  新ࡋい補語 XLABEL࡜ YLABELࡀ追加ࠋࡓࡋࡲࢀࡉ  
MESH  新ࡋい補語： 

ROUNDING boolean_val 

INTERVAL int_val 

FOLLOW boolean_val  

CMAP CUSTOM：࢝ࡣࣉࢵ࣐࣮࣭࣒ࣛ࢝ࢱࢫ SET CUSTOM 
COLORMAP PAIR࡛指定ࠋࡍࡲࢀࡉ 

PAIR –int_val：࣮ࣔࡢࣉ࣮࢙ࢩࢻ ࡟ࡘ1 180ᗘࡢ఩相ࢆࢺࣇࢩ適
用࡟ࡵࡓࡿࡍ使用ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 

MESH MARK ELEMENT ECS：要素ᗙ標系࣐࣮࣮࢝ࢆ追加ࡲࡋ
 ࠋࡍ

TENSOR：࣓ࢸࡢୖࣗࢩࢵンࢆࢱ࣮ࢹ࣭ࣝࢯ写像ࠋࡍࡲࡋ 
SEARCH   STRAIN࡜ STRESSࠋࡓࡋࡲࢀࡉࢺ࣮࣏ࢧࡀ 
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SEARCH MODE  補語[int_val1[TO int_val2]]࡜ BETWEEN freq1 freq2ࡀ ANSYS
びࡼ࠾ ABAQUS࢖ンࠋࡍࡲࢀࡉࢺ࣮࣏ࢧ࡛ࢫ࢖࢙ࣇ࣮ࢱ㸦以
前ࠊࡣNASTRANࠋࡓࡋ࡛ࢺ࣮࣏ࢧࡢࡳࡢ㸧 

RESPONSE STRAIN  新ࡋい引ࡁ数ࡀ追加ࠋࡓࡋࡲࢀࡉ 

SET STATIC  ࢩンࡀࢫࢡࢵࢱ修ṇࠋࡓࡋࡲࢀࡉ 

STRESS  ࢩンࡀࢫࢡࢵࢱ修ṇࠋࡓࡋࡲࢀࡉ 

TABLE  補語 TENSORࡀ追加ࠋࡓࡋࡲࢀࡉ  

削除さࢀたコ࣐ンࢻ 

 PRETEST FRF࣐ࢥンࡣࢻ DEFINE FRFSࡾྲྀ࡜替えࠋࡍࡲࢀࡽ 
 CLEAR STRESS࣐ࢥンࡣࢻ CLEAR TENSORࡾྲྀ࡜替えࠋࡍࡲࢀࡽ 

FEMtoolsࢺࣉࣜࢡࢫ 

ENCODE࣐ࢥン࢚࡛ࢻンࠊࡣࢺࣉࣜࢡࢫ࣭࣒ࣛࢢࣟࣉࡿࢀࡉࢻ࣮ࢥᣑ張子࡞ࡢいࢆࣝ࢖࢓ࣇ Include࣓ࢺ࣮ࢸࢫン
 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ指定࡛ࢺ

࢚ンࠊࡣࢲ࣮ࢥincludeࢫࣃ中ࢆ᥈索ࠊࡋINCLUDEPATH補語࡛指定࣐ࢥࡓࢀࡉンࡢࢻᣑ張子 BASあࡿいࡣ EBAࢆ
備えࢆࣝ࢖࢓ࣇࡓ᥈索ࠋࡍࡲࡋ 

ᪧࣙࢪ࣮ࣂン࡛ࠊࡣᣑ張 BASあࡿいࡣ EBA࡛含ࢆࣝ࢖࢓ࣇࡓࢀࡲ指定ࠋࡓࡋ࡛ࢇࡏࡲࡾ࡞ࡤࢀࡅ࡞ࡋ 

FEMtools API 

新ࡋい FEMtools API関数 

いࡋ新ࡣンࣙࢩࢡࢭࡢࡇ FEMtools API関数ࡘ࡟い࡚記述ࠋࡍࡲࡋ 

Ft_GetMatrix  ࣐ࢆ࢕ࢸࣃࣟࣉ࣭ࢫࢡࢵࣜࢺ返ࡍࡲࡋ 
Ft_GetObject   ࣈ࢕ࢸࢡ࢔ OLE࣮࢜ࣙࢩ࣮࣓ࢺン㸦ActiveX㸧࢜ࣁ࡟ࢺࢡ࢙ࢪࣈンࢆࣝࢻ

返ࠋࡍࡲࡋ 

Ft_GetShapeData  個々ࢆ࢕ࢸࣃࣟࣉ࣭ࣉ࣮࢙ࢩࡢ返ࠋࡍࡲࡋ 

Ft_GetShapeProp  ࢆ࢕ࢸࣃࣟࣉ࣭ࣉ࣮࢙ࢩ࣭ࣝࣂ࣮ࣟࢢ返ࠋࡍࡲࡋ  
Ft_GetWindows   ࡢࡇ関数ࡣ機能別࡟ Ft_GetGraphicࠊFt_GetTableࠊFt_GetEditorࡢ関数ࢢ࡟

 ࠋࡍࡲࡋ化ࣉ࣮ࣝ

Ft_MatrixCommand ࣐ࢫࢡࢵࣜࢺ演算࡟使用ࡢࡇࠋࡍࡲࢀࡉ新ࡋい関数ࠊࡣFt_NewMatࠊ 

Ft_DelMatࠊFt_GetMatListࠊFt_MatExistsࠊFt_GetMatࠊFt_PutMatࠊ
Ft_MatSizeࡢ࡝࡞古い API関数࡜重複ࠋࡍࡲࡋ 

 ࠋࡍࡲࢀࡉ推奨ࡀ使用ࡢ関数ࡋ新ࡣ࡟ࡵࡓࡢ互換性ࡢࡑ

Ft_SetMatrix  ࣐ࢆ࢕ࢸࣃࣟࣉ࣭ࢫࢡࢵࣜࢺ設定ࠋࡍࡲࡋ 

Ft_SetShapeData  個々ࢆ࢕ࢸࣃࣟࣉ࣭ࣉ࣮࢙ࢩࡢ設定ࠋࡍࡲࡋ  
Ft_SetShapeProp  ࢆ࢕ࢸࣃࣟࣉ࣭ࣉ࣮࢙ࢩ࣭ࣝࣂ࣮ࣟࢢࡣ設定ࠋࡍࡲࡋ   
Ft_SetWindows   ࡢࡇ関数ࡣ機能別࡟ Ft_GetGraphicࠊFt_GetTableࠊFt_GetEditorࡢ関数ࢢ࡟

 ࠋࡍࡲࡋ化ࣉ࣮ࣝ
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以ୗࡢ関数ࢸࡣン࡟ࣝࢯ関ࡿࡍ新ࡋいࡣࡽࢀࡑࠋࡍ࡛ࢫࣛࢡ Strain࡜ Stressࢆࢱ࣮ࢹࡢ格納࡟ࡵࡓࡿࡍ使用ࡲࢀࡉ
 ࠋࡍ

Ft_ClearTensor  ࢸンࣝࢯ㸦Strainࡣࡓࡲ Stress㸧ࢆ削除ࠋࡍࡲࡋ 
Ft_DefTensor  ࢸンࣝࢯ㸦Strainࡣࡓࡲ Stress㸧ࢆ定義ࠋࡍࡲࡋ 

Ft_GetTensor  ࢸンࣝࢯ㸦Strainࡣࡓࡲ Stress㸧ࢆ返ࠋࡍࡲࡋ 

Ft_GetTensorComp  ࡢࢻࢵࣜࢯࡣࡓࡲ࢙ࣝࢩ Face࡟関ࢸࡿࡍンࣝࢯ構成要素値ࢆ返ࠋࡍࡲࡋ 

Ft_GetTensorCS  ࢸンࡢࣝࢯ 3x3変換࣐ࢆࢫࢡࣜࢺ返ࠋࡍࡲࡋ 

Ft_GetTensorData  特定࢖ンࢫࢡࢵࢹ㸦࣮ࣟࢻ࣮ࣔࡣࡓࡲࢫ࣮ࢣ࣭ࢻ㸧ࢸࡢンࢆࢱ࣮ࢹ࣭ࣝࢯ

返ࠋࡍࡲࡋ  
Ft_GetTensorProp  ࢸンࣝࢯ特性ࢆ返ࠋࡍࡲࡋ 

Ft_MoveTensor  ࢸンࢆࣝࢯ改ྡࠋࡍࡲࡋ  
Ft_PutTensor  既Ꮡࢸࡢンࢆࣝࢯ交換ࠋࡍࡲࡋ 

Ft_PutTensorCS  Ft_PutTensorCSࡣ要素ࣜ࡟ࢺࢫ変換࣐ࢫࢡࣜࢺ㸦3x3㸧ࢆ割ࡾ当࡚ࠋࡍࡲ
ෆ部࢚࢜ࣜンࣙࢩ࣮ࢸン࣭࣐ࡣࢫࢡࢵࣜࢺ四元数࡚ࡋ࡜格納ࠋࡍࡲࢀࡉ 

Ft_SetTensorData  定࢖ンࢫࢡࢵࢹ㸦࣮ࣟࢻ࣮ࣔࡣࡓࡲࢫ࣮ࢣ࣭ࢻ㸧ࢸࡢンࢆࢱ࣮ࢹ࣭ࣝࢯ設

定ࠋࡍࡲࡋ 

Ft_SetTensorProp  ࢸンࣝࢯ特性ࢆ設定ࠋࡍࡲࡋ 
Ft_SetupTensor  複数఩置ࡼ࠾びࢸ࡟࣮ࣂ࢖࢓ࣇンࡀࣝࢯᏑᅾࢆ࡜ࡇࡿࡍ明示ࠋࡍࡲࡋ 

Ft_SetupTensorCS  複数఩置ࡼ࠾びࢸࡀ࣮ࣂ࢖࢓ࣇン࢚࣭ࣜ࢜ࣝࢯンࣙࢩ࣮ࢸンࢆ持ࢆ࡜ࡇࡘ

明示ࠋࡍࡲࡋ 

Ft_TensorCount  ࢸン࡟ࣝࢯ格納ࢻ࣮ࣔࡣࡓࡲࢫ࣮ࢣ࣭ࢻ࣮ࣟࡓࢀࡉ数ࢆ返ࠋࡍࡲࡋ 

修正さࢀた FEMtools API関数 

ࡢ࡛ࢫ࣮ࣜࣜࡢࡇࠊࡣンࣙࢩࢡࢭࡢࡇ FEMtools API関数ࡢ変更点ࡘ࡟い࡚記述ࠋࡍࡲࡋ 

Ft_ConvertElements  新ࡋい補語ࠕlintoquad 変ࡢ࡬஧次要素ࡽ࠿一次要素ࠊࡣtracetosurfࠖࠕࠊࠖ
換࢖ࣛࢫ࣮ࣞࢺࠊンࡽ࠿ 2D要素ࢆ生成࡟ࡵࡓࡿࡍ追加ࠋࡓࡋࡲࢀࡉ変換
ࡣ数ࡢࣉ࢖ࢱ quadtolinࠕࠊ࡚ࡋ࡜補語ࡢ௚ࡢࡑࠊࢀࡉࡽ減࡟5 ࠊࠖ
quadtotriaࠕ  ࠋࡓࡋࡲࢀࡉ追加ࡀsurftoline2ࠖࠕࠊࠖ

Ft_Set/GetForm  属性ࠕnotificationlevelࠖ追加ࡢࡇࠋࡓࡋࡲࢀࡉ属性ࡣ全形式࡟当࡚ࡲࡣ
࡛ࡀ࡜ࡇࡃ࠾࡚ࡋ࡟ࢡンࣛࣈࡣྡ࣮ࣝࣟࢺンࢥࠊ࡚ࡗࡀࡓࡋࠋࡍࡲࡾ

 ,"")Ft_SetForm "", "notificationlevel", ival = Ft_GetFormࠋࡍࡲࡁ
"notificationlevel")  
if ival >= 1：任意஦象+ࣜཷࢆࢪ࣮ࢭࢵ࣓࣭ࣗࢩࢵࣞࣇ理ࢀࡇࠋࡍࡲࡋ
 ࠋࡍ࡛ࢺ࢛ࣝࣇࢹࡣ
ival >=2：更新ཷࢆࢪ࣮ࢭ࣮࣮࣓࣭ࢡࢵ࢕ࣇࣛࢢ理ࠋࡍࡲࡋ 

Ft_GetGraphic   新ࡋい属性："rounding", "intervals", "follow" 

ヲ細ࠕࡣ環境変数ࠖࢆ参照ࡉࡔࡃ࡚ࡋいࠋ 

 ࠋࡓࡋࡲࢀࡉ追加ࡀ ”ylabel“ ࡜ ”い属性 “xlabelࡋ新ࡿࡍ関࡟ࢫࢡࢵࣜࢺ࣐
Ft_GetRespProp  Ft_GetResponse࡟対応ࡿࡍ FEA࣏ࣞࢫンࢫ特性ࢆ検索ࠊ࡟ࡵࡓࡿࡍ㈇࢖ࡢ

ンࡣࢀࡇࠋࡍࡲࢀࡉࢺ࣮࣏ࢧࡀࢫࢡࢵࢹ擬似荷重感ᗘࢆ検索ࢯ࡟ࡵࡓࡿࡍ

 ࠋࡍࡲࢀࡉ中࡛使用ࣂ࢖ࣛࢻ࣭࣮ࣂࣝ

௚ࡢ変更：Ft_SetRespPropࢆ参照ࡉࡔࡃ࡚ࡋいࠋ 
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Ft_GetRespStrain  補語ࡢ追加ࠊ࡚ࡗࡼ࡟Face࡜ dirࢥࡀン࣏࣮ࢿンࡾྲྀ࡜ࢺ替えࡋࡲࢀࡽ
ࡢ両方ࡀdir補語ࠊࡣ以前ࠋࡓ Strainࢥン࣏࣮ࢿン࡜ࢺ Face࡟ࡵࡓࡢ使用
 ࠋࡓࡋࡲࢀࡉ

 ࢫࢡࢵࢱンࢩ
 
Ft_GetRespStrain i, id, elem, dir, component, face, csid 

Ft_Import  “strain” ࡜ “stress” ࡟関ࡀࢺ࣮࣏ࢧࡿࡍ追加ࠋࡓࡋࡲࢀࡉ 

Ft_SendGraphicCommand  新ࡋい補語"capture "ࣉࣕ࢟ࡓࡲࠊࡵࡓࡿࡍ࣮ࣕࢳࣉࣕ࢟ࢆࢡࢵ࢕ࣇࣛࢢࡀ
 ࠋࡓࡋࡲࢀࡉ追加࡟ࡵࡓࡃ開ࢆ࣮ࣝࢶ࣭࣮ࣕࢳ

 い属性ࡋ新ࡿࡍ࣮ࣝࣟࢺンࢥࢆンࣙࢩ࣮࣓ࢽ࢔࣭ࣉࢵࢸࢫ

"step.suspend"：ࣙࢩ࣮࣓ࢽ࢔ン࣭ࢆ࣮࣐࢖ࢱ保留ࠊࡾࡼ࡟࡜ࡇࡿࡍ現ᅾࡢ
 ࠋࡍࡲࡋ凍結ࢆ࣒࣮ࣞࣇン࣭ࣙࢩ࣮࣓ࢽ࢔

"step.resume"：保留࡚ࢀࡉいࣙࢩ࣮࣓ࢽ࢔ࡿンࢆ再開ࠋࡍࡲࡋ 

"step.backward"：表示ࢆ࣒࣮ࣞࣇ戻ࠋࡍࡲࡋ 

"step.forward"：表示ࢆ࣒࣮ࣞࣇ進ࠋࡍࡲࡵ 

"step.first"：最初ࡢ表示ࠋࡍࡲࡋࣉࢵ࢟ࢫ࡟࣒࣮ࣞࣇ 

"step.last "：最後ࡢ表示ࠋࡍࡲࡋࣉࢵ࢟ࢫ࡟࣒࣮ࣞࣇ 

新ࡋい補語"tracker.move"ࡀ Ft_SetGraphic࡛指定ࡓࢀࡉ新ࡋい఩置ࢸࢡ࢔࡟
 ࠋࡓࡋࡲࢀࡉ追加࡟ࡵࡓࡿࡏࡉ移動ࢆ࣮࢝ࢵࣛࢺࣈ࣮࢝ࣈ࢕

Ft_SetGraphic   新ࡋい属性: "rounding", "intervals", "follow" 
 ࠋいࡉࡔࡃ࡚ࡋ参照ࢆ環境変数ࡣヲ細ࡢࡽࢀࡑ

属性"tracker "：値 ࡟ࣈ࢕ࢸࢡ࢔ࢆン中心㸧ࣆࡢ㸦回転ࢻン࣭࣮ࣔࣆࡣ15
 ࠋࡍࡲࢀࡉ追加࡟ࡵࡓࡿࡍ

  "い属性："xlabel", "ylabelࡋ新ࡢࡵࡓࡢࢺࢵࣟࣉ࣭ࢫࢡࢵࣜࢺ࣐
Ft_SetRespProp  RD_DIRECTIONࡶ使用࡛ࠊࡀࡍࡲࡁ次ࡼࡢうࢥ࡟ン࣏࣮ࢿンࢺ+Faceࢆ組

 ࠋࡍࡲࡏ合わࡳ

direction = (face1)*3+component  

RD_COMPONENTࡣ Strainࢥン࣏࣮ࢿンࢺ㸦SX=1ࠊSY=2ࠊTXY=3㸧 

RD_FACEࠊࡣStrain要素 Face㸦TOP=1ࠊBOTTOM=2ࡢࢻࢵࣜࢯࠊ Face㸧
 ࠋࡍࡲࢀࡉ使用࡟ࡵࡓࡿࡍ設定ࢆ

Ft_ShowDialog  "IMPORT_FEA_STRAIN" & "IMPORT_FEA_STRESS"ࡀ追加ࠋࡓࡋࡲࢀࡉ 

࡜Strainࠊࡽ࠿࣮ࣗࢽ࣓ࢺン࣏࣮࢖ࡣࢀࡇ Stressࢸࡢン࢖ࡢࣝࢯン࣏࣮ࢺ
 ࠋࡍࡲࢀࡉ使用࡟ࡵࡓࡿࡍ࡟能ྍࢆ
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Ft_Parseࡢコ࣐ン࣭ࣝ࣋ࣞࢻ応答ࢺ࣮࣏ࢧࡢ 

ࡍ返ࢆ番号࣭ࣝ࣋ࣞࢻン࣐ࢥ Ft_Parse関数࡟属性“level”ࡀ追加ࠋࡓࡋࡲࢀࡉ 

Ft_Parse "level", iLevel  

ࣞ࣋ࣝ番号ࡣ iLevel࣮ࢱࣜ࡟ンࠋࡍࡲࢀࡉ 

ࡣiLevelࠊ場合ࡢࢻン࣐ࢥ࣭࣮ࣝࢯンࢥ  ࠋࡍ0࡛

 階ᒙ+1㸧ࣝ࢖࢓ࣇ࣭ࢻン࣐ࢥ場合㸦ࡢࣝ࢖࢓ࣇ࣭ࢻン࣐ࢥ：0 <

 場合㸦Ft_Command㸧ࡢ࣒ࣛࢢࣟࣉ：0 >

例 

次࢕ࢸࢵࢭࡢࡑࠊࡣࢻ࣮ࢥࡢンࡢࢢ指定方法ࢆ示࣐ࢥࠊࡋンࢻ SET REDUCTION࣐ࢥࡀン࢖ࣛࢻンࡽ࠿出ࡿࢀࡉ
場合ࢥࠊン࣮ࣝࢯ中࡟出力ࠋࡍࡲࢀࡉ 

…  ft_parse "level", level  if level = 0 then    'Print output  

    iSilent = Ft_GetInt("console.silent")  

    If bHasSilent = True Then Ft_PutInt "console.silent", 1     Ft_Report "title", "REDUCTION SETTINGS :"  

    If (bHasSolver = True Or bNoComplements = True) Then _   

       Ft_Report "text", "Solver                : " & sSolver  

    If (bHasMethod = True Or bNoComplements = True) Then _  

       Ft_Report "text", "Method                : " & sMethodList(iMethod)  

    If (bHasFrequency = True Or bNoComplements = True) Then _  

       Ft_Report "text", "Frequency             : " & dFrequency     If (bHasIterations = True Or bNoComplements 
= True)  Then _  

       Ft_Report "text", "Number of iterations  : " & nIteration  

    If (bHasCore = True Or bNoComplements = True) Then _  

       Ft_Report "text", "Core                  : " & sCoreList(iCore+1)  

    Ft_PutInt "console.silent", iSilent  end if …  

[extract from script set_reduction.bas]  

定数 

RT_STRAIN㸦=13㸧࣏ࣞࢫンࠊࡣࣉ࢖ࢱ࣭ࢫFEMtools定数࡚ࡋ࡜定義ࠋࡍࡲࢀࡉ 
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環境変数 

 ࢢンࣜࢺࢫと࣮ࣛ࢝ࢫ

mesh.contour.rounding  BOOLEAN  

NOTࡀ設定ࡿࢀࡉ場合ࠊtrue min/max値ࡣ中間値࣮࢝ࣛࢥ࡛ࡋ࡞ン࣮ࢱ表示
 ࠋࡍࡲࢀࡉ

࠾࡜ࡢ次ࡣ修ṇ部ศࠋࡍࡲࢀࡉ中࡛設定ࣝ࢖࢓ࣇINIࠊࡣ値ࢺ࢛ࣝࣇࢹࡢࡑ
 ࠋࡍ࡛ࡾ

MESH .... ROUNDING boolean_val ....  

ࡶ࡜ࡇࡿࡍ使用ࢆ"Ft_Set/GetGraphic: "roundingࠊࡣ࡟ࡿࡍࢫࢭࢡ࢔࡟値ࡢࡇ
 ࠋࡍࡲࡁ࡛

mesh.contour.intervals  INTEGER  

࡞ࢀࡉ使用ࡀ補間㸦rounding㸧ࠋࡍࡲࡋ指定ࢆ表示間隔数ࡢࢻ࣮࣮ࣔࢱンࢥ
い場合㸦mesh.contour.rounding=false㸧ࠊ使用ࣂࡿࡍンࡢࢻṇ確࡞数ࡣ指定ࡉ
 ࠋࡍ࡛ࡁ࡭ࡿࢀ

࠾࡜ࡢ次ࡣ修ṇ部ศࠋࡍࡲࢀࡉ中࡛設定ࣝ࢖࢓ࣇINIࠊࡣ値ࢺ࢛ࣝࣇࢹࡢࡑ
 ࠋࡍ࡛ࡾ

MESH .... INTERVAL int_val .... 

 ࠋࡍ16間隔࡛ࠊࡣ最大値ࡢࡑ

ࡶ࡜ࡇࡿࡍ使用ࢆ"Ft_Set/GetGraphic: "intervalsࠊࡣ࡟ࡿࡍࢫࢭࢡ࢔ࢆ値ࡢࡇ
 ࠋࡍࡲࡁ࡛

mesh.contour.animation  BOOLEAN  

 ࠋࡍࡲࡋ明示࠿う࡝࠿ࡿࡏࡉ対応࡟変形振幅ࢆ࣮࣭࣮ࣛ࢝ࢱンࢥ

࠾࡜ࡢ次ࡣ修ṇ部ศࠋࡍࡲࢀࡉ中࡛設定ࣝ࢖࢓ࣇINIࠊࡣ値ࢺ࢛ࣝࣇࢹࡢࡑ
 ࠋࡍ࡛ࡾ

MESH ..... FOLLOW boolean_value .....  

FOLLOWࠊࡣANIMATE࡜矛盾࡞ࡋいࡼう࡟使用ࠋࡍࡲࢀࡉ 

 ࠋࡍࡲࢀࡉ適用࡟両方ࡢࣉ࣮࢙ࢩ複素数ࡣࡓࡲࣉ࣮࢙ࢩ実数ࡣࢀࡑ

節点࣐࣮࣮࣭࣮࢝ࣔࡢࢻ場合ࣙࢩ࣮࣓ࢽ࢔ࡣ࣮࣭࣮࣮࣐ࣛ࢝࢝ࡢࡑࠊン振幅

ࡇࡿࡏࡉ移動࡟࠿ࡎわࢆࡽࢀࡑ操作࡛ࢢン࢟ࢵࣆࡢ࣮࣮࣐࢝ࠋࡍࡲࡋ対応࡟

 ࠋࡓࡋࡲࢀࡉ改善ࡀ表示処理ࢺࢫࣛࢺンࢥࡢࣗࢩࢵ࣓ࡿࡼ࡟࡜

࡛ࡶ࡜ࡇࡿࡍ使用ࢆ"Ft_Set/GetGraphic: "followࠊࡣ࡟ࡿࡍࢫࢭࢡ࢔࡟値ࡢࡇ
 ࠋࡍࡲࡁ
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graphic.customcolormap.colornn  HEXADECIMAL  

及ぶ࡟16～01ࠊ࡚ࡋ࡜ࢫࢡࢵࢹン࢖ࡢࣉࢵ࣐࣮࣭࣒ࣛ࢝ࢱࢫ࢝ nnࢆ指定ࡋ
ࢫ࢝ࡢࡇ࡟場合ࡿい࡚ࢀࡉ設定࡟ࢻ࣮࣭ࣔࢻンࣂࡀmesh.contour.styleࠋࡍࡲ
 ࠋࡍࡲࢀࡉ使用ࡀࣉࢵ࣐࣮࣭࣒ࣛ࢝ࢱ

例 

graphic.customcolormap.color01=FF0000 
graphic.customcolormap.count  INTEGER  

ࣛ࢝ࡢࡃ多ࡾࡼࠋࡍࡲࡋ指定ࢆ数ࢻンࣂ࣭࣮ࣛ࢝ࡢࣉࢵ࣐࣮࣭࣒ࣛ࢝ࢱࢫ࢝

 ࠋࡍࡲࢀࡉ使用࡟場合ࡿࡍ指定ࢆ࣮
graphic.antialiaslimit  INTEGER  

࡜ࡇࡃ引࡟効率的࡛ࢢンࢩ࢔ࣜ࢖࢚ࢳン࢔࡟前ࡿ変わ࡟ࢢンࣜࣉンࢧࢳ࣐ࣝ

ࡿࡁ࡛ࡀ wireframe線ศࡢ最大ࡢ数ࢆ指定ࠋࡍࡲࡋ 

 8192=ࢺ࢛ࣝࣇࢹ
Ilp64  BOOLEAN  

FEMtoolsࡢ࣮ࣂࣝࢯ ILP64࣮ࣔࢥࢆࢻンࠋࡍࡲࡋ࣮ࣝࣟࢺ  
static.strain  静的 Strainࡢ計算ࢥࢆンࠋࡍࡲࡋ࣮ࣝࣟࢺ 

static.stress  静的 Stressࡢ計算ࢥࢆンࠋࡍࡲࡋ࣮ࣝࣟࢺ  

INI変数 

修正さࢀた設定 

mesh.contour.banded=Yes  

新ࡋい設定  

mesh.contour.rounding=No mesh.contour.intervals=16 
mesh.contour.animation=No graphic.customcolormap.color01=FF0000 
graphic.customcolormap.color02=FF8080 
graphic.customcolormap.color03=FFFFFF 
graphic.customcolormap.color04=8080FF 
graphic.customcolormap.color05=0000FF graphic.customcolormap.count=5 
graphic.antialiaslimit=8192 graphic.mode=1  

削除さࢀた設定 

static.strfield static.master 
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FEMtools 4.1.1ࡢ概要 

FEMtools 4.1.1ࠊࡣいࡢ࠿ࡘࡃ機能ᣑ張ࡼ࠾びࢢࣂ修ṇࢆ伴う࣓ンࢼࢸンࣙࢪ࣮ࣂ࣭ࢫ࣮࣭ࣜࣜࢫン࡛ࠋࡍ 

 構成、ࢫンࢭ࢖ࣛ、ンࣙࢩ࣮ࣞࢺࢫン࢖

 ンࣙࢩ࣮ࣞࢺࢫン࢖

 ࢖ンࣙࢩ࣮ࣞࢺࢫン手⥆࡟ࡁ関࣒ࢸࢫࢩࡿࡍ必要条件ࡘ࡟い࡚ࠊ前ࣙࢪ࣮ࣂンࡽ࠿変更ࡣあࠋࢇࡏࡲࡾ 
 View File࣎ࢱンࡀWindows࢖ンࢭ࢖ࣛࡢ࣮࣮ࣛࢺࢫン࡟ࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ࣭ࢫ追加ࢹࡣࢀࡇࠋࡓࡋࡲࢀࡉ

ࢺ࢛ࣝࣇ PDFࡢ࢔࣮ࣗࣅ PDFࣝ࢖࢓ࣇ dds_sla.pdfࢆ開ࠊࡁ必要࡟応ࣜࣉ࡚ࡌンࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍࢺ 
 Microsoftࣟࢦ必要条件࡟対応ࡢ࡚࡭ࡍࠊࡵࡓࡿࡍ FEMtools EXEࠊDLLࡼ࠾ࣝ࢖࢓ࣇび࢖ン࣮࣮ࣛࢺࢫEXEࡣ

ࡢ࢕ࢸࣜࣗ࢟ࢭࡢ最高ࠊ従い࡟㸧ࢫンࢭ࢖㸦ࣛࢢンࢽ࢖ࢧࢻ࣮ࢥ࣭ࣝࢱࢪࢹ SHA256ࢆ࣒ࢬࣜࢦࣝ࢔使用ࡲࡋ
 㸧ࡳࡢンࣙࢪ࣮ࣂ㸦Winndowsࠋࡍ

 ࢫンࢭ࢖ࣛ

 ࣮࣑ࣟンࢭ࢖࣭ࣛࢢンࡢࢫ期限㸦残ࡢࡾ᪥数㸧࡟ࢀࡇࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍࢡࢵ࢙ࢳࢆ関ࢡࢵ࣎ࢡࢵ࢙ࢳࡿࡍ

ࡣ期限ࡢࡑࠋࡓࡋࡲࢀࡉ追加࡟ࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲFEMtools License Configurator - Roaming Licensesࠊࡀࢫ
最終᪥ࡢ真夜中ࢆ࡛ࡲ意味࡟࡜ࡇࡿࡍ注意ࡉࡔࡃ࡚ࡋいࠋ 
 

 

コ࣐ン࢖ࣛࢻン࣭ࢱ࣮࣓ࣛࣃ࣭ࣉࢵ࢔ࢺ࣮ࢱࢫ 

 -e࣐ࢥン࢖ࣛࢻン࣭ࡢࢱ࣮࣓ࣛࣃ指定ࢭ࢖ࣛࠊ࡚ࡗࡼ࡟ンࢡࢵ࢙ࢳࡢࢫ後ࣝ࢖࢓ࣇ࣭ࢺࢡ࢙ࢪࣟࣉ࡟㸦ࡋࡶ指
定ࡤࢀࢀࡉ㸧ࢻ࣮ࣟࢆ後ࣉࢵ࢔ࢺ࣮ࢱࢫࠊ時࡟実行ࡿࢀࡉ FEMtools࣐ࢥンࢆࢺࣉࣜࢡࢫࡣࡓࡲࢻ実行ࡇࡿࡍ
 ࠋࡓࡋࡲࡋࡇ起ࡁ引ࢆ࣮࢚ࣛ࡟使用時ࡢࢻン࣐ࢥࡢࡇࡣン࡛ࣙࢪ࣮ࣂ前ࠋࡍࡲࡁ࡛ࡀ࡜
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 ンࣙࢩ࣮ࢸキ࣓ࣗンࢻ

FEMtools࣓ࣗ࢟ࢻンࣙࢩ࣮ࢸン࡟ࢫ࣮ࣜࣜࡢࡇࡀ伴い更新ࠋࡓࡋࡲࢀࡉ 

例題ࡢ更新 

 新ࡋい例題ࠊ࡚ࡋ࡜PARAMETER MATERIAL࣐ࢥンࢆࢻ実証ࠊࡀࢺࣉࣜࢡࢫࡢࡵࡓࡿࡍ
\examples\updating\disk_modal࡟追加ࠋࡓࡋࡲࢀࡉ 
 
run08_material_sensitivity.cmd  
run08_material_updating.cmd 
 

 新ࡋい例題..\dynamics\selem\nastran_op4：NASTRAN Ouput4ࡢࣝ࢖࢓ࣇ使用࣮ࣃ࣮ࢫࠊࡋ要素࣐ࡢࢫࢡࢵࣜࢺ
 ࠋࡍࡲࡋ実証ࢆࢺン࣏࣮࢖

 例題ࡢ\dynamics\selem\nastranࡀ\dynamics\selem\nastran_dmigࠋࡓࡋࡲࢀࡉ࣒࣮ࢿࣜ࡟ 

FEMtools࣒࣮ࣞࣇワ࣮ࢡ 

 ࣗࢩࢵ࣓

 ศ離ࡢࢻࢵࣜࢯࡓࢀࡉ஧次要素ࢆ一次要素࡟変換ࡿࡍ場合ࡢ処理ࡀ修ṇࠋࡓࡋࡲࢀࡉ前ࣙࢪ࣮ࣂン࡛ࣜࣇࠊࡣ

 ࠋࡓࡋࡲࡾあࡀ㸦ศ離㸧問題ࢪࢵ࢚࣮

 ࣝࣈ࣮ࢸ

 ᗙ標系㸦CS: Coordinate Systems㸧ࡢࣝࣈ࣮ࢸ編集࠾࡟い࡚ࠊCSࢆ追加࡜ࡿࡍ対象ࣕࢪ࡟ࣈࢱンࠋࡍࡲࡋࣉ
㸦例： 3ࢆࣈࢱ࣭ࢻ࣮ࣀࡢࡘ指定ࡢࡘ9ࠊࡋ CSࢆ追加ࠊ࡜ࡿࡍあ࡚ࡵࡓࡽ 㸧以前ࠋࡍࡲࢀࡉ表示ࡀࣈࢱࡢࡘ9
 ࠋࡓࡋࡲ見え࡟うࡼい࡞い࡚ࢀࡉ更新ࡀࣝࣈ࣮ࢸCSࠊࡣ

 ᗙ標系㸦CS㸧࡟参照ࡀ付ࡓࢀࡽࡅ FEࢻ࣮ࣀあࡿいࡣ測定࣏࢖ンࢆࢺ削除ࡓࡋ場合ࡢࡑࠊ対象 CSࡶ削除ࢀࡉ
 ࠋࡍࡲ

 ࡼ࠾ࢻ࣮ࣀࡢ࡚࡭ࡍび࣏࢖ンࢻ࣮ࣝ࢕ࣇ࣭ࢺ㸦ࠊࢻ࣮ࣀ要素࢖࣏ࠊࢫ࣮ࣞࢺࠊン࢖࣏ࢻ࣮ࣀࠊࢺンࢸ࣭࢔࣌ࢺ

ࡢ整数ࢺࢵࣅ10桁㸦32ࠊࡣࢺࢵ࣐࣮࢛ࣇࡢ㸧ࣝࣈ࣮ 2＾32㸧ࠋࡍࡲࡾ࡞࡟ 

 ࢫࢡࢵ࢕ࣇࣛࢢ

 NVidia࣮࢝ࡼ࠾ࢻびࣙࢪ࣮ࣂ࣭ࣂ࢖ࣛࢻンࢆ備えࢫࢡࢵ࢕ࣇࣛࢢࡢࣝࢹࣔࡓ表示ࡀ修ṇࠋࡓࡋࡲࢀࡉ適ษࢢ࡞
ࡢࣝ࢖࢓ࣇ࣭ࢢン࢕ࢸࢵࢭ࣭࣮ࢨ㸦࣮ࣘࠋࡍࡲࢀࡉ設定࡛ࢺ࢛ࣝࣇࢹࡀࢳࢵ࢖ࢫࡢ表示ࢫࢡࢵ࢕ࣇࣛ

graphic.mode࡟  㸧ࠋࡍࡲࢀࡉ設定ࡀ1
 FRF࣮࢝ࡢࣈ重ࡡ合わࡏ表示࠾࡟い࡚ࠊ第 ࡢ2 FRF࡞ࣈ࢕ࢸࢡ࢔ࡀ場合࠾࡟い࡚ࡶ第 ࡢ1 FRFࡣ常ࢸࢡ࢔࡟

 ࠋࡍࡲࢀࡉ࡞見࡜ࣈ࢕
 FRFࣜࡿࡍ࣮ࣝࣟࢡࢫࢆࢺࢫ場合ࠊFRF࣮࢝ࡢࣈ水ᖹ成ศࠋࡍࡲࢀࡉ࣒࣮ࢬࡀ 
 ࢖࣏ࡢ࡚࡭ࡍンࡢࢺṇ規表面ୖ࡜限࡞ࡽい場合ࠊ表面࢕ࢹ࣮࢙ࢩンࡢୖࢢ要素顔番号ࡢ表示ࡀ修ṇࠋࡍࡲࢀࡉ 

ソ࣮ࣝࣂ 

 ILP64࢕ࢸࢵࢭン࡚ࡋ࡜ࢺ࢛ࣝࣇࢹࡣࢢ設定ࠋࡍࡲࢀࡉᑠ࡞ࡉ FEࣔࡢࣝࢹ解析࡛ࡢࡑࠊࡣ ILP64ࢆࢳࢵ࢖ࢫ
ษࡀ࡜ࡇࡿ推奨ࠋࡍࡲࢀࡉ 

 FEMtoolsࡢ࣮ࣂࣝࢯ DYNAMIC࣐ࢥンࢆࢻ使用ࠊࡋ縮ᑠ࣮ࣔࢆࢻ解析ྍࡀ࡜ࡇࡿࡍ能ࠋࡓࡋࡲࡾ࡞࡟以前
ࢻン࣐ࢥࠊࡣ REDUCEࢆ必要ࠋࡓࡋࡲࡋ࡜ 
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 選択ࡢࢫン࣏ࢫとࣞࢱ࣮࣓ࣛࣃ

材料特性ࢱ࣮࣓ࣛࣃと幾何学特性ࢱ࣮࣓ࣛࣃ 

新ࡋい࣐ࢥンࢻ PARAMETER MATERIAL࡜ PARAMETER GEOMETRYࠊ࡚ࡗࡼ࡟要素 IDࢆ参照ࠊࡃ࡞࡜ࡇࡿࡍ
直接ࠊ材料特性࡜幾何学的特性ࢆ指定ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 

ࢢࡣࡓࡲ࣮ࣝ࢝ࣟࠊࡃ࡞࡜ࡇࡿࡅ付ࢆ参照࡟ࢺࢫび要素ࣜࡼ࠾ࣝࣈ࣮ࢸࡢ幾何学特性ࡣࡓࡲ材料特性ࡣࢱ࣮࣓ࣛࣃ

ࡢ幾何学特性ࡣࡓࡲ材料特性ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ設定ࢆࢱ࣮࣓ࣛࣃࡢࣝࣂ࣮ࣟ IDࠊࡣ間接的ࠊ࡟一群ࡢ要素࡟
ࡢࡇ ID࡟参照付ࠊࡅ新ࡋい材料特性ࡣࡓࡲ幾何学特性ࡢ IDࡀ作成ࠋࡍࡲࢀࡉ 

ࡢ幾何学特性ࡣࡓࡲい材料特性ࡋ新ࡣࢻン࣐ࢥࡢࡇ IDࢆ生成ࡿࡍ必要࡞ࡀい場合࡟᭷用࡛ࠋࡍ即ࠊࡕ
PARAMETER GLOBALࡣࡓࡲ PARAMETER LOCALࡢ代わ࣐ࢥࡢࡇ࡟ࡾンࢆࢻ使用ྍࡀ࡜ࡇࡿࡍ能ࠋࡍࡲ࡞࡟ 

 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ操作࡛ࢻン࣐ࢥい࡞少ࡾࡼࠊࡵࡓࡿࡍ関係࡟数ࡢ幾何学特性࡜材料特性ࡣࡽࢀࡑ

Nastran࣮ࣘࡢ࡬࣮ࢨ注意点 

 材料特性ࠊࡣࢱ࣮࣓ࣛࣃPSHELL変換ࢆ使用ࠊࡃ࡞࡜ࡇࡿࡍPCOMP࣮ࣞࣖ࢖幾何学特性ࡼ࠾びMIDࢆ直接使
用ࠋࡍࡲࡋ 

 MID1ࠊMID2ࠊMID3ࠊMID4ࢱ࣮࣓ࣛࣃࡢ Dࢱ࣮࣓ࣛࣃࠊ࡚ࡗࡼ࡟ࢀࡇࠋࡍࡲࢀࡉࢺ࣮࣏ࢧࡀ数ࡀ縮ᑠࡉ
ࢱ࣮࣓ࣛࣃࠋࢇࡏࡲࡾあࡣ必要ࡿࡍ定義ࢆ関係ࡢ㡯ࢫࢡࢵࣜࢺ弾性࣐ࡢ異方性ࠋࡍࡲࡾ࡞ࡃ扱い易ࠊࢀ D
 ࠋࡍ係数࡛࣮ࣝࢣࢫࡢࢫࢡࢵࣜࢺ各弾性࣐ࡢMID4ࠊMID3ࠊMID2ࠊMID1ࠊࡣ

FEMtoolsࢺࢫࢸࣜࣉࡢ解析と相関分析  

 MAC࡜ POCࡢ基準ࡢ計算࠾࡟い࡚ࠊDOF࣌ࡀࣝࣈ࣮ࢸ࣭࢔Ꮡᅾ࡞ࡋい場合ࠊDOFࢺࢵࢤ࣮ࢱࡀ࣮ࢱࣝ࢕ࣇ
 ࠋࡍࡲࢀわ࡞行࡟暗黙ࡀࢢンࣜ࢔DOF࣌ࠊࡋ使用ࢆࣉ࣮࢙ࢩࢻ࣮࣭ࣔࢺࢫࢸࡢ࡚ࡋ࡜

 Manual Sensor Selectionࡢࣝࢿࣃ Show Sensor Node Numberingࡿࢀࡉࢡࢵ࢙ࢳࡀ場合ࠊAdd SensorsࠊRemove 
SensorsࠊMove Sensorsࡀ᭷効ࠋࡍࡲࡾ࡞࡟ 

 ่࣮ࣔࣝࢲ激解析㸦MPA㸧ࡼ࠾び่࣮ࣔࣝࢲ激࣐ࣉࢵ㸦MPM㸧࠾࡟い࡚ࠊ質量ࢆ持࡞ࡓいࡀࢻ࣮ࣀ入力 DOF
 ࠋࡍࡲࢀࡉ使用࡚ࡋ࡜

FEMtoolsࣔ࢕ࢸ࣮ࢹࣉࢵ࢔ࣝࢹンࢢ 

 要素 IDࢆ参照ࠊࡃ࡞࡜ࡇࡿࡍ直接的࡟材料特性࡜幾何学的特性ࢆ指定ࢆࢱ࣮࣓ࣛࣃࠊ࡚ࡗࡼ࡟࡜ࡇࡿࡍ選択
ࢻン࣐ࢥいࡋ新ࡢࡵࡓࡿࡍ PARAMETER MATERIAL࡜ PARAMETER GEOMETRYࠋࡍࡲࢀࡉࢺ࣮࣏ࢧࡀ 

 PARAMETER MATERIAL࣐ࢥンࢆࢻ実証ࡿࡍ新ࡋいࢺࣉࣜࢡࢫ例ࠊࡀ..\examples\updating\disk_modal࡟追加ࡉ
 ࠋࡓࡋࡲࢀ
run08_material_sensitivity.cmd  
run08_material_updating.cmd 

 Correction㸦཰束㸧計算࠾࡟い࡚ࠊ外部ࡀ࣮ࣂࣝࢯ使用ࡿࢀࡉ場合ࡢ要素࣐ࢺ࣮ࢹࣉࢵ࢔ࡢࢫࢡࢵࣜࢺ処理ࢆ
回避ࠊ࡟ࡵࡓࡿࡍDOE COMPUTE࣐ࢥンࠋࡓࡋࡲࢀࡉࢺ࣮࣏ࢧࡀࢻFEMtoolsࡀ࣮ࣂࣝࢯ使用ࡿࢀࡉ場合ࡳࡢ
要素࣐ࡀࢺ࣮ࢹࣉࢵ࢔ࡢࢫࢡࢵࣜࢺ実行ࠋࡍࡲࢀࡉ 

ANSYS࢖࣭ࢱ࣮ࢹンࢫ࢖࢙ࣇ࣮ࢱとࣂ࢖ࣛࢻ 

 集中要素質量࣐ࠋࡓࡋࡲࢀࡉࢺ࣮࣏ࢧࡀࢺࢵ࣐࣮࢛ࣇ࣭ࢫࢡࢵࣜࢺ以前ࡼࡢࡑࡣう࡞集中質量࣐ࢫࢡࢵࣜࢺ

ࡲࡋ計算ࢆࢫࢡࢵࣜࢺ質量࣐ࡓࡋ一㈏ࠊࡣ࡛ࢺ࢛ࣝࣇࢹࡢANSYSࠋࡓࡋࡲࢀࡉ格納ࡀࢫࢡࢵࣜࢺ࣐ࡢ0ࠊࡣ
ࡢࡃ多ࠊࡓࡲࠋࡍ FE࣒ࣛࢢࣟࣉ㸦FEMtoolsࡶ含ࡴ㸧ࠊࡣ࡛ࢺ࢛ࣝࣇࢹࡢ集中要素質量࣐ࢆࢫࢡࢵࣜࢺ生成ࡍ
 ࠋいࡉࡔࡃ࡚ࡋ注意࡟࡜ࡇࡿ

 異方性材料ࠊࢀࡉࢺ࣮࣏ࢧࡀTB㸦ANEL㸧ࠊTBTEMࠊTBDAT࣮࢟ワ࣮ࠊࡀࢻFEMtools ANISO3D材料特性࢖ࢱ
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ࢹࣝࣈ࣮ࢸANSYS TB,ANELࠊࡣFEMtools ANISO3D材料特性ࠊࡶ࡚ࡋ際࡟ࢺ࣮࣏ࢫࢡ࢚ࠋࡍࡲࢀࡉ変換࡟ࣉ
 ࠋࡍࡲࢀࡉࢺ࣮࣏ࢫࢡ࢚࡚ࡋ࡜ࢱ࣮

 倍精ᗘ値࡞0࡛ࠊࡣい基数ࡢ指数ࢆࢺࢵ࣐࣮࢛ࣇ使用ࠊࡋANSYS࢖ン࡚ࡗࡼ࡟ࢫ࢖࢙ࣇ࣮ࢱ出力ࠋࡍࡲࢀࡉ
ࢆ誤差ࠊࢀࡉ出力࡚ࡋ使用ࢆ0ࠊ࡚ࡋ࡜基数ࡢ値ࡢࡽࢀࡇࡣ更新前ࠋࡍࡲࡋ準ᣐ࡟ANSYS CDWRITEࠊࡣࢀࡇ
引ࡁ起ࡍࡇ要因࡚ࡗ࡞࡟いࠋࡓࡋࡲ 

例 
更新前 MPDATA,R5.0, 1,EX , 1, 1, 0.684338600E+11, 
更新後 MPDATA,R5.0, 1,EX , 1, 1, 6.843386000E+10,  

LS-DYNA࢖ンࢫ࢖࢙ࣇ࣮ࢱとࣂ࢖ࣛࢻ 

 MAT_ANISOTROPICࠊ࡟ࡵࡓࡿࡍࢺ࣮࣏ࢧࢆLS-DYNA࢖ンࡀࢫ࢖࢙ࣇ࣮ࢱᣑ張ࠊ࡚ࡗࡼ࡟ࢀࡇࠋࡓࡋࡲࢀࡉ
弾性࣐ࢫࢡࢵࣜࢺ㸦C11, C12,...㸧ࢫࢭࢡ࢔࡟ᶒࡀ୚えࠊࢀࡽ_TET4TOTET10ࢻࢵࣜࢯࡢ要素࢜ࣙࢩࣉン࡛᭷効
 ࠋࡍࡲࡾ࡞࡟

NASTRAN࢖࣭ࢱ࣮ࢹンࢫ࢖࢙ࣇ࣮ࢱとࣂ࢖ࣛࢻ 

NASTRANࣝ࢖࢓ࣇ࣭ࢱ࣮ࢹ࣭ࢡࣝࣂࡢ㸦BDF㸧ࢆ解析ࡿࡍ場合ࠊ対象࣐ࢫࢡࢵࣜࢺ係数ࡀᏑᅾ࡞ࡋい㸦ࡀ࡚࡭ࡍ
修࡟うࡼい࡞ࡋ出力ࢆDMIGࠊ場合࡞うࡼࡢࡑࠋࡓࡋࡲࡋࡇ起ࡁ引ࢆ࣮࢚࣭ࣛࢺン࣓ࢺ࣮ࢸࢫDMIGࠊ㸧場合ࣟࢮ
ṇࠋࡓࡋࡲࡋ 

Output4࡛ࢺࢵ࣐࣮࢛ࣇ࣭ࣝ࢖࢓ࣇ格納ࡓࢀࡉ Superelement㸦SELEM㸧࣐ࡼ࠾ࢫࢡࢵࣜࢺび対応ࡿࡍ外部࡜ࢻ࣮ࣀ
DOF࢖ࢆン࣏࣮ࡣࢀࡑࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍࢺ関連ࣃࡿࡍンࣝ࢖࢓ࣇ࣭ࢳ㸦PCH㸧࢖ࡽ࠿ン࣏࣮ࡓࢀࡉࢺ構成要素
 ࠋࡍࡲࢀࡉ追加࡟定義ࢻ࣮ࣔࡢ
以前ࠊࡣDMIG࣮࢝ࡀࡅࡔࢻ Superelement࣐࢖ࢆࢫࢡࢵࣜࢺン࣏࣮࡚ࢀࡉࢺ࣮࣏ࢧ࡟ࡵࡓࡿࡍࢺいࠋࡓࡋࡲ 

 ࣂ࢖ࣛࢻとࢫ࢖࢙ࣇ࣮ࢱン࢖ࡢࢱ࣮ࢹ࣭ࣝ࢖࢓ࣇ࣭ࣝࢧ࣮ࣂࢽࣘ

 IDEAS㸦ࣘࣝ࢖࢓ࣇ࣭ࣝࢧ࣮ࣂࢽ㸧ྡࢫࢡࢵࣜࢺ࣐ࡣ以外ࠊ࡚ࡋ࡜ࣉ࢖ࢱ࣭ࢱ࣮ࢹࡢ࡚࡭ࡍࡢUniversal File࡟
変更ࠋࡍࡲࢀࡉ 

SAP2000࢖࣭ࢱ࣮ࢹンࢫ࢖࢙ࣇ࣮ࢱとࣂ࢖ࣛࢻ 

 SAP2000࢖ンࠊࡣࢫ࢖࢙ࣇ࣮ࢱSAP2000 v21ࠋࡍࡲࡋࢺ࣮࣏ࢧࢆ 
 新ࡋい CSiAPIv1.DLLࠊࡀCSiBridge࡜ ETABS࡜互換性ࢆ保࡟ࡵࡓࡘ使用ࠋࡍࡲࢀࡉ 
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 ࢺࣉࣜࢡࢫ࣭࣒ࣛࢢࣟࣉ࣭࣮࢕ࢸࣜ࢕ࢸ࣮ࣘ

以ୗࡢ新ࡋい࣮ࣘࡀࢺࣉࣜࢡࢫ࣭࢕ࢸࣜ࢕ࢸ..\scripts\utilities࡟追加ࠋࡓࡋࡲࢀࡉ 

makecustommap 10%以ୖࡢ変更㸦値ࡀ ࢱࢫ࢝ࡿࡍࢺ࢖ࣛ࢖ࣁࢆ場合㸧ࡿࡍ変化࡟100%～0
࡜MATRIXࠊࡣࣉࢵ࣐࣮࣭࣒ࣛ࢝ࢱࢫ࢝ࠋࡍࡲࡋ定義ࢆࣉࢵ࣐࣮࣭࣒ࣛ࢝
MESH࣐ࢥࡢン࡛ࢻ CMAP補語࡜共࡟使用ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 

xfrfpair.bas xfrfpair.basࡣ選択ࡓࢀࡉ FRF࣌࢔振幅ࢆᢳ出ࢥࠊࡋン࣮ࣝࢯ表示値あࡿいࡣ
ࡲࡁ࡛ࡀ࡜ࡇࡿࡍ指定ࢆ周波数ࡢ最大࡜最ᑠࠋࡍࡲࡋ調整ࢆ表示値ࢱンࣜࣉ

 ࠋࡍ

matmove.ba ࣐ࡣࢀࡇࠋࡍࡲࡋ࣒࣮ࢿࣜࢆࢫࢡࢵࣜࢺ௚࢕ࢸࢵࢭࡢンࢆࢢ使用࡚ࡋ得ࢀࡽ

含ࢆ㸧ࢫࢡࢵࣜࢺ感ᗘ࣐ࡤ結果㸦例え࡟うࡼࡿࡁ࡛ࡀ࡜ࡇࡿࡍ比較࡜結果ࡓ

 ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ使用࡟ࡵࡓࡿ作ࢆࣉࢵ࢔ࢡࢵࣂࡢࢫࢡࢵࣜࢺ࣐ࡴ

copy_cs_paired.bas 対応࢖࣏࣭࢔࣌ࡿࡍン࡟ࢺ FEᗙ標系㸦CS㸧ࠋࡍࡲࡋ࣮ࣆࢥࢆ 

decimate_mesh.bas ࢻ࣮ࣀ間ࡢ最ᑠ距離ࢆ使用ࡢࢺࢵࢭ1ࠊࡋ対象ࢆࢻ࣮ࣀ 10ศࡢ ࠋࡍࡲࡋ࡟1
ࣔࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ使用࡟解析ࢺࢫࢸࣜࣉࠊࡋ縮ᑠࡢࢻ࣮ࣀ対象ࡣࢀࡑ

 ࠋࢇࡏࡲࡋ࡜必要࡟ࡵࡓࡿࡍ使用ࢆࢻン࣐ࢥࡢࡇࡣࣉ࣮࢙ࢩࢻ࣮

updbounds.bas ࢺ࣮ࢹࣉࢵ࢔処理後ࢺ࣮ࢹࣉࢵ࢔ࡢࢱ࣮࣓ࣛࣃࡢୗ限ୖ࡜限ࢆ調節ࠋࡍࡲࡋ

ࢺ࣮ࢹࣉࢵ࢔ࡢ一ྠࡀ処理ࢺ࣮ࢹࣉࢵ࢔࡞ࡓ新࡞的⥆⥅ࠊ࡚ࡗࡼ࡟調節ࡢࡇ

ୗ限ୖ࡜限ࢆ使用ࠊࡋ異࣏ࢫࣞࡿ࡞ン࡟ࢫ対࡚ࡋ始ࡏࡲࢀࡋࡶ࠿ࡿࢀࡽࡵ

ࡿあࢫン࣏ࢫࣞࡿ࡞異ࠊࡋ使用ࢆ境界値ࢱ࣮࣓ࣛࣃ࡞相対的ࠊࡣࡃࡋࡶࠋࢇ

いࠊ࡚ࡗࡼ࡟ࢱ࣮࣓ࣛࣃࡣ新ࢆࢺ࣮ࢹࣉࢵ࢔࡟ࡓ実行ࠋࡍࡲࡁ࡛ࡀ࡜ࡇࡿࡍ 

viewmidparam.bas ࢖ࣞࣉࢫ࢕ࢹ PSHELL MIDࠊࡣPARAMETER MATERIAL࣐ࢥン࡛ࢻ選択ࡉ
 ࠋࡍࡲࡅ関連付ࢆࢱ࣮࣓ࣛࣃࡓࢀ

コ࣐ンࢻ 

修正さࢀたコ࣐ンࢻ 

EXAMINE MEF 新ࡋい補語 NODE࡜ LOCATIONࡀ追加ࠊࢀࡉ剛体質量࣐ࡢࢫࢡࣜࢺ計算ࡢ
 ࠋࡍࡲࡁ基࡙࡟ᗙ標系ࡢ原点ࠊࡣ࡛ࢺ࢛ࣝࣇࢹࠋࡍࡲࡋ指定ࢆ఩置ࡢࡵࡓ

PARAMETER MATERIAL 要素 IDࢆ参照ࠊࡃ࡞࡜ࡇࡿࡍ直接的࡟材料特性ࢆ指定ࡾࡼ࡟࡜ࡇࡿࡍ材料
特性ࢆࢱ࣮࣓ࣛࣃ定義ࠋࡍࡲࡋ 

PARAMETER GEOMETRY 要素 IDࢆ参照ࠊࡃ࡞࡜ࡇࡿࡍ直接的࡟幾何学特性ࢆ指定ࡾࡼ࡟࡜ࡇࡿࡍ幾
何学特性ࢆࢱ࣮࣓ࣛࣃ定義ࠋࡍࡲࡋ 
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FEMtoolsࢺࣉࣜࢡࢫ 

修正さࢀた FEMtoolsࢺࣉࣜࢡࢫ関数 

OpenFileName 4番目ࣙࢩࣉ࢜ࡢン引ࡁ数ࢆྡࣝ࢖࢓ࣇ࣭ࢺ࢛ࣝࣇࢹࠊ࡚ࡗࡼ࡟指定ࡿࡍ機
能ࢆ追加ࡀࢀࡑࠋࡓࡋࡲࡋ指定ࡓࢀࡉ場合ࠊOpen Fileࢫࢡࢵ࣎ࢢࣟ࢔࢖ࢲ
ࡲࡁ࡛ࡀ࡜ࡇࡿࡍ選択ࢆࣝ࢖࢓ࣇࡢࡑࠊࡋ示ࢆ࣮ࣜࢺࢡࣞ࢕ࢹ࣭ࣝ࢖࢓ࣇࡣ

 ࠋࡍ

WriteIni 最初ࡢ 次ࡣࣗࢩࢵࣕ࢟ࡢ中࣓ࣜࣔࠊ場合ࡿࢀࡉ渡࡟WriteIniࡀ数ࡁ引ࡢࡘ3
ࡢ ReadIni関数ࡀ実行ࡿࢀࡉ場合࡟ࣝ࢖࢓ࣇࡢ引ࡣࢀࡇࠋࡍࡲࢀࡀ⥅ࡁ外部
࡛変更ࡓࢀࡉ㸦編集ࡓࢀࡉ㸧INIࡢ࡬ࣝ࢖࢓ࣇ対処࡟᭷効࡛ࡢࡇࠋࡍ機能
࡜ࡇࡿ見࡟常ࢆࣝ࢖࢓ࣇINIࠊࡣWindows࡛ࠊࡾ必要࡛あࡳࡢLinux࡛ࠊࡣ
 ࠋࡍࡲࡁ࡛ࡀ

FEMtools API 

修正さࢀた FEMtools API関数 

 ࠋࡍࡲࡋい࡚記述ࡘ࡟変更ࡢ࡬FEMtools API関数ࠊࡣン࡛ࣙࢩࢡࢭࡢࡇ

Ft_SetGraphic 属性 pick.extendࡀ現ᅾࢻ࣮ࣀ࡞ࣈ࢕ࢸࢡ࢔あࡿいࡣ要素࢟ࢵࣆࡢࢺࢵࢭࡢン
 ࠋࡍࡲࢀࡽ加えࡅ付࡟ࡵࡓࡿࡍ࡟能ྍࢆࢢ

Ft_Set/GetTable 属性 indexࡀ現ᅾࢥࡢン࣎㸦combo㸧࢖࣭ࣈࢱࡣࡓࡲンࢆࢫࢡࢵࢹ変更ࡿࡍ
 ࠋࡍࡲࢀࡽ加えࡅ付࡟ࡵࡓ
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