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FEMtools 3.7.1 アップデート・ノート 

FEMtools 3.7.1 の変更点／改良点 

FEMtools 3.7.1は、フレームワーク、解析コンポーネント、データ・インターフェイス・プログラム、ユーザ

ー・インターフェイス、コマンド、API関数のバグ修正と機能拡張のためのメンテナンス・リリース・バージ

ョンです。 

インストール、ライセンス、構成 

• FEMtools 3.7.1 Linuxバージョンとしては、RHEL 5（CentOS 5）とRHEL6（CentOS 6）のプラットフォー

ムに対応するために、MKLライブラリの対応をサポートしました。前バージョン（v3.7.0）では、RHEL 
6（CentOS 6）のみがサポート対象でした。 

• このバージョンは、超高解像度をサポートし、かつWindows8/8.1（FEMtoolsフレームワーク、グラフィ

ックスを参照）上でのタッチ・スクリーン機能をサポートします。 

• 書き込みセキュリティ問題がない場合でも、セッティング・ダイアログボックス中の外部FEAソルバー・

ドライバのセッティングを変更するときに、書き込みセキュリティ・エラーが発生していました。この

問題を修正いたしました。 

FEMtools 3.7.1プラットフォーム・サポート 

次の表に、FEMtools 3.7.1のサポート対応プラットフォームを示します。  

プラットフォーム オペレーティング・システム プロセッサ 

WIN32  Windows XP, Vista/7/8/8.1 32-bit  Intel x86; AMD 32  

WIN64  Windows XP Pro 64-bit, Vista/7/8/8.1 64-bit  Intel 64; AMD 64  

LIN64  Linux 64-bit （RHEL 5, RHEL 6+, CentOS 
6+,…）  

Intel 64; AMD 64  

MAC64  Mac OS X 10.7+  Intel 64  

 

プラットフォーム・サポートに関する最新情報などについては、FEMtoolsウェブサイト

（http://www.femtools.com）をチェックしてください。 

FEMtools 旧バージョンからのアップグレード 

以下は、FEMtoolsの旧バージョンから、FEMtools 3.7.1にアップグレードするユーザーのため情報です。 

• デフォルトのインストール・ディレクトリ（c:￥femtools￥3.7.1.）のように新しいディレクトリに、

FEMtools 3.7.1をインストールすることを推奨します。 

• 永久ライセンスを保有し、v3.3.x～3.6.xにアップグレードされているシステムは、FEMtools 3.7.1を使用

するためにあたって新しいライセンス・ファイルを必要とします。FEMtools 3.4.x、3.5.x、3.6.x、3.7の期

限付きライセンス（年間、30日、...）は、それらの有効期限までv3.7.1を使用することができます。 

• 初めてこのバージョンを起動する場合、ユーザー・ホームディレクトリに新しいセッティング・ファイ

ルのfemtools_371.iniが作成されます。 
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以前にインストール・セッティング・ファイル中での修正データは、インストール直後の起動時に新し

いセッティング・ファイルにコピーすることができます。 
旧バージョン中で使用されるドライバー・スクリプトのドライバー・セッティングおよびカスタマイゼ

ーションは、FEMtools 3.7.1には適用されません。 
そのため、それらのドライバに設定されたカスタマイゼーションは、FEMtools 3.7.1バージョンのINIファ

イルやBASドライバー・スクリプトにおいて、再設定しなければなりません。 
それらのファイルは、<installdir>¥scripts¥drivers に存在します。 

• FEMtools 3.7.1リリース・ノートやヘルプのコマンド・リファレンス・セクションのFEMtoolsコマンド言

語の変更点を確認し、必要に応じて、既存のコマンド・スクリプトを更新してください。 

• FEMtools 3.7.1リリース・ノートやヘルプのAPIリファレンス・セクションのFEMtools APIの変更点を確

認し、必要に応じて、既存のプログラム・スクリプトを更新してください。 

• FEMtools 3.xプロジェクト・ファイルは、FEMtools 3.7.1にインポートすることができます。 

ドキュメンテーション 

• すべて、FEMtoolsドキュメンテーションは、このリリースに伴う変更のために更新されます。 

FEMtools フレームワーク 

ユーザー・インターフェイス 

• ユーザー・インターフェイスは、高解像度スクリーンをサポートします。スタート・コマンドラインで、

-zパラメータを使用し、次のようなズーム操作が可能です。 

 Increase（拡大：ズーム係数>1）あるいはDecrease（縮小：ズーム係数<1）によって、アイコン・サ

イズを設定することができます。そのスケール係数=2では、解像度3200×1600ピクセルのスクリー

ンに推薦されます。 

 アイコン間のスケール間隔 

 スケールFEMtoolsスクリーンをはねかせます。 

 グラフィックス、テーブル、コンソール、エディタ・ウィンドウのデフォルト・サイズのスケーリ

ング 

• エクスプローラ・ウィンドウの幅とドック位置（左、右、...）やドック・コンソールの高さが各セッシ

ョンで保存されます。高解像度スクリーンでのデフォルト・サイズが適切でない場合、GUIコントロー

ル・サイズを一度だけ調整しなければなりません。 

• Customizeダイアログを使用してコンソールに送られたいくつかシステム・メッセージは消去されます。

例えば、そｒは、Linux上のCustomizeメッシュ・ダイアログボックスを開いたときの「QLayout: Cannot add 
null widget to AHBoxLayout」のようなメッセージです。 この問題が解決されました。 

• システム情報メニュー・コマンド（Help > System Information）は、Qtライブラリのバージョン番号を返

します。 

• エディタ・ウィンドウ中のCtrl+F（Find）とCtrl+H（Replace）のショートカットは、次のように改善され

ました。それらのショートカットを実行したとき、既に、Find / Replaceダイアログボックスが開いてい

る場合は、そのダイアログボックスがアクティブになります。 

• 次のメニュー・コマンドが追加されました。 
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 Tools > Pretest Analysis > Initialize FE Model：プリテスト解析（pretest）モジュールに使用する既存

のFEモデルを初期化します。 

 Tools > Pretest Analysis > Clean-up FE Model：プリテスト解析後のFEモデルを消去します。 

 Tools > Pretest Analysis > Import Sensor Configuration :ファイルからセンサー構成をインポートし

ます。 

 Tools > Pretest Analysis > Export Sensor Configuration :ファイルにセンサー構成をエクスポートし

ます。 

それらのより詳細については、プリテスト解析（Pretest Analysis ）のセクションを参照してください。 

データベース 

• CLEAR FEM CSとCLEAR TEST CSのコマンドを実行した場合、FEやTESTのCoordinate Systems テー

ブルは自動的にリフレッシュされます。 

データのエクスポート 

• COMPRESS補語がSAVEコマンドに追加されました。それによって、グローバル圧縮セッティングのウ

上書きが可能になります。 

グラフィックス 

• グラフィックス・ウィンドウは、タッチ・スクリーン入力をサポートします。 

 指触移動（One finger movements）によるメッシュやマトリックスのグラフィックス中の回転操作を

可能にします。 

 2本指挟み込み操作（Two fingers pinch gestures）は、メッシュやカーブのグラフィックスのズームや

移動を一緒に動作させることを可能にします。メッシュでは、xpan、ypan、ズーム操作ができます。

また、カーブでは、xpanとypanがサポートされますが、ズームは単にx軸に対して行なわれます。挟

み込み（ピンチ）操作では、xとyの方向に異なるズーム係数は適用されません。 

• SHOW PLOTELやSHOW MPCセッティングが修正されると、FEメッシュ・プロットは自動的にリフレッ

シュされます。 

• FEMtoolsメイン・アプリケーション・ウィンドウあるいはチャイルド・ウィンドウのアクティブ化や非

アクティブ化の操作によって、すべてのOpenGLウィンドウはリフレッシュされます。これはアクティブ

/非アクティブ化によって、大規模モデルが表示されている場合、遅延感ととらえられるかもしれない再

描画（redraws）を回避するために採用されます。 

• MESHコマンドのEXCLUSIVEとISOLATEDの補語は、アクティブなグラフィックス・ウィンドウのみの

ローカル・セッティングを変更します。 

• タブ操作モードでのグラフィックス・ウィンドウのクローズ処理における中断問題が解決されました。 

• 要素のないメッシュのグーロー・シェーディング表示の際の中断問題が解決されました。 

ツールバー 

• エディタ・ウィンドウが選択された時、グラフィックス・ツールバー上のContourボタンは時々アクティ

ブなままでした。この問題が解決されました。 
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• グラフィックス・ツールバー上のExclusiveボタン機能は、アクティブなグラフィックス・ウィンドウの

みのローカル・セッティングに変更されました。 

ABAQUS FEA データ・インターフェイスとドライバ 

• 次の新しい特徴として、ODBファイル・フォーマットの新しい直接的リーダ機能がサポートされました。 

 正規モード、複素モード、静的変位、定常解析の変位が、FEMtoolsデータベースにインポートする

ことができます。 

 ODBリーダは、個別のABAQUS、ABAQUS CAEインストールおよびABAQUS APIライブラリを必

要としません。 

 ABAQUS 6.9～6.13によって出力されたODBファイルを直接インポートすることができます。 

 .odbを最新のODBバージョンに変換するために、「abaqusアップグレード」を使用する必要はあり

ません。 

 解析が数ステップにおよぶ場合、インポート・ステップ・ログをサポートします。 

新しいリーダは、従来のABAQUS CAE Pythonベースのリーダより高速です。 

SEARCH MODEとSEARCH DISPLACEMENTのコマンドあるいはFile > Import コマンドの使用し、.odbフ
ァイルを指定する場合、ODBリーダが自動的に選ばれます。 

ステップは次の方法で指定することができます: 

 グローバル：可変インターフェイス interface.abaqus.step [integer] デフォルト=-1 が使用されます。 

 ローカル：SEARCHコマンドで新しいSTEP引き数が使用されます。 
 
SEARCH MODE/DISPLACEMENT FORMAT ABAQUS STEP step_id FILE ...  

利用可能なステップと対応した解析がコンソール出力でリストされます。nステップが利用可能な場合、

step_idは[1..n]あるいは[-1.-n]の範囲になります。ここで、負の索引は配列アクセスのためのピュートーン

基準に準拠します。 

 -1 = 最後のステップ = ステップn 

 -2 = 最後から二番目のステップ = ステップn-1  

 -n = 最初のステップ = ステップ1   

• 21の弾性係数の材料特性がサポート（インポート/エクスポート）されました。 

• ABAQUS入力ファイル・フォーマット（inpファイル）に材料特性と幾何学特性をエクスポートするため

に、Baseラベルが使用され、ABAQUSインターフェイス・セッティング・ファイル（abaqus.ini）の[LABELS]
セクションでカスタマイズされます。 
Labelのカスタマイゼーションは、大規模モデルへの対処、ローカル・パラメータの大きな番号によるア

ップデート、新しいセクションや材料の生成による問題が生じる場合に必要となります。 
 
ABAQUSは、8文字以内と8文字以上のラベルを区別します。8文字以上を使用するラベル数は、そのコ

ード化おいて制限があります。また、この制限に到達する場合、ABAQUSの解析ではエラーメッセージ

を出力します。その解決策として、それらのラベルやIDの連結により、MATERIALs名とSECTIONs名を
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形成するために使用されるラベルの長さを制限することです。これは、ABAQUSインターフェイス・セ

ッティング・ファイル（abaqus.ini）の[LABELS]セクションのラベル名接頭辞の変更により行うことがで

きます。 

• 正規モード解析（LANCZOS、SUBSPACEあるいはAMS）のために使用されるABAQUSソルバーは、維

持されています。そのため、新しい内部変数のinterface.abaqus.eigensolverが追加されました。その変数は、

インポートモデル中での指定ソルバーで初期化されます。ソルバーが入力ファイル中で指定されない場

合は、変数のinterface.abaqus.eigensolverは空のストリングとして初期化されます。この場合、abaqus.ini
ファイル中のeigensolverエントリによって指定されたソルバーが使用されます。データベースの消去や

新しいプロジェクトの開始は、interface.abaqus.eigensolver変数を消去することに注意してください。 

ANSYS FEA データ・インターフェイスとドライバ 

• CMBLOCKデータは、FEMtoolsの節点や要素セットおよびFEMtoolsセットとして、ANSYS CDBファイル

からインポートすることができ、また、CMBLOCKデータとしてエクスポートすることができます。 
デフォルトでは、CMBLOCKのインポートとエクスポートのスイッチがアクティブになります。この設

定は、FEMtoolsセッティングで変更することができます。例えば、多くのFEMtoolsセットがあり、ANSYS 
CDBファイルとして、これらのセットをエクスポートする必要がない場合、CMBLOCKのエクスポート・

スイッチを非アクティブにすることもできます。より詳細については、「ANSYS Interface and Driver 
User’s Guide （インターフェイスとドライバ・ユーザーズガイド）」を参照してください。 

NASTRAN FEA データ・インターフェイスとドライバ 

• マグニチュウド/位相フォーマットが、NASTRAN DISPLACEMENT=..., VELOCITY=..., 
ACCELERATION=...カード上で指定された場合、NASTRANは、OP2インターフェイス・ファイルに（REAL、
IMAGINARY）コンポーネントの代わりに（MAGNITUDE、PHASE）コンポーネントを出力します。こ

の状況が検知され、（（MAGNITUDE、PHASE）値は自動的に（REAL、IMAGINARY）値に変換されま

す。このデータ例は、<installdir>/examples/interfaces/nastran/op2_phaseフォルダーで見つけることができま

す。 

ユニバーサル・ファイル・テスト・データ・インターフェイス 

• ユニバーサル・ファイル・フォーマットのFRFのエクスポートにおいて、いくつかのモード解析プログ

ラムでは、FRFタイプを出力しない場合があります。FEMtools MPE（モードパラメータ・エクストラク

ター）のようなFEMtoolsモジュール中では、不明なFRFタイプの使用が回避されます。新たなUFFイン

ターフェイスでは、未知のFRFタイプを扱うことを明示することが可能です。その利用可能なオプショ

ンは次のとおりです。 

• 何もせず、オリジナルのFRFをインポートする場合のタイプは、UNKNOWNになります。以降において、

MODIFY FRFコマンドを使用し、FRFタイプを再定義することが可能です。 

 信号処理技術を使用し、FRFタイプを識別し、UNKNOWNタイプのFRFに自動でFRFタイプを設定

します。そのルーチンは、"unknownFRF"のタイプを識別したすべてのFRFに同一のタイプを設定す

ることに注意してください。つまり、UNKNOWNタイプのFRFはすべて同一タイプと仮定されます。 

 UNKNOWNタイプのすべてのFRFをACCELERANCE（A/F）FRFに再定義します。 

 UNKNOWNタイプのすべてのFRFをMOBILITY（V/F）FRFに再定義します。 

 UNKNOWNタイプのすべてのFRFをRECEPTANCE（D/F）FRFに再定義します。 

 UNKNOWNタイプのすべてのFRFをCROSS SPECTRUM（A/A）FRFに再定義します。 

• UFFインターフェイスの形成方法 
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 UFF Interface SettingsダイアログボックスのFix FRFs with Unknown Typeコンボボックスを使用す

る。このダイアログボックスは、Importing FRF TESTダイアログボックスのSettingsボタンをクリ

ックすることによりアクセスすることができます。 

 Settingsダイアログボックスから、Edit > Settings > Data Interfaces > Universal File Format Test 
Interface > Fix UNKNOWN FRF typeを使用します。  

 SET INTERFACE UFF TYPEFIXコマンドを使用する。 

• FRFタイプの検証や修正は、GUI（File > Import > Test FRFs）を使用して、FRFがインポートされるとき

のみに使用されます。INPUTコマンドによって、FRFをインポートされる場合、タイプの検証や修正は

行なわれません。 

• 自動FRF認識アルゴリズムから付加的なフィードバック診断ルーチンモードのスイッチをアクティブに

する（Edit > Run Mode > Diagnostics Mode）ことができます。 

• 加振力の代わりに反力（分母）とする、FRF関数（データセット58）を定義されたユニバーサル・ファ

イルがサポートされます。そのプログラム例としては、Vibrant Technology 社のME'Scopeがあります。こ

のFRFは、UNKNOWNタイプの代わりに、accelerance FRFと考えられます。 

Polytec データ・インターフェイス 

• マイクロソフト・ウィンドウズのドイツ語版システム上では、Polytec FileAccess APIは、信号の名前を返

し、Polytecインターフェイスによって正しく認識されませんでした。FEMtools Polytecインターフェイス

の新バージョンでは英語とドイツ語の信号名をサポートします。 

• FRFをインポートする場合、テスト・グリッドはインポートされません。これは他のデータ・インター

フェイス（例えば、ユニバーサル・ファイル(UFF)インターフェイス）との互換性を保つためです。 

• 以下の方法を使用し、データベース中にFRFをアペンド・インポートすることが可能です。 

 Polytecインターフェイス・セッティング・ダイアログボックス中のAppend to Existing FRFsチェッ

クボックスをチェックする。このダイアログボックスは、Importing FRF TESTダイアログボックス

中のSettingsボタンのクリックによりアクセスされます。 

 Settingsダイアログボックスから、Edit > Settings > Data Interfaces > Polytec .svd Interface > Append 
FRF to the Databaseを選択します。  

 SET INTERFACE POLYEC APPENDコマンドを使用する。 

• Polytecデータ・インターフェイスの安定化のため、その他の修正や改良が行なわれました。 

メッシュ・ツール 

• GENERATE MOVEコマンドのSOURCE補語は、SETとしてドキュメント化されました。そのドキュメン

テーションは修正されましたが、コマンドは修正されていません。 

• 重複した外部節点IDがないかどうかのチェック機能が、GENERATE BRICK、GENERATE CURVE、
GENERATE RECTANGLE、GENERATE SURFACEのコマンドに追加されました。これらのコマンドは、

重複外部節点番号を伴う節点を作成する場合、エラーメッセージは出力し、メッシュ手続きは異常終了

します。 

基礎的な FEA 

• Hessenbergソルバーが修正され、もはや複素モードを計算しません。 
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• FEMtools eigenmodes 固有値解析ソルバーは、メモリ占有条件を縮小するためにバンド解析をサポートし

ました。多数モードを計算しなければならない場合、それらのステップでモードを計算することが可能

です。最初に考慮した周波数レンジは、多くの周波数バンド（帯域）に細分され、モードが各周波数バ

ンドにおいて計算されます。このような細分化メモリ容量を使用したモード計算法は、一度にすべての

モードを計算する場合より時間の節約につながります。 

• バンド・モード計算は、DYNAMICコマンドの新しいBAND補語を使用するか、Advanced Modes Analysis 
Settingsダイアログボックス（Tools > Modes Analysis > Advance）中で周波数バンド数を指定することに

よって行なうことができます。 

• 指定された周波数レンジ（[FMin; FMax]）内のすべてのモードを計算するのには、以下のようないくつ

かの方法があります。 

 Modes Analysisダイアログボックス中のAll Modesチェックボックスをチェックする。 

 DYNAMICコマンドで、VECTOR ALL補語を使用する。 

 モード数に-1を設定ずる。これは、DYNAMIC VECTOR ALLと同等です。 
 
すべてのモードを計算するには、その上限周波数バンドとして、FMax<1E30を指定します。このオ

プションは、FEMtools、NASTRAN、ABAQUSなどのソルバーのためにサポートされます。 

動解析 

• MODIFY FRFコマンド中のTYPE補語（エイリアス）として、MOBILITY、COMPLIANCE、RECEPTANCE、
CROSSが追加されました。 

• データベース中に剛性（stiffness）と質量（mass）のマトリックスが未定義の場合、メニュー（Tools > 
Frequency Response Analysis）のHarmonic Response Analysisがアクティブになりませんでした。これが

修正され、あらかじめ計算された剛性と質量のマトリックスを必要とすることなく、ハーモニック・レ

スポンスを直接的に計算することが可能です。剛性と質量のマトリックスが未定義の場合、ハーモニッ

ク解析ソルバーがそれらを計算することに注意してください。 

• スーパー要素（SELEM）ルーチンは、以下のように修正、拡張されました。 

 スーパー要素は、GUIで定義することができるようになりました。そのためには、最初に、エクス

プローラから、Tables > Model: FE > SuperElementsを選択し、続いて、メイン・メニューから、Edit 
> Table > Add Recordsを実行します。 

 スーパー要素生成中のエラー・ハンドリングが改良され、節点が未定義の場合、エラーが表示され

ましたが、SELEMの定義が残されたままでした。その問題が解決され、SELEMの定義は消去され

ました。 

 Craig-Bampton（スーパー要素）ソルバーのロバスト特性が修正され、2Dと3Dの要素をリンクする

ための外部DOF選択機能が改善されました。 

• モーダル・ベース・アセンブリ（MBA）ルーチンの修正と拡張 

 グランド設置のスプリングやダンパーがサポートされました。GUIでもグランド設置のスプリング

やダンパーは、修正要素タイプと同様に利用することができます。また、コマンド言語では、グラ

ンド設置のスプリングやダンパーは、DEFINE MBA SUBSTRUCTUREコマンドのNODE補語に1つの

節点ID番号を使用することにより定義することができます。 

 それはサブストラクチャ（部分構造）を削除さる場合、対象サブストラクチャの有限要素を選択す
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ることが可能です。そのために、KEEP補語がCLEAR MBA SUBSTRUCTUREコマンドに追加されま

した。 

 サブストラクチャが削除されると、アクティブなMBAサブストラクチャを視覚化するために使用さ

れたプロット要素も削除されます。 

 MBAモジュールは、サブストラクチャの基本的なFE要素の外部識別番号の独自性を保証します。

MBAサブストラクチャの定義データとの矛盾を回避します。 

 EXCLUDE補語が、MBAコマンドに追加されました。この補語はサブストラクチャを連結するため

に使用される個別の指定節点の定義に使用されます。 

• FRFベース・アセンブリ（FBA）ルーチンの修正 

 対象がFEモデルである場合、FBAは、SAC/CSAC関数の相関基準をリフレッシュします。 

プリテスト解析 

• EXAMINE DIRCOSコマンドは、ローカル座標系を持たない節点を扱うことができませんでしたが、これ

が修正されました。 

• Pretest Analysis（プリテスト解析）の実行下のToolsメニューにおいて、Normalized Modal Displacement
（NMD）とNodal Kinetic Energy （NKE）アイテムが見当たらなかった問題が修正されました。 

• モード刺激解析（MPA：Mode Participation Analysis）の修正 
 

 モード刺激解析は、ローカル座標系をサポートします。MPAのためのローカル座標系を使用するに

は、Mode Participation AnalysisダイアログボックスのCoordinate Systemロップダウンリストで、

Local Coordinate Systemsを選択するか、EXAMINE MPAコマンドにLOCAL補語を追加します。 

 モード刺激解析の公式は、モード数の制限を受けないように変更されました。ただし、MPA結果は

使用されるモード数に依存しないわけではありません。 

 新しい公式は、モード数の超過入力数を使用できます。 

 ダイアログボックスは、事前のMPA解析の入力DOFを使用によってInput DOFテーブルを初期化し

ます。 

• 正規サーフェイス座標系の生成において、ローカルX軸方向をコントロールすることが可能になりまし

た。これはGENERATE CSコマンドに新しいTYPE補語を使用することによって行なわれます。利用可能

な2つのタイプの座標系としては、STANDARDとXVERTICALがあります。STANDARDでは、ローカル

X軸とグローバルX軸は接近し、XVERTICALでは、X軸が垂直になります。 

• センサー選択の手続きの修正 

 local CSを使用し、未確定の座標系を参照する節点を追加した時、センサー選択解析手続きが中断す

る問題がありました。この問題のチェック機能が追加され、適切なエラーメッセージがコンソー

ル・ウィンドウに表示されます。 

 初期化機能が追加され、その初期化機能では、FEモデルをチェックし、プリテスト・モジュールと

互換性をもつように、それらの座標系をすべて変換します。その初期化をスタートするには、メイ

ン・メニューから、Tools > Pretest Analysis > Initialize FE Modelを選択するか、PRETEST INITIALIZE
コマンドを実行し、FEモデルを初期化します。その初期化手続きの詳細については、「FEMtools 
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Pretest and Correlation Analysis User’s Guide（プリテスト解析ユーザーズガイド）」を参照してくだ

さい。 

 センサー選択では、テンポラリ座標データを扱います。これらのテンポラリ座標系はPRETEST 
CLEANコマンドを使用して削除することができます。また、メニューのTools > Pretest Analysis > 
Clean-up FE Modelを使用することも可能です。 

 センサー構成のロードや保存もコマンド言語でサポートされます。 
 
ロード：  PRETEST LOAD CONFIGURATION 
保存：  PRETEST SAVE CONFIGURATION 

 FEMtoolsコマンド・リファレンスには、これらの新しいコマンドの追加情報が提示されています。

センサー構成の保存とロードは、ManualとAutomated Sensor Selectionのパネルからアクセス可能で

す。 

 センサー構成データベースには、トレースライン（tracelines）が含まれます。新しいセンサー構成

をロードしても、する場合、トレースラインは失われません。 

 センサー構成のインポートおよびファイルへのエクスポートがサポートされます。これは、

PRETEST IMPORTとPRETEST EXPORTのコマンドを使用して行うことができます。GUIを使用し、

Tools > Pretest Analysisメニューから、センサー構成はインポートすることができます。 

相関分析 

• FEM-TESTの重ね書きプロットが改良され、初めに、TESTモデルが描画され、次に、FEMのFE 描画（要

素、MPC、plotels）をオーバーラップすると、テスト・メッシュのトレースラインを残して表示されま

す。 

パラメータとレスポンスの選択 

• Ft_SetParamValue API関数が直接的にアップデーティング・パラメータ値をセットするために、追加され

ます。また、パラメータ・プロパティを修正するために、Ft_SetParamProp関数が追加されます。 

感度解析 

• 再解析アプローチを使用し、ソルバーが感度解析中にレスポンスやパラメータを削除した場合に中断す

る問題が解決されました。 

モデルアップデーティング 

• パラメータ・リレーション・データの下で、GAINコマンドを使用し、ゲイン・マトリックスを計算する

場合、FEMtoolsフレームワークでの中断を引き起こす問題が解決されました。 

• 1つのチャイルド・ウィンドウの下で、FEMtoolsメイン・ウィンドウがアクティブでなかった場合、TUNE
コマンドの実行おいて、“Error -80: Ft_SETWINDOWPROP , maximized : Illegal Window Name”が生じる問

題が解決されました。 

• デフォルトでは、Reject Updating Stepsダイアログボックス（Tools > Model Updating > Reject Updating 
Steps）は、すべての反復ステップをすべて選択します。以前のバージョンでは、最後のステップを選択

していました。 

• バックアップ・プロジェクト・ファイルを出力する場合、ユーザーが書き込み許可を持っていないフォ

ルダーに対して、モデルアップデーティング（TUNEコマンド）を実行したとき、問題を引き起こす場
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合がありました。その結果に関してユーザーに通知するために、適切な警告メッセージがコンソール・

ウィンドウに出力されます。 

• マルチ・アップデーティング（MMU） 

 Multi Model Updating Project Managerダイアログボックスは、MMU Working Directoryディレクト

リの指定ができるようになりました。これはMMU問題を実行するために使用されるディレクトリ

であり、すべてのファイルはこのフォルダーに作成されます。また、コマンドを使用して、MMU
問題が実行する場合は、そのMMUコマンドを実行する前に、SET DIRECTORYコマンドを使用し、

MMU作業ディレクトリを指定することができます。外部ソルバーを使用し、MMU問題を実行する

場合は、特定のMMU作業ディレクトリを使用することを推奨します。それらの詳細については、

「FEMtools Model Updating User’s Guide（モデルアップデーティング・ユーザーズガイド）を参照し

てください。 

 MMUプロジェクトのファイルを整理する方法としてのガイドラインを記述する新しいセクション

が、ドキュメンテーションに追加されました。そのセクションは外部ソルバーを使用し、MMUプ

ロジェクトを実行する場合に重要です。 

最適化 

• DEFINE OPTPARAMコマンドのいくつかの検証チェックにおいて、内部と外部の幾何学番号に混乱が存

在しました。これによる不適切エラーメッセージの問題が解決されました。 

コマンド 

新しいコマンド 

このセクションでは、FEMtools 3.7.1リリースで利用可能な新しいコマンドについて記述します。 

PRETEST EXPORT PRETEST EXPORTコマンドは、センサー構成をファイルに保存する。 

PRETEST IMPORT PRETEST IMPORTコマンドは、ファイルからセンサー構成をロード

する。 

PRETEST INITIALIZE PRETEST INITIALIZEコマンドは、プリテスト解析モジュールを使用

するために既存のFEを初期化する。 

PRETEST LOAD PRETEST LOADコマンドは、特定のセンサー構成をロードする。 

PRETEST SAVE PRETEST SAVEコマンドは、現在のセンサー構成を保存する。 

修正されたコマンド 

このセクションは、FEMtools 3.7.1リリースの変更されたコマンドについて記述します。 

CLEAR MBA SUBSTRUCTURE MBAサブストラクチャ（部分構造）のFE要素が削除されるか、削除

されないかを選択するために、KEEP補語が追加されました。デフォ

ルトでは、=OFFであり、要素は削除されます。 

DEFINE MBA SUBSTRUCTURE NODEコマンドは、1節点IDあるいは2節点IDを指定することができま

す。2節点IDは従来のスプリング/ダンパーを生成します。一方で、1
節点IDはグランド設置されたスプリング/ダンパーを生成します。 

DYNAMIC  使用する周波数バンドの数を指定するために、新しいBAND補語が追
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加されました。さらに、VECTOR補語は、ALL（すべて）値を意味し、

指定周波数レンジ内のすべてのモードを計算します。 

EXAMINE MPA 解析がローカルかグローバルの座標系で実行されるかを選択するた

めに、LOCALとGLOBALの補語が追加されました。 

GENERATE CS 座標系として、ローカルX軸方向を選択するために、TYPE補語が追

加されました。 

MBA COMPUTE サブストラクチャを連結するために使用される節点を除外するため

に、EXCLUDE補語が追加されました。 

MODIFY FRF COMPLIANCE、CROSS、MOBILITY、RECEPTANCEなどが、TYPE
補語と同様に追加されました。 

SAVE COMPRESS補語がグローバルな圧縮セッティングがローカル上書に

追加されました。 

SET DYNAMIC 使用する周波数バンド数を指定するために、BANDS補語が追加され

ました。 

SET INTERFACE POLYTEC    FRFをアペンド（追加）インポートすることを明示するために、

APPEND補語が追加されました。 

SET INTERFACE UFF 未定義タイプのFRFをインポートするためのTYPEFIX補語が追加さ

れました。 

FEMtools スクリプト 

一般情報 

• MacOSでのNaN定義が修正されました。これは未初期化値や利用可能できない値のマーカーとして、レ

スポンス、MBAのレンジやNaNに関するいくつかの問題を解決します。 

• マトリックスのQR分解のための新しい関数が追加されました。（QR） 

• OLEインターフェイス関数  

 空配列の転換 

 ストリング配列の直接的参照 

 ブール配列の直接的参照 

 変数配列の直接的参照 

 整数（ロング）型の直接的参照 

 ブール（BOOL）型の直接的参照 

 ストリング（BSTR）型の直接的参照 

 ブール型固定長配列の直接的参照 
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新しい関数 

このセクションでは、FEMtools 3.7.1のリリースで新たに利用可能になった関数について記述します。 

QR     実数または複素数のマトリックスのQR分解を行ないます。 

修正済機能 

このセクションは、FEMtools 3.7.1のリリースで変更された関数について記述します。 

HWInfo    フレームワークのQtバージョンを検索するためのQtオプションが追

加されました。 

FEMtools API 

新しいAPI関数 

このセクションでは、FEMtools 3.7.1リリースで新たに利用可能になったAPI関数について記述します。 

Ft_GetCurrentWindow   メインのFEMtoolsアプリケーションがフォーカスを持たなくても、

アクティブ・チャイルド・ウィンドウの名前を返します。この関数

はFt_GetActiveWindow関数に似ていますが、Ft_GetActiveWindowと異

なり、メインのFEMtoolsアプリケーションがフォーカスを持たなく

ても、値を返します。 

Ft_SetParamProp   パラメータ・プロパティ値を修正する。 

Ft_SetParamValue     パラメータ値をセットする。 

修正されたAPI関数 

このセクションは、FEMtools 3.7.1リリースで変更されたAPI関数について記述します。 

Ft_Exec この関数は、LinuxやMacOSの下でFEMtools手続きの安定化させるた

めに修正されました。 

Ft_Report この関数は、デバッグ・モードのメッセージを表示するためのオプ

ションとして拡張されました。GUIモードでは、そのデバッグ情報は

デバッガへ送られます。そのため容易に使用することができ、メッ

セージが送信された後にアプリケーションが中断したとしても、デ

バッグ情報を確認することができます。デバッグ情報を読むには、

デバッグ・ビューアが必要です。その有効なビューアー・アプリケ

ーションとして、Microsoft DebugView v4.81が利用できます。それは、

次の際とからダウンロードすることができるでしょう。 
http://technet.microsoft.com/en-us/sysinternals/bb896647.aspx 
コマンドライン・モードでは、すべてのLinuxとMacOSのバージョン

で、FEMtoolsが開始されたターミナルへそのデバッグ情報が送られ

ます。 

Ft_GetGraphic ローカル・バージョン（mesh.exclusive, mesh.show. isolated.nodes, and 
mesh.show.isolated. points variables）をコントロールするために、

exclusive, isolated.nodes and isolated.pointsが新たにサポートされます。 
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Ft_Report デバッガへ情報を送るために、debugオプションがサポートされます。 

Ft_SetGraphic ローカル・バージョン（mesh.exclusive, mesh.show. isolated.nodes, and 
mesh.show.isolated. points variables）をコントロールするために、

exclusive, isolated.nodes and isolated.pointsが新たにサポートされます。 

新しいAPIイベント 

• 新しいイベントのGE_PICK_POLYGONが追加されました。このイベントは、ピッキング・ポリゴンを閉

じる（ダブルクリック）ときに生成されます。そのイベント値は、節点=1、要素＝2、ポイント=3、トレ

ースライン=4です。また、その値は、アイテムが追加される場合は正（>0）であり、アイテムが削除さ

れる場合は負（<0）です。 

新しいAPI定数 

GE_PICK_POLYGON 1005値は、ピッキング・ポリゴンを閉じる（ダブルクリック）とき、

イベントが再生成されたことを示します。 

新しいAPI環境変数 

スカラーとストリング 

dynamic.bands モード解析に使用する周波数バンドの数を指定します。（デフォル

ト=1） 

interface.abaqus.eigensolver ABAQUSの正規モード解析に使用するソルバー（LANCZOS、
SUBSPACEあるいはAMS）を指定します。その変数は、インポート

モデル中で指定されるソルバーで初期化されます。ソルバーが入力

ファイル中で指定されない場合、その変数は空ストリングとして初

期化されます。その場合、abaqus.iniファイル中のeigensolverエントリ

によって指定されたソルバーが使用されます。データベースが消去

されるか新しいプロジェクトのスタートによって、すべて変数が消

去されることに注意してください。 

interface.ansys.set.export CMBLOCKとして節点と要素のセットをエクスポートするために指

定します。 

interface.ansys.set.import 節点または要素のセットとしてCMBLOCKSをンポートするために

指定します。 

interface.polytec.append PolytecインターフェイスでインポートされるFRFをアペンド（追加）

するか、FRFデータベースに上書きするかどうか明示します。 

interface.uff.typefix 未定義タイプのFRFのUFFインターフェイスによる処理方法を明示

します。 

project.ini FEMtoolsアプリケーションによって使用されたファイル（.iniファイ

ル）が現在のプロジェクトを作成するために使用したセッティング

として指定します。 

project.version FEMtoolsアプリケーションのバージョンが現在のプロジェクトを作

成するために使用されたことを明示します。 
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修正されたAPI環境変数 

• file.iniとversion変数は、プロジェクト・ファイルの保存とオープンの過程でその前後で、現在のバージョ

ン変数は修正されません。（以前より、version変数は保存されていましたが、その取り扱い方法が修正

されました。）プロジェクトで見つかったバージョンは、project.versionに格納されます。プロジェクト

で見つかったiniファイル変数は、project.iniに格納されます。プロジェクトがロードされない場合、

project.versionとproject.iniの両方は空になります。 

• グローバルのmesh.exclusiveセッティングは、MESH EXCLUSIVEコマンドやグラフィックス・ツールバ

ーのExclusiveボタンによる影響を受けず、そのmesh.exclusive値はデフォルトのままです。そのローカル

のmesh.exclusiveセッティングは、Ft_Set/GetGraphicの"exclusive" API関数でコントロールすることができ

ます。メッシュ・カスタマイゼーション・ダイアログボックスとグラフィックス・ツールバーはそのロ

ーカル・セッティングを変更します。 

• グローバルのmesh.show.isolated.nodeかmesh.show.isolated.pointなどのセッティングは、MESH ISOLATED
コマンドの影響を受けず、そのmesh.show.isolated.node/point値はデフォルトのままです。そのローカルの

セッティングは、Ft_Set/GetGraphic "isolated.nodes" あるいは Ft_Set/GetGraphic "isolated.points"API関数で

コントロールすることができます。メッシュ・カスタマイゼーション・ダイアログボックスは、そのロ

ーカルのセッティングを変更します。 
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