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序文 
本マニュアルについて 

このマニュアルは、FEMtools 3.5 における新しい機能、機能強化、および訂正について記述したものです。 

FEMtools マニュアルにおいて使用される規則 

FEMtools マニュアルは、視覚的に情報を識別するのに便利なように、いくつかの規則を設けています。 

タイプのスタイルまたは記号          用途                     

extract nodes FEMtools コマンドラインの例 

SET ECHO FEMtools コマンドまたはコマンドの構文 

Settings メニュー・コマンド 

※ この規則は日本語マニュアルにおいて、必ずしも適用されるとは限りません。 

統一性と UNIX プラットフォームでの大文字／小文字の区別を考慮して、FEMtools コマンド・スクリプトに

おけるすべてのコマンドと引数（特にファイル名）に対して小文字が使用されています。しかし、FEMtools
のドキュメンテーションでは、読み易くするためにコマンドは通常大文字で記されています。 

関係のあるドキュメンテーション 

本マニュアルは、次のマニュアルと一緒に用いるのがよいでしょう。 

• FEMtools Getting Started Manual（入門マニュアル） 

ドキュメンテーションの使用について 

FEMtools ドキュメンテーションは、HTML ベースのヘルプとして、および PDF フォーマットでのオンライン

マニュアルとして利用できます。 

ヘルプにアクセスするには、Help メニューから Help Topics を選びます。 

• 全マニュアルの目次の完全なリストを見たい場合は、Contents タブを使います。 

• すべてのインデックスエントリのリストを見たい場合は、Index タブを使います。 

その他のタブは、使用するオペレーティング・システムに依存して利用することができます。 

マニュアルにアクセスするには、Help メニューから Manuals を選んでください。PDF ファイルを読むには、

Adobe Acrobat Reader がシステムにインストールされなければなりません。 
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FEMtools 3.7 概観 

FEMtools 3.7最新版は、新しい動解析とサブストラクチャリング（動的補正、モーダル・ベース・アセンブリ）

の機能が搭載された主要なアップデーット・バージョンです。そのアップデートに伴って、FRＦベース・ア

センブリ、プリテスト解析、相関分析およびモデルアップデーティングの機能も更新されます。また、イン

ターフェイス・プログラム、コマンド関数、API関数などの多くも改良、拡張されました。 

FEMtools 3.7最新版のハイライトを以下に示します。 

FRFの計算方法 

周波数応答関数（FRF）の計算方法は次のように拡張されました。 

• ＦＲＦモード計算法が動的補正法を使用し、機能アップされました。 

• 直接FRF計算機能のパデ近似法に自動収束コントロール機能が追加されました。 

• 直接FRF計算機能にマルチ・リファレンスの変位やローカル座標系がサポートされました。 

モーダル・ベース・アセンブリ（MBA） 

モーダル・ベース・アセンブリ（MBA）は、構造動特性の更新要因を推定することができる新しい動的サブ

ストラクチャリング法として追加されます。FEMtools 3.7のMBA機能は、FEAデータをサポートし、そのFEA
とテストデータの組み合わせ（ハイブリッド・モデリング）を可能にします。MBAは構造変更シミュレーシ

ョン（SDM）へ拡張され、以前のFEMtoolsバージョンのSDMはMBAに統括されます。 

FRFベース・アセンブリ（FBA） 

FRFベース・アセンブリ（FBA）は、FEMtools 3.7において拡張されました。FBAトランスファー・パス解析

（TPA）のために、荷重と応答がFBAモジュールに導入されます。また、FBA接続ポイントのマルチポイン

ト拘束や強制変位に伴う内力の計算機能がサポートされました。FBAの適用例証としての新たな例題が追加

されました。 

プリテスト解析 

プリテスト解析は、すべてのセンサー選択方法に同一マンマシン・インターフェイスのGUIパネルを使用し

ます。これにより、固定センサー位置の指定が可能となり、最小のセンサー選択と候補位置のプレビュー機

能が容易になります。 

相関分析 

相関分析は、非接触センサー（振動計走査レーザー）で得られたポイント群の大きなデータセットを処理す

るために新しい空間相関アルゴリズムを導入します。同一方向のノード-ポイント・ペアやマルチステップ・

ノード-ポイント・ペアが追加されます。モードシェープ・ペアリングとして、POCベースおよび軸対称構造

のモードシェープがサポートされます。 

モデルアップデーティング 

モデルアップデーティングは、新たなベイズ法アップデート方程式の条件を自動的に更新する方法が使用さ

れました。これはアップデート・パラメータやアップデート・レスポンスとして多数の値を持つ場合のロバ

スト・アップデート・プロセスに有効です。また、FEMtools 3.7では、アップデート結果を柔軟に拒否（中断）

するためオプションが追加されます。その他の改良としては、テキストベースのパラメータ・アップデート、

マルチ・モデルアップデーティングなどがあります。標準的なレスポンスによるモデルアップデートでは、

非標準的なレスポンスの場合に比べてより柔軟なアプローチが使用されます。 

スクリプト関数の拡張 

コマンド・スクリプトで使用可能な27の新しいコマンドの拡張スクリプト関数が追加されます。それらは、

FEMtoolsスクリプト・プログラマの新しいユーティリティやFEMtools API関数として利用されます。 

 



 

 2 

データの圧縮 

FEMtoolsデータベースおよびプロジェクト・ファイル（fdb、fpj）は、圧縮フォーマットをサポートします。 

インターフェイスの更新 

• FEデータ・インターフェイスとソルバー・ドライバ（Nastran、Abaqus、Ansys,...）が改良されました。例

えば、AbaqusとAnsysのインターフェイスは、FRFデータのインポートをサポートします。また、Nastran
ドライバは、MSC.Nastran ACMSソルバーをサポートします。 

• ユニバーサル・ファイル・フォーマット・インターフェイスが改良され、そのセッティングは、 Settings
ダイアログボックスでコントロールすることができます。 

• Polytecファイル・インターフェイスは、そのパフォーマンスと機能が改良されました。 
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FEMtools 3.7 ドキュメントとトレーニング・コース 
FEMtools 3.7ドキュメントは、オンラインヘルプ、コース・ノート、マニュアル（PDF）などで構成されます。

すべてのドキュメントは変更点を反映するために更新されました。 

新規および上級のユーザーのためにトレーニング・コースの情報が提供されます。 

ドキュメント概観 
FEMtools 3.7ドキュメントは以下のドキュメントで構成されます。 

• FEMtools 3.7 Release Notes（リリースノート）：このマニュアルは、FEMtools 3.7の新しい特徴を紹介し、

また既存バージョンからのアップグレード方法について解説します。 

• FEMtools 3.7 Getting Started Manual（入門マニュアル）：このマニュアルは、インストール方法、ライ

センス管理、FEMtoolsシステム構成および実行方法について解説します。 

• FEMtools 3.7 Framework User's Guide（フレームワーク・ユーザーガイド）：このガイドは、FEMtools
モジュールの基本機能（ユーザー・インターフェイス、データベース、データ・インターフェイス、ス

クリプト言語、グラフィックス）についての情報を解説します。 

• FEMtools 3.7 Mesh User's Guide（メッシュ・ユーザーガイド）：このガイドは、メッシュ生成、メッシ

ュ変形、要素変換、メッシュ精度のメッシュ・ツールについて解説します。 

• FEMtools 3.7 Dynamics User's Guide（ダイナミクス・ユーザーガイド）：このガイドは、FEMtoolsによ

る構造ダイナミクス・シミュレーションの理論的背景、実行方法、例題について解説します。 

• FEMtools 3.7 Pretest and Correlation Analysis User's Guide（プリテスト解析と相関分析ユーザーガイ

ド）：このガイドは、プリテスト解析と相関分析に関する理論的背景、実行方法、例題について解説し

ます。 

• FEMtools 3.7 Model Updating User's Guide（モデルアップデーティング・ユーザーガイド）：このガイ

ドは、感度解析を使用し、モデルアップデーティング、外力同定、確率論的解析の実行方法について解

説します。 

• FEMtools 3.7 Model Updating Theoretical Manual（モデルアップデーティング理論マニュアル）：このマ

ニュアルは、FEMtoolsモデルアップデーティングの差分法、ツールなどの理論的背景を解説します。 

• FEMtools 3.7 Model Updating Examples Manual（モデルアップデーティング例題マニュアル）：このマ

ニュアルは、典型的なモデルの例題により、FEMtoolsモデルアップデーティングを解説します。 

• FEMtools 3.7 Optimization User's Guide（最適化ユーザーガイド）：このガイドは、一般非線形プログラ

ミング、DOE/RSM機能を使用し、サイズ、形状、トポロジー、トポメトリーの最適化に応用される構造

最適化の理論的背景、実行方法、例題について解説します。 

• FEMtools 3.7 Modal Parameter Extractor User's Guide（モーダル・パラメータ・エクストラクター・ユ

ーザーガイド）：このガイドは、デジタル信号処理機能とモーダル・パラメータ・エクストラクター（抽

出）に関する機能と例題を解説します。 

• FEMtools 3.7 Rigid Body Properties Extractor User's Guide（剛体特性モーダル・パラメータ・エクストラ

クター・ユーザーガイド）：このガイドは、その理論的背景、周波数応答関数（FRF）から剛体特性を

抽出するための実行方法と例題について解説します。 

• FEMtools 3.7 ARTeMIS Interface User's Guide（ARTeMISインターフェイス・ユーザーガイド）：このガ

イドは、ARTeMISファイルをインポート／エクスポートする方法を解説します。 

• FEMtools 3.7 ABAQUS Interface and Driver User's Guide（ABAQUSインターフェイス・ユーザーガイ

ド）：このガイドは、ABAQUSファイルをインポート／エクスポートする方法を解説します。 

• FEMtools 3.7 ANSYS Interface and Driver User's Guide（ANSYSインターフェイス・ユーザーガイド）：

このガイドは、ANSYSファイルをインポート／エクスポートする方法を解説します。 

• FEMtools 3.7 NASTRAN Interface and Driver User's Guide（NASTRANインターフェイス・ユーザーガイ

ド）：このガイドは、NASTRANファイルをインポート／エクスポートする方法を解説します。 
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• FEMtools 3.7 UNIVERSAL FILE Interface and Driver User's Guide（ユニバーサル・ファイル・インター

フェイス・ユーザーガイド）：このガイドは、ユニバーサル・ファイル・フォーマットのファイルをイ

ンポート／エクスポートする方法を解説します。 

• FEMtools 3.7 SAP2000 Interface User's Guide（SAP2000インターフェイス・ユーザーガイド）：このガイ

ドは、SAP2000ファイル・フォーマットのファイルをインポート／エクスポートする方法を解説します。 

• FEMtools 3.7 Programmer's Guide（プログラマーズ・ガイド）：このマニュアルは、多様なアプリケー

ション・プログラム例題によって、FEMtoolsスクリプト・リファレンスマニュアル、APIリファレンスマ

ニュアルを補足解説します。 

• FEMtools 3.7 GUI Reference（GUIリファレンス）：これは、メニュー、ツールバー、ダイアログボック

スの情報に関する電子リファレンスマニュアルです。 

• FEMtools 3.7 Command Reference：これは、FEMtoolsコマンド言語要素、シンタックス、引き数、例題、

各コマンドの詳細情報に関する電子リファレンスマニュアルです。同様の完全な電子バージョンはソフ

トウェアに付属しています。 

• FEMtools 3.7 Scripting Reference（スクリプト・リファレンス）：これは、FEMtoolsスクリプト言語要素

（変数、演算子、関数、ステートメント）に関する電子リファレンスマニュアルです。完全な電子バー

ジョンはソフトウェアに付属しています。 

• FEMtools 3.7 Application Programming Interface (API) Reference（アプリケーション・プログラミング・

インターフェイス・リファレンス）：これは、FEMtoolsデータベースを操作するための機能に関する電

子リファレンスマニュアルです。完全な電子バージョンはソフトウェアに付属します。 

次の表にはリリース・フォーマットの一覧を示します。 

ドキュメント名 フォーマット 

FEMtools 3.7 Getting Started Manual  PDF, Help  

FEMtools 3.7 Release Notes  PDF  

FEMtools 3.7 Framework User's Guide  PDF, Help  

FEMtools 3.7 Mesh User's Guide  PDF, Help  

FEMtools 3.7 Dynamics User's Guide  PDF, Help  

FEMtools 3.7 Pretest and Correlation Analysis User's 
Guide  

PDF, Help  

FEMtools 3.7 Model Updating User's Guide  PDF, Help  

FEMtools 3.7 Model Updating Theoretical Manual  PDF  

FEMtools 3.7 Model Updating Examples Manual  PDF  

FEMtools 3.7 Optimization User's Guide  PDF, Help  

FEMtools 3.7 Modal Parameter Extractor User's Guide  PDF, Help  

FEMtools 3.7 Rigid Body Properties Extractor User's 
Guide  

PDF, Help  

FEMtools 3.7 ARTeMIS Interface User's Guide  PDF, Help  

FEMtools 3.7 ABAQUS Interface and Driver User's 
Guide  

PDF, Help  

FEMtools 3.7 ANSYS Interface and Driver User's Guide  PDF, Help  

FEMtools 3.7 NASTRAN Interface and Driver User's 
Guide  

PDF, Help  

FEMtools 3.7 UNIVERSAL FILE Interface and Driver 
User's Guide  

PDF, Help  

FEMtools 3.7 SAP2000 Interface User's Guide  PDF, Help  

FEMtools 3.7 Programmer's Guide  PDF  
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FEMtools 3.7 GUI Reference Manual  Help  

FEMtools 3.7 Command Reference Manual  Help  

FEMtools 3.7 Scripting Reference Manual  Help  

FEMtools 3.7 API Reference Manual  Help  

 

Helpは、FEMtools Helpメニューからアクセス可能なドキュメントとして参照され、HelpはMicrosoft HTMLヘ
ルプ（Windows）、HTLM（Linux、MAC OS）を使用します。 

PDFは、Adobe Acrobat Portable Document Format （PDF）を参照します。これらのファイルは、Adobe Reader
ソフトウェアは、アドビ・システムズ（www.adobe.com）からダウンロード可能なWindows、Linux、Mac OS 
X対応の無料ユーティリティを使用することができます。Adobe Acrobatからは、それらのPDFマニュアルを印

刷することもできます。 

電子マニュアルにアクセスするには、Helpメニューから各マニュアルを選択してください。 

FEMtools ウェブサイト 
インターネット上のFEMtoolsカスタマー・サポート・サイトは、FEMtoolsメンテナンスおよび技術サポート

サービス（FtMTS）契約者のすべてのFEMtoolsユーザーのためのコミュニケーション・サイト、サポート・

センターとして利用されるように意図されています。 

それぞれのサイトからソフトウェア・インストール・パッケージに付属するドキュメントの補足情報を見つ

けることができます。さらに、最新バージョンのソフトウェア、パッチ、スクリプト、ドキュメントなどを

ダウンロードすることができます。 

www.femtools.com/support  

www.femtools.com/rlm  

www.reprisesoftware.com/RLM_License_Administration.html  

FEMtools トレーニング・コース 
DDS(Dynamic Design Solution)およびFEMtoolsソリューション・パートナーは、新規ユーザー向イントロダク

ション・コースおよび上級ユーザーやFEMtoolsアプリケーション開発者向トレーニング・コースをオープン

しています。 

それらの詳細については、http://www.femtools.com/courses を閲覧するか、support@femtools.com にお問い合

わせください。 

http://www.femtools.com/support
http://www.femtools.com/rlm
http://www.reprisesoftware.com/RLM_License_Administration.html
http://www.femtools.com/courses
mailto:support@femtools.com
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FEMtools 3.7 の変更点 

インストール、ライセンス、構成 
以下に、サポート・オペレーティング・システムおよび最小インストール必要環境を示します。 

FEMtools 3.7 プラットフォーム・サポート 
次表は、FEMtools 3.7対応する主なプラットフォームを示します。 

プラットフォーム オペレーティング・システム プロセッサ  

WIN32  Windows XP, Vista/7/8 32-bit  Intel x86; AMD 32  

WIN64  Windows XP Pro 64-bit, Vista/7/8 
64-bit  

Intel 64; AMD 64  

LIN64  Linux 64-bit (RHEL 6+, CentOS 
6+,…)  

Intel 64; AMD 64  

MAC64  Mac OS X 10.7+  Intel 64  

 

最新の対応プラッフォーム情報については、FEMtoolsウェブサイト（http://www.femtools.com）を参照してく

ださい。 

最小インストール必要条件 

Windows 

• Microsoft・WindowsXP、XPPro64ビット、Vista（32/64ビット）、Windows7（32/64ビット）、Windows8
（32/64ビット） 

• 最小4 GB RAM 

• 最小500MB ハードディスク・スペース 

• OpenGL用サポート・グラフィックスカード 

• OpenGL対応グラフィックスカード。OpenGL対応ハードウェア・アクセレレータが使用される場合、グラ

フィックス機能が高速化されます。 

• CDや電子メールからのインストール用CD-ROMドライブ、インターネット接続 

• USBポート（ドングル用ノードロック・ライセンス・オプション） 

• ライセンスサーバー用TCP/IPコネクタ（ネットワーク・ライセンス・オプション） 

• Adobe Acrobat Reader、あるいは互換ソフトウェア（PDFドキュメント・リーダー） 

Linux 

• Linux 64ビットOS、Intel64（RHEL 6+、CentOS 6+、...）対応IntelMKL 11.0、その他のLinux互換システム 

• 最小4 GB RAM 

• 最小500MB ハードディスク・スペース 

• OpenGL対応グラフィックスカード。OpenGL対応ハードウェア・アクセレレータが使用される場合、グラ

フィックス機能が高速化されます。 

• CDや電子メールからのインストール用CD-ROMドライブ、インターネット接続 

• USBポート（ドングル用ノードロック・ライセンス・オプション） 

• ライセンスサーバー用TCP/IPコネクタ（ネットワーク・ライセンス・オプション） 

• Adobe Acrobat Reader、あるいは互換ソフトウェア（PDFドキュメント・リーダー） 
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Mac OS X 

• Mac OS X 10.7+用Intelプロセッサ 

• 最小4 GB RAM 

• 最小500MB ハードディスク・スペース 

• OpenGL対応グラフィックスカード。OpenGL対応ハードウェア・アクセレレータが使用される場合、グラ

フィックス機能が高速化されます。 

• CDや電子メールからのインストール用CD-ROMドライブ、インターネット接続 

• USBポート（ドングル用ノードロック・ライセンス・オプション） 

• ライセンスサーバー用TCP/IPコネクタ（ネットワーク・ライセンス・オプション） 

• Adobe Acrobat Reader、あるいは互換ソフトウェア（PDFドキュメント・リーダー） 

インストール処理の変更点 
• FEMtoolsアドオン・マネージャーは、空白を含むパスネームを扱うことができます。 

• 新しいパッチがある場合、アドオン・マネージャーはスタート時では表示されません。新たなアドオンが

ある場合のみ表示されます。 

• システムにインストールされたライセンスがない場合、新たなアドオンのためのパッケージ・マネージャ

ーは、表示されません。ライセンスがないアドオンは、今までどおりパッケージ・マネージャーを手動で

（Add-ons > Install/Remove Add-on）開くことができます。 

ライセンス処理の変更点 
• FEMtools 3.7はライセンス管理のためにRLM 10.1を使用します。より詳細な情報に関しては、RLMドキュ

メントを参照してください。 

• RLM FEMtools 3.7ネットワーク・ライセンス・ファイルは、デフォルト・ポートとしてポート5053を使用

します。FEMtoolsの旧バージョンではデフォルトとしてポート2764を使用していました。 

• 標準構成の「FEMtools Correlation（相関分析）」はリネームされ、「FEMtools Pretest and Correlation（プ

リテスト解析と相関分析）」」となります。 

FEMtools 旧バージョンからのアップグレード方法 
以下は、FEMtoolsの旧バージョンからFEMtools 3.7にアップグレードするユーザーのための情報です。 

• 新しいディレクトリにFEMtools 3.7をインストールすることを推奨します。そのデフォルト・インストー

ル・ディレクトリは、c:￥femtools￥3.7です。 

• 永久ライセンス仕様のユーザーまた、v3.3.x、およびそれ以前にアップグレードしたユーザーのすべてに

おいて、新しいライセンス・ファイルを必要とします。FEMtools 3.4.x、3.5.x、3.6.x用の期日指定ライセン

ス（年、30日試用など）は、v3.7においても現在のライセンス・ファイルが有効であり、その期限まで使

用できます。 

• 最初にこのバージョンをスタートアップする時、新しいセッティング・ダイアログボックス・ファイルが

ホームディレクトリに作成されます。以前のセッティング・ダイアログボックス・ファイル中の修正は、

新しいセッティング・ダイアログボックス・ファイルにコピーすることができます。 

• 旧バージョンで使用されたドライバ・スクリプトのドライバ・セッティングおよびカスタマイズは、

FEMtools 3.7には自動的に適用されません。そのためドライバなどのカスタマイズについては、FEMtools 
3.7バージョンのINIファイルやBASドライバ・スクリプトにおいて再設定しなければなりません。それら

のファイルは、<installdir>¥scripts¥driversに存在します。 

• ヘルプおよびFEMtools 3.7リリースノートのコマンド・リファレンス・セクションのFEMtoolsコマンド言

語の変更点を確認してください。必要に応じてコマンド・スクリプトを更新してください。 

• ヘルプやFEMtools 3.7リリースノートのAPIリファレンス・セクションのFEMtools APIの変更点を確認して

ください。必要に応じてプログラム・スクリプトを更新してください。 
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• FEMtools 3.xプロジェクト・ファイルは、FEMtools 3.7にもインポートすることができます。 

ドキュメントと例題の変更 
ドキュメントと例題のディレクトリでは、以下のように変更されました。 

• FEMtoolsのすべてのドキュメントがこのリリースにおいて更新されました。 

• FEMtools 3.6Dynamics User's Guide（ダイアナミクス・ユーザーガイド）には、モーダル・ベース・アセン

ブリ（ＭＢＡ）の新しい章が追加されました。SDMはMBAに統合（踏襲）され、SDM例題もMBA例題と

なります。MBA例題は、フォルダ：<installdir>¥examples¥dynamics¥mba¥で見つけることができます。 

• ドキュメント中で示される相関係数（CCABS、CCMEANなど）の表現は、実際の機能を表わすために更

新されました。 

• HELPコマンドの出力フォーマットが改良されました。 

• FRFを選択するコマンド・シンタックスがドキュメントに追加されました。コマンド・リファレンスの

Selecting FRFs（FRFの選択）を参照してください。 

• フォルダ：../examples/dynamic/frf/verificationのdamping.cdamp、damping.g、damping.ge、damping.modalは、

nastran.damping.cdamp、nastran.damping.g、nastran.damping.ge、nastran.damping.modalにリネームされました。 

• Linuxでは、FEMtools GUIから開かれる個々の新しいヘルプ・トピックは新しい（Firefox）インスタンス

中で開かれます。以前のFEMtoolsバージョンでは、新しいヘルプ・トピックは新しいブラウザ・タブ中で

開かれました。ブラウザが既に開いていて、別のアプリケーションの後ろに隠された時、新しいトピック

が開かれても見えませんでした。この変更により、ヘルプは開かれたアプリケーション上に現われるよう

になります。 

データ・インターフェイスとドライバ・プログラム 
データ・インターフェイス・プログラムの主な変更点を以下に示します。 

FEMtools プロジェクト・ファイル 
有限要素とテストのモデルは、ますます大規模になる傾向があり、プロジェクト・ファイルや結果ファイル

の操作、保存、移動、アーカイブ用の保管およびサポートのためには、膨大なディスク・スペースを占有す

るかもしれません。 

そのため、データ・ストリーム圧縮技術を使用し、それらのファイル・サイズの縮小化機能をサポートし、

約65%の縮小が、大容量ファイルで可能にります。エクスポート速度もその圧縮モードによって短縮されま

す。ただし、その圧縮アルゴリズムの使用にあたってはパフォーマンスと速度のバランスが必要となります。

データ圧縮は、FEMデータ、テストデータ、モード、変位、剛性マトリックス、質量マトリックス、FEA FRF、
テストFRFなどの.fdbファイル・フォーマットに利用されます。 

圧縮モードのコントロール方法 

• FEMtoolsのInterface Settings ダイアログボックスを開くことにより、またデータ・エクスポート・ダイア

ログボックスのSettingsボタンをクリックすることにより指定されます。それがユーザーによって変更さ

れれば、選択されたセッティング（compressed：圧縮、uncompressed：非圧縮）は、次のセッションに使

用されます。 
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• Settingsダイアログボックス（メイン・メニューから、Edit > Settings）を開き、Data Interfaces > Default .fdb 
Compression Mode セッティングから変更することができます。引き続き、Okボタンをクリックし、

Settingsダイアログボックスを閉じることによって、そのセッティングが次ぎのセッションで使用されま

す。それをデフォルト値として修正済のセッティングを格納するには、Settingsダイアログを閉じる前に保

存ボタンをクリックしてください。 

FEMtools ソルバー・ドライバ 
FEMtoolsドライバは、analysis.solver.nameという変数を介して初期化されます。 

ABAQUS インターフェイスとドライバ 
• ABAQUSソルバーから剛体モードを得るために、ドライバは自動的にSUBSPACEソルバーに変更され、デ

フォルト値が0Hzだった場合、その最小周波数を0.001Hzに変更します。ただし、これらの処理は拘束され

たモデルの場合には適用されません。FEMtoolsは境界条件あるいはグラウンド・スプリングの存在をチェ

ックします。それらの存在が確認されてもいかなる処理も行なわれません。それらのドライバが検知した

対象や処理に関する診断ルーチンメッセージが通知されます。 

• ABAQUSドライバは、TUNE SENSITIVITY{INTERNAL|EXTERNAL} セッティングをサポートします。

これによって、FEMtools要素マトリックスの使用し、感度係数を計算することが可能です。SET TUNEコ
マンドのドキュメントでは、この機能の追加情報が記述されます。 

• ABAQUSドライバは、analysis.solver.nameをabaqus変数によって初期化します。 

• FRFデータのインポートは、ABAQUSインターフェイスにおいてサポートされます。 

 FRFは、ASCIIとバイナリの.filファイルの両方からインポートすることができます。Importing FEA 
FRFダイアログボックスは、ファイルタイプ・ドロップダウンリストに、ABAQUS（ASCII）とABAQUS
（バイナリ）のエントリを持っています。SEARCHとINPUTコマンドも、ABAQUS.filファイル用の

FRF FEMをサポートします。 

 インポートするFRFのレスポンスDOFの選択を可能にするために、DOF補語がSEARCHとINPUTコマ

ンドに追加されました。そのデフォルト値は、Settingsダイアログボックス（Edit > Settings > Data 
Interfaces > FRF DOF Mask）でカスタマイズすることができ、interface.frf.dof.mask変数によってコン

トロールされます。インポートされるDOFも、Importing FEA FRFダイアログボックスのSettingsダイ

アログボックス・ボタンで選択することができます。 

 ABAQUS FRFのインポート例題は、フォルダ：../examples/dynamic/frf/verificationで見つけることがで

きます。 

• 追加サポートされたインポート・セッティングとして、.inpファイルのインポートにおいて、*FREQUENCY
カードに遭遇する場合、次のように処理されます。 

 dynamic.vectorsがモード数にセットされます。 

 dynamic.fminがfmin/shiftにセットされます。 

 dynamic.fmaxはfmaxにセットされます。 

 interface.abaqus.eigensolverは、"LANCZOS"、"AMS"、"SUBSPACE"にセットされます。 

• interface.abaqus.couplingセッティングは、接続データをどのようにインポートするかをコントロールするた

めに導入されました。 



 

 10 

 0がセットされていると、*SURFACE、*RIGID BODY、*KINEMATIC COUPLING、* DISTRIBUTING 
COUPLING、*COUPLING、*KINEMATIC、*DISTRIBUTINGなどのすべてのカードは、abaqus.dmp
ファイルに直接ダンプされ、インターフェイスによる変換処理は行なわれません。 

 1がセットされていると、インターフェイスはそれらのカードを処理し、RBE2とRBE3の拘束条件

（constraints）に変換されます。*SURFACEカードも処理されますが、abaqus.dmpファイルにダンプさ

れることに注意してください。以前は、それらのデータは、FEMtoolsデータベースに格納されません

でした。 

ANSYS インターフェイスとドライバ 
• ANSYSドライバは、analysis.solver.nameをansys変数によって初期化します。 

• ANSYSからFRFをインポートするサポートが改良されました。そのDOF補語がFRFをインポートするレス

ポンスDOFの選択を可能にするために、SEARCHコマンドに追加されました。デフォルト値は、Settings
ダイアログボックス（Edit > Settings > .Data Interfaces > FRF DOF Mask）でカスタマイズでき、

interface.frf.dof.mask変数によってコントロールされます。 

• FRFデータのインポートがANSYSインターフェイスでサポートされます。 

 ダイレクトFRFは、.rstファイルからインポートすることができます。また、モーダルFRFは、.rfrqフ
ァイルからインポートすることができます。Importing FEA FRFダイアログボックスは、ファイルタ

イプ・ドロップダウンリストにANSYSエントリを持ちます。SEARCHコマンドは、ANSYS結果ファ

イル用のFRF FEMをサポートします。 

 DOF補語がインポートするFRFのレスポンスDOFの選択を可能にするために、SEARCHコマンドに追

加されました。そのデフォルト値は、Settingsダイアログボックス（Edit > Settings > .Data Interfaces > 
FRF DOF Mask）でカスタマイズすることができ、interface.frf.dof.mask変数によってコントロールさ

れます。インポートするDOFも、Importing FEA FRFダイアログボックスのSettingsダイアログボッ

クス・ボタンで選択することができます。 

 ANSYS FRFのインポート例題は、フォルダ：../examples/dynamic/frf/verificationで見つけることができ

ます。 

• インターフェイスは、MATRIX27要素のGENERIC幾何学データをサポートします。 

• インターフェイスは、GENERIC line2要素（MATRIX27）をエクスポートすることができます。 

• mat/plyではないシングルply SHELL181/281要素がサポートされました。 

• 9ノード要素に対応するHEX20要素がサポートされました。 

• SHELL 181-281要素のセクション・オフセットがサポートされました。 

• CMBLOCKカードがサポートされました。このコンポーネント定義はセットに変換されます。ノードと

要素の両方がサポートされました。 

• .EMATからインポートされた要素マトリックスは、ノードの座標系と要素のグローバル座標系

（COMBIN14とMATRIX27）に関して回転されます。 

• さらに次の問題が解決されました。 

 ブロック・フォーマットの実定数のエクスポート 

 ブロック・フォーマットの節点座標（ANGLES対応）のエクスポート 

 節点ブロック・フォーマットの角度データの読み込み時の最大ライン長さ問題のサポート 

 空の.rstファイルをインポートした場合でも、そのファイルは適切に閉じられます。 

NASTRAN インターフェイスとドライバ 
• ユーティリティ・スクリプトのop2cards.basが追加されました。このユーティリティは、OP2ファイルで使

用されるすべてのカードのリストを抽出します。OP2のインポート処理のトラブルシュートとして、ある

データセットがOP2中に存在するか否かを確認するのに有効です。 

• 新しい機能として、エクスポート・モデルに、DISPLACEMENTステートメントを選択する機能が導入さ
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れました。 

 nastran.iniファイルがdisplacement変数を含む場合、FEMtoolsは、エクスポートするモデルに、

DISPLACEMENTステートメントとして、その変数の値を使用します。デフォルトでは、nastran.ini
には、displacement変数は含みません。displacement変数が存在しても、その値として識別されない場

合（例えば、ゼロ・レングス・ストリング）、この機能は無視されます。 
 
例：DISPLACEMENT（PLOT）=ALLを指定するには、nastran.iniファイルに次のラインを追加してく

ださい。 
 
displacement=DISPLACEMENT(PLOT) = ALL  

 nastran.iniにdisplacement変数が存在せず、インポートファイルにDISPLACEMENTまたはVECTORのス

テートメントを含む場合、FEMtoolsはエクスポート・モデルにそのステートメントをコピーします。 

 nastran.iniにdisplacement変数が存在せず、インポート・モデルにPARAMETERまたはVECTORのステ

ートメントを含まない場合、FEMtoolsはエクスポート・モデルにDISPLACEMENT=ALLステートメン

トを追加します。 

• NASTRANドライバは、analysis.solver.name変数をnastran変数によって初期化します。 

• NASTRANドライバは、PARAM BAILOUTステートメントがインポート・モデルに存在するかどうかチェ

ックします。ドライバは、多数のPARAM BAILOUTステートメントがインポート・モデルに存在しないこ

とを確認することができます。 

• インターフェイスは、ACMSセッティングをサポートします。モデルをエクスポートする場合、ACMSセ
ッティング（DOMAINSOLVER ACMS）を保存します。また、ACMSを使用したモデルアップデーティン

グが可能になります。 
 
ACMSソルバーは対象周波数レンジ内のモードをすべて計算する（周波数レンジ内のモード数が要求モー

ド数以上の場合でも）ことに注意してください。ただし、FEMtoolsは最大モード数の指定を尊重するため、

Nastran結果ファイル中に最大モード数以上が存在しても、要求されたモード数以上をインポートしません。

そのため対象周波数レンジのすべてのモードを必要とする場合は、十分に大きなモード数を指定してくだ

さい。 

• NASTRANからFRFをインポートする機能が改良されました。 

 インポートするFRFのレスポンスDOFの選択を可能にするために、SEARCHとINPUTコマンドにDOF
補語が追加されました。そのデフォルト値は、Settingsダイアログボックス（Edit > Settings > .Data 
Interfaces > FRF DOF Mask）でカスタマイズすることができ、interface.frf.dof.mask変数によってコン

トロールされます。インポートされるDOFも、Importing FEA FRFダイアログボックスのSettingsボ
タンで選択することができます。 

 パンチ・ファイルからFRFデータを読むためのINPUT FRF FEM FORMAT NASTRANコマンドは、

回転DOFもインポートするためにも使用することができます。 

 バイナリの.51と.op2ファイルからのFRFのインポートがサポートされます。Importing FEA FRFダイ

アログボックスのファイルタイプ・ドロップダウンリストには、NASTRAN（バイナリ）エントリが

存在します。また、SEARCHコマンドは、FRF FEMもサポートします。 

 NASTRAN FRFのインポートの例題は、フォルダ：../examples/dynamic/frf/verificationで見つけること

ができます。 

• INITキーワードのサポートが追加されました。ドライバはシングルとマルチラインのINITステートメント

の両方をサポートすることに注意してください。 

• 尖端形状ビームのためのNSI（non-structural inertias：非構造慣性）とNSM（non-structural mass：非構造質

量）のインポートがサポートされます。 

• OUG1、OVG1、OAG1ブロックのサポートが、Ft_ReadOP2関数に追加されました。PARAM、POST、-1に
よるファイル対処によって、これらのカードに対応します。Ft_ReadOP2関数はオンラインヘルプのAPIリ
ファレンスにも追加されました。この関数は既に導入されていましたが、ドキュメント化されていません

でした。 
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• さらに次の問題が解決されました。 

 トレイリング実数フィールド（ALPHA=熱膨張係数）を持つRBE2のインポート 

 “ALPHA”ラベルに基づくRBE3要素の消去（パージ） 

 ブランク（空白）が存在するRBE3のインポート 

 “INCLUDE”カードのインポートは、ブランク（空白）の存在に寛容で、4文字（INCL）の省略を

サポートします。 

 GRID入力と共に使用される再帰的座標系（CORD**カード）のサポート 

 SPOINT/GRID IDオーバーラップは、ID>GRID IDを伴う開始番号SPOINTにより回避されます。 

ユニバーサル・ファイル FE データ・インターフェイスとドライバ 
• IDEASドライバは、analysis.solver.name変数をideas変数によって初期化します。 

ユニバーサル・ファイル・テストデータ・インターフェイスとドライバ 
• ユニバーサル・ファイル・テストデータ・インターフェイスの更新点 

 インポートとエクスポートのダイアログボックス（File > Import > Test Model and Shapes / Test 
FRFs、File > Export > Test Model and Shape）のSettingsボタンが改良されました。このボタンによ

って、データのインポート/エクスポート方法をカスタマイズすることが可能なSettingsダイアログ

ボックスを開きます。 
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 新たにインポートされるモード、実稼動シェープ、FRFが既存データに追加するか交換するかを選

択するためのセッティングがあります。 

 ローカル座標系のインポート/エクスポートのサポートが改良されました。 

 トレースリンクのエクスポートのサポートが改良されました。トレースリンクを要素としてエクス

ポートするか、ワイヤー・フレームとしてエクスポートするか、あるいはいかなるトレースリンク

もエクスポートしない方法を指定することができます。 

• interface.uff.flagsセッティングは、Settingsダイアログボックス（Edit > Settings > Data Interfaces > UFF Test 
Interface Flag）から取り除かれ、変数のinterface.uff.aflags 、interface.uff.rflags、interface.uff.wflags（Edit > 
Settings > Data Interfaces > Universal File Format Test Interface）によって設定されます。  

• SET INTERFACE UFFコマンドが、UFFテストデータ・インターフェイスを設定するために追加されまし

た。 

SAP2000 インターフェイス 
• SAP2000は、FE解析モデルの自動メッシュ・リファイン（細分化）機能を持っています。このオプショ

ンはSAP2000アプリケーションにおいて適用されます。しかし、そのモデルをFEMtoolsにエクスポート

すると重大問題を引き起こします。SAP2000は、メッシュを.s2kファイルとしてエクスポートする場合、

デフォルトでは、FE解析内部で使用されるリファイン・メッシュではなく、コース（疎）メッシュをエ

クスポートします。そのため、FEMtoolsにインポートされるモデルは、SAP2000中で使用されるモデル

と異なる場合があります。リファイン・メッシュをエクスポートすることも可能ですが、そのエクスポ

ート・ファイルはFE解析に必要なすべてのデータを含むとは限りません。そのため、自動的に細分化さ

れたメッシュは、FEMtoolsへインポートすべきではありません。 
 
したがって、SAP2000モデルはすべての自動メッシュ細分化オプションのスイッチをオフにし、FEMtools
へインポートしなければなりません。自動メッシュの細分化を非アクティブにする方法の詳細について

は、SAP2000ドキュメントを参照してください。 
 
SAP2000インターフェイスは、リファイン・メッシュを含む.s2kファイルに遭遇するとエラーメッセージ

を生成します。 

• .s2kファイル・フォーマットの変更に伴って、SAP2000インターフェイスも改良されました。データテー

ブルが.s2kファイルに現われる順番はバージョン間で変わる傾向があります。SAP2000インターフェイス

は、.s2kファイルに現れるデータテーブルの順番に影響されません。 

Polytec インターフェイス 
• Polytecファイル・インターフェイスは、より汎用的で強力なデータ・インターフェイスとして再設計され

ました。インポートされるデータセットには5つの特性の指定が可能です。 



 

 14 

 Data type：データ・タイプとして、バンド範囲、ポイント範囲、ポイント・アベレージ範囲など対

応するデータセットを読み込むかどうかを明示します。Polytecインターフェイスはバンドやポイン

トの範囲に基づくシェープを抽出することもできます。また、ポイント範囲とポイント・アベレー

ジ範囲に基づくカーブを抽出することもできます。 

 Domain：データ領域タイプを指定します。その典型的な領域タイプは、FFTやRMSです。 

 Channel：データ・チャネル・タイプを指定します。その典型的なチャンネル・タイプは、Vib 3D、

Vib X、Ref1、Vib Z&Ref1などです。 

 Signal：データ信号タイプを指定します。典型的な信号タイプは、変位、速度、加速度などです。 

 Display：ディスプレイ・タイプを指定します。典型的なディスプレイ・タイプは、Magnitude（マ

グニチュウド）やReal &Imag.（実数と虚数）です。 

• GUIを使用し、Polytec Interface Settingsダイアログボックスから5つの特性を指定することができます。そ

のダイアログボックスには、データ・ファイル中のデータセットが示されます。Polytecインターフェイス・

セッティングはSettingsダイアログボックス（Edit > Settings > Data Interfaces > Polytec .svd Interface）か

らアクセスすることができます。 
 

 
 

• コマンドモードでは、それらのデータセットは、SET INTERFACE POLYTECコマンドで指定することが

できます。そのデータは、SEARCH…FORMAT POLYTECコマンドでインポートされます。 

• インターフェイスは、TRIA3/QUAD4トレースリンク要素、あるいはLINE2トレースラインとしてのPolytec
要素をインポートすることができます。このセッティングは、Polytec Interface Settingsダイアログボック

スのConvert Elements to LINE2チェックボックス、あるいはSET POLYTEC INTERFACE WIREFYコマ

ンドによってコントロールされます。 

• polytecinfo.basユーティリティが追加されました。このユーティリティは、どのデータセットがPolytecデー

タ・ファイルにおいて利用可能かチェックし、Polytecデータ・ファイル全体をスキャンし、遭遇したデー

タセットをすべてリストします。 

メッシュ生成 
構造メッシュ・ジェネレータは高速化のために最適化されました。これは大規模メッシュにおいて顕著な処

理時間の短縮が可能になります。この最適化は、GENERATE BRICK、GENERATE CURVE、GENERATE 
RECTANGLE、DSPACEなどのコマンドの処理速度も改良します。 
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データベース管理 
このセクションでは、FEMtools 3.7リリースでのデータベース管理の変更点について記述します。 

マスターDOF 選択と検証 
MDOFは、ペアDOFセット（モデル相関結果）あるいは他のユーザー定義DOFセットに由来し、その縮小化

精度はMDOFの選択に依存します。したがって、適切な選択を行なうことが重要です。通常、MDOFに適切

なDOFは低剛性/質量比（K/M比）を指定します。その計算されたK/M比は、次の操作で結果を視覚化するこ

とができます。 

• メイン・メニューから、Database > K/M Ratioを選択する。 

• EXAMINE KMRコマンドを使用する。 

結果は次の4つの方法で視覚化することができます。 

• Absolute：計算結果のK/M比値 

• Normalize：0～1間に正規化されたK/M比値 

• Ranking：DOFは、昇順のK/M比値によってラインキングされます。最低のK/M比インデックスは1に等し

く、最大のK/M比インデックスは、モデルのDOF数と等しくなります。プロット表示では、青色エリアは

低K/M比値のゾーンを示し、赤色エリアは高K/M比値のゾーンを示します。 

• MDOF：正規化K/M比は、MDOFに依存し、MDOFが定義されている場合のみ、このオプションが適用さ

れます。 

グラフィックス・ウィンドウの左上隅のドロップダウンリストから適切なビジュアル方法を選択してくださ

い。 

単位 
モーダル・ベース・アセンブリ（MBA）ツールは、単位（Unit）の使用をサポートします。MBAにおいて単

位が使用される場合、それらの単位のポイント、ノード、材料特性、幾何学特性を定義するには、ダイアロ

グボックスが使用されます。その単位系の変更は、単にダイアログボックスのラベルのみを変更し、データ

ベースに格納されたデータには適用されないことに注意してください。これらのラベル中の単位は適切な単

位のデータ入力を支援するためのガイドラインとして有効です。 

FE モデルの単位変換 
FE Model Units Conversionダイアログボックスのレイアウトが更新されました。スケーリング・オプション

としては、力（force）ベースの単位スケーリング、質量（mass）ベースの単位スケーリング、構造質量（structural 
mass）プロパティ・スケーリングの3つがあります。典型的な単位系間でモデルを変換するために必要とされ

るスケーリング係数を自動的に検索するためのボタンが追加され、MKS、mmNS、IPS、FPSなどの単位系が

サポートされます。 
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座標変換 
Transformation PanelダイアログのAmplitudeボックスのラベル機能が変更されました。そのAmplitudeは選択

される変換機能に基づいた、Scaling Factor（スケーリング係数）、Translation Step（変換ステップ）、Rotation 
Angle（回転角）になりました。 

オイラー・アングル 
オイラー・アングル（Euler Angles ）を使用し、座標系を定義するユーティリティ・スクリプト（define_euler.bas）
が追加されました。スクリプトは、LMS Test.Labに準拠したオイラー角変換法を使用します。このスクリプ

トはオイラー角を9つの座標ベースの直交座標系を定義するために使用される変換マトリクスに変換します。 

モードシェープ実部表現 
いくつかのモードシェープ実部表現（Realization）の手続きが改良されました。 

• モードシェープ実部表現されたデータが、複素シェープのデータ・オブジェクト

（ST_TEST_CMODE_DISPL）として保存される場合がありました。この問題が修正され、モードシェー

プは実部シェープとして格納されます。 
 
ST_TEST_NMODE_DISPL 

• シェープが実部表現されても、エクスプローラ中のモードシェープ・ラベルは更新されません。 

• コンソール・ウィンドウ中の出力形式（フィードバック）が改良されました。 

• ドキュメントが改良されました。 

シェープの FREEZE コマンド 
FREEZEコマンドが改良され、変位フィールドの回転は適切に処理されず、（RX、RY、RZ）が（0、RX、

RY）に変換されていました。この問題が修正されました。 

周波数応答関数 
周波数応答関数（FRF）データベースの変更点 

• テーブルやグラフィックスのウィンドウが開いている場合のFRFプロセス速度が最適化されました。 

• FRFの未知の加振位置や方向を指示として、その加振ポイント番号とDOFのには、0が使用されます。 
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• FRFの未知の応答位置や方向を指示として、その加振ポイント番号とDOFのには、0が使用されます。 

周波数レンジ 
• DEFINE RANGE…STEPコマンドの近似化（まるめ）エラーにより、範囲の最終値が設定されないことが

ありました。この近似化エラーを修正しました。 

• FRF（FEAまたはテスト）に参照付けられている範囲を再定義すると、FRFの再サンプリングを行ないま

す。必要に応じて、追加するFRFラインが外挿法によって追加されます。 

• FRFがすべて消去された場合でも、その範囲設定は消去されません。CLEAR PROJECTやCLEAR RANGE
コマンドが実行される場合のみ、それらが消去されます。 

ダンピング 
モードシェープのチェック・コマンドとしてのDEFINE DAMPING STRUCTURAL/VISCOUSコマンドが削

除されました。このチェックは次のエラーメッセージを出力していました。 

ERROR : Need FEA MODE SHAPES to define MODAL DAMPING  

このメッセージは、グローバルな粘着や構造のダンピング（減衰）において、適切ではありませんでした。 

FRF - ODS 変換 
周波数応答関数（FRF）と実稼動変形シェープ（ODS）のデータ変換のための新しい2つのユーティリティ・

スクリプトが追加されました。 

• frf2ods.bas：指定のFRFセットををODSセットに変換します。 

• ods2frf：指定のODSセットをFRFセットに変換します。 

それぞれのスクリプトは、FEMtoolsインストール・フォルダ：../scripts/utilitiesで見つけることができます。 

モデル・プロパティ 
Ft_GetModel関数として、modal.a、modal.b、modal.mass がサポートされます。 

要素セット生成 
感度レベルに基づいたセットを生成するユーティリティ・スクリプト（definesetsen.bas）が追加されました。

このユーティリティにより、最大感度の要素セットを迅速に生成することが可能になりました。そのスクリ

プトはインストール・フォルダ：../scripts/utilitiesで見つけることができます。そのユーティリティの補足情報

については、HELP DEFINESETSENコマンドで得られます。 

インポート/エクスポート・セット 
インポート/エクスポート・セットのためのimpset.basとexpset.basのユーティリティが次のように改良されまし

た。 

• インポート・ルーチンはバイナリサーチ法を使用し、データセットをインポートする時間の縮小化が図ら

れました。大きなデータセットの場合には、その処理時間を100%以上短縮します。 

• コンソール・フィードバックが改良されました。 

セットの消去 
Ft_Clear setあるいはCLEARコマンドが改良されました。例えば、パラメータ定義（グローバル・パラメータ）

やレスポンス定義（例えば、要素セットの質量）に参照付けられたセットが削除されます。 

ポイント群（Point Clouds） 
ポイント群を扱うAPI関数が追加されました。この関数はポイント群のオブジェクトを作成し、それらの距離

に基づいたポイントをフィルタリングとするために使用することができます。ポイント群の扱い関する詳細

情報は、FEMtools Scripting Reference Manual （スクリプト・リファレンスマニュアルあるいはオンラインヘ
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ルプ）の CreateObject、Fill and NearestPoint topics で見つけることができます。 

グラフィックス 

Edges 
Edges（エッジ）は、エッジ・リムーバブル（Edit > Settings > Rendering）が修正される場合、再描画されま

す。 

Curve 
• デフォルトのCurve（カーブ）色として、新しい2つのセッティング（curve.color.femとcurve.color.test）が

追加されました。これらの2つの変数は、FEAとテストのカーブのデフォルトの色を定義します。これら

の2つの変数の青色（FEデータのメッシュ・プロットのデフォルト）は、FEA FRFのデフォルトの色とな

り、赤色（テストデータのメッシュ・プロットのデフォルト）は、テストFRFのデフォルトの色となりま

す。これはデータ・タイプに一貫した色を与えます。これらの新しい変数のデフォルト・セッティングは、

Settingsダイアログボックス（Edit > Settings > Style > Curve Graphics > Color Settings））でカスタマイズ

することができます。 

• FRFペア・プロットで使用されるインデックスは、実際のFEAとテストのFRFのインデックスに変更され

ました。旧バージョンでは、FRFペア・インデックスが使用されました。 

• ボード線図と実数部/虚数部の2段目のプロット・ウィンドウのズーム処理が改良されました。 

• ボード線図と実数部/虚数部の2段目のプロット・ウィンドウのパニング処理が改良されました。 

メッシュ・プロット 
• セット選択用のドロップダウン・リストボックスがモーダルと要素シェープのデータプロットのために追

加されました。 

• 60FPS（VSYNC）で生じるフレームレート問題を回避するために、OpenGLグラフィックス設定（リフレ

ッシュ間隔を0にセット）を改良しました。 

ユーザー・インターフェイス 
本章は、FEMtoolsユーザー・インターフェイスの主な変更点を示します。 

コンソール・ウィンドウ 
• Select a Menu Fileダイアログボックスで、Cancelボタンを押したときにコンソール・ウィンドウにエラー

メッセージを出力しないように改良しました。 

• <ESC>キーストロークのチェック処理において、CPU時間を短縮するように、WAITコマンドが最適化さ

れました。 

• コマンド・スクリプトの終了時に、常に「END OF COMMAND SCRIPT」メッセージを出力します。 

• コンソール・ウィンドウにはコマンド・スクリプトの実行時間を表示します。その実行時間は、任意時間

（秒～時～日）を出力します。 

• WindowsやLinuxにおいて、科学的浮動小数点出力フォーマットとして、0.0000E+000に代わり、0.0000E+00
で出力されるように修正されました。 

グラフィックス・ウィンドウ 
• 新しいユーティリティ・スクリプトは、メッシュまたはマトリックスのグラフィック表示の正規面を得る

ために付け追加されました。その詳細については、../scripts/utilities/normaltoview.bas.を参照してください。

このユーティリティはアクティブ・グラフィックス・ウィンドウに適用されるため、エディター・ウィン

ドウをアクティブ・ウィンドウとしたエディター・ウィンドウからユーティリティを実行するべきでない

ことに注意してください。このユーティリティを使用するには、対象のグラフィックス・ウィンドウを選

択し、コンソール・ウィンドウのコマンド・エントリー・ラインに、NORMALTOVIEWコマンドと入力

してください。 
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エクスプローラ 
• 次の2つのオプションがエクスプローラのTablesタブの質量と剛性の縮小マトリックスのポップ・アップ

メニューに追加されました。 

 マトリックス・プロットとしての縮小マトリックス表示（Display the reduced matrix as a matrix plot.） 

 縮小マトリックスの消去（Clear the reduced matrix.） 

• エクスプローラ表示は、MPEアプレットの終了後に回復されます。 

パネル 
• モーダル・ベース・アセンブリ（MBA）解析のための新しいパネルが追加されました。パネルを開くに

は、メイン・メニューから、Tools > Modal Based Assembly (MBA) > Analysis、あるいはMBA PANELコマ

ンドを使用します。 

テーブル 
• テーブル・コンテンツの10進数数値データはコンマを使用して、クリップボードにをエクスポートするこ

とができます。このオプションをアクティブするには、Settingsダイアログボックス（Edit > Settings）の

Table Windows > Export Tables Using Decimal Comma をチェックします。 

• WindowsやLinuxにおいて、科学的浮動小数点出力フォーマットとして、0.0000E+000に代わり、0.0000E+00
で出力されるように修正されました。 

ダイアログボックス 
• モーダル・ベース・アセンブリ・セッティングを編集するためのダイアログボックスが追加されました。

ダイアログボックスを開くには、メイン・メニューから、Tools > Modal Based Assembly (MBA) > Settings
を選択します。  

• 前バージョンでは、1000を越える幾何学特性や材料特性が存在する場合、Element Selectionダイアログボ

ックスにおいて、GeometryやMaterialのツリーが表示されませんでしたが、その問題を修正し、それらの

ツリーが表示されます。また、幾何学特性や材料特性のリストの代わりにメッセージが示されます。幾何

学特性や材料特性のすべてを示すことは、ダイアログボックスの表示において過度な時間が必要となりま

す。 

• エクスポート・ダイアログボックスには、圧縮モードをコントロールするためのSettingsダイアログボック

スがあります。 
 

 
• 手動でGUIベースのDOFペアを定義する機能が追加されました。レコード追加（Add Record）操作（Edit > 

Table > Add Records, Toolbar > Add Record or Popup-menu > Add Record）あるいはポップ・アップメニ

ューのAdd Recordを実行すると、DOF Pairingダイアログボックスの代わりに、Create/Edit DOF Pairsプ
ロパティ・ボックスが開かれます。そのCreate/Edit DOF Pairsは、指定DOFペアの生成を可能にします。

プロパティ・ボックスにはその他のボタンがあり、Automatedボタンは、自動DOFペア生成のためのDOF 
Pairingダイアログボックスにアクセスすることができます。 
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• Generate Master DOFsダイアログボックスのレイアウトがアップグレードされました。そのダイアログボ

ックスは、ジャーナル中にMDOFを定義するために使用されるコマンドを出力します。Automatedボタン

が、Generate Master DOFsダイアログボックスへアクセスするために、Create/Edit Master DOFプロパテ

ィ・ボックスに追加されました。 

• ユーザーの書き込み許可がなく、外部ソルバーの.iniファイルに変更を追加しなければならない場合、

Settingsダイアログボックスは対応するエラーメッセージを生成します。 

• 相関分析（correlation analysis）ダイアログボックスのドロップダウン・リストボックス（MAC, MSF, EVO, 
POC, DAC, DSF, DPC, AutoMAC FEA, AutoMAC Test, AutoEVO FEA, AutoEVO Test, AutoDAC FEA, 
AutoDAC）がすべてのダイアログボックスと同じ記法を使用するように修正されました。その他の改良と

して、内部セット（負の外部ID）の表示をなくし、また座標系の記述などがあります。 

• 用語としてのEMAは、Displacement Pairingダイアログボックスにおいて、Testに替えられました。 

• ヘルプ・セクションが、Settingsダイアログボックス（Edit > Settings）の下方に追加されました。このパ

ネルは、構成変数のサポート値に関する補足ヘルプを示します。選択された変数で利用可能なヘルプがあ

る場合、そのパネルが現われます。 
 

 
• 多くのアイテムを持つドロップダウン・リストボックスの処理（初期化）が改良されました。 

メニュー・コマンド 

新しいメニュー・コマンド 

次のメニュー・コマンドが追加されました。 

Database > K/M Ratio DOFの剛性/質量比を計算します。  

Tools > Frequency Response Analysis > Dynamic Compensation モーダルベース・アプローチを使用して計算さ

れたFRFのダイナミック補正（Dynamic 
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Compensation ） 

Tools > Modal Based Assembly (MBA) > Settings  モーダルベース・アセンブリ・セッティングを

定義します。 

Tools > Modal … (MBA) > Substructures   MBAサブストラクチャの追加と修正 

Tools > Modal … (MBA) > Analysis   モーダル・ベース・アセンブリ（MBA）ソル

バー・パネルを開きます。   

Tools > Modal … (MBA) > Clear FEM Base   モーダル・ベースの剰余FEモデルを消去しま

す。 

Tools > Modal … (MBA) > Parameters  MBAパラメータの追加と編集 

Tools > Modal … (MBA) > Compute Range   一連のパラメータ値の指定範囲に関するレス

ポンスを計算します。 

Tools > Pretest … > Automated Sensor Selection   自動センサー選択パネルを開きます。   

修正されたメニュー・コマンド 

次のメニュー・コマンドが修正されました。 

File > New Project このメニューは、File > New サブメニューに

移動され、また、Project としてリネームされ

ました。 

削除されたメニュー・コマンド 

次のメニュー・コマンドは削除されました。 

Structural Dynamics Modification (SDM)  このサブメニューは、Modal Based Assembly 
(MBA)サブメニューに替えられました。 

Sensor Placement using Normal Modal Displacement (NMD) このコマンドは、Automated Sensor Selection
メニュー・コマンドに替えられました。 

Sensor Placement using Nodal Kinetic Energy (NKE) このコマンドは、Automated Sensor Selection
メニュー・コマンドに替えられました。 

Sensor Elimination using Effective Independence Method (EIM) このコマンドは、Automated Sensor Selection
メニュー・コマンドに替えられました。 

Sensor Elimination using MAC Method (SEAMAC)  このコマンドは、Automated Sensor Selection
メニュー・コマンドに替えられました。 

Sensor Elimination using Iterative Guyan Reduction (IGR) このコマンドは、Automated Sensor Selection
メニュー・コマンドに替えられました。 

ツールバー 
• 新しいプロジェクトを作成するためのProjectアイテムが、メインツールバーの新しい（）ボタンのサブメ

ニューに追加されました。 

• Save As（ ）ボタンがメインツールバーに追加されました。 

解析 
解析（Analysis）モジュールの主要な変更点を以下に示します。 

FEMtools ソルバー 
• FEMtools fta.exeソルバーは、テンポラリファイル・パスにワーキング・パスを変更し、一旦、解析が終わ

ると最初のワーキング・パスを回復します。前バージョンでは、ソルバーがユーザーの介在によって中断

された時、例えば、ストップ・ボタンの実行された場合、必ずしもワーキング・フォルダを適切に回復す
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るとは限りませんでした。この問題が解決され、ソルバーは常に、デフォルト値のワーキング・パスに戻

します。 

• マトリックス処理は、Windows上に比べて、LinuxとMac OS X上ではより多くの時間がかかりました。Linux
とMac OS X用のMKLライブラリは、FFT、SVD、EIGなどの関数速度の改良によりアップグレードされま

した。これらの関数は、モードパラメータ推定（MPE）でも広範囲に使用され、LinuxやMac OSX.におい

ても高速化されました。 

• FEMtoolsは、総括的な幾何学特性をサポートします。総括的な幾何学特性は、12x12要素マトリックスの

対角上部によって表わされます。幾何学特性はマトリクス・タイプ（剛性、質量、減衰）、および対応す

る要素マトリックスの対角上部の78の係数によって定義されます。その総括的な幾何学特性は、DEFINE 
GEOMETRY GENERICコマンド、Ft_DefGeoGeneric API関数あるいはグラフィックス・インターフェイス

（Explorer > Tables > FE-Model > Geometrical Properties）を使用し、定義することができます。総括的な

幾何学特性の定義についての詳細情報は、オンラインヘルプ（Help > Help Topics）のコマンド・リファレ

ンスやFEMtools APIリファレンスで見つけることができます。 

モデルの縮小 
• SET REDUCTIONコマンドのMETHOD補語として、DIRS、DYNAMIC、GUYAN、IIRSなどの値が追加

されました。このコマンドは、既に設定されたそれらの互換値を維持します。 

• 補語SILENTがコンソール出力を抑制するために、SET REDUCTIONコマンドに追加されました。 

• Compute Reduces System Matrices （Database > Reduce FEM System Matrices）ダイアログボックスは、

dynamic reduction（動的縮小）やdynamic IRSの実行コマンドにおいて、構文エラーを生成しません。 

• REDUCEDコマンドに、MASSとSTIFFNESSの補語が追加されました。これらの補語は縮小質量や縮小剛

性のマトリクスを計算しなければならないことを明示します。そのため必要に応じて、縮小質量マトリク

スを計算してください。FEMtoolsソルバーが縮小化に使用される場合のみ、MASSとSTIFFNESSの補語が

サポートされることに注意してください。例えば、NASTRANが縮小化ソルバーとして使用されている場

合は、これらの補語はサポートされません。 

• REDUCEコマンドのコンソール出力が改良されました。 

FRF の計算 
著しい変更は、FRF計算（直接法、Pade、モーダル）用の異なる既存の方法に行なわれました。 

それらについては後述されます。また、動的補正を使用する新方式がこのリリースで導入されました。 

直接法のFRF計算 

新しいコマンドDIRECTFRFが直接法のFRF計算の精度と高速化を改良するために導入され、以前のDFRFコマ

ンドに取って替わりました。 

• 高速化 
FEMtools fta.exeソルバーは、周波数に依存する動的マトリックスを生成することなく、対象周波数レンジ

における計算を繰り返します。この特殊な因数分解法の導入において、各周波数ラインの動的マトリック

スがその因数分解を行なう前に構築され、対象周波数ライン間での必要以上のディスク・アクセスは行な

われません。ソルバーに与えられる荷重は、微小とされ、レスポンス出力がFRFのリファレンスDOFに制

限される場合、その加振DOFセットに制限された周波数依存する値が示されます。生成されるFRF値は、

ポインタ・アルゴリズムによってFRF構造に直接的に与えられ、多数のFRF（FBAの例題参照）では、メ

モリー上での重複を回避します。 

• ローカル座標系の追加サポート 
解析は、ローカル座標系での剛性、質量、減衰のマトリックスに対して実行されます。これは、ローカル

座標系でのFRFを生成するために、ローカルな境界条件、強制変位、荷重（ロード）にも対応し、NASTRAN
のデータも利用できます。 

• マルチ・リファレンス強制変位のサポート 
マルチ・リファレンス強制変位は、指定された変位と等価な1セットの動的力の生成をサポートします。

これらの力は次式によって計算されます。 
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ここで、i：強制変位DOF、j<>iは、動的力が適用されるその他のDOFです。これらの力は周波数に依存（ω
またはω2）し、強制変位DOFにはダンパーあるいは、特定の質量が指定されます。周波数に依存する力は

ω0、ω1、ω2の項に分解され、対象周波数レンジでループ計算され、再構築されるようにソルバーに渡され

ます。このアプローチのsの他の利点としては、低周波数での慣性が軽減されることなくモデルが生成さ

れることです。 

パデ近似法 

パデ近似（Pade approximants）法のFRF計算アプローチが拡張されました。 

• パデ近似アプローチに、GUIが追加されました。パデ近似アプローチは、FRF Analysisダイアログボック

スのFRF計算方法として、メイン・メニューから、Tools > Frequency Response Analysis > Frequency 
Response Functionsを選択することができます。 

• 再帰的リファイン・ルーチンが収束結果を保証するために付け追加されました。 

• 必要な精度結果と実行反復数をコントロールすることができます。その反復数と精度結果は、FRF 
Analysisダイアログボックス中でコントロールされ、また、PADEFRFコマンドの新しいITERATIONと

PRECISIONの補語を使用することができます。 

• ローカル座標系がサポートされました。 

• マルチ・リファレンスの強制変位がサポートされました。 

• その他の問題が解決されました。 

モーダル・ベースのFRF計算 

新しいコマンドのMODALFRFがモーダル・ベースのFRF計算を改良するために導入されました。 

• MODALFRFコマンドは、既存のFRFコマンドより効率的な効果を提供します。これは、FBAアプリケーシ

ョンなどの多くのFRFを計算する場合において有用です。 

• MODALFRFコマンドは、FRFコマンドより強力な方法で多数の強制変位リファレンスをサポートします。 

• MODALFRFコマンドは、FRFコマンドの代用として使用することはできません。いくつかの機能（例えば、

感度解析）では、MODALFRFコマンドはサポートされません。 

• FRF TESTコマンドが拡張されました。 

 UPDATEの補語として、SAC、CSAC、CSFおよびレスポンスを更新すべきかどうか示すために追加され

ました。デフォルト=ON 

 RESIDUALの補語として、剰余値を使用すべきかどうか示すために追加されました。デフォルト=ON 

 SCALEの補語として、計算されたFRFに適用されるスケーリング係数を指定するために追加されました。

デフォルト=1.0 
正規と複素のモードシェープがサポートされます。 

動的補正 

動的補正（Dynamic compensation）、即ち、直接的FRFシミュレーションにおいて多くの周波数ラインを使用

するモーダルの重ね合せFRFの誤差を縮小化する技術が追加されました。 

• 動的補正は、剰余ベクトルの使用に取って替わります。 

• 動的補正は荷重（ロード）と強制変位の両方でサポートされます。 

• 参照周波数は手動あるいは自動的に定義することができます。 

• 動的補正は次のように実行されます。 

 Tools > Frequency Response Analysis > Frequency Response Functionsから、FRF Analysisダイアログ

ボックスを開き、modal-based FRF computationオプションを選択します。 
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 Tools > Frequency Response Analysis > Dynamic Compensationから、Dynamic Compensation ダイア

ログボックスを開き、1セットの既存のFRFに適用します。 

 DYNCOMPコマンドを使用する。 

FRF ベース・アセンブリ（FBA） 
FBAソルバーが拡張され、改良されました。 

• FBAソルバーは、計算に使用するFRFセットに関して様々な予備チェックを行ないます。例えば、ドライ

ビング・ポイントのFRFがインターフェイスDOFに必要とされるかなどをチェックします。 

• MPCのサポートが、JOINTSやBOUNDINGSの代案として追加されました。 

• FBA LOADSとFBA RESPONSESが追加され、周波数に依存する荷重がサポートされました。 

• FBA FRFとFRF RESPONSESは、joints、boundings、MPCの内部力の出力をサポートします。これは、例え

ば、インターフェイス間の力の作用によるスタンドアロン・コンポーネントの研究に有効です。 

• 強制変位が加速度FRFの入力コンポーネントとしてサポートされます。 

• トランスファー・パス解析（TPA）は、FBA荷重、FBAレスポンス、FBA TABLESのジョイント内部力の

変換をサポートします。 

• いくつかの例題がこれらの新しいFBA機能を例証するために追加されました。 

モーダル・ベース・アセンブリ（MBA） 
FEMtools 3.7はモーダル・ベース・アセンブリ（MBA）、動解析用の新しいツールを導入しました。その詳

細については、FEMtools Dynamics User's Guide（ダイナミック・ユーザーガイド）の7章を参照してください。 

MBAコマンド 

次のMBAコマンドが利用可能です。 

CLEAR MBA PARAMETER MBAパラメータを削除します。 

CLEAR MBA SUBSTRUCTURE MBAサブストラクチャを削除します。 

DEFINE MBA PARAMETER 新しいMBAパラメータを作成します。 

DEFINE MBA SUBSTRUCTURE 新しいMBAサブストラクチャを作成します。 

EXTRACT MBA PARAMETER コンソール・ウィンドウのMBAパラメータ情報をリストしま

す。 

EXTRACT MBA SUBSTRUCTURE コンソール・ウィンドウのMBAサブストラクチャ情報をリス

トします。 

MBA CLEAMFEMBASE 剰余FEモデルのモーダル・ベースを消去します。 

MBA COMPUTE モーダル・ベース・アセンブリ問題の解析を実行します。 

MBA EXPLODE MBAサブストラクチャをFEモデルに変換します。 

MBA PANEL モーダル・ベース・アセンブリ・パネルを開きます。 

MBA RANGE 一連のMBAパラメータ値に関するレスポンス推定します。 

MODIFY MBA PARAMETER MBAパラメータのプロパティを修正します。 

MODIFY MBA SUBSTRUCTURE MBAサブストラクチャのプロパティを修正します。 

SET MBA モーダル・ベース・アセンブリのデフォルト・セッティングを

指定します。 

プリテスト解析 

モード刺激解析 
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• Mode Participation Analysisダイアログボックスは、事前にMPA解析に使用された設定値をデフォルト値

として、Define Input DOFsテーブルに入力されたそれらの入力DOFに再設定されます。 

• 使用モード刺激解析を例証する例題：../examples/pretest/mpa/mpa_beam.cmdが追加されました。  

Kinetic Energy（運動エネルギー）分布 

• EXAMINE KEDコマンドは、Kinetic Energy分布を計算するためのベースとしてのDOFノードの使用をサ

ポートします。これは新しい補語BASEによって行われます。 

• ヒストグラムのビン数は、EXAMINE KEDコマンドの補語BINSによって、カスタマイズすることができ

ます。 

• KEDは、グローバル座標系、ローカル座標系あるいは正規表面方向で計算することができます。使用する

座標系は、EXAMINE KEDコマンドの新しい補語CSで指定されます。 

• EXAMINE KEDコマンドによって生成されたXYプロットは、エクスプローラ・ウィンドウに追加され、

KEDを再計算することなく、再プロットすることができます。 

マニュアル・センサー選択 

• 典型的なノード選択を手動で行うことができ、また、1つのコマンド・ステートメントでマルチ・センサ

ーを削除することができるように、PRETEST REMOVEコマンドの補語NODEが拡張されました。 

• 手動マルチ・センサーの手続きが最適化され、その結果、典型的なノード選択において使用される

PRETEST ADD/REMOVEコマンドの処理時間が短縮されました。 

• マルチ・センサーのために使用されるのPRETEST ADDコマンドのコンソール出力が改良されました。 

• Manual Sensor Selectionパネル上でセンサーを追加すると、メッシュ・プロットのDOFマーカーが直ちに

リフレッシュされます。 

自動センサー選択 

• Automated Sensor Selection選択パネルのFixed Sensor Locationsセクションのコントロールの不能問題が

修正されました。 

• 候補ノードとしてのカスタム・ノード・セットの選択動作が修正されました。 

• ノード・セットが作成されるか削除された場合、ノード・セット・ドロップダウンリストが適切にリフレ

ッシュされます。 

• Automated Sensor Selectionパネルは、FEMtoolsで使用される正規化モーダル変位（NMD：Normalized Modal 
Displacement）、節点運動エネルギー（KNE：Nodal Kinetic Energy）、有効独立法（EIM：Effective Independence 
Method）、自動センサー除去MAC法（SEAMAC：Automated Sensor Elimination use MAC）、反復Guyan縮
小化（IGR：Iterative Guyan Reduction）などの自動センサー選択技術のすべてをサポートします。 

正規化モーダル変位 

• 正規化モーダル変位（NMD：Normalized Modal Displacements）は、正規表面方向で計算されます。Normalized 
Modal Displacement (NMD)ダイアログボックス中のCoordinate Systemドロップダウンリストから、

Normal-to-surfaceを選択することができます。オプションのNORMALが、EXAMINE NMDコマンドのCS
補語に追加されました。 

• NMDを使用した自動センサー配置技術が拡張されました。 

 あらかじめ指定された固定センサー位置を使用することができます。その結果は手動センサー選択

あるいは他の自動センサー選択技術の初期ポイントとして使用されるセンサー位置として格納す

ることができます。 

 センサー配置位置の最小数や平均NMDを使用することができます。 

 EXAMINE SPANMDコマンド・シンタックスが修正されました。このマニュアルの「修正されたコ

マンド（Modified Commands）」セクションに、その変更点の詳細を示します。 
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 自動NMDセンサー配置技術は、Automated Sensor Selectionパネルに統合されました。このパネルに

よって提供されるオプションは、NMDセンサー配置技術をサポートします。 

 旧バージョンでは、EXAMINE SPANMDはNMDを再計算しましたが、新バージョンでは、この再

計算されたNMDは既存のNMDシェープで上書されます。データベース中のNMDシェープには、

EXAMINE SPANMDが使用されます。 

節点運動エネルギー 

• 節点運動エネルギー（NKE：Nodal Kinetic Energy）は、ローカル座標系あるいは正規表面方向で計算す

ることができます。Nodal Kinetic Energy (NKE)ダイアログボックスのCoordinate System（座標系）ドロ

ップダウンリストから適切な参照システムを選択することができます。また、EXAMINE NKEコマンド

はCS補語で拡張されました。 

• NKEを使用する自動センサー配置技術が拡張されました。 

 あらかじめ指定された固定センサー位置を使用することができます。その結果は手動センサー選択

あるいは他の自動センサー選択技術の初期ポイントとして使用されるセンサー位置として格納す

ることができます。 

 センサー配置位置の最小数や平均NKEを使用することができます。 

 EXAMINE SPANKEコマンド・シンタックスが修正されました。このマニュアルの「修正されたコ

マンド（Modified Commands）」セクションに、その変更点の詳細を示します。 

 自動NKEセンサー配置技術は、Automated Sensor Selectionパネルに統合されました。このパネルに

よって提供されるオプションは、すべてのNKEセンサー配置技術をサポートします。 

 旧バージョンでは、EXAMINE SPANKEがNKEを再計算しましたが、新バージョンでは、この再計

算されたNMDは既存のNMDシェープに上書されます。データベース中のNKEシェープには、

EXAMINE SPANKEが使用されます。 

有効独立方法 

• 有効独立法（EIM：Effective Independence Method）の自動センサー除去技術が拡張されました。 

 あらかじめ指定された固定センサー位置を使用することができます。その結果は手動センサー選択

あるいは他の自動センサー除去技術の初期ポイントとして使用されるセンサー位置として格納す

ることができます。 

 EXAMINE EIMコマンド・シンタックスが修正されました。このマニュアルの「修正されたコマン

ド（Modified Commands）」セクションに、その変更点の詳細を示します。 

 自動NKEセンサー除去技術は、Automated Sensor Selectionパネルに統合されました。このパネルに

よって提供されるオプションは、すべてのEIMセンサー除去技術をサポートします。 

反復Guyan縮小化 

• 反復Guyan縮小化（IGR：Iterative Guyan Reduction）の自動センサー除去技術が拡張されました。 

 あらかじめ指定された固定センサー位置を使用することができます。その結果は手動センサー選択あ

るいは他の自動センサー選択技術の初期ポイントとして使用されるセンサー位置として格納するこ

とができます。 

 IGR法は正規表面のセンサーをサポートします。 

 EXAMINE IGRコマンド・シンタックスが修正されました。このマニュアルの「修正されたコマンド

（Modified Commands）」セクションに、その変更点の詳細を示します。 

 自動IGRセンサー除去技術は、Automated Sensor Selectionパネルに統合されました。このパネルによ

って提供されるオプションは、すべてのIGRセンサー除去技術をサポートします。 

MAC法センサー除去技術 - SEAMAC 

• SEAMACアルゴリズムは、入力座標系（ICS）に対応して動作します。 
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デジタル信号処理 

無効チャンネルの検知 

• DSP FINDDEADCHANNELSは、自動的に無効（DEAD）チャンネルを検知するために追加されました。

サンプル値がすべて指定されたしきい値より低いチャンネルのステータスは、DEADに切り替えられます。

他のすべてのチャンネルのステータスはACTIVEとしてマークされます。DSP FINDDEADCHANNELSコ
マンドは、無効とされたチャンネルを復活することもできます。 

参照チャンネルの検知 

• アクティブチャンネル数が要求されたチャンネル数より少ない場合、DSP FINDREFERENCESコマンド

はや時期尚早にもたらさないDSP。 

• DSP FINDREFERENCESコマンドは適切に無効チャンネルをフィルタ処理します。さらに、それらのす

べてのDEADサンプルは、0チャンネルとしてマークされます。 

ロード時間（Load Time）データ 

• LOAD TABLEコマンドは、データを読んだチャンネルのステータスをACTIVEにリセットします。 

モーダル・パラメータ・エクトラクター 
• GUIインターフェイスは、自動的に検出されないテストポイントの生成機能を提供します。自動的に生成

されたテストポイントは、原点位置に設定され、これらのポイントはモードシェープとしては表されませ

ん。しかし、それらはモーダル・パラメータ・エクトラクターでは有効とされ、テストデータから周波数

や減衰比を抽出するために使用されます。 

• モーダル・パラメータ・エクトラクターは、対象周波数レンジの上限と下限の近似整数値を使用していま

した。これは低周波数で問題（例えば、周波数レンジ[0.1Hz～0.6Hz]が、[0Hz～0Hz]）を引き起こす場合

がありました。そのため、その近似化（丸め）メカニズムが変更されました。また、周波数レンジが10Hz
以上の場合、周波数境界は最も接近した整数に近似されます。 

• 多くの測定DOFを使用し、AutoCOMACを計算すると多くの時間消費を招く場合があります。そのため、

AutoCOMAC計算のスイッチを切ることができます。それには、Poles ExtractionタブのShow Stabilization 
Settingsをチェックし、Modes ExtractionのCompute AutoCOMACチェックボックスを解除します。 

• Mode Extractionタブで表示される測定データのプロットにおいて、オリジナルのFRFとシンセシスFRFの
色が反転されました。シンセシスFRFは青色でプロットされ、オリジナルのFRFは赤色でプロットされま

す。これはデフォルトの色設定（テストデータは赤色、計算データは青色）です。 

• サードパーティのソフトウェアとの互換性を図るため、最低/最高の剰余値を示すかもしれない静的変位

も複素数のODSとして格納されます。その下限と上限の周波数帯域値はODS周波数として格納されます。

ただし、ODSの虚数部は常に0です。 

• FRFシンセシスはFRF TESTコマンドによって適切に生成されるように、最高/最低の残余値に関係する参

照ノード、参照DOFを適切に定義します。 

• .unvファイルにMPE結果をエクスポートする場合、残余ODSプロパティ（最高/最低の残余、参照ノード、

参照方向）は、FEMtools MPEによって生成された.unvファイルをインポートした後に、FRFシンセシスに

残余値を含むことを可能にする方法で書かれています。 

• DOFに関係する多くの修正がなされました。 

 APPLY DOFRELATIONSコマンド -> APPLY DOF RELATIONS 

 DEFINE_DOFRELATIONコマンド -> DEFINE DOF RELATION 

 EXTRACT DOFRELATIONコマンド -> EXTRACT DOF RELATION 

 CLEAR DOF RELATIONコマンドがDOF RELATIONを削除さるために導入されました。 

 DOF RELATIONのロバストが改良されました、例えば、DOF RELATIONは連続する識別番号が指

定されてはなりません。 
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 DOF RELATIONを使用する方法を例証する例題が追加されました。その例題ファイルはフォルダ：

<installdir>/examples/mpextractor/dofrelationで見つけることができます。 

• DOF RELATIONのドキュメントが改良されました。その例題（<installdir>/examples/mpextractor/dofrelations）
は、DOF RELATIONの使用方法を例証するために追加されました。 

相関分析 

空間相関（Spatial Correlation）分析 

相対空間の相関許容値用の新しい変数（correlation.tolerance.eps）が導入されました。この変数は最大モデル

サイズとの比率としての絶対空間の相関許容値を表します。変数（correlation.tolerance.eps）は、デフォルト

のcorrelation.tolerance値を計算するために使用されます。そのデフォルト値は0.05（5%）で、Settingsダイア

ログボックス中のAnalysis > Spatial Modal Correlation > Relative Spatial Correlation Toleranceでカスタマイ

ズすることができます。 

MAC寄与度分析 

テストシェープが複素データで、FEAシェープ数がテストシェープ数と等しくない場合、MAC寄与度分析は

実行されませんでしたが、この問題が回避されました。 

ノード-ポイント・ペアリング 

• PAIR NODEコマンドは次の補語によって拡張されました。 

 DIRECTION：ノード-ポイント・ペアリングの方向を指定します。従来のノード-ポイント・ペア

リングでは、ペアは3D空間のノード-ポイント間の距離に基づいて定義されました。ペアする方向

を指定する場合は、指定方向に垂直な平面上のノード間やポイント間の2D距離に基づいて定義され

ます。例えば、実際の構造物が屈曲し、FEメッシュにおいても屈曲が定義されている場合、この種

のペアリングは非常に有用です。またテストデータがカメラやスキャンニング装置で得られる場合

などにも有用です。 

 MERGE：自動ノード-ポイント・ペアリングの各ステップで使用可能なマージ機能 

 TOLERANCE：最大許容ノード-ポイント距離を指定する。 

• Node-Point Pairingダイアログボックスがアップグレードされました。 

 Directional node-point pairing（方向指定ノード-ポイント・ペアリング）、multiple step node-point pairing
（ マルチステップ・ノード-ポイント・ペアリング）がダイアログボックスに追加されました。 

 複数点間のノード-ポイント・ペアリング・インターフェイスが改良されました。 

 Applyボタンはダイアログボックスに追加されました。このApplyボタンによって、ダイアログボッ

クスを再オープンすることなく、ノード-ポイントのペア生成を繰り返すことが可能です。 

• 新しいユーティリティ（nppair.bas）が追加されました。このユーティリティは、方向指定ノード-ポイン

ト・ペアリングの機能を提供します。このユーティリティはノード-ポイント・ペアリングの希望するプ

ロセスためにカスタマイズすることが可能です。 

• いくつかの新たな相関分析例が追加されました。その例題は、フォルダ：../examples/correlation/ 
node_point_pairing/で見つけることができます。 

DOFペアリング 

• DOF PairingダイアログボックスとShape Correlation Filtersダイアログボックスは1つのダイアログボッ

クスに統合されました。その新しいDOF Pairingダイアログボックスには、DOFペアを生成するためのコ

ントロールのすべてを含みます。また、Shape Correlation Filtersメニュー項目がメニューから取り除かれ

ました。 

• DOF PairingダイアログボックスのDOF Maskラベルは、可変コンテキストです。グローバル座標系が選

択されている場合、Ux、Uy、...、Rzが使用され、ローカル座標系が選択される場合は、U1、U2、...、U6
ラベルが使用されます。 
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• DOF Pairingダイアログボックスのコンソール出力が改良されました。 

モードシェープ・ペアリング 

• 自動モードシェープ・ペアリングは従来のMACの代案として、POCに基づいて行うことができます。それ

は、Mode Shape Pairingダイアログボックス（Tools > Correlation Analysis > Mode Shape Pairs）のPairing 
Metricドロップダウンリストから、Pseudo Orthogonality Check (POC)を選択するか、PAIR MODEコマン

ドの新しいPOC補語を使用することによって行います。 

• MACの代案としてPOCを使用することができ、そのPOC結果の単位は絶対値からパーセンテージに変更さ

れました。例えば、0.9のPOC値は、90[%]として格納され、表示されます。 

• Mode Shape Pairingダイアログボックスは、最後に使用されたペアリング・タイプを維持し、コントロー

ルを適切に初期化します。 

• Mode Shape Pairingダイアログボックスは、再度ダイアログボックスを開くことなく、複数のモードシェ

ープ・ペアを手動で定義することを可能にするApplyボタンを持っています。 

• 実稼動モード解析シェープが使用される場合、混乱を回避するために、"EMA"は、Mode Shape Pairingダイ

アログボックス中で"Test"に替えられます。 

• PAIR MODE関数のMAC補語がドキュメント化されました。これは新しいの補語ではありませんが、これ

までドキュメント化されていませんでした。 

• モードシェープ・ペアのプロット処理が改良されました。モードシェープ・ペアは次の方法で表わすこと

ができます。 

 Full FEM and Test：これは、完全なFEモデルとテストモデルを重ねて表示します。 

 Reduced FEM & Test at Paired DOFs：これは、ペアされたDOFのポイントのみのテストモデルのグ

リッドでFEモデルとテストモデルのペアを表示し、また、ペアされたDOFの変位のみで表示されま

す。以前は、このプロットには完全なテストグリッドを使用しました。 

 FEM Mapped on Test：これは、FEモデルと完全なテストモデルのグリッドで表わされたペアを表

示します。その変位は、すべての測定テストDOFとペアのFE DOFによって示されます。以前、これ

は、Reduced FEM at Paired DOFsと称しました。 

 以前のReduced FEM at Paired Nodesオプションは削除されました。 

モードシェープペア・プロットを生成するコマンド・シンタックスも同様に変わりました。MESH PAIR 
int_val REDUCEDコマンドは、常に、Reduced FEM & Test at Paired DOFs としてプロットされます。この

コマンドが生成するプロットは、mesh.reduced.style変数に依存しません。"FEM Mapped on Test plot"は、 
MESH PAIR int_val MAPPED コマンドで生成することができます。 

FRFペアリング 

• Applyボタンが、FRF Pairing ダイアログボックスを再オープンすることなく、マルチFRFペアを定義でき

るように、FRF Pairingダイアログボックスに追加されました。 

• 自動FRFペアリングがサポートされました。ノード-ポイント・ペアが定義されている場合、FRFペアはそ

れらのノード-ポイント・ペアに基づいて生成されます。ノード-ポイント・ペアが定義されていない場合、

FRFはノードID=ポイントIDに基づいてペアリングします。ノードとポイントの両方が定義されている場

合のみ、自動FRFペアリングが可能です。GUIでは、自動FRFペアリングは、FRF Pairingダイアログボッ

クスを使用します。コマンド言語では、FRFペアリングは補語のないPAIR FRFコマンドの実行により処理

されます。 

座標変換 

Transformationパネル中のAmplitudeラベルは、コンテキスト変数ではなく、選択された変換関数に基づく、

Scaling Factor、Transformation Step、Rotation Angleに替えられました。パネル操作のみが修正され、

Transformation関数機能の変更にありません。 
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グローバル・シェープ相関 

• MAC、DAC（DPC）、DSFなどの基準係数は、指定モード数に従って計算することができます。これはデ

ータベースにモード数の次元を持たないMAC/DAC/DPC/DSFマトリックスによって可能になります。これ

は、TUNEコマンドと矛盾するため、MAC/DAC/DPC/DSFが指定のモード数で計算される場合、その結果

は、mac.modeset、dac.modeset、dpc.modeset、dsf.modesetなどのマトリックスとして格納されます。エクス

プローラには、それらの「縮小（reduced）」マトリックスがそれらの名前に従って示され、例えば、Modal 
Assurance Criterion（MAC – Mode セット）では「Mode Set」タグで示されます。 

• AutoMAC、POC、DAC、AutoDAC、DPCなどのテーブルの数値フォーマットがグローバル・シェープ相

関テーブルで示され、デフォルトの0.00000E+00フォーマットは、0.0フォーマットに変更されました。MAC
テーブルは、既に0.0フォーマットを使用していたことに注意してください。 

• EVO、AutoEVO、MSF、DSFなどのテーブルの数値フォーマットはグローバル・シェープ相関テーブルで

示され、デフォルトの0.00000E+00フォーマットは、0.000フォーマットに変更されました。 

固有ベクトル直角（EVO） 

• DOFセットを使用するFEモードのautoEVOの計算では、EXAMINE EVOコマンドを実行すると中断する問

題ありました。この問題が解決されました。 

• autoEVOの計算は、MDOFを使用して行うことができます。そのために、MDOFオプションにDOF補語が

追加されました。 

• ペアDOFがマスターDOFと同じ順番でなかった場合、テストモードのautoEVOは正しく計算されませんで

した。この問題が解決されました。 

• データベース内で利用可能な縮小システム・マトリックスのEVOを計算することができます。また、縮小

マトリックスは、EVOルーチンによって自動的に再計算することはありません。すべてのEVO計算ダイア

ログボックス（AutoFEM、AutoTest、FEMテスト）は、縮小マトリックスを再計算するためのCompute 
Reduced Matricesマトリックス・チェックボックスを持っています。コマンドライン・モードでは、再計

算セッティングをコントロールするために、EXAMINE EVOコマンドのREDUCTION補語を使用してくだ

さい。縮小化マトリックスがない場合、あるいは縮小マトリックスの次元がペアDOFの選択と一致しない

場合、縮小マトリックスは再計算セッティングに関係なく計算されることに注意してください。 

• EVO計算をスタートする前に、データベース中にMDOFが存在する場合、EVO計算ではMDOFを消去しま

せん。もしEVO計算をスタートする前にMDOFが存在しなければ、縮小システム・マトリックスを計算す

るために生成されるMDOFは、EVO計算の終了時点で消去されます。 

• ユーザーが現在のワーキング・ディレクトリに書き込み許可を持っていない場合でも、EVOを計算するこ

とができます。旧バージョンでは、「Access denied（アクセス無効）」というエラーメッセージを出力し

ました。 

感度解析 
次の2つの修正がパラメータ・スライダー・コントロールに追加されました。 

• 対象モデル要素がすべて修正要素として定義された場合でもスライダーは動作します。つまり、未使用の

FEモデルはありません。 

• 周波数がスライダーによって修正される場合、FEモード・プロットのドロップダウンリスト中のテキスト

も更新されます。 

モデルアップデーティング 

マニュアル・パラメータ・アップデーティング 

マニュアル（手動）パラメータ・アップデーティング・ルーチンがアップグレードされました。パラメータ

を修正してもレスポンスを自動的に更新しません。これによって、レスポンスを再計算し、相関性を再評価

する前に、対象のパラメータをすべて適切に修正することを可能にします。ただし、モデルが自動手続きに

よって更新された適用パラメータの変化と相関結果は、トラッキング歴に格納されます。トラッキング歴で

は、レスポンスの1つのマニュアル再計算が自動アップデーティング・プロセスの1反復ステップに相当しま
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す。 

Manual Parameter Updatingダイアログボックスはパラメータ値をリストします。そのダイアログにはパラメ

ータ値を修正するためのApplyボタンとレスポンスを再計算するためのUpdateボタンを持っています。その

補足情報は、Manual Parameter UpdatingダイアログボックスのHelpボタンのクリックすることによって参照

することができます。 

自動モデルアップデーティング 

• レスポンスの重要度とベイズ法の目的レスポンス・コンポーネントのバランスを保つ自動重み付けアルゴ

リズムは、単にある条件がいつ満たされるかによって変わります。つまり、その自動重み付けスイッチが

オンの場合は、重み付けは自動的に変更されませんが、それがオフの場合は単に重み付けを変更します。

また、自動重み付けがアクティブな場合はコンソールに反復ステップ情報を出力します。 

• TUNEコマンドによるコンソール出力のシンボル表示の意味を次に示します。 

 <--：PMAX指定が適用された前の最大パラメータ変更を示します。 

 （*）：自動重み付けがアクティブだったことを示します。 

• 感度マトリックスに0以外の値を含むかどうか検証するチェック機能が追加されました。感度マトリック

スに0の値を含む場合のみ警告メッセージが出力されるます。 

マルチ・モデルアップデーティング（MMU） 

マルチ・モデルアップデーティング手続きに多くの改良と修正が追加されました。 

• Multi Model Updating Project Managerは、ダイアログウィンドウからカスタマイズ可能なセッティングを

すべて処理します。 

• mmu.basスクリプトの詳しいヘルプ・セクションが追加され、それは、HELP MMUコマンドで出力されま

す。 

• MMUはマルチモデル・アップデーティング・プロセスに関係するすべてのアップデーティング・セッテ

ィング値に影響します。コンソール出力で使用される記述は、TUNEコマンドの出力記述と同様です。 

• MMUコマンドのSAVE補語が作動しませんでした。この問題が回避され、SAVE補語のデフォルト値はON
にセットされました。 

結果の無効化 

モデルアップデーティングでは、データベースに格納されるFEモデルが修正され、アップデーティング・ル

ープの終了後、ユーザーは結果の無効化（Reject）を検討することができます。旧バージョンでは、単に更

新前のデータベースに戻すことができただけですが、任意の反復ステップに戻すことが可能です。 

アップデーティング結果を無効にするには、以下の1つを行ってください。 

• メイン・メニューから、Tools > Model Updating > Reject Updating Stepsを選択する。  

• コンソールから、REJECTコマンドを実行する。 

次の2つの無効化メカニズムがあります。 

1）プロジェクト・ファイルからデータを回復する。 

2）最後の必要な反復を再計算します。 

バックアップ・ファイルとしてデータ（モード、システム・マトリックスなど）を回復することは容易です

が、すべての反復ステップのデータをすべて格納することは大量のディスク・スペースを必要とする場合が

あります。常に最後の反復を再計算することは、新たなディスク・スペースを必要としませんが、FEモデル

の解析や感度解析を行なう場合には、高速化は望めないかもしれません。 

回復データが存在する場合、第1のアプローチが自動的に選択され、回復データが存在しない場合は、再計算

アプローチが選択されます。tune.ibackupセッティング（SET TUNE IBACKUP）がアップデーティングをス

タートする前にオンに切り替えられていれば、回復データは残されます。 
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指定の反復ステップ数を無効にする場合、2)のアプローチが使用されます。すべての反復ステップを無効に

する場合は、そのデータはバックアップ・ファイルから回復されます。デフォルトでは、tune.keepセッティ

ングがオン（SET TUNE KEEP）で、バックアップ・ファイルが作られます。アップデート・モデルがロー

カル・パラメータの場合には、材料特性や幾何学特性の追加指定が可能です。すべての反復ステップを削除

すると、モデルアップデーティング以前の状態のデータベースを回復します。これは幾何学特性とパラメー

タの定義の変更が未完成であることを暗示します。 

各反復ステップで作成されるバックアップ・プロジェクトは、RMFコマンドで削除されます。 

POCレスポンスの定義 

POCレスポンス・タイプが追加されました。これはターゲットとしてPOC値を使用し、FEモデルアップデー

ティングするために使用することができます。POCレスポンスは、MACレスポンスと等価ですが、FEモデル

の質量分布が考慮されます。POCレスポンスを定義するには、Create Responseダイアログボックスの

PropertiesタブのPOCチェックボックスをチェックしてください。また、POCレスポンスは、RESPONSE POC
コマンドで作成することができます。 

POCレスポンスは、FEモデルアップデーティングを実行するためにも使用され、それはアップデーティング･

ターゲットとして使用されるMACレスポンスと類似します。 

総括的レスポンスの使用方法 

総括的レスポンス（generic responses）のサポートが追加されました。この総括的レスポンスの値はプログラ

ム・スクリプトで得られるレスポンス値です。そのプログラム・スクリプトは、FEMtoolsデータベースから

レスポンス値を推定するか、外部ソルバーの結果ファイルからそれらを直接インポートするか、あるいは計

算によって得る方法をサポートします。このプログラム・スクリプトでレスポンス値を得ることができる場

合、その総括的レスポンスにいかなる制限もありません。 

総括的レスポンスは、モデルアップデーティングに柔軟で普遍的なアプローチを提供します。従来のレスポ

ンス・タイプと異なり、総括的レスポンスは有限要素モデルや関連する結果ファイルによって処理され、イ

ンターフェイス・プログラムによって、FEMtools内部データベースに格納することを必要としません。 

総括的レスポンスは新しいコマンドRESPONSE GENERICで定義されます。このコマンドはレスポンス値を

推定するために使用しなければならないスクリプトに参照付けられます。総括的レスポンスのより詳細情報

については、FEMtools Model Updating User's Guide （モデルアップデーティング・ユーザーズガイド）を参

照してください。 

レスポンスの検証 

レスポンスの検証ルーチンがアップデーティング・プロセスに追加されました。 

• FEAのレスポンスが存在する時、アップデーティング手続きはスタートせず、エラーメッセージが出力さ

れ、またアップデーティング手続きは異常終了しました。現在のレスポンス値とターゲット値の間にいか

なる不一致もない場合、アップデーティングにおいて、FEAのレスポンスを使用することは無意味です。

そのためFEAのレスポンスは感度解析のためのみに使用されるように意図されています。 

• 以前のバージョンではアップデーティング・ルーチンがスタートする時、定義されたレスポンスがアクテ

ィブでない場合は、アップデーティング・プロセスを中断しました。この問題が回避され、アップデーテ

ィング・プロセスが正常にスタートします。 

総括的パラメータ（形式的、テキスト・パラメータ）の使用方法 

総括的パラメータのサポートが改良、拡張されました。 

• 総括的パラメータのドキュメントが改訂されました。また、インストール・システムにはANSYS、ABAQUS、
NASTRANのソルバーを使用した例題が含まれます。これらの例題はフォル

ダ：../examples/updating/generic_parametersで見つけることができます。 

• 総括的パラメータの追加プロパティ（ローカル/グローバルのダンピング・パラメータ）は、プロジェク

ト・ファイル中に保存され、またプロジェクトのロード時にインポートされます。 

• コマンドPARAMETER TEXTは、FORMAT補語で拡張されました。これはフォーマット・スクリプトを使

用する代わるより簡単な方法です。しかし、フォーマット・スクリプトの使用も一般的なアプローチです。 
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• 総括的パラメータ定義によって選択されているテキストを視覚化するユーティリティ

（../scripts/utilities/check_generic_parameters.bas）が追加されました。このユーティリティは、黄色の背景を

伴うパラメータを示すHTMLドキュメントを生成します。また、それはパラメータ定義を迅速に検証しま

す。 
 

 
 

パラメータの操作 

新たな機能がパラメータを操作するために追加されました。 

• Ft_GetParamProp関数がパラメータ・プロパティを検索するために追加されました。 

• すべてのパラメータは、PP_LABELプロパティを持っています。以前は総括的パラメータのみが、

PP_LABELプロパティを持っていました。そのラベル・プロパティは、PARAMETERコマンドのLABEL
補語で定義することができます。ラベルはパラメータ・テーブルの最後カラムに示され、また、EXTRACT 
PARAMETER、EXTRACT PARAMETER DIFFERENCEコマンドによってコンソールに出力されます。 

パラメータ・リレーション 

パラメータ・リレーションのウェイト（重み値）は、「confidence values（確信値）」の代わりに「scatter values
（分散値）」に替えられます。その分散値は、以前のバージョンのパラメータとレスポンスの定義において、

確信値から変更されました。そのため、この修正により一貫したパラメータ・リレーション定義が可能にな

ります。DEFINE RELATIONとSET RELATIONコマンドのCONFIDENCE補語もSCATTER補語に替えられ

ました。ダイアログボックスにおいても確信値に代わって、分散値を入力します。デフォルトのパラメータ・

リレーションの分散値は、1e10（以前のデフォルト値）の確信値に対応し、1e-6に設定されました。 

レポート処理 

• EXTRACT PARAMETER DIFFERENCEコマンドが追加されました。これはコンソール・ウィンドウ中

にアップデーティング・ルーチンによってパラメータ修正が行われたことをレポートします。 

• EXTRACT RESPONSE DIFFERENCEコマンドが追加されました。これはコンソール・ウィンドウ中にア

ップデーティング後の剰余レスポンス差分をレポートします。 

• モデルアップデーティング・ログ・ファイルはパラメータ確信値に代わって、パラメータ分散値を示しま

す。 

• モデルアップデーティング・ログ・ファイルには追加された情報が出力されます。 
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 FREQ、MAC、MODEのレスポンスのレスポンス・テーブルにはモード・オーダーが提供されます。

それによって、FEAとテストのモード・ペアリングの迅速な確認が可能になります。 

 「Objective Function（目的関数）」テーブルが「Model Updating（モデルアップデーティング）」に

に替わりました。目的関数データの追加に伴って、そのテーブルには、アクティブ・レスポンス数、

アクティブ・パラメータ数、評価と応用のための最大パラメータ変更が示されます。 

 以前のバージョンでは、TUNEセッティング値は詳細がレポートされませんでした。新バージョン

では、そのセッティングとして、自動ウェイティング、反復バックアップ、反復スクリプト、ラー

ジモデル、ログ・ファイル、ログ詳細、PMETHOD（パラメータ更新情報）、プリント、感度、tolg
（許容値情報）などが追加されました。 

 リレーションが存在しない場合、リレーションはOFFとして処理されますが、セッティングがONで

もOFFとしてレポートされていました。この問題は修正されました。 

 ログ・ファイルにすべてのアップデーティング・エラーや警告メッセージを出力します。 

• TUNEコマンドのコンソール歴に出力されたDSF係数は、100と示されていました。これが修正されました。 

最適化 

トポロジーの最適化 

最小動的コンプライアンス（minimal dynamic compliance）の例証が改良されました。これについては、FEMtools 
Optimization User's Guide（最適化ユーザーガイド）を参照してください。 
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FEMtools コマンド 
FEMtools 3.7コマンド言語は多くの新しいコマンドで拡張されました。また、既存のコマンドも強化されまし

た。同様の情報については、FEMtoolsヘルプのFEMtools Command Reference （コマンド・リファレンス）で

見ることができます。 

新しいコマンド 
FEMtools3.7のリリースにおいて利用可能な新しいコマンドについて次に示します。 

APPLY DOF RELATIONS APPLY DOFRELATIONSコマンドが更新されました。 

CLEAR DOF RELATION DOFリレーションを削除します。 

CLEAR MBA PARAMETER MBAパラメータを削除します。 

CLEAR MBA SUBSTRUCTURE MBAサブストラクチャを削除します。 

DEFINE DOF RELATION DEFINE_DOFRELATIONコマンドが更新されました。 

DEFINE FBA LOAD 新しいFBAロード・ケースを作成します。 

DEFINE FBA MPC 新しいFBAマルチポイント拘束を作成します。 

DEFINE FBA RESPONSE 新しいFBAロード・ケースを作成します。 

DEFINE FRFS FRFマトリックスのFRFを作成します。 

DEFINE GEOMETRY GENERIC 総括的幾何学特性を作成します。 

DEFINE MBA PARAMETER 新しいMBAパラメータを作成します。 

DEFINE MBA SUBSTRUCTURE 新しいMBAサブストラクチャを作成します。 

DIRECTFRF 直接法FRF計算 

DSP FINDDEADCHANNELS しきい値に基づいた無効チャンネルの検知を自動化しまし

た。 

DYNCOMP FRFの動的補正 

EXTRACT DOF RELATION EXTRACT DOFRELATIONコマンドが更新されました。 

EXAMINE KMR 選択DOFに関する剛性/質量比（K/M）を計算します。 

EXTRACT MBA PARAMETER コンソール・ウィンドウにMBAパラメータ情報をリストしま

す。 

EXTRACT MBA SUBSTRUCTURE コンソール・ウィンドウにMBAサブストラクチャ情報をリス

トします。 

EXTRACT PARAMETER DIFFERENCE アップデーティング・ルーチンによるパラメータ修正をリス

トします。 

EXTRACT RESPONSE DIFFERENCE 更新後のレスポンス差分をリストします。 

MBA CLEARFEMBASE 剰余FEモデルのモーダル・ベースを消去します。 

MBA COMPUTE モーダル・ベース・アセンブリ問題を解析します。 

MBA EXPLODE MBAサブストラクチャをFEモデルに変換します。 

MBA PANEL モーダル・ベース・アセンブリ・パネルを開きます。 

MBA RANGE 一連のMBAパラメータ値に関するレスポンスを検証します。 

MODIFY MBA PARAMETER MBAパラメータのプロパティを修正します。 

MODIFY MBA SUBSTRUCTURE MBAサブストラクチャのプロパティを修正します。 

RESPONSE GENERIC 感度解析とアップデーティングのための総括的レスポンス
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を定義します。 

RESPONSE POC 感度解析とアップデーティングのためのPOCレスポンスを

定義します。 

SET INTERFACE POLYTEC、Polytec データ・インターフェイスのためのデフォルト・セッティン

グを指定します。 

SET INTERFACE UFF UFFテストデータ・インターフェイスのデフォルト・セッテ

ィングを明示します。 

SET MBA モーダル・ベース・アセンブリのデフォルト・セッティング

を指定します。 

修正されたコマンド 

FEMtools 3.7のリリースにおけるコマンドの変更点について示します。 

BCSPRING これは旧式になり、BC2SPRINGコマンドのDOF補語がドキュ

メント化されました。これはドキュメントから削除されまし

た。 

CLEAR FBA FBA MPCを消去するために、MPC補語が追加されました。 
FBAロードを消去するために、LOAD補語が追加されました。 
 
FBAレスポンスを消去するために、RESPONSE補語が追加さ

れました。FBAテーブルを消去するために、TABLE補語が追

加されました。 

CLEAR RESPONSE POCレスポンスを削除するために、POC補語が追加されたま

した。 

DEFINE CHANNEL 一貫性を保つために、DEATH補語がDEADにリネームされま

した。 

DEFINE FBA FRF DIRECTION補語がDOF補語の代替記法として追加されまし

た。 
 
テストのFRFの場合、POINT補語はNODE補語の代替記法と

して追加されました。 
 
JOINT補語がレスポンス位置としてFBAジョイント（継ぎ目）

を使用可能にするために追加されました。BOUNDING補語が

レスポンス位置としてFBA バウンディング（接続）を使用

可能にするために追加されました。MPC補語がレスポンス位

置としてFBA MPCの使用を可能にするために追加されまし

た。 

DEFINE FBA MASS MX、MY、MZに同じ値を設定するために任意のラベルを伴

う実数値を受理します。 

DEFINE FBA TABLE FRFに基づいたテーブルを定義するために、FRF MODEL補語

が追加されました。 

DEFINE RELATION CONFIDENCE補語がSCATTER補語に替えられました。 

EXAMINE EIM KEEP補語がSENSORS補語に替えられました。 
 
CORNER、EDGE、SURFACE、SETなどの補語が総括的ノー

ドを選択するために、NODE補語に替えられました。 
 
あらかじめ指定した位置センサーを定義するために、

PRESELECTED補語が追加されました。 
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補語TARGETは、2つの値を持ちます。それらは、識別番号

とスティング・タイトルです。 

EXAMINE EVO MDOFオプションはDOF補語を追加しました。このオプショ

ンはマスターDOFを使用して、FEモードのautoEVOの計算を

可能にします。 
 
縮小システム・マトリックスを再計算することを明示する

REDUCTIONコマンドを追加されました。 

EXAMINE IGR KEEP補語がSENSORS補語に替えられました。 
CORNER、EDGE、SURFACE、SETなどの補語が総括的ノー

ドを選択するために、NODE補語に替えられました。 
 
あらかじめ指定した位置センサーを定義するために、

PRESELECTED補語が追加されました。 
 
補語TARGETは、2つの値を持ちます。それらは、識別番号

とスティング・タイトルです。 
 
補語NORMAが正規表面のセンサーを使用するために追加さ

れました。 

EXAMINE KED BASE補語がノードあるいDOFに基づくKEDを計算するため

に追加されました。 
 
BINS補語がヒストグラムのビン数を指定するために追加さ

れました。 
 
CS補語がKEDを計算する座標系（グローバル、ローカル、正

規表面）を指定するために追加されました。 

EXAMINE NKE CS補語がローカル座標系あるいは正規表面方向のNKE値を

計算するために追加されました。 

EXAMINE NMD NORMAL値が正規表面方向のNMD値を計算するためにCS補
語に追加されました。 

EXAMINE SPANKE KEEP補語がSENSORS補語に替えられました。 
CORNER、EDGE、SURFACE、SETなどの補語が総括的ノー

ドを選択するために、NODE補語に替えられました。 
 
補語WEIGHTEDとMAXIMUMが削除され、METRIC補語の値

に替えられました。METRIC補語はAVERAGE値とMINIMUM
値を受理します。 
 
あらかじめ指定した位置センサーを定義するために、

PRESELECTED補語が追加されました。 
 
補語TARGETは、2つの値を持ちます。それらは、識別番号

とスティング・タイトルです。 

EXAMINE SPANMD KEEP補語がSENSORS補語に替えられました。 
CORNER、EDGE、SURFACE、SETなどの補語が総括的ノー

ドを選択するために、NODE補語に替えられました。 
 
補語WEIGHTEDとMAXIMUMが削除され、METRIC補語の値

に替えられました。METRIC補語はAVERAGE値とMINIMUM
値を受理します。 
 
あらかじめ指定した位置センサーを定義するために、
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PRESELECTED補語が追加されました。 
 
補語TARGETは、2つの値を持ちます。それらは、識別番号

とスティング・タイトルです。 

EXTRACT FBA MPC補語がFBA MPC定義を抽出するために追加されました。 
 
LOAD補語がFBAロード定義を抽出するために追加されまし

た。 
 
RESPONSE補語がFBAレスポンス定義を抽出するために追

加されました。 
 
TABLE補語がFBAテーブル定義を抽出するために追加され

ました。 

EXTRACT RESPONSE POC補語がPOCレスポンス情報を抽出するために追加された

ました。 

FRF TEST UPDATE補語が、SAC、CSAC、CSFおよびレスポンスが更新

すべきかどうか示すために追加されました。（デフォルト

=ON） 
 
RESIDUAL補語は剰余値を使用すべきかどうか示すために

追加されました。（デフォルト=ON） 
 
SCALE補語が計算FRFに適用するスケーリング係数を指定

するために追加されました。（デフォルト=1.0） 

INPUT DOF補語がインポートのされたFRFのDOFレスポンスを選択

するために追加されました。 
 
FRF FEM補語は、ASCII ABAQUS.filファイルをサポートしま

す。 

MESH PAIR MAPPED補語が「FEM Mapped on Test」プロットを生成する

ために追加されたました。 
 
REDUCED補語は常に「Reduced FEM & Test as Paired DOFs
（縮小FEM&テスト・ペアDOF）」プロットを生成します。 
 
生成されるプロットは、mesh.reduced.style変数の値に依存し

ません。 

MMU SAVE補語のデフォルト値はONです。 

MODIFY PARAMETER CONFIDENCE補語は削除されました。それはバージョン3.1
以来、使用されていました。 

MODIFY RESPONSE CONFIDENCE補語は削除されました。それはバージョン3.1
以来、使用されていました。 

PADEFRF 補語として、ITERATION、LOGSCALE、PRECISION、

VERBOSEが追加されました。 

PAIR DISPLACEMENT DAC補語がドキュメント化されました。これは新しい補語で

はありません。しかし、旧バージョンでは、それはドキュメ

ント化されていませんでした。 

PAIR FRF 追加補語なしで実行することができます。PAIR FRFコマンド

（追加補語なし）は自動FRFペアリングに使用されます。 

PAIR NODE 補語DIRECTIONは方向ペアリングを可能にします。それには
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指定方向に垂直な平面上の投影される2Dノード-ポイント・

ペアを使用します。 
 
補語MERGEが自動ノード-ポイント・ペアリング・ステップ

において機能するために追加されました。 
 
補語TOLERANCEが、最大ノード-ポイント許容距離を修正す

るために追加されました。 

PAIR MODE POC補語が、POC値に基づいたモードシェープ・ペアを定義

するために追加されました。 
 
MAC補語がドキュメント化されました。これは新しい補語で

はありませんが、旧バージョンでは、ドキュメント化されて

いませんでした。 

PARAMETER CONFIDENCE補語は削除されました。それはバージョン3.1
から採用されていました。 
 
LABEL補語が、PARAMETER LOCAL、PARAMETER 
GLOBAL、PARAMETER DAMPINGなどのコマンドに追加さ

れました。 

PARAMETER TEXT FORMAT補語がフォーマット・スクリプトの使用の容易な代

案として使用できるように追加されました。 

PRETEST REMOVE NODE補語は一般的なノード選択方法（マルチ・ノードID、

ノード・セットIDなど）をサポートしました。 

REDUCE FEM 縮小された質量や剛性のマトリクスを計算するかどうかを

明示するために、MASSとSTIFFNESSの補語が追加されまし

た。 

REJECT 3つの補語（ALL、ITERATIONS、TO）が追加されました。

これらの補語は拒否するステップ数を定義するために使用

することができます。 

RESPONSE COG CONFIDENCE補語は削除されしました。それはバージョン

3.1から採用されていました。 

RESPONSE CSC CONFIDENCE補語は削除されしました。それはバージョン

3.1から採用されていました。 

RESPONSE DEFORMATION CONFIDENCE補語は削除されしました。それはバージョン

3.1から採用されていました。 

RESPONSE DISPLACEMENT CONFIDENCE補語は削除されしました。それはバージョン

3.1から採用されていました。 

RESPONSE FREQUENCY CONFIDENCE補語は削除されしました。それはバージョン

3.1から採用されていました。 

RESPONSE FRF CONFIDENCE補語は削除されしました。それはバージョン

3.1から採用されていました。 

RESPONSE INERTIA CONFIDENCE補語は削除されしました。それはバージョン

3.1から採用されていました。 

RESPONSE MAC CONFIDENCE補語は削除されしました。それはバージョン

3.1から採用されていました。 

RESPONSE MASS CONFIDENCE補語は削除されしました。それはバージョン

3.1から採用されていました。 

RESPONSE MODE CONFIDENCEは削除されしました。それはバージョン3.1か
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ら採用されていました。 

RMF RMFコマンドはアップデーティング・ルーチンの各反復ステ

ップで作成されるプロジェクトのバックアップを削除しま

す。 

SEARCH DOF補語がインポートするFRのレスポンスDOFを選択する

ために追加されました。 
 
NASTRANの.51、op2、ANSYSの.rst、.rfrq、ABAQUSバイナ

リの.fil などのファイルからFRFをインポートするために

FRF FEMがサポートされします。 

SET PARAMETER CONFIDENCE補語は削除されしました。それはバージョン

3.1から採用されていました。 

SET REDUCTION METHOD補語は、それぞれの指定方法（DIRS、DYNAMIC、
GUYAN、IIRS、IRS）が追加されました。補語SILENTはコ

ンソール出力を抑制するために追加されました。 

SET RELATION CONFIDENCE補語はSCATTER補語に替えられました。 

SET RESPONSE CONFIDENCE補語は削除されしました。それはバージョン

3.1から採用されていました。 
 
SCRIPT補語は総括的レスポンスのデフォルト処理スクリプ

トを定義するために追加されました。 

UPDATE 1つのオプションの補語（COMPUTE {ON | OFF}）が追加さ

れました。 

削除されたコマンド 
このセクションは、FEMtools 3.7のリリースで削除されたコマンドについて記述します。 

APPLY DOF RELATIONS  APPLY DOF RELATIONSに替えられました。 

CLEAR SDM  SDMコマンドはMBAコマンドに替えられました。 

DEFINE_DOFRELATION  DEFINE DOF RELATIONに替えられました。 

DEFINE SDM  SDMコマンドはMBAコマンドに替えられました。 

DFRF  DIRECTFRFコマンドに替えられました。 

EXTRACT DOFRELATION  EXTRACT DOF RELATIONに替えられました。 

EXTRACT SDM  SDMコマンドはMBAコマンドに替えられました。 

SDM ABSORBER  SDMコマンドはMBAコマンドに替えられました。 

SDM COMPUTE  SDMコマンドはMBAコマンドに替えられました。 
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FEMtools スクリプト言語 
FEMtools 3.7スクリプト言語は、いくつかの新しい関数で拡張され、また、既存の関数も強化されました。同

様の情報は、FEMtools helpのFEMtools Script Reference（スクリプトリ・ファレンス）で参照できます。 

新しい関数 
以下は、このバージョンに追加された新しい関数です。 

CreateObject ポイント群のようなデータベース・オブジェクトを作成します。 

Fill データベース・オブジェクト（ポイント群）にデータを追加し

ます。 

FindNearest ポイント群で最も近いポイントを見つけます。 

Kaiser Kaiser（カイザー）ウィンドウを生成します。（DSP対応） 

Kurtosis  配列サンプルのkurtosis（カートシス、尖度）を計算します。 

Skewness  配列サンプルのSkewness （スキューネス、ひずみ）を計算しま

す。 

修正された関数 
Ft_HWInfo  Ft_HWInfo（"type"）は、64ビットのウィンドウ・プラットフォ

ーム上の"x64"を返します。 
 
"mkl"オプションは、MKLライブラリのバージョンを検索するた

めに追加されました。 
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FEMtools API 
FEMtools 3.7 APIはいくつかの新しい関数で拡張されました。また、既存の関数も強化されました。同様の情

報は、FEMtools helpのFEMtools API Referenceで参照できます。 

ソルバー管理 
変数analysis.solver.nameがソルバーの名前を格納するために導入されました。この変数は、ソルバー・ドライ

バ（即ち、analysis.solver変数）の指定スクリプトによって初期化されます。このanalysis.solver.nameの目的は、

使用されているソルバーを参照するためです。変数analysis.solverはドライバ・スクリプトの名前を格納する

ためにも使用され、ソルバーの名前と同じである必要はありません。 

新しい FEMtools AP 関数 

データベースAPI関数 

Ft_DefGeoGeneric 総括的幾何学特性を定義します。 

Ft_GetGeoGeneric 総括的幾何学特性を返します。 

Ft_GetParamProp パラメータ特性を返します。 

修正された FEMtools API 関数 
このセクションは、FEMtools 3.7リリースでのFEMtools API関数の変更点について記述します。 

データベースAPI機能 

Ft_GetMatList マトリックスをリストするかどうかを明示するために、オプシ

ョンの引き数sType（all、public、private）が追加されます。 

Ft_GetShapeList 次の2つのオプションの引き数が追加されます。 
 
iGroup：シェープ・グループを指定するために使用します。 
sType（all、public、private）：シェープをリストするかどうかを

明示するために使用します。 

ユーザー・インターフェイスAPI関数 

Ft_Clear fem.facesとtest.facesのテーブルのサポートのために追加されま

した。 

Ft_Refresh mba.parameterとmba.substrucutresのサポートのために追加されま

した。 

プロセス制御API関数 

新しい API 定数 
EG_FORMAT_PERCENT 0～100間の値のマトリックスのフォーマットを最適化します。

（値 = 2048） 

EG_FORMAT_SHORT マトリックスにショート・フォーマット（0.000）を使用します。

（値 =4096） 

EG_PRIVATE プライベイトとして、マトリックスをマークします。（値

=1048576） 

EG_ALL すべてのエクスプローラ・グループのマトリックスまたはシェ

ープ（値=-1） 

EG_VISIBLE すべてを表示、例えば、not EG_HIDDEN、マトリックスまたは

シェープ（値=-2） 



 

 43 

GT_GENERIC 総括的幾何学データ（値=18） 

PA_C1, … PA_C78  総括的幾何学特性係数（値=1001、...1078） 

PA_KROT 回転接続強度、MBA（値=2006） 

PA_KTRANS 並進接続強度、MBA（値 2005） 

PA_M 集中質量、MBA（値=2004） 

PA_MATRIX 総括的幾何学特性マトリックス形式（値=173） 

PA_TADAMP 動吸収器のダンパー、MBA（値=2003） 

PA_TAFREQ 動吸収器の周波数、MBA（値=2001） 

PA_TAMASS 動吸収器の質量、MBA（値=2002） 

旧 API 定数 
EG_ELEMENT_MAP 従来から使用されていましたが、削除されました。 

新しい API 環境変数 

テーブル 

fem.faces  FEMのｆaces（面）、edges（エッジ）、wedges（くさび形） 

test.faces テストのｆaces（面）、edges（エッジ）、wedges（くさび形） 

マトリックス 

dac.modeset 選択モードで計算されたDACマトリックス 

dpc.modeset 選択モードで計算されたDPCマトリックス 

dsf.modeset 選択モードで計算されたDSFマトリックス 

mac.modeset 選択モードで計算されたMACマトリックス 

スカラーとストリング 

analysis.solver.name ソルバーの名前を指定します。この変数はソルバー・ドライバ

（即ち、analysis.solver変数によって指定されたスクリプト）に

よって初期化されます。 

correlation.tolerance.eps 最大モデルサイズに関する相対空間の相関許容サイズを指定し

ます。 

correlation.tolerance.eps はcorrelation.toleranceのデフォルト値を計算するために使用され

ます。 

curve.color.fem FEMデータ（FRF）のカーブのデフォルト色を指定します。 

curve.color.test テストデータ（FRF）のカーブのデフォルト色を指定します。 

interface.abaqus.coupling ABAQUSの接続データの処理方法を指定します。 

 0：インポートされず、abaqus.dmpにダンプされます。 

 1：インポートされ、RBE2またはRBE3に変換されます。 

interface.femtools.compress FEMtoolsデータベース・フォーマット（.fdb）ファイル中のデー

タを圧縮するべきかどうかを明示します。（デフォルト=FALSE
（非圧縮）） 

interface.frf.dof.mask FRFをインポートする場合に読み込むべきレスポンスDOFを指

定します。この変数は、Ux, Uy, Uz, Rx, Ry, Rz のビット・マス

クとしてコード化されます。デフォルト値は7 = Ux+Uy+Uz です。 
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interface.uff.aflags インポート・データの拡張モードを定義するマスク： 

 UFF_GEOMETRY=1、UFF_MODE=2、UFF_ODS=4、UFF_FRF=8 

 （デフォルト=14 UFF_MODE、|UFF_ODS|UFF_FRF） 

interface.uff.global インポート・シェープの座標系を指定します。 

 -1：自動、ベンダー依存（デフォルト） 

 0：モーダル/ODSの変位はローカル座標系と仮定されます。 

 1：モーダル/ODSの変位はグローバル座標系（IDEASなど）と仮

定されます。 

interface.uff.globalize エクスポート・シェープの座標系を指定します。 

 0：ローカル座標系のモーダル/ODS変位（デフォルト） 

 1：ローカル座標系は廃棄され、グローバル座標系で変位を出力

します。 

interface.uff.invert ローカル座標系の方法を指定します。 

 -1：自動またはベンダーの定義に依存します。（デフォルト） 

 0：標準の座標系マトリックスが提供されると仮定します。 

 1：逆座標系マトリックスが提供されると仮定します。（LMSベ
ンダー・デフォルト・オプション） 

interface.uff.rflags インポートするパート（データセット）定義のマスク： 

 UFF_GEOMETRY=1、UFF_MODE=2、UFF_ODS=、UFF_FRF=8
（デフォルト=7 UFF_GEOMETRY、|UFF_MODE|UFF_ODS） 

interface.uff.wflags エクスポートするパート（データセット）定義のマスク： 

 UFF_GEOMETRY=1、UFF_MODE=2、UFF_ODS=4、UFF_FRF=8
（デフォルト=7 UFF_GEOMETRY、|UFF_MODE|UFF_ODS） 

interface.uff.wirefy エクスポートする要素の指定： 

 0：要素のエクスポート要素（デフォルト） 

 1：要素変換、要素（TRIA3->HEX20）の場合、トレースライン

に変換します。 

 2：要素はエクスポートせず、トレースラインのみをエクスポー

トします。 

interface.polytec.channel Polytecデータ・ファイルのチャンネルを指定します。（デフォ

ルト=""） 

interface.polytec.display Polytecデータ・ファイルのディスプレイを指定します。（デフ

ォルト=""） 

interface.polytec.domain Polytecデータ・ファイルの領域を指定します。（デフォルト=""） 

interface.polytec.signal Polytecデータ・ファイルの信号を指定します。（デフォルト=""） 

interface.polytec.type Polytecデータ・ファイルのデータ・タイプのを指定します。（デ

フォルト=0） 

interface.polytec.wirefy 要素のワイヤー（wirefy）化をするかしないかのスイッチ（（デ

フォルト=OFF） 

mba.autocompute Modal Based Assembly Solverパネルのチェックボックスが更新

された場合、MBA結果を再計算すべきかどうかを指定します。

（デフォルト=TRUE） 
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mba.complex 実数か複素数のモードを計算するために指定します。（デフォ

ルト=FALSE） 

mba.fmax 対象周波数レンジの上限を指定します。（デフォルト=1e30） 

mba.fmin 対象周波数レンジの下限を指定します。（デフォルト=0） 

mba.link 連結特性の計算方法を指定します。 

 1：MAXIMAL（最大値）、2：MINIMAL（最小値）、3：MEAN
（中間値） （デフォルト=MAXIMAL） 

mba.tolerance 連結すべき重ね合わせ条件の許容値を指定します。（デフォル

ト=1e-5） 

mba.unitsystem MBAダイアログボックスのラベルで使用する単位系を指定しま

す。 
0：NONE、1：MKS、2：MMN、3：IPS、4：FPS（デフォルト

=NONE） 

mba.vector 計算するモード数を指定します。（デフォルト=5） 

pbox.optional.visible プロパティ・ボックスのオプション・ボタンの表示コントロー

ル 

pbox.optional.labe プロパティ・ボックスのオプション・ボタン上のテキスト指定 

pbox.optional.script プロパティ・ボックスのオプション・ボタンが押される場合に

実行されるスクリプトを指定します。 

旧 API 環境変数 

スカラーとストリング 

interface.uff.flags この変数は、interface.uff.aflags、interface.uff、interface.uff.wflags
などに替えられました。 

mesh.reduced.style MESH PAIRコマンドのコマンド・シンタックスをもはや修正す

る必要はありません。 
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