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FEMtoolsデータベース概論 
本ドキュメントは、FEMtools 3.ｘバージョンの FEMtools データベースに関する以下の補足ガイドとしてリ
リースされます。 

• FEMtools データベース・マネージメント（Database Management） 

データベース・マネージメント 

FEMtoolsの解析関数はモジュール構成に基づき、線形静解析、正規／複素モード解析、周波数応答解析、調
和応答解析、実験モーダル解析などに利用できます。有限要素モデルデータ、テストモデルを含むすべての

データは、FEMtoolsデータベースのリレーショナル・データベースとして格納され、多くのデータテーブル
を介してアクセスされます。 

データテーブルに格納された解析データ、実験収集データは、汎用FEAシステム、CAEアプリケーション、
メッシュ生成ソフトウェア（有限要素プリプロセス）、ポスト・プロセッサなどの外部プログラムによって

作成された外部データ・ファイルからインポートされます。特に、FEMtoolsにはいくつかのダイレクト・イ
ンターフェイス・プログラムがサポートされています。このように、FEMtoolsはCAE環境において、アプリ
ケーション間の統合に利用することができるプログラムです。 

外部データベースとのインターフェイスは以下のような目的にも有効です。 

• メッシュ・ジェネレータで作成された有限要素メッシュのインポートし、要素特性を再定義し、解

FEMtoolsでの解析を実行する。 

• 解析と実験のデータベースを比較するために統合する。 

• テストモデルをエクスポートし、モーダル解析に利用する。 

• データ・フォーマット間のデータ変換 

データベース中のテーブルを完成させるには、インターフェイス・プログラムの使用に加えて、対話やコマ

ンドのモードでのテーブル・ウィンドウ・データの編集が可能です。 

本章はデータテーブルの編集方法、データテーブルのインポートやエクスポートの方法、データベースマネ

ージメントオプション、SET（セット）操作、変換、モードシェープの正規化、データテーブルのコピー、
拡張、縮小などの機能に関する情報を含んでいます。 

FEMtoolsデータベース 

FEMtoolsユーザーに利用可能なデータは、すべてリレーショナル・データベースに格納されます。FEMtools
データベースは、主に3つのデータベース・セクションから成ります。 

• 解析的FEデータ 

• テスト・データ 

• FEMtools解析結果データ 

データベースの解析的セクションは、ノード座標、要素定義などを備えた有限要素メッシュ・データ、構造

要素マトリックス、解析結果を含んでいます。 

データベースのテストデータ・セクションは、テストモデル、実験的に得られた実稼働シェープ（静的／動

的）、モーダルパラメータ（共振周波数、モーダル減衰、モードシェープ）、FRFの定義を含んでいます。 

データベースの結果セクションは、解析に必要なすべての定義データとFEMtoolsの解析ツールを使用して生
成された新しいデータを含んでいます。 
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これらのセクションのデータは特定のデータタイプを持ち、1つ以上のデータタイプを含んでいます。各デー
タタイプに異なるデータテーブルが形成され、そのデータテーブルはデータベース階層の最下層レベルです。 

データテーブルはユニークで一貫したフォーマットを使用します。インターフェイス・プログラムがテーブ

ル・データをインポートするために使用される場合、データベースにそれらを格納する前に外部データを適

切に変形します。ほとんどのデータテーブルはコンピュータの内部メモリ中に維持されますが、要素マトリ

ックスのような大規模テーブル・データはテンポラリディスク・ファイルに格納されます。 

データベースの容量はコンピュータ・メモリサイズおよび利用可能スペースによって制限され、データベー

ス用メモリの割り当ては、プログラムによってダイナミックに行われます。これはデータベース・サイズが

増大や縮小によって、そのリソースがシステムに返され、より多くのメモリーリソースが割り当てられるこ

とを意味します。 

関連項目 

データベース情報の確認（Showing Database Information） 

データベースの再初期化（Reinitializing the Database） 

データベース情報 

FEMtoolsデータベース・サイズはハードウェア・リソースによって制限されます。そのメモリは必要に応じ
てダイナミックに割り当てられ、ハードウェア・リソースより多くのメモリが割り当てられることはありま

せん。要素マトリックスのような大規模データのセットはメモリ中でではなくディスク・ファイルに維持さ

れます。 

ユーザーは、SHOW SPACEコマンドによりプログラムに割り当てられたメモリ容量（ワード数）をチェック
することができます。FEMtoolsは、現在割り当てられたメモリのワード総数を示します。 

データベースはいくつかのテーブルで構成され、Database > Dimensionsまたは、EXTRACT DIMENSIONS
を使用し、内容の簡略情報は確認することができます。 
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解析または実験のデータベースのプロジェクトにタイトルは割り当てることができます。それにはコンソー

ルから、Database > Titlesを使用するか、SET TITLE、SET FEM、SET TESTなどのコマンドを使用します。
現在のタイトルは、EXTRACT TITLESコマンドで表示されます。 

データベースの再初期化 

データベースは新しいプロジェクトをスタートするためにいつでも再初期化することができます。その直後

には、占有されたていたメモリ・スペース数は0ワードにリセットされます。コンソールから、CLEARコマ
ンドを使用し、データベースから特定のデータテーブルを削除することができます。 

完全なデータベースを再初期化し、新しいプロジェクト・タイトルを定義するには、Fileメニューまたは、
Database > Delete > Databaseから、Newを選択します。コマンドモードでは、CLEAR PROJECTまたは、
CLEAR ALLを使用し、新しいプロジェクト・タイトルを定義するには、SET PROJECTコマンドを使用しま
す。 

解析的データベース・セクションを再初期化するには、Database > Delete > FE Modelまたは、コンソールか
ら、CLEAR FEMコマンドを使用します。また、それぞれの要素マトリックスやFEA結果テーブルを削除す
ることも可能です。 

実験データベース・セクションを再初期化するには、Database > Deleteのサブメニューまたは、コンソールか
ら、CLEAR TESTコマンドを使用します。 

Database > Deleteのサブメニューまたは、CLEARコマンドを使用し、その他のデータ・グループを削除する
ことも可能です。 

関連項目 

プロジェクトマネージメント（Managing Projects）  
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データタイプ 

データベース・オペレーションは、データタイプによって指定されたグループのデータテーブルに対して行

なわれます。インターフェイス・プログラムがデータをインポート／エクスポートするために使用される場

合やFEMtoolsデータベース編集コマンドが使用される場合に有効です。 

各データタイプはユニークな以下のようなラベルによって識別されます。 
 

データベース・セクション  データタイプ・ラベル 記述 

解析 FEM ノード座標、要素定義、材料特性、要素幾何学特性、

境界条件、... 

  STIFFNESS 要素剛性マトリックス 

  REDUCED STIFFNESS 縮小システム剛性マトリックス 

  MASS 質量マトリックス 

  REDUCED MASS 縮小システム質量マトリックス 

  DISPLACEMENT 静的／動的実稼働シェープ 

  MODES 解析正規モード、共振周波数、... 

  FRF FEA 解析周波数応答関数（FRF） 

テスト TEST テストモデル定義、テストポイント、トレースリン

ク、静的／動的結果、モーダル 

  FRF TEST 実験周波数応答関数（FRF） 

結果 RESULTS 感度、相関係数、MAC マトリックス、パラメータ定
義データなどの FEMtools解析結果... 

すべてのセクション PROJECT データベース上のすべてのデータテーブル 

関連項目 

FEM Data Type  

STIFFNESS and MASS Data Types  

DISPLACEMENT Data Type  

MODES Data Type  

TEST Data Type  

RESULTS Data Type  

FRF Data Type  

PROJECT Data Type  
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FEMデータタイプ（FEM Data Type）  

有限要素法の構造モデリングおよび解析データは、有限要素と呼ばれる多くの規則的な構造区分によって幾

何学的データで構成されます。その構造応答はグリッド位置あるいはノードと呼ばれる要素位置から推定さ

れます。それらの位置で応答は、その構造系の一次方程式を解析することによって得られ、例えば、変位、

速度、加速、構造に作用する外力などです。 

系の方程式を組み立てるために必要なすべての有限要素定義データは、多くのFEMテーブルに格納されます。 
 

データテーブル  データテーブル・ラベル 記述 

ノード座標 NODE 外部番号が割り当てられたグリッドまたはノードの位

置（グローバル・デカルト座標） 

要素定義 ELEMENT 外部番号が割り当てられた有限要素定義データ：このデ

ータは要素タイプ（構成ノード、材料特性と幾何学特性

の識別番号およびタイプ、ローカル座標系などの要素リ

スト）を含んでいます。 

材料特性 MATERIAL 材料特性識別番号に対応する材料特性は、要素データの

材料タイプが定義されます。 

幾何学的特性 GEOMETRY 幾何学的特性識別番号に対応する幾何学特性は、要素デ

ータの幾何学タイプが定義されます。 

減衰 DAMPING グローバル減衰係数：レーリー減衰係数（2つの値）あ
るいはモーダル減衰（データベースのモード数ごと値）

です。 

境界条件 BOUNDARY ノードの変位や回転の剛拘束 

次のテーブルもFEM定義データと関係します。 
 

データテーブル データテーブル・ラベル 記述 

ノード正規方向 NORMALS ノード表面の垂直方向の方向余弦 

ローカル要素軸 ORIENTATION 一次元要素のローカル軸方向 

ローカル座標系 CS ノードのローカル座標系 

荷重ケース LOAD 静解析の荷重ケース 

節点力 FORCE 静的節点力 

拘束条件 MPC 自由度間のリレーション 

カップル DOF RBAR, RBE2, RBE3 DOF間の剛結合リレーション 

マスターDOF MDOF 縮小システム・マトリックス用のマスターDOF 

スーパー要素 SELEM 縮小コンポーネント解析および合成解析用のスーパー

要素 

DOFマスク MASK 作用 DOFの選択ための DOF：例えば、外力識別 

プロット要素

（NASTRAN） 
PLOTEL モデルのビジュアル化のために使用される要素（テスト

モデルのトレースラインに類似します。） 

モーダル・マトリックス MODAL モーダル・システム・マトリックス 
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ノード座標や要素の定義テーブルには構造の幾何学データが記述され、一般に「メッシュ」と呼ばれます。

それらは、FEMtools解析に必要です。 

FEMtoolsデータベースの次元は、メッシュのノードや要素の総数、構造（1、2、3）の次元、およびノード当
たりの自由度数の関数です。 

ノード当たりの自由度 

メッシュの各ノードは、ノード当たり、最大3つの並進と3つの回転の自由度を持っています。これらの自由
度のコンビネーション数が、実際上使用されます。次の表は、FEMtoolsでサポートされる自由度コンビネー
ション（o：未使用DOF）を示します。 

 

このリストに含まれていないDOFコンビネーションや対象以上のDOFを含む解析モデルは、このサポート・
コンビネーションを使用してシミュレートされます。また、サポートDOFにおいても、そのDOFを拘束する
ことにより、解析から除外することができます。 

3Dソリッド要素を含むFEモデルがインポートされる場合、DOF数はノード当たり3つの並進DOFが設定され
ます。ただし、MPCが存在する場合（MPC、RBE3、RBE3、RBAR）、FEモデルが3Dソリッド要素を含んで
いても、DOFマスクは6つのDOF/ノードに維持されます。 
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要素タイプ 

次の図は対応する識別ラベルを備えた要素タイプ、要素当たりのノード数と要素次元を示します。 

 
 

集中質量は、1つのノード要素でモデル化されます。境界条件はノードとグランド間のDOFの剛結合関係で定
義します。弾性境界条件をモデル化するには、スプリング要素を使用されるべきです。 

次の選択肢がデータベース中のFEMデータテーブルでサポートされます。 

• データ・インターフェイス・プログラムを使用する。 

• テーブル・ウィンドウを編集する。 

• FEMtoolsコマンド（DEFINE）を使用する。 

• FEMtoolsスクリプト・プログラムやFEMtools API関数を使用する。 

• テストモデルを、解析データベースへコピーする。 

剛性と質量のデータタイプ 

FEMtools解析の多くは構造物の要素マトリックスを必要とします。その構造要素マトリックスは剛性
（STIFFNESS）または質量（MASS）のマトリックスです。データタイプ・ラベルは剛性と質量のマトリッ
クスに使用され、各データタイプは1つのテーブルを含んでいます。 
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データテーブル  データテーブル・ラベル 記述 

要素剛性マトリックス STIFFNESS グローバル座標系で定義された要素当たりの剛性マ

トリクス 

要素質量マトリックス MASS グローバル座標系で定義された要素当たりの質量マ

トリクス 

すべての解析が剛性と質量の両方のマトリックスがデータベース中に必要とされるとは限りません。 

次の選択肢がデータベース中のFEMデータテーブルでサポートされます。 

• データ・インターフェイス・プログラムを使用する。 

• FEMtoolsコマンド（DEFINE）を使用する。 

• FEMtoolsスクリプト・プログラムやFEMtools API関数を使用する。 

• FEMtoolsで計算した要素マトリックスを使用する。 

縮小剛性と縮小質量のデータタイプ 

いくつかのFEMtools解析は、FEモデルの縮小システム剛性と縮小質量マトリクスを必要とします。各データ
タイプ・ラベルは縮小剛性や縮小質量マトリックスに使用されます。 
 

データテーブル  データテーブル・ラベル 記述 

縮小剛性マトリクス REDUCED STIFFNESS グローバル座標系で定義された縮小システム剛性マ

トリクス 

縮小質量マトリクス REDUCED MASS グローバル座標系で定義された縮小システム質量マ

トリクス 

すべての解析が剛性と質量の両方のマトリックスがデータベースに必要とするとは限りません。 

次の選択肢がデータベース中のREDUCED STIFFNESSおよびREDUCED MASSデータテーブルでサポートさ
れます。 

• データ・インターフェイス・プログラムを使用する。 

• FEMtoolsスクリプト・プログラムやFEMtools API関数を使用する。 

• FEMtoolsシステム・マトリックスの縮小（コマンドREDUCE）を使用する。あらかじめ、マスターDOF
の定義を必要とします。 
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変位データタイプ 

一般に、実稼働シェープは外力荷重の結果としての変形シェープです。それは動的荷重ですが、静的荷重や

変形（加振周波数：0Hz）においても使用されます。 

次の表のように分類されます。 
 

データテーブル データテーブル・ラベル 

静的／動的実稼働シェープ DISPLACEMENT 

動的外力 EXCITATION 

静的節点外力 FORCE 

荷重ケース定義  LOAD 

静的圧力荷重 PRESSURE 

ダイアグラム DIAGRAM 

調和周波数 HARMONIC FREQUENCY 

調和荷重 HARMONIC LOADS 

調和応答 HARMONIC RESPONSES 

次の選択肢がデータベース中の動的実稼働シェープのためにサポートされます。 

• データ・インターフェイス・プログラムを使用する。 

• テーブル・ウィンドウを編集する。 

• FEMtoolsコマンド（DEFINE）を使用する。 

• FEMtoolsスクリプト・プログラムやFEMtools API関数を使用する。 

• テストモデルを解析データベースへコピーする。 

モード・データタイプ 

次の表のように分類されます。 
 

データテーブル  データテーブル・ラベル 記述 

共振周波数、モーダル

減衰 
FREQUENCY 計算された共振周波数 Hz、モーダル減衰値 

モードシェープ  MODE 解析結果の正規モードシェープおよび複素モードシェ

ープであり、モードシェープ・コンポーネントはノード

の自由度によって決定されます。すべてのノードは同じ

自由度を持ちます。 

これらの2つのテーブルは関連付けられ、両方によって構成されます。 

次の選択肢がデータベース中のMODEデータテーブルを得サポートします。 

• データ・インターフェイス・プログラムを使用する。 
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• テーブル・ウィンドウを編集する。 

• FEMtoolsコマンド（DEFINE）を使用する。 

• FEMtoolsスクリプト・プログラムやFEMtools API関数を使用する。 

• テストモデルを解析データベースへコピーする。 

テスト・データタイプ 

テスト・データタイプは、すべての構造試験と関係するデータテーブルから成り、テストポイント、トレー

スリンク、自由度、静的／動的実稼働シェープ、共振周波数、モードシェープなどの実験値としてのデータ

が含まれます。TESTデータタイプは次のテーブルで構成されます。 
 

データテーブル データテーブル・ラベル 記述 

測定ポイント POINT テスト・データの得られた位置として、通常、センサー

位置になります。グローバル・デカルト座標が使用され

ます。 

ポイント・トレースリン

ク 
CONNECTIVITY 接続ポイント番号を指示し、それらはテストモデルを視

覚化するために使用されます。 

ローカル座標系  CS ポイントのローカル座標系 

静的／動的実稼働シェー

プ 
DISPLACEMENT 静的／動的な実稼働シェープが格納されます。静的変位

には 0値の加振周波数が割り当てられます。 

共振周波数、 

モーダル減衰 
TEST FREQUENCY 計算された共振周波数 Hz、モーダル減衰値 

モードシェープ  TEST MODE 解析結果の正規モードシェープおよび複素モードシェ

ープであり、モードシェープ・コンポーネントはポイン

トの自由度によって決定されます。すべてのポイントは

同じ自由度を持ちます。 

測定ポイントは常に必要とされ、モードシェープ・テーブルが含まれる場合、共振周波数が必要とされます。

モードシェープとポイント・トレースリンク・テーブルは必ずしも必要としません。 

 

注意：FEMtoolsドキュメンテーションの全体にわたって、ポイントはテスト・グリッド位置を参照し、ノー
ドは有限要素グリッド位置を参照します。トレースライン（tracelines）は、ポイント接続と同意語とみなさ
れます。同様に、要素接続（Element connectivities）は、有限要素の定義データを参照します。 

 

次の選択肢がデータベースにテスト・データテーブルを格納するためにサポートされます。 

• データ・インターフェイス・プログラムを使用する。 

• テーブル・ウィンドウを編集する。 

• FEMtoolsコマンド（DEFINE）を使用する。 

• FEMtoolsスクリプト・プログラムやFEMtools API関数を使用する。 

• 解析データをテストモデル・データベースへコピーする。 
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FRFデータタイプ 

周波数応答関数は、実際の測定データもしくは減衰データを使用し、解析および実験のモードシェープから

合成されます。3つの減衰モデル（粘性、構造(ヒステリ)、モーダル減衰）が、FRF合成のためにサポートさ
れます。 

以下に次のテーブルが含まれています。 
 

データテーブル データテーブル・ラベル 記述 

周波数レンジ・データ RANGE DEFINITION レンジ識別番号、下限／上限周波数、周波数ステッ

プなどの周波数レンジ情報. 

周波数レンジ RANGE 各レンジ用（応答対象の周波数リスト）  

解析 FRF定義 FRF FEM DEFINITION FRF情報識別番号、加振 DOFと応答 DOF 

解析 FRFデータ FRF FEM 各周波数ステップ、モジュール／位相および実数／

虚数の応答情報 

実験 FRF定義 FRF TEST DEFINITION FRF情報識別番号、加振 DOFおよび応答 DOF 

実験 FRFデータ FRF TEST 各周波数ステップ、モジュール／位相および実数／

虚数の応答情報 

次の選択肢がデータベースにFRFデータテーブルを格納するためにサポートされます。 

• データ・インターフェイス・プログラムを使用する。 

• テーブル・ウィンドウを編集する。 

• FEMtoolsコマンド（DEFINE）を使用する。 

• FEMtoolsスクリプト・プログラムやFEMtools API関数を使用する。 

• FRF合成（シンセサイズ）機能を使用する。 

結果データタイプ 

FEMtools解析結果が格納されている場合のデータベースのテーブルは解析のタイプに依存します。より詳細
については、「解析」の章を参照してください。 

プロジェクト・データタイプ 

PROJECTデータタイプは、すべてのデータタイプに対応するバックアップ・インターフェイス・プログラム
と共に使用し、全データベース、ディスク・ファイル、全データベース上でオペレーションを行なう場合に

有効。ラベルPROJECTはプロジェクト・データタイプを識別するために使用されます。 

関連項目 

プロジェクトマネージメント（Managing Projects） 



 

12 

データ・インターフェイス 

データ・インターフェイス・プログラムは、FEMtoolsでの解析に必要なデータテーブルを得るために使用さ
れます。汎用解析システムやテスト・システムによって生成された外部データベースのインターフェイス・

プログラムを利用するには、FEMtoolsのライセンス条件に依存します。MSC.Nastran、ANSYS、ABAQUS、
COSMOS/M、MSC.Marc、UGS I-DEAS、Femap、Algor、SAPなどの有限要素データテーブル対応と実験モー
ダル解析用のユニバーサル・ファイルがサポートされています。ユニバーサル・ファイルは、CADA, SDRC 
TDAS, MTS Engineering Office, m+p Smart Office, ME’SCOPE, Prodera P-Modal, ICATS, SD STARなどのテス
ト・システムによって使用されています。新しいインターフェイス・プログラムも必要に応じて追加可能で

す。複数のインターフェイス・プログラムがインストールされた場合、それぞれのフォーマットでデータを

インポート／エクスポートすることが可能です。 

外部ファイルとしては、ASCIIまたはバイナリのフォーマットがサポートされ、それらの外部ファイル・フォ
ーマットは、インターフェイス・プログラムに依存します。 

データテーブルをインポートするには、 

• FileメニューからImportを選択する。 

• データタイプを選択する。 

• ファイル名を入力します。Typeリストボックスのリスト・ファイルから、ファイルによって使用される
データ・フォーマットを選択します。FEMtoolsは各フォーマット用のデフォルト拡張子を使用し、ファ
イルをリストします。別の拡張子が使用する場合は、最初にデータ・フォーマットを選択し、次に、フ

ァイル名ボックス中の拡張子を変更してください。すると、FEMtoolsは選択可能なファイルのリストを
更新します。 

• ファイルを選び、ファイルをインポートすめるために、Openボタンをクリックする。 

あるいは 

• コマンドモードでは、データテーブルがアスキーファイルで格納されている場合は、INPUTコマンドを
使用します。 

あるいは 

• コマンドモードでは、データテーブルがバイナリ・ファイルで格納されている場合は、SEARCHコマン
ドを使用します。 

• データテーブルをエクスポートするには、 

• FileメニューからExportを選択する。 

• データタイプを選択する。 

• タイプ・リストボックスのリスト・ファイルから、データを出力するためにデータ・フォーマットを選

択します。FEMtoolsは各フォーマット用のデフォルト拡張子を使用し、ファイルをリストします。最初
にデータ・フォーマットを選択し、次に、ファイル名ボックス中の拡張子を変更してください。任意の

拡張子を備えた作業ディレクトリ中のファイルをすべてリストするには、ファイル名ボックス中の拡張

子を変更してください。 

• ファイルをエクスポートするために、Saveボタンを選択する。 

あるいは 

• コマンドモードでは、データテーブルをアスキーファイルで保存するOUTPUTコマンドを使用します。 

• あるいは 



 

13 

• コマンドモードでは、データテーブルをバイナリ・ファイルで保存するために、SAVEコマンドを使用
します。 

データ・インターフェイス、インターフェイス・プログラム、それらの使用方法などのより詳細については、

FEMtoolsデータ・インターフェイス・マニュアルを参照してください。 

プロジェクト・ファイルの使用方法 

プロジェクト・ファイルは、プラットフォームに無関係なダンプ（バックアップ）ファイルです。それらは

バイナリ形式なので、それぞれのプラットフォーム（Windows、Linux、MacOSなど）の互換性に基づいて利
用することができます。 

プロジェクト・ファイルのデフォルト拡張子は、.FPJ.です。プロジェクト名がスタートアップで定義された
場合、それはプロジェクト・ファイル名として使用することができ、オペレーティング・システムの指定さ

れたファイルと共通化されます。 

ファイル名は、File > Save Project Asまたは、SET PROJECTコマンドを使用し、データベースに割り当てら
れ、そのプロジェクト名はデフォルト・プロジェクト・ファイル名として使用されます。 

コマンドINPUT、OUTPUT、SEARCH、SAVEは、PROJECTデータタイプをエクスポート／インポートする
ために使用することができます。PROJECTデータは、FEMtoolsフォーマットを使用して保存されるため、フ
ォーマットを指定する必要はありません。 

例 

>SET PROJECT TUBE  
>SAVE PROJECT  

このコマンドは、TUBE.FPJ名のプロジェクト・ファイルを保存します。 

 

注意：プロジェクト・ファイルはデータベース中のモデル・サイズに依存することに注意してください。解

析結果を伴う大規模モデル・サイズのデータを保存する場合、個別のデータを保存したり、不要なデータを

削除したりする必要があるかもしれません。個別のデータを保存するには、データテーブルのインポート／

エクスポート操作を使用します。また、データを削除するには、Database > Deleteまたは、CLEARコマンド
を使用します。 

 

プロジェクト・ファイルがインポートされた場合、データベースはプロジェクト・ファイルの保存時に戻さ

れます。そのため、例えば、モデルアップデート済みプロジェクトに新たなモデルアップデート処理を追加

することができます。 

FEMtoolsコマンド・スクリプトとして FEMデータをバックアップ 

FEモデルを保存するには、FEMtoolsコマンド・スクリプトとして保存することも可能です。それには、File > 
Export > FE ModelおよびフォーマットFEMtoolsコマンド・スクリプトを選択します。このファイルはアスキ
ー形式なので、バイナリ・ファイルの非互換プラットフォーム間でのFEモデルを転送するために使用するこ
とができます。 

FEモデルをインポートするには、File > Read Command Fileを使用します。 

関連項目 

プロジェクトマネージメント（Managing Projects） 
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FEMtoolsデータベース・ファイル 

FEM、MODEなどのデータタイプは、FEMtoolsデータベース・ファイルと呼ばれ、デフォルト拡張子.FDB.
のバイナリ・ファイル・タイプに格納されます。 

FDBフォーマットは、FPJファイルに含まれるデータベース・ダンプおよびセッティング全体のデータベース
の部分集合である以外はFPJフォーマットに似ています。 

FEMtoolsデータベース・ファイル・フォーマットを指定するためのフォーマット・ラベルFEMTOOLS、FT、
FDBはコマンドOUTPUTやSAVEと共に使用することができます。 

FEMtoolsデータベース・ファイルをインポートするには、 

• Fileメニューまたは（ ）をクリックし、Importコマンドを選択する。 

• 利用可能なデータタイプのリストからデータタイプを選択する。 

• ファイルが格納されている場所のディレクトリ・パスに変更する。 

• リストボックスから、FEMtoolsを選択する。 

• デフォルト拡張子のファイルがリストされます。インポートしたいファイルがリストに表示されていな

い場合は、File Nameボックスに、*.* を入力することによりすべてのファイルをリストすることができ
ます。 

• ファイル名を選択し、Openをクリックする。 

あるいは 

• コマンドモードでは、コマンドINPUTかSEARCH、フォーマット（FEMTOOLS）、ファイル名を使用
します。 

 
例 
Command> INPUT TEST FORMAT FEMTOOLS FILE DATA.FDB 

FEMtoolsデータベース・ファイルをエクスポートするには、 

• Fileメニューから（ ）をクリックし、Exportコマンドを選択する。 

• 利用可能なデータタイプのリストからデータタイプを選択する。 

• ファイルが格納されている場所のディレクトリ・パスに変更する。 

• リストボックスから、FEMtoolsを選択する。 

• ファイル名を入力し、Saveをクリックする。 

あるいは 

• コマンドモードでは、コマンドOUTPUTかSAVE、フォーマット（FEMTOOLS）およびファイル名を使
用します。 
 
例 
 
Command> OUTPUT TEST FORMAT FEMTOOLS FILE DATA.FDB 

サポート・データタイプ 
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以下のデータタイプが、FEMtoolsデータベース・ファイル・インターフェイス・プログラムにおいてサポー
トされます。 

• FEM 

• MODE 

• FRF FEM 

• STIFFNESS 

• MASS 

• TEST 

• FRF TEST 

• RESULTS 

• PROJECT 

圧縮 

有限要素とテストのモデルのサイズは、大規模する傾向にあります。それに伴って、解析結果ファイル、プ

ロジェクト・スナップショットなどの保存に膨大なディスク・スペースを占領します。 

データ・ストリーム圧縮技術を使用し、ファイル・サイズを縮小することは可能です。その技術によって、

大規模ファイルの場合、約-65%の縮小が可能になり、エクスポート速度も短縮されます。その圧縮アルゴリ
ズムは速度と解析のバランスを維持するように設計されています。データ圧縮化は、FEMデータ、テスト・
データ、モード、変位、剛性マトリックス、質量マトリックス、FEA FRF、テストFRFに利用されます。 

圧縮モードは以下の方法でコントロールされます。 

• データ・エクスポート・ダイアログボックスのSettingsボタンをクリックすることにより、FEMtools 
Interface Settingsダイアログボックスを開きます。選択されたセッティング（compressed：圧縮、
uncompressed：非圧縮）は、以降のセッションで使用されます。 

• Settingsダイアログボックス（メイン・メニューのEdit > Settings）を開き、Data Interfaces > Default .fdb 
Compression Modeモード・セッティングを変更し、Okボタンでセッティング・ダイアログボックスを
閉じます。新しいセッティングは以降のセッションで使用されます。新しいデフォルト値として変更し

たセッティングを格納するには、Settingsダイアログボックスを閉じる前にSaveボタンをクリックしてく
ださい。 

備考 

• FEモデルをインポート後、プログラムがインターフェイス・プログラムを使用する前にデータ検証モー
ドにセットされていれば、インターフェイス・プログラムはメッシュを検証行します。これは要素タイ

プ数、分離ノードなどのチェックが実行されます。そのデータ検証機能は、コマンドSET 
VERIFICATION ONあるいはデータ・インターフェイス・セッティング・ダイアログボックス（Edit > 
Settings > Data Interfaces > FEM Verification）で設定されます。 

• データテーブル抽出はデータテーブルが、FEMtoolsデータベースに正確に格納されていることを確認す
るために使用することができます。グラフィックス・ディスプレイもFEモデルおよびモードシェープが
正確にインポートされたことを確認するために使用されます。 

• OUTPUTとSAVEのコマンドでサポートされるデータタイプのテーブル以外のデータテーブルをエクス
ポートするには、カスタム・プログラム・スクリプトの使用を推奨します。 

関連項目 

Default File Name Extensions  
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Data Interface Programs  

INPUT | SEARCH | SET VERIFY  

データ・インターフェイス・プログラム 

FEMtoolsは、FEA／TESTデータをインポート／エクスポートするためのインターフェイス・プログラムを搭
載しています。 

FEAデータ・インターフェイス 

FEMtoolsは主なFEAのプログラムとして、ABAQUS、ANSYS、NASTRAN、I-DEASユニバーサル・ファイル
などのアドオン・インターフェイス・プログラムをサポートしています。それらのインターフェイスはバイ

ナリコード化され、高水準のデータ変換、パフォーマンス、メンテナンスが提供されます。 

その他のインターフェイスとして、バイナリコード化されたMARCやFEMtoolsスクリプトのFEMAP、SAP、
ALGORなどがサポートされています。それらは基本的なデータ変換機能がサポートされ、FEMtoolsフレーム
ワーク・ライセンスに含まれています。また、スクリプトベースのインターフェイスはユーザーによってカ

スタマイズすることが可能です。 

テスト・データ・インターフェイス 

FEMtoolsフレームワーク・ライセンスは、ユニバーサル・ファイル・フォーマットのテスト・データをイン
ポート／エクスポートするためのインターフェイスをサポートしています。そのファイル・フォーマットは、

MTS I-DEAS TDAS、STARModal、Smart Office、ME'Scope、ICATS、Proderaなどで使用されます.。 

これらのインターフェイス・プログラムの詳細情報に関しては、FEMtoolsデータ・インターフェイス・マニ
ュアルを参照してください。また、新しいインターフェイスも随時に追加されます。その最新情報について

は、FEMtoolsサポート情報を確認してください。 

関連項目 

NASTRANインターフェイス・プログラム 

ANSYSインターフェイス・プログラム 

ユニバーサル・ファイル・インターフェイス・プログラム 

ABAQUSインターフェイス・プログラム 

SAP2000インターフェイス・プログラム 

Polytecインターフェイス・プログラム 

ARTeMISインターフェイス・プログラム 

ファイル名拡張子 

Fileメニューから、Import、Exportのコマンドを使用し、データをインポート／エクスポートする場合、デフ
ォルト・ファイル名拡張子が使用されます。インターフェイス・フォーマットを選択するとき、そのダイア

ログボックスの選択ディレクトリ中では、対象フォーマットに関連した拡張子を備えたすべてのファイルを

リストします。デフォルトの拡張子が以下のとおりです。 
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拡張子 ファイル記述 

.FPJ FEMtoolsプロジェクト・ファイル 

.FDB FEMtoolsデータベース・ファイル 

.CMD FEMtoolsコマンド・スクリプト・ファイル 

.BAS FEMtoolsプログラム・スクリプト・ファイル 

.SNF FEMtools中間ファイル（ASCII）：データテーブル*OBSOLETE* 

.BIN FEMtools中間ファイル（バイナリ）：データテーブル*OBSOLETE* 

.PRJ FEMtools中間ファイル：プロジェクト・ファイル*OBSOLETE* 

.ASC ユニバーサル・ファイル 

.UNV ユニバーサル・ファイル 

.UFF ユニバーサル・ファイル 

.PCH NASTRANパンチ・ファイル 

.BDF、.DAT NASTRANバルクデータ・ファイル 

.11 感度データのNASTRAN OUTPUT2ファイル 

.51 モードデータのNASTRAN OUTPUT2ファイル 

.61 縮小システム剛性マトリクスのNASTRAN OUTPUT4ファイル 

.62 縮小システム質量マトリクスのNASTRAN OUTPUT4ファイル 

.91 剛性マトリックスのNASTRAN OUTPUT2ファイル 

.92 質量マトリックスのNASTRAN OUTPUT2ファイル 

.28 ANSYSインターフェイス・ファイル（Rev.4.x） 

.CDB ANSYSインターフェイス・ファイル（Rev.5.x） 

.RST ANSYS結果ファイル 

.EMA ANSYS要素マトリックス・ファイル 

.INP ABAQUS入力ファイル 

.FIL ABAQUS結果と要素マトリックスのファイル 

.S2K SAP2000インターフェイス・ファイル（モデルと結果） 

.SVD Polytecスキャン・ファイル 
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.CFG ARTeMISプロジェクト・ファイル 

INPUT、OUTPUT、SEARCHまた、コンソールからSAVEコマンドを使用する場合、デフォルト・ファイル
拡張子は必要ありません。 

各データタイプのインターフェイス・ファイルのデフォルト拡張子のセッティングは、セッティング・ファ

イル（femtools_310.ini）の [Filters]セクションで指定されます。それらのインターフェイス・ファイル拡張子
と関係するセッティングはエディタを使用し、セッティング・ファイルを編集することができます。 

例えば、FEMtoolsプロジェクト・ファイル・インターフェイスを形成するには、次のエントリが使用されま
す。 

PROJECT.FEMTOOLS.RB=FEMtools Project File (Binary):*.fpj;*.prj 

エントリ名はデータタイプ（プロジェクト）、インターフェイス名（femtools）、I/Oオプション（R=読み込
み、W=書き込み、B=バイナリ）を含んでいます。 

File OpenとFile Saveダイアログボックスの=記号の右側にファイル情報が示されます。ファイル記述とデフォ
ルト・ファイル拡張子はコロン記号（:）によって区分され、セミコロン記号（;）は複数の拡張子を区分指定
することができます。 

インターフェイス・プログラムのとして実行されるプログラム・スクリプトを補語の引き数に指定すること

ができます。 

次の例では、バイナリのI-DEASファイルから要素剛性マトリックスをインポートするためのスクリプト
ideaskm.bas（<installdir>¥scripts¥interfaces）の指定方法を示します。 

STIFFNESS.IDEAS.RB=I-DEAS Binary Stiffness File:*.stf:ideaskm.bas 

これは、FEMtoolsスクリプトで書かれた新しいインターフェイスの指定方法にも適用できます。 

以下に典型的な有限要素フォーマットの指定方法を示します。 

FEM.NEUTRAL.RW=FEMtools Neutral (ASCII):*.snf 

FEM.ABAQUS.RW=ABAQUS:*.inp 

FEM.ANSYS.RW=ANSYS 5.x:*.cdb 

FEM.MARC.RW=MARC:*.dat 

FEM.NASTRAN.RW=NASTRAN:*.bdf;*.dat;*.nas 

FEM.MS.RW=Universal File:*.asc;*.unv;*.uff 

FEM.FEMAP.R=FEMAP:*.neu:femap.bas 

編集用のスクリプト・ファイル、ジャーナル・ファイル、グラフィックス・ファイル、コンソール・ウィン

ドウ・プリント・ファイル、テーブル・ウィンドウ・プリント・ファイルおよび一般ファイル用にデフォル

ト・ファイル名の拡張子の変更が可能なことに注意してください。 

デフォルト・インターフェイス・フォーマット 

デフォルト・インターフェイス・フォーマットはデータ・インターフェイス・セッティング・ダイアログボ

ックスで指定することができます。このダイアログボックスを開くには、Settings > Data Interfacesを使用し



 

19 

ます。 

フォーマット・ラベルを使用して、FEMとTESTのデータ・ファイルのデフォルト・インターフェイスを指定
します。これらの省略書式が指定される場合、INPUT、OUTPUT、SEARCH、SAVEのコマンドのFORMAT
ラベルは省略することができます。 

それぞれFEMとTESTのデータのフォーマットをセットするfemtools.iniエントリは、FemFormat=、TestFormat=
です。 

インターフェイス・データのエコー・モード 

FEMデータをインポートする場合、そのインターフェイス・プログラムを使用する前にエコー・モードに設
定されているときは、その処理ラインはコマンドモード・ウィンドウで再帰的に実行されます。 

Edit > Settings > Data Interfacesを選択し、VerboseモードをONに設定します。 

コマンドモードでは、SET VERBOSEを使用します。 

 

注意：これがインターフェイスに依存するため、すべてのインターフェイスにおいてこの機能がサポートさ

れるとは限らないことに注意してください。 

 

ファイルの上書きモード 

ファイルの保存処理において、既存のファイルが存在する場合、既存のファイルの上書きを回避し、新しい

ファイル名（拡張子.old）で作成するためのスイッチを提供されます。このスイッチを非アクティブ化すると
ファイル上書きモードに設定されます。 

Edit > Settings > Data Interfacesを選択し、File overwriteモードをONに設定する。 

コマンドモードでは、SET OVERWRITEを使用します。 

データテーブルのインポートとエクスポート 

OUTPUTとSAVEのコマンドでサポートされるデータタイプ以外のデータテーブルをエクスポートするには、
カスタム・プログラム・スクリプトの使用が推奨されます。同様のスクリプト例は、<installdir>¥scripts¥interfaces
で見つけられます。これらのインターフェイス・スクリプトの呼び出しは、File > Import > FEMtools Tables
やFile > Export > FEMtools Tablesのサブメニューに含まれます。 

個々のマトリックスもメイン・メニュー（File > Export > FEMtools Matrices）やデータベース・エクスプロ
ーラ（マトリックス・エントリのポップアップ・メニュー中のExport Matrix）からアクセス可能なMatrix 
Exportダイアログボックスを使用してエクスポートすることができます。 

FEMtoolsマトリックスのインポートとエクスポート 

FEMtools内部マトリック・スデータをASCIIまたはバイナリ・ファイルとしてエクスポートすることが可能で
す。バイナリ・ファイルの場合、データをFEMtoolsまたはMATLABフォーマットでエクスポートすることが
できます。マトリックスはメイン・メニューのFile > Export > FEMtools Matrices か、データベース・エクス
プローラのMatrixエントリのポップアップ・メニュー（マウス右ボタンのクリック）のExport Matrixの選択、
あるいはEXPORT MATRIXコマンドによってエクスポートされます。 

バイナリ・ファイル（FEMtoolsあるいはMATLABフォーマット）で格納されたマトリックスは、IMPORT 
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MATRIXコマンドを使用して、FEMtoolsへインポートすることができます。 

より詳述情報については、Export Matrixダイアログボックスのヘルプから、EXPORT MATRIXとIMPORT 
MATRIXのコマンドを参照してください。 

データの検証 

FEMtoolsには有限要素とテストのデータの整合性をチェックするコマンドがサポートされています。データ
のインポート時にいくつかの検証がインターフェイス・プログラムによって行なわれ、また、ベリファイ・

コマンドも使用されます。 

要素定義データの整合性 

次のようなデータベース検証が行われます。 

• 要素で使用される材料特性と幾何学特性の識別番号とプロパティの整合 

• 要素タイプと材料／幾何学タイプ間の互換性チェック 

• 要素定義データ中の未定義ノード 

• 要素定義データ中の重複ノード 

• 要素の剛性と質量の未定義マトリックス 

• 非サポート要素タイプ 

• ビーム要素の未定義ローカル軸情報 

Database > Verify > Check FE Data Integrityを使用するかコンソールから、VERIFYコマンドを使用します。 

新しいデータをインポートする場合、VERIFYコマンドによって行なわれるデータベース検証は自動的に実
行することができます。それには、Edit > Settings > Data Interfacesを選択し、FEM検証モードをONに設定し
ます。 

モードシェープの Auto-MAC 

モードシェープのインポート後、それらの線形相関は、Auto-MACマトリックス（モードシェープの自己モー
ダル相関基準）の計算により確認することができます。それは次の機能を含んでいます。 

• Auto-MAC FEAモード：FEAモードシェープの自己相関性を確認するために使用することができます。
構造の質量分布がMACを使用して、グローバルなモードシェープ相関を行なうために十分な相関性があ
る場合、Auto-MAC FEAが使用されます。対角項以外が高すぎる場合、質量分布によるMACを使用する
ことは推奨されません。それは必要に応じて、モーダル直交化（OVE）を使用したグローバルなシェー
プ相関を行なわなければなりません。 

• Auto-MAC TESTモード：テスト・モードシェープの自己相関性を確認するために使用することができま
す。Auto-MAC Testはテストシェープ間の線形相関性を確認することができ、通常、テストポイント数が
不十分な結果は空間エリアジング法で示されます。 

Auto-MAC を計算するには、次の操作が使用されます。 

• Database > Verify > Auto-MAC FEA Modes 

• Database > Verify > Auto-MAC Test Modes 

あるいは 
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• コマンドモードでは、EXAMINE MAC TYPE FEMあるいはEXAMINE MAC TYPE TESTコマンドを使用
します。 

FEMAuto-MACについては、すべてのアクティブDOFが使用されるべきです。 

Auto-MAC Testについては、テスト・モードシェープ・ベクトルが未測定なDOFに対応する0値を含んでいる
かもしれません。それらは最小変位値（アクティブ座標系）による自動フィルタ指定が可能です。最小モー

ダル変位を指定するには、Auto-MACダイアログボックスのSET CORRELATION DISPLACEMENTあるいは
Minimum Displacement Valueフィールドを使用します。 

Auto-MAC値はグローバル、ローカルおよび任意座標系で計算することができます。座標系は、Auto-MACダ
イアログボックス中あるいはEXAMINE MACコマンドのCS補語で指定することができます。 

実稼働シェープの Auto-DAC 

実稼働シェープのインポート後、それらの線形相関は、Auto-DACマトリックスの計算により確認することが
できます。即ち、モード間の実稼働相関基準が形成され、それには次の機能を含んでいます。 

• Auto-DAC FEAモード：DACを使用し、FEAモードシェープの自己相関性を確認するために使用するこ
とができます。Auto-DAC FEAの高い対角項は対象変形を線形に提示する荷重ケースを確認するために使
用することができます。 

• Auto-DAC Testモード：DACを使用し、テスト・モードシェープの自己相関性を確認するために使用す
ることができます。実稼働シェープは必ずしも線形的とは限りません。通常、テストポイント数が不十

分な結果は空間エリアジング法で示されます。Auto-DAC FEAの２つの荷重ケース間の線形性を確認する
ために使用することができます。 

Auto-DACを計算するには、次のように操作します。 

• Database > Verify > Auto-DAC FEA Modes 

• Database > Verify > Auto-DAC Test Modes 

あるいは 

• コマンドモードでは、EXAMINE DAC TYPE FEMあるいはEXAMINE DAC TYPE TESTコマンドを使
用します。 

テストAuto-DACについては、テスト・モードシェープ・ベクトルが未測定なDOFに対応する0値を含んでい
るかもしれません。それらは最小変位値（アクティブ座標系）による自動フィルタ指定が可能です。最小モ

ーダル変位を指定するには、Auto-DACダイアログボックスのSET CORRELATION DISPLACEMENTあるい
はMinimum Displacement Valueフィールドを使用します。 

Auto-MAC値はグローバル、ローカルおよび任意座標系で計算することができます。座標系は、Auto-MACダ
イアログボックス中あるいはEXAMINE MACコマンドのCS補語で指定することができます。 

モードシェープの自動直交化 

モードシェープ、要素の質量と剛性のマトリックスをインポート後、モードシェープの直角性が、Auto-EVO
マトリックスの計算（モードシェープ間のモーダル直角化）により確認することができ、それには次の機能

が含まれています。 

• Auto-EVO FEAのモードは、FEAモードの自動直交性を計算します。これはモーダル・マトリックス（Full  
FEA-to-FEA）あるいは縮小されたシステム・マトリックス（reduced FEA-to-FEA）の品質チェックを計
算するために使用することができます。 
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• Auto-EVOテスト・モードは、テスト・モードの自動直交性を計算します。これは拡張テストシェープと
システム・マトリックスおよび初期のテストシェープと縮小システム・マトリックスを使用して実行さ

れます。Auto-EVOテストは、不均一質量分布を備えた構造の場合にはテストシェープの直角性を検証し
ます。 

Auto-EVOを計算するには、次のように操作します。 

• Database > Verify > Auto-EVO FEA Modes 

• Database > Verify > Auto-EVO Test Modes 

あるいは 

• コマンドモードでは、EXAMINE EVOコマンドを使用します。 

ラージモデルの縮小化 

FEMtoolsデータベースのサイズは、ノード当たりデフォルトの6 DOFの代わりにノード当たり3DOFが使用さ
れることを明示することによって縮小されます。FEMtoolsで定義したFEモデルまたは、インターフェイス・
プログラムを使用してインポートしたFEモデルに対して行われます。 

以下に、ANSYSからインポートされたモードシェープを3つ並進自由度の指定により、サイズの縮小化例を
示します。 

INPUT FEM FORMAT ANSYS FILE myfile.cdb 

DEFINE FEM DOF UX UY UZ 

SEARCH MODES FORMAT ANSYS FILE mymodes.rst 
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データベース・テーブルの編集 

データ・インターフェイス・プログラムはデータベース中に解析データおよび実験データを定義し、編集す

るために使用されます。それには以下の特徴があります。 

• 有限要素モデリング・ソフトウェアや解析コードは利用できない場合でも可能です。 

• 単純な構造のモデル化が可能です。 

• シミュレート結果のテスト・データも使用可能です。 

• 既存テーブルへのデータの追加が可能です。 

• 選択的なモデリングが可能です。 

テーブル・ウィンドウのデータはコンソールのコマンド言語あるいはプログラム・スクリプトのFEMtools API
関数を使用して編集することができます。 

関連項目 

テーブル・ウィンドウによるデータテーブルの編集 

コマンド言語によるデータテーブルの編集 

新しいテーブル・ウィンドウの作成 

データテーブルはテーブル・ウィンドウに示され、テーブル・ウィンドウが存在しない場合、エクスプロー

ラ・ウィンドウからデータテーブルを選択し、作成します。いくつかのテーブル・ウィンドウを同時に開く

には、ViewメニューのUse New Windowモードをアクティブ化するか、エクスプローラからテーブルを選ぶ
場合、テーブル・ネーム上で右クリックし、View in New Windowを選択するか、またはツールバーの新しい
ウィンドウ・モードをアクティブ化するための（）をクリックします。テーブル・ウィンドウはツールバー

とステータスバーを含んでいます。 

テーブル・ツールバー 

Tableツールバーは、Add Records、Select Records、Delete Records、Record in Set、Edit Selected Recordなど
の編集のためのボタンを含んでいます。 

いくつかのテーブルでは、フィルタ機能をもつリストボックスを含むツールバーがあります。そのリストボ

ックスには、グループのアイテム（例えば材料タイプ）の対応する識別番号が含まれます。また、ユーザー

が指定したアイテム（例えば要素セット）のセットをフィルタとすることが可能です。 

ステータスバー 

テーブル・ウィンドウのステータスバーはテーブル中で選択されたレコード番号やレコード総数を示すカウ

ンターを含みます。 

ポップアップ・メニュー 

標準のGUI機能に準拠したマウス右ボタン操作（あるいはShift+F10）はコンテキストを備えたポップアップ・
メニューを表示するために使用されます。 

関連項目 
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テーブル・ウィンドウのアレンジ 

テーブル・ウィンドウをクローズ 

テーブル・ウィンドウのアレンジ 

いくつかのテーブル・ウィンドウが同時に開いている場合、表示されるデータを適切に表示するために、そ

れらをアレンジする必要があるかもしれません。 

ウィンドウをアレンジするには、以下のいずれかの操作を行ってください。 

• Windowsメニューから、Tile、Cascade、Tabifyを選択する。 

• コマンドモードでは、TILE、CASCADE、TABIFYを使用する。 

• 標準ツールバーのTile Horizontal、Tile Vertical、Cascade、Tabifyなどのボタンをクリックする。 

• マウスを使用し、ウィンドウを移動、サイズ変更をする。 

次のマウス操作が利用可能です。 

• Move：上部ボーダー（境界線）のクリックにより、ウィンドウの位置を変更し、新しい位置へドラッグ
する。 

• Resize：コーナーまたはボーダーのクリックにより、新しいサイズにドラッグし、ウィンドウ・サイズ
を変更する。 

• Minimize：iconizeボタンのクリックによりウィンドウをアイコンする。 

• Maximize：maximizeウィンドウ・ボタンのクリックにより最大サイズ・ウィンドウに変更する。 

• Close：ウィンドウ・ドロップダウンメニュー・ボタンのダブルクリックによりウィンドウをクローズす
る。 

• Restore：アイコンのクリックによりグラフィックス・ウィンドウのアイコンを回復します。 

テーブル・ウィンドウはアイコンに最小化することができます。これらのアイコンはメイン・アプリケーシ

ョン・ウィンドウに表示されます。 

 

参考：WINDOWコマンドでウィンドウを作成する場合、グラフィックス・ウィンドウの位置とサイズは指定
することができます。 

 

テーブル・ウィンドウの選択 

テーブルは現在アクティブ・テーブル・ウィンドウに表示されます。ウィンドウをアクティブ・ウィンドウ

にするには、以下のいずれかの操作を行ってください。 

• テーブル・ウィンドウのキャプション・バーをクリックします。 

• WINDOWメニューのオープン・ウィンドウのリストからテーブルを選択する。 

• オープンされているウィンドウ間を切り替えるには、WINDOWメニューからNext（Alt+C）ウィンドウ
選択する。それを必要に応じて繰り返してください。 

 

注意：テーブル中でクリックするとクリックされたアイテムが選択されます。 
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テーブル・ウィンドウのクローズ 

テーブル・ウィンドウはそれらが閉じられるまで開かれます。テーブル・ウィンドウを閉じるには、ウィン

ドウ・キャプション上部の左アイコンをダブルクリックするか上部の左アイコンをクリックし、Closeを選択
するか、上部の右アイコンをクリックします。 

すべてのテーブル・ウィンドウを閉じるには、WindowsメニューからClose All Table Windowsを選択します。 

コマンドモードでは、CLOSE int_valを使用します。nt_valはテーブル・ウィンドウ番号です。 

テーブル・ウィンドウのデータテーブル編集 

次のオペレーションがテーブルで利用可能できます。 

• テーブル中のレコードの選択と非選択 

• テーブル中のデータの追加、削除、修正 

すべてのテーブルが編集できるとは限りません。例えば、FEA結果テーブルは編集することができません。
ただし、テスト・モーダルパラメータ（共振周波数、モードシェープ）を備えたテーブルは編集することが

できます。これは実験的に得られた参照データを期待する値に編集するために使用されます。 

データテーブルを編集するには、エクスプローラ・ウィンドウからテーブルを選んで開いてください。 

 

参考：データテーブル・ウィンドウがアクティブな場合、利用可能なオペレーションを備えたポップアップ・

メニューを表示するためにはマウス右ボタンをクリックしてください。 

 

レコードの選択 

テーブル・ウィンドウ中の個々のアイテムを選択するには、アイテムを定義するデータを含むラインをクリ

ックしてください。選択されたレコードは、ハイライト・ライン表示されます。 

グループを選択するには、マウス左ボタンを押したまま、最後の選択レコードまでカーソルを移動させてく

ださい。 

選択基準を使用するには、Edit > Table > Select Recordを選択するか、テーブル・ツールバー上の（ ）を

クリックします。 

テーブル・ウィンドウのアイテムの選択を逆転するには、Edit > Table > Invert Selectionを選択します。 

テーブル・ウィンドウの選択されているレコードを非選択にするには、Edit > Unselectをクリックします。 

レコードの編集 

テーブル・ウィンドウ中の選択レコードを編集するには、以下のいずれかの操作を行います。 

• 編集されるデータを含んでいるライン上でダブルクリックします。 

• レコードを選択し、Edit > Table > または、ポップアップ・メニューから、Edit Selected Recordを選択
します。 

• レコードを選択し、テーブル・ツールバーから（ ）を選択します。 
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レコードをテーブルに追加するには、以下のいずれかの操作を行います。 

• Edit > Table >  または、ポップアップ・メニューからAdd Recordsを選択します。 

• テーブル・ツールバー上の（ ）をクリックします。 

レコードの削除 

レコードを削除するには、削除するレコードを選択し、以下のいずれかの操作を行います。 

• Edit > または、ポップアップ・メニューからDelete を選択します。 

• テーブル・ツールバー上の（ ）をクリックします。 

コマンド言語によるデータテーブルの編集 

次のテーブルは、コンソールまたはコマンドのスクリプトからのテーブル編集およびデータベース・マネー

ジメントに利用可能なFEMtoolsコマンドを含んでいます。 

コマンド 機能                                

CLEAR テーブルあるいはテーブル項目の削除 

DEFINE 既存データの再定義または追加データの定義 

EXTRACT テーブルまたは、テーブル項目の抽出 

MODIFY データの修正 

これらのコマンドの詳細情報に関しては、FEMtoolsコマンド・リファレンス・マニュアルを参照してくださ
い。 

データの抽出 

EXTRACTコマンドは、判読可能な形式で全テーブルまたは選択レコードのデータをリストするために使用
されるユーティリティ・コマンドです。これは対話式に定義データや外部データベースからインポートされ

たデータを確認したり、計算結果を検討したりするために有効です。 

必要な情報はコマンドEXTRACTに続くテーブル・ラベルによって識別されます。個々の情報を抽出すると
いう意味でも、この補語はユニークです。その補語は一連のラベルと数値から構成されます。 

デフォルトでは、テーブルはターミナル・スクリーン上でリストされますが、その出力デバイスとしてログ・

ファイルにするには、LOGFILEコマンドで変更することができます。 

各EXTRACTコマンドの詳細情報に関しては、FEMtoolsコマンド・リファレンス・マニュアルを参考にして
ください。 

FEデータの修正 

コマンドMODIFYは次の情報を修正するために使用されます。 

• FEM次元 

• FEノード定義 
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• 要素の材料識別番号 

• 要素の幾何学識別番号 

• 共振周波数 

• FRF定義 

• 減衰係数 

境界条件は、DEFINE BOUNDARYコマンドで再定義することにより修正することができます。 

テスト・データの修正 

コマンドMODIFY TESTはモードシェープ・データテーブルを修正するために使用されます。 

FRFデータの修正 

コマンドMODIFY DAMPING、MODIFY FRF、MODIFY RANGEは、FRF合成（シンセサイズ）のための減
衰係数や周波数レンジを修正するために使用されます。 
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アイテムとセット 

FEMtoolsのテーブルは、データ・マネージメント・コマンドによるデータ操作方法と同様の方法が使用され
ます。前節ではデータテーブルをインポート／エクスポートし、定義、編集、削除のコマンドについて記述

されました。次のステップでは、テーブル中のデータ（アイテム）をグループ化し、細分化データ操作につ

いて記述されます。 

アイテムは有限要素とテストモデルの基本的対象データであり、それらは幾何学的アイテムまたは結果デー

タでありえます。FEMtoolsは次のタイプのアイテムをサポートします。 

• 自由度（Degrees-of-freedom） 

• ノード（Nodes） 

• 要素（Elements） 

• 測定ポイント（Measurement points） 

• 測定ポイントのトレースライン（Measurement point tracelines） 

• 実稼働シェープ（Operational shapes） 

• モードシェープ（Mode shapes） 

アイテムはデータテーブル・ウィンドウで選択するか、またはFEMtoolsコマンドで使用することができます。 

アイテム・セットは、テーブル抽出、テーブル定義、テーブル編集、パラメータ選択などのすべてのオペレ

ーションにおいて有用です。 

セットは１つ以上のアイテム選択によって、あるいは以前に作成されたセットの論理演算（結合、積、差分

など）によって定義されたアイテム・コレクションです。また、FEMtoolsはアイテムのセットを作成するた
めのグラフィック・ピッキング機能をサポートします。 

関連項目 

グラフィック・ピッキング 

内部番号と外部番号 

多くのプリ／ポスト・プロセッサと同様に、FEMtoolsも２つのアイテム番号が付けられます。 

• ユーザー定義の外部番号：これらはユーザーによって、あるいはメッシュ生成のような外部プログラム

によって定義された番号です。 

• 連続的内部番号：ノード、要素、ポイント、トレースラインがインターフェイス・ファイルから読まれ

た順番に従って、FEMtoolsによって生成され、番号付けされた内部番号です。 

これらの２つの番号は対で使用され、アイテムを選択するには、それぞれの番号を使用することができます。

デフォルトでは外部番号が使用されます。コマンド言語を使用し、ラベルINTERNALがアイテム選択時に明
示される場合以外は、外部番号スキームが使用されます。ただし、内部番号を使用する方が有利な状況があ

ります。 

• 大きな外部番号：自動メッシュ・ジェネレータは、大きな番号を生成する傾向がありますが、それらの

番号は不連続であったり、ギャップが存在したりしますが、より小さな連続番号を使用することが望ま

れます。 

• 不連続番号：外部番号は不連続でもかまいませんが、いくつかの有限要素コードはアイテム番号に応じ
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たデータベース・スペースを確保することに注意してください。 

関連項目 

アイテムの再番号付け 

アイテムの再番号付け 

FEMtoolsは内部番号付けスキームによる外部アイテム番号の再番号付けのためのユーティリティを提供しま
す。この場合、データベース中のアイテム数より大きな番号を割り当てるべきではありません。 

また、その後のモデル構築が行われる場合にはオフセット値を使用して、アイテム番号付けをすることが有

用かもしれません。 

アイテムの再番号付けは、RENUMBERコマンド、Edit > Table > Renumber Itemsの選択、またはポップアッ
プ・メニュー操作によって実行されます。Renumber Itemsコマンドはアクティブ・テーブル（ノード、要素、...）
のアイテムを再番号付けするために使用されます。 

デフォルトでは、再番号付けは、1からスタートします。 

必要に応じて、オフセット値を入力することができます。ノードと測定ポイントの再番号付けは有限要素定

義テーブル、ポイント結線テーブル、ペアリング・ノード／ポイント・テーブル、ペアリングDOFテーブル
を更新します。 

アイテムの選択 

DOFの選択 

通常、作成されたDOFセットは、データベースまたは解析コマンドによって内部で使用されます。例えば、
ペアリングDOは1セットのペアDOFに帰着します。このセットはモデル縮小用のマスターDOFのセットに変
換されます。 

DOFセットが作成された場合、それらはセット概観テーブルに現われます。そのテーブルのレコード上で右
クリックし、Show Set in a New Table Windowを選択することにより、DOFセットを示すテーブル・ウィンド
ウをオープンすることが可能です。コマンドモードでは、TABLEは、DOFテーブルを開くために引き数を使
用します。 

セット中で標準のレコード選択方法によって、新しいDOFセットのテーブルを作成することができます。 

ノードの選択 

ノードの選択は、以下のいずれか、あるいはいくつかのコンビネーションが使用されます。 

• 外部番号（デフォルト）または内部番号（ラベルINTERNAL）によるノードの選択には数列を使用する
ことができます。 

• 平面上のノード（ラベルX、Y、Z） 

• ２つの平行平面間のノード（ラベルBETWEEN X、YあるいはZ） 

• 参照ノードの近似ノード（ラベルNEAR） 

• セットに属するノード（ラベルSET） 

• 要素に属するノード（ラベルIN ELEMENT） 

• テストポイントとペアのノード（ラベルPAIRED） 
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• FEM表面上のノード（ラベルSURFACE） 

• FEMコーナー上のノード（ラベルCORNER） 

• FEMエッジ上のノード（ラベルEDGE） 

• NMD基準を使用して選択されたノード（ラベルNMD） 

• メッシュのすべてのノード（ラベルALL） 

ノードを選択するためのラベルはラベルNODEの後に指定します。 

選択基準を使用してノードを選択するには、Edit > Table > Select Recordsを選択します。 

 

要素の選択 

FEMtoolsは、ノードの選択に似た要素の選択方法を提供します。それらは、以下のいずれか、あるいはいく
つかのコンビネーションが使用されます。 

• 外部番号（デフォルト）または内部番号（ラベルINTERNAL）の要素番号付けスキームの選択が数列を
使用して行うことができます。 

• ２つの平行平面間の要素（ラベルBETWEEN X、YあるいはZ） 

• セットに属する要素（ラベルSET） 

• メッシュ中のすべての要素（ラベルALL） 

• 次元要素（1、2あるいは3）（ラベルDIMENSION） 

• 要素タイプ（ラベルTRIA3、QUAD4など） 

• 材料識別番号あるいはタイプ（ラベルMATERIAL） 

• 幾何学識別番号あるいはタイプ（ラベルGEOMETRY） 

要素を選択するラベルはラベルELEMENTの後に指定します。 

選択基準を使用して要素を選択するには、Edit > Table > Select Recordsを選択します。 
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ポイントの選択 

測定ポイントの選択は、以下のいずれか、あるいはいくつかのコンビネーションが使用されます。 

• 外部番号（デフォルト）または内部番号（ラベルINTERNAL）によるポイントの選択には数列を使用す
ることができます。 

• 平面上のポイント（ラベルX、Y、Z） 

• ２つの平行平面間のポイント（ラベルBETWEEN X、YあるいはZ） 

• セットに属するポイント（ラベルSET） 

• テストモデル中のすべてのポイント（ラベルALL） 

ポイントを選択するラベルはラベルPOINTの後に指定します。 

選択基準を使用してポイントを選択するには、Edit > Table > Select Recordsを選択するか、テーブル・ウィン

ドウ・ツールバー（ ）をクリックします。 
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ポイント・トレースラインの選択 

測定ポイント・トレースラインの選択は、要素の選択に似ています。その選択には以下のいずれか、あるい

はいくつかのコンビネーションが使用されます。 

• 外部番号（デフォルト）または内部番号（ラベルINTERNAL）によるポイント・トレースラインの選択
は数列を使用して行うことができます。 

• セットに属するトレースライン（ラベルSET） 

• テストモデル中のすべてのトレースライン（ラベルALL） 

トレースラインを選択するラベルはラベルCONNECTIVITYの後に指定します。 

選択基準を使用してトレースラインを選択するには、Edit > Table > Select Recordsを選択します。 

モードシェープの選択 

モードシェープの選択は、以下のいずれか、あるいはいくつかのコンビネーションが使用されます。 

• モードシェープの指定 

• 定義周波数境界間のモードシェープ 

• モードのペア 

• セットに格納されたモードシェープ 

モードシェープを選択するラベルはラベルMODEかFREQUENCYの後に指定します。 

選択基準を使用してモードシェープを選択するには、choose Edit > Table > Select Recordsを選択します。 

関連項目 

ノード選択シンタックス 

要素選択シンタックス 

ポイント選択シンタックス 

ポイント・トレースライン選択シンタックス 

モードシェープ選択シンタックス 

選択アイテムの許容距離 

アイテムのセットを作成するには、参照アイテムに関するアイテム空間値が使用され、例えばピッキング操

作において定義されたその許容距離が使用されます。その場合、参照アイテムの許容距離内にあるアイテム

のすべてが選択されます。デフォルトの許容距離は、FEMモデルの最大サイズ1%にセットされ、
femtools_xxx.iniファイル中あるいはコマンドSET DEFAULT PICKでダイレクトに変更することができます。 

許容距離の現在値を確認するには、コマンドSHOW DEFAULTを使用します。 
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セットの定義 

手動でセットを作成するか、あるいは新しいFEモデルをインポートする場合、要素セットをプログラムに自
動的に作成させることができます。 

手動によるセットの定義 

セットは次の方法で作成することができます。 

• テーブル中のレコードをハイライトし、セットにそれらを記録する。 

• DEFINE SETコマンドを使用し、アイテム・リストを指定するか、あるいは既存のセット上でブール演
算子を使用する。 

• グラフィック・ピッキングの使用 

テーブルでのセットの記録 

セット生成（要素、ノード、ポイント、...）可能なアイテム・テーブルにおいて、アイテムをハイライト化
し、それらをセットに記録することにより作成することができます。アイテムのハイライト化は、テーブル

中のレコードのクリックまたは、Selectionダイアログボックスを使用して行われます。 

• テーブル中でのクリック操作でレコードをハイライト化するか、あるいは選択ダイアログボックスを開

くために、Edit > Table > Select Recordsを選択します。 

• Edit > Table > Save Selection in a Setを選択するか、あるいはテーブル・ツールバー上の（ ）をクリッ

クします。 

• Define New Setダイアログボックスでセット番号を指定するか、あるいは自動生成された番号を受理しま
す。必要に応じて、セット・タイトルは入力することができます。既存のセット番号が使用されている

場合、そのセットに上書きされます。 

• セットを作成するためにOKをクリックします。 

DEFINE SETコマンドの使用 

コマンドモードでは、DEFINE SETコマンドを使用します。セットの識別番号がこのコマンドに続きます。こ
の番号が省略される場合、その番号はプログラムによって自動的に生成されます。 

その番号が別のセットとして既に使用されている場合、そのセットに上書きされます。そのラベルやシンタ

ックスの詳細に関してはコマンド・リファレンス・マニュアルに参照してください。 

例 

• １つ以上のアイテム選択が後続するセット（ラベルNODE、ELEMENT、POINT、CONNECTIVITY、MODE
など）のタイプが指定されます。アイテムを選択するすべてのコマンドに適用されることに注意してく

ださい。 

 

> DEFINE SET 10 NODES 1 TO 8 INTERNAL + 
> 101 102 + 
> BETWEEN X 2 (2 + 0.5) 
 
これはノード1～8（内部番号）を含むセット番号10が作成し、次にノード101と102を追加し、さらに式
X=2とX=2.5の平行平面間に存在するノードが追加されます。 

• ２つの特別なノード・セットの生成方法として、境界条件（ラベルBOUNDARY）と集中質量（ラベル
MASS）のいずれかが定義されたノードのセットを生成方法が提供されます。 
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>DEFINE SET 1 BOUNDARY 
 
セット1は境界条件が定義されているノードのすべてが含まれます。 

• 前もって定義されたセットに使用し、新しいセットを生成することが可能です。それぞれのセットの積、

和、差分などの論理演算子手法によっては新しいセットを生成することができます。この演算例を次に

示します。 

 

> DEFINE SET 100 NODES 1 TO 10 STEP 2 
> DEFI SET 200 NODE 1 TO 10 STEP 3 
> DEFINE + 
> SET 300 INTERSECTION 100 200 + 
> SET 400 UNION 100 200 +  
> SET 500 DIFFERENCE 100 200 + 
> SET 600 DIFFERENCE 200 100 
 
このメッシュはノード1～10が定義されていると仮定し、次の表にリストされたコマンドで定義されたセ
ット内容を示します。 

Set Id No items  List of items 

100  5  1 3 5 7 9 

200  4  1 4 7 10 

300  2  1 7  

400  7  1 3 5 7 9 4 10 

500  3  3 5 9 

600  2  4 10 

注意：積（INTERSECTION ）や和（UNION）演算の対照性や差分（DIFFERENCE）演算結果をセット
500と600から確認することができます。 

グラフィック・ピッキングの使用 

セットを定義する別の方法として、FEやテストのモデルを表示し、グラフィック上でセットに記録するアイ
テムを選択する方法があります。このグラフィック・ピッキングについては、グラフィック・ピッキングの

章を参照してください。 

セットの自動定義 

新しいFEモデルをインポートする場合、自動的に要素セットを作成することができます。これらのセットは
共通の材料特性、幾何学特性、トポロジー特性に基づいて生成されます。自動セット生成オプションをアク

ティブにするには、データ・インターフェイス・ダイアログボックス（Edit > Settings > Data Interfaces）中
のSet Generation Setingsの対象スイッチをアクティブにします。 

コマンドモードでは、DEFINE SET AUTOMATICコマンドを使用します。 

いくつかのFE入力データ・ファイルでは、FEMtools要素セットに変換するトランスレータによって解釈され
る要素セットが含まれることに注意してください。その場合、自動セット生成は行われません。例えば、

ABAQUS入力ファイル（inp）は、独自のセット定義を含むため、セット生成を行われません。 
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セットの色分け 

セット・アイテムに色を指定することが可能です。セット・テーブルには、割り当てられたセット色を示す

カラムを持っています。それらの色を変更するには、レコード上でダブルクリックし、編集ツリーリストを

開きます。 

 

セットに自動的に色が割り当てるには、 

• 割り当てられた色のないセットを含むモデルがインポートされたとき 

• 新しいセットが定義されたとき 

コマンドモードでは、DEFINE SETやMODIFY SETでセット色を指定するためのラベルCOLORを使用するこ
とができます。 

色付けされた要素セットのメッシュの表示に関しては、Color-Coding Meshesを参照してください。 

セットの選択 

多くのコマンドあるいはダイアログボックスでは、セットIDが選択するレコードを明示するために使用され
ます。セットは前もって特定の手続きを使用し、別々に作成されます。 

現在のセットをリストするには、エクスプローラ・ウィンドウ（Tablesタブ）のセットを選ぶか、あるいは
コンソールから、EXTRACT SETコマンドを使用します。 

すべてのセットの概観を備えたテーブルがあります。その概観テーブルでは、セットに割り当てられたセッ

ト・タイトルや色を編集することができます。このテーブルを表示するには、エクスプローラ・ウィンドウ

（Tablesタブ）のSetsを選択します。 

セット・テーブル・ウィンドウがアクティブ・ウィンドウの場合、レコードがハイライト化され、ビュー・

メニューあるいはテーブル・ウィンドウ・ポップアップ・メニューにおいて、Show Set in a New Table Window
やShow Set in a New Graphics Windowなどのコマンドが利用可能になります。これらのコマンドがすべての
タイプのセットに利用できると限らないことに注意してください。例えば、1セットの要素は、ハイライト化
されたセット中の要素を備えたグラフィックス・メッシュ・ウィンドウに表示されます。 

テーブルのカラム数が100以上（例えば、感度マトリックス）の場合、その表示カラムを100カラムまでに制
限することが可能です。その 範囲はコンボボックス（101-200、......-ncol）で選択することができます。 
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また、コンソールからはコマンドモードのセット・コンテンツを表示するEXTRACT SETコマンドを使用しま
す。コマンドTABLEもセット・コンテンツを示すテーブルを開くために使用することができます。（エクス
プローラのツリーリストの使用の代わり） 

 

注意：フィルタ・リストボックスを使用し、セット中のレコードを表示する場合、アイテムを選択し、新し

いセットとして順番にそれらを記録することが可能です。 

 

アイテムの選択を必要とする場合、すべてのコマンド文で、以前に定義されたセットを使用することが可能

です。それには、セット識別番号の後に続けて、ラベルSETを使用します。また、ダイアログボックスのリ
ストボックスには選択可能なタイプのすべてのセットが含まれます。 

例1 

> EXTRACT NODE SET 1 
> PAIR NODE SET 1  

例2 

> EXTRACT SET  
Number Set_id N items Type  
----- ------ ------- --------- 
1 22 3 elements 

例3 

> EXTRACT SET 22  
Set number 22 contains 3 elements 
List of items (external numbering):  
--------------------------------- 
1 2 3 
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データベース・セクション間のテーブル・コピー 

FEMtoolsの解析において、FEAデータをTESTデータベースへあるいはTESTデータをFEAデータベースをコピ
ーすることが必要になります。以下にそのいくつかの例を示します。 

• データのテンポラリバックアップ：データベースのマネージメントは、拡張、分割、スムージングなど

のコンビネーションを必要とするかもしれません。その後の再使用のためにデータのコピーを保存する

ことは有用です。FEAあるいはテストのいずれかのデータをインポートする場合、その新しいデータは
データベース・セクション中の既存のデータに上書されます。このことは別のデータベース・セクショ

ンにデータを格納する方法に反映されます。同様のデータベース処理の例題として、FEMtools例題マニ
ュアルのforce_pressure（容器内圧力荷重の識別）を参照してください。 

• 複素FEAモードシェープの正規化：いくつかのタイプのデータ処理、FEAまたはテスト・データのいず
れかに利用可能です。例えば、複素FEAモードシェープを正規化するために、最初にテスト・データベ
ースにそのFEAモードシェープをコピーし、次に、その複素モードシェープを実モードシェープ（正規
化モードシェープの参照）に変換し、最後にテスト・モードシェープをFEデータベースに正規化モード
シェープを戻します。 

• プリテスト解析：実験データベースにFEMモデルをコピーし、空間エリアジングをチェックするための
相関性ツールを使用します。 

• 構造変更シミュレーション（SDM）：構造変更がFEデータまたは、変更前と変更後の構造間の相関分析
のために使用する場合、FEデータベース中へのテストのモーダル・データをコピーする必要があります。
SDMがFEデータに対して使用される場合、テスト・データベース中のコピーは変更前の構造モデルのバ
ックアップ・コピーとして使用されます。 

• FEAデータ間の相関分析：最初にFEAデータをインポートし、それを実験データベースにコピーします。
次に、新たなFEAデータをインポートし、相関分析が実行されます。モードシェープおよび実稼働シェ
ープのコピーに先行または続いてシェープ・タイプを変換しなければならないかもしれません。（シェ

ープの変換を参照） 

• テスト・データ間の相関分析：最初にTESTデータをインポートして、それを解析データベースにコピー
します。次に、新たなTESTデータをインポートし、相関分析が実行されます。モードシェープおよび実
稼働シェープのコピーに先行または続いてシェープ・タイプを変換しなければならないかもしれません。

（シェープの変換を参照） 

コピーは、コピー先データベースが空であることが必要ですが、コピー先データベースにおいてソース・デ

ータベースからのデータはコピーまたはマージされます。これはデータベースの分割や拡張にも結びつきま

す。（データテーブルの拡張およびデータテーブルの縮小を参照） 

解析データのコピー 

解析データベースに存在するすべてのテーブルが実験データベースにコピーされるとは限りません。例えば、

材料特性は実験データベースに含まれないため、そのようなテーブルはコピーされません。 

要素接続データとPLOTEL要素はテストモデルのトレースラインに変換されます。 

解析データのコピーは、FEノードに参照が付けられたOCS座標系を含んでいます。 

実験データベースに解析データをコピーするには、 

• Choose Database > Copy > FEA to Testを選択する。 

• 必要に応じて、ノード・セットを指定することができます。デフォルトでは、すべてのノード（=FE model）
が指定されます。ノード・セットの指定は、セット中のノードのFEAデータをコピーします。これによ
って、実験データベース中に縮小FEモデルをコピーするために使用することができます。 
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• ダイアログボックスを閉じるためにOKをクリックします。解析データをコピーする前に、実験データベ
ースが消去されることに注意してください。 

あるいは 

• コマンドモードでは、COPY FEMの前に、CLEAR TESTが実行されます。 

テスト・データのコピー 

空の実験データベースが解析データベースにコピーされると、空の解析データベースが作成されます。 

テスト・データのコピーは、テストポイントによって参照が付けられたOCS座標系を含んでいます。 

解析データベースに実験データをコピーするには、 

• Database > Copy > Test to FEAを選択します。実験データをコピーする前に、解析データベースが消去さ
れることに注意してください。 

あるいは 

• コマンドモードでは、COPY TESTの前にCLEAR FEMが実行されます。 

モーダル減衰のコピー 

ペアリング・モード用にTESTのモーダル減衰をFEのモーダル減衰としてコピーするユーティリティ・スクリ
プトが利用きます。 <installdir>¥scripts¥utilitiesのcopy_damping.basを参照してください。 

単位変換 

FEMtools有限要素モデルの単位は任意であり、すべてのデータ関する物理的特性としての単位は一貫性が要
求されるだけです。ただし、Units Conversionダイアログボックスが、長さ、力、質量の単位のスケーリング
のために使用されます。これは複数のグループによって異なる単位の使用した外部FEAデータベース（例え
ば、I-DEASユニバーサル・ファイル・フォーマット）のデータがインポートされた場合などに有用です。尚、
このコンテキスト中の質量と質量密度を混同しないように注意してください。 

単位転換ダイアログボックスを開くには、Database > Transform > Unitsを使用します。同様のAPI関数として
は、Ft_ScaleFEMUnitsがサポートされていますが、コンソール・コマンドはサポートされません。 

スケーリング単位には３つのオプションがあります。 

• 長さベースの単位スケーリング：長さと力の単位のスケーリング係数の指定によって、質量のスケーリ

ング係数は力スケーリング係数／長さスケーリング係数から自動的に適用されます。 

• 質量ベースの単位スケーリング：質量単位のスケーリング係数の指定では、長さと力の単位のスケーリ

ング係数は適用されません。 

• 構造質量スケーリング（WTMASS）：構造質量スケーリング係数を指定では、質量と関係付けられます
が、他のスケーリング係数に適用されません。このオプションは、NASTRAN中で使用されるWTMASS
スケーリングに使用されます。 

単位の転換は、FEデータベース：FEメッシュ、幾何学データ、材料データ、力、圧力に適用されます。「FE
データベース」は、材料特性と幾何学特性を含むFEモデル・エクスプローラ中のすべてのテーブルを意味し
ます。また、「FEメッシュ」はノード、要素定義データ、座標系を意味します。 

FEMtoolsは、最も一般的な単位系に変換するためにスケーリング係数を提供し、次の単位系がサポートされ
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ます。 

• mks：[m]、[kg]、[s]  

• mmNS：[mm]、[N]、[s] 

• IP：[in]、[lbf]、[s]  

• FP：[ft]、[lbf]、[s] 

詳細情報については、Units ConversionダイアログボックスのHelpボタンをクリックしてください。 

座標系の変換 

FEMとテストのデータテーブルをインポートするために使用されるインターフェイス・プログラムはローカ
ル座標系をすべてグローバルなデカルト座標系に変換します。ただし、FEノードとTestポイントでは異なる
座標系を使用することができます。また、FEとTestのデータベース中では、異なる長さの単位を使用するこ
とができます。そのため場合に応じて、座標系の修正によるメッシュ・データの変換が必要になります。そ

の変換は、手動あるいは自動で行うことができます。 

次の手動による変換が可能です。 

変換  記述                                       

SCALE  指定の係数でテーブル中のデータをすべてスケーリングする。 

TX  グローバルX方向の移動 

TY  グローバルY方向の移動 

TZ  グローバルZ方向の移動 

Rx  グローバルX軸回りの回転 

RY  グローバルY軸回りの回転 

RZ  グローバルZ軸回りの回転 

必要な移動変換を指定する代わりに、FEMtoolsの自動移動変換機能を使用することが可能です。FEMtoolsは、
FEとテストのモデル間の最適位置相関を得るために移動と回転のコンビネーションを自動的に適用します。
その自動移動変換には係数として10の倍数..., 0.1, 1, 10, ...を使用します。これは異なるSI単位系間を自動変換
し、幾何学特性値（例えば、加速度係数：0.98）誤りも回避します。 

ノード／ポイント・ペアが定義されていない場合、変換は幾何学データ中心の位置と3Dボリュームの次元に
基づきます。 

少なくとも３つのノード／ポイント・ペアが定義されている場合、最小平方ソリューションがペアになった

FEノードとTestポイント間の最小変換距離を見つけるために使用されます。 

座標系を移動変換するには、 

• Database > Transform > FEA Data or Database > Transform > Test Dataを選択する。 

• マニュアル移動変換では、移動タイプを選択し、スケーリング係数／移動ステップ／回転角度を設定し、

Applyボタンをクリックします。最後の操作を無効にしたい場合は、Undoボタンをクリックします。 

• 自動変換の実行は、自動ボタンをクリックします。プログラムは、最適位置を見つけるためにモデルを
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スケーリング／移動／回転させます。さらに、手動による調整が必要かもしれません。最後の操作を無

効にしたい場合は、Undoボタンをクリックします。 

あるいは 

• コマンドモードでは、TRANSFORM FEMまたはTRANSFORM TESTコマンドを使用します。自動変換
のためにはラベルAUTOMATICを使用します。 

 

注意：グローバル座標系変換は単に、メッシュとシェープ（FEまたはテスト）に適用されますが、FEモデル
のプロパティや要素マトリックスには適用されません。長さ単位をスケーリングするには、FEデータをすべ
て変形する単位転換（Units Conversion）を使用しなければなりません。 

 

FRFスケーリング 

インポートされた実験FRFと解析FRFの相関分析を行う前にそれらのスケーリングが必要になるかもしれま
せん。 

Scale Test FRFsダイアログボックス（Database > FRFs > Scale Test FRFs）は、Test周波数応答関数の振幅の
スケーリングに使用されます。そのようなスケーリングは、しばしばFE解析とテスト・システムのセットア
ップの違いによって必要になります。その典型的なスケーリング係数としては、10の累乗（1000、100000、...
など）です。 

必要に応じて、スケーリング係数を選択テストFRFに適用することができます。その選択FRFはこのダイアロ
グボックスを使用する前にセットとして格納されていなければなりません。そのようなセットは、TestFRF
テーブル（Tables > FRF > Test FRF Definition）において作成することができます。TestFRFが異なるソース
からインポートされる場合に必要になるかもしれません。 

他のいくつかのオペレーションとして、周波数レンジを再定義、加振と応答のDOF交換、再サンプリング、
タイプの変更などをFRFに対して行なうことができます。 

周波数バンドの下限と上限を修正するには、Database > FRFs > Trim ニュー・コマンドを使用します。 

応答と加振のDOFを交換するには、Database > FRFs > Swapメニュー・コマンドを使用します。 

より詳細についてはコマンドMODIFY FRFを参照してください。 

ユーティリィティ・スクリプトfrfcleanup.basは、定義されてない応答または加振のポイントのFRFを削除する
ことができます。 

モードシェープの正規化 

解析と実験のモードは、それらを得るために使用されたアプリケーション・プログラムによってスケーリン

グされます。FEMtoolsでは、さらにいくつかの方法があります。 

FEAモードの正規化 

FEAによって計算されたモードは、質量マトリクスに関してスケーリングされます。この正規化は、FEMtools
感度解析やモデルアップデーティングに必要になり、正規モードが計算される場合のデフォルトとして使用

されます。ただし、それとは異なるデフォルト・スケーリングを使用するFEAプログラムもあります。その
場合、必要に応じて、FEMtools中で質量マトリクスに関して正規化されたモードに変換することができます。 

解析モードシェープを正規化するには、 
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• Database > Normalize/Scale > Normalize FEA Modesを選択する。 

• 正規化タイプを選択する。 

• 正規化を終了するためにOKを選択する。 

あるいは 

• コマンドモードでは、コマンドNORMALIZEを使用し、質量マトリックス、剛性マトリックスまたは、
最大単位に関して正規化されることを明示します。 

 

注意：インポートされた解析モードが複素モードの場合、正規化は実数部によって影響されます。 

 

テスト・モードの正規化 

テスト・モードに対し、異なるタイプの正規化が可能です。 

実験の実モードシェープの最大単位による正規化 

解析とペアの実験のモードシェープを正規化（剛体モード・フィルタリングの有無指定） 

ペアの解析モードシェープに関するモーダル・スケーリング係数（MSF）に基づいて正規化されます。 

テスト・モードを正規化するには、 

• Database > Normalize/Scale > Normalize Test Modesを選択する。 

• 正規化タイプを選択する。 

• 正規化を終了するためにOKを選択する。 

あるいは 

• コマンドモードでは、コマンドNORMALIZEかSCALEを使用します。 

複素テスト・モードを実モードに変換するには、複素モードシェープの実モードシェープ化（Realizing 
Complex Mode Shapes）を参照してください。 

複素モードシェープの実モードシェープ化 

複素モードシェープの実モード化は複素モードシェープから実モードシェープを得る手法です。それには次

の３つの方法が利用されます。 

• 係数法（Modulus Method）：複素コンポーネント係数を使用する単純な方法です。そのサインは、実部
と虚数部分の比率に依存します。 

• 変換法（Transformation Method）：この方法は、N.Niedbalによって提案され、複素モードを実モードに
変換するために複素変換マトリクスを使用します。正確な複素応答から実正規モードの解析的に決定す

る方法です。（文献：Analytical Determination of Real Normal Modes from Measured Complex Responses, 
Proceedings of the 25th Structures, Structural Dynamics and Materials Conference (SSDM), Palm Springs, CA, 
May 1984.） 

• 位相角法（Phase Rotation Method）：この方法は実モードと複素モード間のMACを最大限にする位相角
係数を使用します。（文献：Gladwell & Ismail "Extracting Real Modes from Complex Measured Modes, 
Proceedings IMAC 1995.） 
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より詳細情報についてはFEMtools理論マニュアルを参照してください。 

複素テスト・モードシェープを実モードシェープ化するには、 

• Database > Normalize/Scale > Normalize Test Modesを選択します。 

• ダイアログボックス中の方法とセッティングを選択します。より詳細情報に参照するには、Helpをクリ
ックしてください。 

• 正規化を終了するためにOKを選択する。 

あるいは 

• コマンドモードでは、コマンドREALIZEを使用します。 

テスト・モードシェープのソート 

FEMtoolsトランスレータは現れる順によってモードデータをインポートするため、そのテスト・モードシェ
ープは昇順の周波数データ・ファイルとして必ずしも格納されるとは限りません。そのため昇順の周波数デ

ータのするためのソート処理スクリプト<installdir>¥scripts¥tools¥sortshapes.basがサポートされています。 

このスクリプトは、Editメニュー（Edit > Table > Sort Shapes）あるいはテスト・モードシェープ・テーブル
（Table > Model: Test > Mode Shapes）のポップアップ・メニューから呼ばれます。 

このスクリプトは任意のソート基準も使用し、任意のシェープ・タイプをソートするために容易に使用する

ことができ、この種のデータベース修正プログラムはデモ・スクリプトとして有効です。 

データテーブルの縮小法 

一般に、動解析に使用されるFEモデルは高精度の応力解析のために使用されるモデルより粗であり、FEメッ
シュのノード数はテストポイント数より多くなります。従って、解析データベースのDOF数も実験データベ
ースのDOF数に増さります。 

FEとTestのデータベースの両方における共通位置での解析結果を比較できるように、データベース中のDOF
に関する相関性をチェックし、相関性がないDOFデータを解析と実験のデータベースから取り除かなければ
なりません。この操作は主としてモードシェープに影響し、この除去処理もモードシェープの縮小化につな

がります。この種の縮小法は質量と剛性のマトリクス演算を含む静的／動的なFEモデル・レダクターゼ法
（Guyan縮小）と異なることに注意してください。 

除去(Elimination)、縮小(Truncation)というワードにもかかわらず、必ずしもデータベースから未使用のDOFに
対応するデータが削除されるとは限りません。縮小モードシェープの使用に基づく相関分析法では、FEMtools
は自動的な暗黙処理によってモードを縮小します。この縮小はデータのコピーに対してローカルに行われま

す。また、オリジナルのデータテーブルは変更されません。ただし、利用されるコマンドはテーブルを縮小

するために使用され、データベースから効果が見込めないデータを削除します。 

メニューから、Database > Truncate/Expand > Truncate FEA Dataを使用するか、またはコンソールから、
TRUNCATE FEMコマンドを使用します。 

解析データテーブルの縮小化には次の処理が含まれます。 

• FEモデルはテストモデルの「有限要素バージョン」と取り替えられます。これはすべてのノードが対応
するテストポイントに取り替えられ、すべての要素がビームと取り替えられることを意味し、テストモ

デル中の各トレースリンクに関するノードと要素以外のすべてのFEMテーブルは失われます。材料特性
や幾何学的特性なども再定義しなければなりません。 
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• FEMtoolsはノード／ポイント・ペアがあるかどうかをチェックし、各ノード／ポイント・ペアはモデル
のDOFに依存し、写像されたDOFとなります。 

• 写像されたDOFに対応するすべての解析モードシェープ・コンポーネントは、MODESテーブル中に維持
されます。写像されないDOFのモードシェープ・コンポーネントは除去されます。 

• テスト・データベース中に写像されないDOFの実験モードシェープ・コンポーネントは解析データベー
スにコピーされます。 

実験データベース中のDOF数が解析データベースのDOF数に増さった場合、テスト・データの縮小は解析デ
ータベースの縮小効果と同様の効果があります。そのような状況は多くはありませんが、必要な場合もあり

ます。例えば、レーザー走査法による実験モーダル解析の場合、そのテストポイント数は膨大になるかもし

れません。これはテストポイント数がFEモデルのノード数より多くなることにつながります。 

結局、解析データベースの縮小は、そのDOF数が実験データベースのDOF数と同一になるということです。
解析データベースの縮小に代わって実験データベースの拡張法があります。その結果も、同一のDOF数にな
るということです。拡張法については次の章に記述されます。 

データテーブルの拡張法 

通常、FEメッシュのノード数は、テストポイント数よりはるかに多数になります。解析データテーブルを縮
小する代わりとして、実験データテーブルを拡張することができます。それは演繹的な精度のデータが加え

られるので、補間的なアプローチですが、以下の拡張法に従って使用されます。 

• 固有ベクトル直交基準（相関分析）：この基準は、FEモデル、解析の正規モード、実験のモードシェー
プの拡張により形成された剛性と質量のマトリックスを使用します。 

• モーダル外力レジデュ（誤差局在化）：この基準は、FEモデル、実験のモードシェープの拡張により形
成された剛性と質量のマトリックスを使用します。 

実験データベースの拡張後、FEモデルのすべてのDOFは、テストモデルのDOFに写像されます。ただし、拡
張されたテストモデルで得られた結果は、その拡張プロセスの精度に依存することに注意してください。 

FEMtoolsのデータ拡張法はデータベースにデータを追加しますが、縮小法と異なり、データのローカルなコ
ピー処理は行われません。モードシェープ拡張は以下の手法に有効です。 

• 固有ベクトル・ミックス（Eigenvector-mixing） 

• システム等価縮小／拡張プロセス（SEREP） 

• スムージングSEREP（SEREP with smoothing） 

• 動的拡張法（Dynamic expansion method） 

これらの手法の詳細情報については、FEMtools理論マニュアルを参照してください。これらの手法は長所と
短所を伴い、解析モデルに応じて適切に評価しなければなりません。拡張法の主な特徴は次のとおりです。 

• データの使用方法によって異なりますが、モードシェープ拡張法は解析的に得られたモードシェープに

依存します。これらのモードデータは適切なFEモデルから得られます。 

• 通常、実験モードシェープに生じるノイズ・ソースのような信頼性の低いデータを生成させ、拡張法は

モードシェープの精度に不確実性を追加します。 

• 絶対的な参照法はありません。したがって、拡張によって得られたるデータ精度には不確実性が残りま

す。 

• 拡張データ精度は、オリジナルDOFと生成DOF間の比率関数になります。一般に、大規模モデルでは、
この比率が非常に小さくなるため、拡張法の誤差は増大します。 
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拡張法を適切に使用すれば、拡張されたモードシェープから新たなモーダル特性を得ることができます。 

実験データベースを拡張するには、 

• Databaseメニューから、Expand Test Dataを選択し、Expand Test Dataダイアログボックスを開きます。 

• 拡張方法（Mode Mixing、SEREP、SEREP with Smoothing、Dynamic Expansion）を選択します。 

• ダイアログボックスを閉じるためにOKをクリックします。 

あるいは 

• コマンドモードでは、EXPAND TESTコマンドを使用します。 

拡張された実験データテーブルには次の特徴があります。 

• テストモデルはFEモデルのテストモデル・バージョンとして生成されます。これは、すべてのポイント
が結節点の位置に対応する新しいポイントに取り替えられることを意味します。また、すべてトレース

リンクも新しいもの（要素接続）に取り替えられます。テストモデルは「マージデータ」として識別さ

れ、その「マージ」されたテストモデルのトレースリンクの結節点は2ポイントとは限りません。 

• ノード／ポイント・ペアの存在をチェックします。 

• 写像されていないDOFに対応するすべての実験モードシェープ・コンポーネントは、選択された拡張法
により得られ、テスト・モードシェープ・テーブルを拡張します。 

すべての手法が同様に利用できるとは限りません。いくつかの手法では、前もって得られた結果データを必

要とします。拡張手法に必要な結果テーブルを選択するためのラベルを次の表にリストします。 
 

拡張手法 必要な結果テーブル 

固有ベクトル・ミックス ノード／ポイント・ペアおよびモードシェープ・ペア 

システム等価縮小／拡張プロセス ノード／ポイント・ペア 

スムージング SEREP ノード／ポイント・ペア 

動的拡張方法  ノード／ポイント・ペア、質量および剛性マトリックス 

それらのモードシェープ拡張手法は、常にノード／ポイント・ペアを必要とします。固有ベクトル・ミック

ス法はモードシェープ・ペアも必要とします。この拡張手法がモードシェープ・ペア機能を増強するために

使用することができます。 

SEREP法はノード／ポイント・ペアのみを必要とする迅速な技術です。このスムージング手法が使用される
場合、実験モードシェープ・テーブルにデータを追加するだけでなくデータ（モード解析システムからイン

ポートされたデータを含む）を修正します。このスムージングは測定データのローカルなノイズの影響を低

減するためにも使用できます。 

データベースのマネージメント例（テスト・データの拡張） 

定義されたすべてのテストポイントのデータ（モードシェープ）が得られない場合があります。また、測定

データからモードシェープが計算されていない場合、そのモードシェープ・コンポーネントは、0がセットさ
れます。デフォルトでは、0の変位と見なされます。FEMtools相関分析基準計算では、その影響による不正確
を回避するために相関分析フィルタ・セッティング（最低条件変位値ベース）が可能です。 

その代替アプローチは次のステップから成ります。 



 

45 

• 新しいスムージング・シェープが、FEモデルと同一結果になるようにFEAシェープを使用してテスト・
データを拡張します。 

• FEモデルを消去し、FEデータベースにオリジナルのテスト・データをコピーします。 

• オリジナルのテストモデルのDOFデータを維持するために拡張テストシェープを縮小します。0値のシェ
ープ・コンポーネントは拡張プロセスによって、新たな値に取り替えられます。 

その手続きは下記コマンド・スクリプトで実証されます。 

INPUT FEM FORMAT ABAQUS FILE "model.inp" 
SEARCH MODE FORMAT ABAQUS FILE "model.fil" 
INPUT TEST FORMAT UFF FILE "EMA_scaled.UFF" 
# 
# EXPAND TEST MODEL TO FE MODEL DOFS 
# 
PAIR NODE ALL 
EXPAND EMA METHOD SEREP MIXED 
OUTPUT TEST FORMAT UFF FILE "exptest.unv" 
# 
# BUILD FEM MODEL WITH ORIGINAL TEST MESH 
# 
CLEAR ALL 
INPUT TEST FORMAT UFF FILE "EMA_scaled.UFF" 
COPY TEST POINT ALL 
# 
# MAP EXPANDED TEST MODEL ON ORIGINAL TEST MESH 
# 
INPUT TEST FORMAT UFF FILE "exptest.unv" 
PAIR NODE ALL 
TRUNCATE TEST 
OUTPUT TEST FORMAT UFF FILE "newtest.unv" 

このスクリプトは前章で記述されたデータベース・コマンドCOPY、EXPAND、TRUNCATEを使用すること
に注意してください。 

変位のフリーズ 

FEMtoolsデータベースに格納される変形シェープ（静解析、動解析、モーダル解析）は、剛体変位および弾
性変形コンポーネントから成ります。これは構造物の支持、拘束条件やテスト・データの場合の構造物がど

のように励起され、テスト・データがどのように得られたかに依存します。 

剛体コンポーネントがFEAとテストのデータで異なる場合、その対象が弾性変形間の比較であるため、相関
性基準による比較は適用できません。その代替手段として、FEMtoolsは、3点のA,B,Cの指定による構造物の
「フリーズ（凍結）」変形ツールを提供します。これらは変形されるFEAまたはテストのデータか依存する
FEノードあるいは測定ポイントです。この変形結果として、Aの変位は0値に設定され、BはAB方向に沿って
移動可能であり、CはABCの平面上で移動可能になります。 

結果、他のすべての位置の変位の弾性変形シェープを生成し、これらの3つの位置に相対的に与えられます。
生成弾性変形シェープは、参照位置A、B、Cの関数になり、その選択は任意です。また、適切な変形が得る
ために、事前に適切な実験が必要になるかもしれません。例えば、AとBが構造物の垂直軸とする場合、Cは
ABに平行になるようすることが推奨されます。 

Database > Advanced > Freezeを使用するか、またはコマンドFREEZE を使用します。 

シェープの変換 

FEMtoolsデータベース中の解析や実験の任意タイプの変位シェープ、モーダルシェープ、実稼働シェープ（そ
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の変形は静的／動的な荷重によって形成されます。）は、同タイプのテーブルに格納されます。例えば、モ

ードシェープを実稼働変位シェープに変換、またその逆が可能です。 

Database > Advanced > Convert Shapesを使用するか、またはコマンドCONVERTを使用します。 

シェープに関する追加オペレーションとしてはスクリプト・プログラムを使用することです。そのようなス

クリプト例として、しきい値（0値）未満でモーダルの変位値をリセットするための
<installdir>¥scripts¥utilities¥filter_mode.basが参考になります。 

DOF拘束の変換 

DOF拘束（あるいは境界条件、SPCなど）は、1つDOFを拘束する剛性として定義されます。非常に大きな剛
性が使用される場合、その外界周囲に拘束されたモデルになります。 

いくつかの問題では、拘束剛性をパラメータとして定義することが有用です。それは要素プロパティとして

定義されます。FEMtoolsでは、幾何学タイプのSPRINGと共に1つのノード・スプリング（要素タイプ：POINT）
あるいは2つのノード・スプリング（要素タイプ：LINE2）を使用して、拘束をモデル化することができます。
これは新しいノードを生成する必要がなく、SPCを1つのノード・スプリングに変換することも容易です。自
動的にSPCから1つのノード・スプリングへ変換するツールも利用できます。 

Database > Advanced > Convert Boundary Conditions ...を使用するか、またはコマンドBC2SPRINGを使用し
ます。 

また、スプリング剛性を感度解析のパラメータとして使用する場合、剛結合接続の周波数感度が0値になるの
で、その過度な剛構造を回避するには、上記のような剛結合DOF拘束を弾性結合に取り換えることが考えら
れます。 

DOFリレーションの変換 

マルチ・ポイント接続（MPC）は、DOFリレーションを定義するための一般的な方法です。それには、RBAR、
RBE2、RBE3などの要素が使用されます。それらを等価なMPCに変換するためのスクリプトがサポートされ
ています。その変換には、次の方法が使用されます。 

Database > Advanced > Convert RBAR -> MPCあるいはスクリプトrbarmpc.bas 

Database > Advanced > Convert RBE2 -> MPCあるいはスクリプトrbe2rmpc.bas 

Database > Advanced > Convert RBE3 -> MPCあるいはスクリプトrbe3rmpc.bas 

備考 

• ANSYSはRBE2と等価なCERIG（剛結合拘束式）を使用します。しかし、CERIGは、ANSYS中で直ちに
MPC（=CE）に変換され、FEMtoolsのインターフェイスに使用される.CDBファイル中ではサポートされ
ません。したがって、RBE2リレーションをNASTRANからANSYSに変換するには、ANSYSにエクスポ
ートする前に、これらのスクリプトを実行するべきです。これは、ANSYS CDBファイルにRBEをエクス
ポートする旧バージョンのCP（カップルDOF）を使用する方法より有用です。 

テストシェープのスムージング 

実験モードシェープあるいは実稼働シェープをスムージングするためのフィルタがサポートされています。

これは高いノイズレベルを伴うデータに使用できます。そのアルゴリズムの詳細に関してはコマンド

FILTERを参照してください。 
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反復数にはフィルタが適用される回数を指定します。その反復数に従って、スムージングが繰り返されます。

必要な反復数は視覚によって評価できます。また、適切な反復数はテスト・データの精度に依存します。通

常、5未満の反復数で十分です。スムージングによって有効な実験結果を生成することが可能かもしれません。
それには、次の方法が使用されます。 

Database > Advanced > Smooth Shapesを使用するか、またはコマンドFILTER を使用します。 

同様のシャープに対する追加のオペレーションとして、スクリプト・プログラムを使用することができます。

そのスクリプト例として、しきい値（0値）未満のモーダル変位値をリセットするための
<installdir>¥scripts¥utilities¥filter_mode.basが有用です。 

テストシェープのマージ 

異なるテスト・モードシェープをマージするユーティリィティ・スクリプトがサポートされています。大き

な構造コンポーネントのモードシェープを形性する（例えば地振動試験）場合、異なるファイルとして格納

されたモードシェープを組み合わせために有用です。 

<installdir>¥scripts¥utilities¥merge.basを参照してください。 

ノイズの生成 

FRF（実稼働シェープあるいはモードシェープ）のようなデータタイプにノイズを加えることができます。 

Database > Advanced > Add Noiseを使用するか、またはコマンドNOISEを使用します。 

コマンドモードでは、コマンドNOISEを使用します。このコマンドは、ユーザーによるカスタマイズがない
場合以外は、メニューから呼び出すことはできません。補語が指定しない場合、対話式応答が可能なダイア

ログボックスが表示されます。 

このコマンドは研究用に提供され、付加的なホワイトノイズ（白色雑音）が直接的に加えられます。FRFに
対しては、同様のホワイトノイズが、FRFの逆FFT変換によって得られる時間領域信号に加えられます。 

このコマンドは、FEMtoolsスクリプト関数NormRndに基づく正規分布を使用したホワイトノイズを生成しま
す。ノイズレベルは正規分布の標準偏差に基づいた分散（Scatter）パーセンテージに反映されます。 

<installdir>¥scripts¥commands¥noise.basを参照してください。 

 


	/
	FEMtoolsデータベース概論
	データベース・マネージメント
	FEMtoolsデータベース
	データベース情報
	データベースの再初期化

	データタイプ
	FEMデータタイプ（FEM Data Type）
	ノード当たりの自由度
	要素タイプ

	剛性と質量のデータタイプ
	縮小剛性と縮小質量のデータタイプ
	変位データタイプ
	モード・データタイプ
	テスト・データタイプ
	FRFデータタイプ
	結果データタイプ
	プロジェクト・データタイプ

	データ・インターフェイス
	プロジェクト・ファイルの使用方法
	FEMtoolsコマンド・スクリプトとしてFEMデータをバックアップ

	FEMtoolsデータベース・ファイル
	データ・インターフェイス・プログラム
	ファイル名拡張子
	デフォルト・インターフェイス・フォーマット
	インターフェイス・データのエコー・モード
	ファイルの上書きモード
	データテーブルのインポートとエクスポート
	FEMtoolsマトリックスのインポートとエクスポート
	データの検証
	要素定義データの整合性
	モードシェープのAuto-MAC
	実稼働シェープのAuto-DAC
	モードシェープの自動直交化

	ラージモデルの縮小化

	データベース・テーブルの編集
	新しいテーブル・ウィンドウの作成
	テーブル・ウィンドウのアレンジ
	テーブル・ウィンドウの選択
	テーブル・ウィンドウのクローズ
	テーブル・ウィンドウのデータテーブル編集
	コマンド言語によるデータテーブルの編集

	アイテムとセット
	内部番号と外部番号
	アイテムの再番号付け
	アイテムの選択
	セットの定義
	セットの選択

	データベース・セクション間のテーブル・コピー
	解析データのコピー
	テスト・データのコピー
	モーダル減衰のコピー
	単位変換
	座標系の変換
	FRFスケーリング
	モードシェープの正規化
	FEAモードの正規化
	テスト・モードの正規化

	複素モードシェープの実モードシェープ化
	テスト・モードシェープのソート
	データテーブルの縮小法
	データテーブルの拡張法
	データベースのマネージメント例（テスト・データの拡張）
	変位のフリーズ
	シェープの変換
	DOF拘束の変換
	DOFリレーションの変換
	テストシェープのスムージング
	テストシェープのマージ
	ノイズの生成


